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Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information.  The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyperlinked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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LAB 1 - Getting Started in InRoads

This lab demonstrates how to start and set up InRoads to work on a project.  It demonstrates the Project 
Creation Utility, starting InRoads, loading data, and changing some InRoads settings.

Chapter Objectives:

 Create a new project folder structure.

 Start InRoads and set up the InRoads project defaults.

 Load the initial project data.

 Demonstrate how the Locks work.

 Demonstrate Precisions and Factors.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 1.1 - Creating a Project Directory

The first step when beginning a project is to create a project directory structure.  Use the 
Project Creation Utility to generate a uniform directory structure which will allow other users 
easy access to the project data when they need it.

Section Objectives:

♦ Create a project directory.

♦ Explore the folder structure created.

♦ Demonstrate how the PCF file works

1. <D> the Project Creation Utility icon or select Start > All Programs 
>_CDOT_CADD_Information > 8.9.xx – XM > Create XM Project Directory 
Structure to open the CDOT Project Creation Utility dialog box.

2. In the CDOT Project Creation Utility dialog box, <D> in the Job Project Code (JPC) field 
and key in 54321.
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3. Verify that Create Project Configuration File is toggled on.  This file automatically sets 
the directory path in MicroStation so that navigating to the correct project folder is easier.

4. <D> Apply then <D> Close to dismiss the dialog box.

5. Open Windows Explorer and navigate to C:\Projects\54321\Design\Drawings\.  
Notice that the directory structure has been built for all diciplines and it has been populated 
with the standard drawings.

6. Close the Windows Explorer.

7. Start MicroStation.

8. In the MicroStation Manager dialog box, set the Project: to 54321.  Notice that the Look 
In: folder automatically changes to the 54321 directory.

9. In the MicroStation Manager dialog box, navigate to the Design > Drawings > 
Reference Files folder.
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10. <D> on 54321DES_Model.dgn then <D> Open.  This is the location and file that most 
Roadway Design work is done in.

11. Close MicroStation.

Section Summary:
♦ Using the Project Creation Utility builds a standard directory structure for the project.

♦ Standard drawing files with project specific names are included in the project 
directories.

♦ Using the PCF file in MicroStation make navigation within the project directory easy.

Lab 1.2 - Initial InRoads Set-up

MicroStation uses the pcf file to set directory paths.  InRoads use a different method called 
Project Defaults.  The process of setting project defaults is normally a tedious job. However, 
using the  CDOT_XM Disciplines.reg file supplied with the CDOT workspace, this job is very 
simple.  The .reg file uses variables stored in the pcf to set the directory paths when opening or 
saving data InRoads related data files.

In addition to setting up the project defaults,  students will learn how to create a project file 
which allows several data files to be loaded into InRoads simultaneously.

Note: This lab uses the 12345 project directory which already has the initial InRoads data for 
the remaining labs.

Section Objectives:

♦ Open MicroStation and InRoads using the 12345.pcf file.

♦ Import the CDOT_XM Disciplines.reg file into the project defaults.

♦ Load the project alignment, surface, and template data.

♦ Create a project (rwk) file.
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1. Start MicroStation and InRoads by selecting Start > All Programs > Bentley > 
InRoads  Group XM > InRoads or select the InRoads desktop icon.

2. In the MicroStation Manager dialog box, set the Project: to 12345.  This setting accesses 
the 12345.pcf file.

3. In the MicroStation Manager dialog box, navigate to the Design > Drawings > 
Reference Files folder.

4. <D> on 12345DES_Model.dgn then <D> Open.  This opens MicroStation and 
InRoads.

5. From the InRoads menu bar, select File > Project Defaults.  This displays the Project 
Defaults dialog box.

6. On the Project Defaults dialog box, <D> the Import button.  This displays the Open 
dialog box.
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7. In the Open dialog box, navigate to C:\Workspace\Workspace-CDOT_XM\  
Standards-Global\InRoads\Preferences\ and highlight the CDOT_XM 
Disciplines.reg file.

8. <D> Open.

This loads the data into the Project Defaults dialog box.  This file only has to be loaded one 
time.  Once loaded, it will work with any project so long as the pcf file is used when 
starting InRoads.

9. Back on the Set Project Defaults dialog box, set the Configuration Name to CDOT 
Design Discipline.

Note: Although the Design Discipline is used for this lab, there are project defaults for 
each of the other disciplines as well.

10. <D> Apply then <D> Close.

Setting the project defaults using this method defines the default locations for both general 
InRoads resource files and project specific data files.  This will make it easier to conform to 
graphics standards and assist in navigating to the correct project directories when loading 
or saving data files.
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11. Select the Preferences tab on the Workspace bar and verify that the correct InRoads 
Project resource files are loaded.

Next, the initial InRoads data files are loaded.

12. From the InRoads menu bar, select File > Open.  This displays the Open dialog box.

13. The Open window defaults to the C:\Projects\12345\Design\ folder.  <D> <D> on the 
InRoads folder.

14. Highlight 12345DES_Geometry.alg and <D> Open.

15. Highlight DES12345_Templates.itl and <D> Open.

Typically, the template library is copied from C:\Workspace\Workspace-
CDOT_XM\Stam\ndards-Global\InRoads\Templates\ , however, for future labs the template 
library (with additional data) was provided in the Design\InRoads\ folder.
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16. In the Open window Look In drop down, navigate to 
C:\Projects\12345\ROW_Survey\InRoads\DTM\ folder.

17. Highlight 12345 Existing Ground.dtm and <D> Open.

18. <D> Cancel to close the Open dialog box.

The project (rwk) file is used to load or save all of the project data files at one time.  This file 
can be updated as new data files are added to the project.  

19. Select File > Save > Project from the InRoads menu bar.  This displays the Save As 
dialog box.

20. In the File name field, key in 12345DES, do not press the Enter key.

21. <D> the Options button.  This displays the Project Options dialog box.
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22. In the Project Options dialog box, toggle on the Update check box for the data files 
loaded above.

23. <D> OK to dismiss the Project Options dialog box.

24. In the Save As dialog box, <D> Save then <D> Cancel to dismiss the dialog box.

Section Summary:
♦ The CDOT_XM Disciplines.reg file only needs to be imported one time, then it can be 

used for any project.

♦ Initial project data is loaded after the project defaults are set up.  This data must include 
an existing ground dtm and may include geometry as well.

♦ Creating a project (rwk) file speeds up the process of loading and saving project data.

Lab 1.3 - Toolbars

This lab demonstrates how the InRoads Interface can be populated with toolbars for easy 
access to commands. The pull-down menus can be used to select the correct tool, but it may be 
more convenient to use toolbar icons.  All InRoads toolbars can be customized to fit your 
workflow or personal preferences.

Section Objectives:

♦ Learn how to access addition toolbars used for viewing and reviewing geometry.

♦ Learn how to access and use the Global Scale Factor Add-in

Opening Additional Toolbars



Colorado Department of Transportation   Page 21

Labs for InRoads XM LAB 1 - Getting Started in InRoads

1. From the pull-down menu select Tools > Customize. The Customize dialog will appear.

2. Under the Toolbars tab, check that the boxes for Review Geometry and View 
Geometry are selected.  When checked on, the toolbars become active in the graphics file 
immediately.

3. <D> the Close button in the Customize dialog.

4. Dock, Undock and Resize the toolbars until you are comfortable repositioning them.  
Notice how toolbars can be docked in the InRoads interface but not MicroStation’s.
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5. From the pull-down menu, select Geometry > View Geometry look at each command 
and the associated image. Notice the correlation of the graphics between the pull-down 
menu and the toolbar.

6. Place the cursor over an icon in any toolbar. A Tool Tip will appear at the lower right of the 
cursor, additionally a description of the command shows in the status field.

♦ The tool tip feature is controlled in the Customize dialog (Tools > Customize) box via 
the Show Tool Tips checkbox and is turned on by default.

Global Scale Factors

Global scale factors are used to determine the size of displayed text, cells, and linestyles. The 
global scale factor function can be found under Tools > Options [Factors] tab. However, 
enabling the command directly from the menu bar is more efficient.
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7. Select Tools > Application Add-ins to display a list of available InRoads commands 
and functions that can be added to the InRoads interface.

Selecting an item will display a description.  The command category shows both the menu 
location and the InRoads product(s) it can be activated with.

8. Toggle on Global Scale Factor, <D> OK, and Close the dialog.

9. Select Tools > Global Scale Factors…

10. Verify all three scale settings are set to 100.

11. <D> Apply then Close.

These settings are multipliers for displayed graphics.  Generally the values should be set to 
correspond to the plotting scale factor. As with most MicroStation or InRoads commands, 
you have the option of either enabling or disabling the lock symbol to input values 
universally or individually.

Note: Digital Terrain Models are not a core topic of this course. However, it is worth 
noting that Global Scale Factors apply to all InRoads data displayed. This includes 
the display of features from a DTM. While possible to ‘regenerate’ plan view 
topography by displaying the features from a survey-supplied DTM, this is NOT 
an accepted workflow.  The reason for this is because any attributes collected in the 
field are processed by InRoads Survey. These attributes (rotation, Q & Z reports, 
etc) are not stored in the DTM and the resulting graphics will be incomplete and/or 
incorrect without being evident.
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Section Summary:
♦ Students learned how to access the Review Geometry and View Geometry toolbars and 

how they compare with the pull-down menus.

♦ Students learned how to access the Global Scale Factor Add-in and how the global 
scale factor impacts grapics generate from InRoads commands.

Lab 1.4 - Locks

This lab illustrates the use of the Feature Filter lock, Pen/Pencil Mode, and Station Lock.

Section Objectives:

♦ Demonstrate how the Feature Filter lock reduces items in list boxes.

♦ Demonstrate the difference between Pen and Pencil mode.

♦ Demonstrate the effects of Station lock.

1. On the InRoads main dialog box, verify that the Feature Filter lock is on and the filter 
name is set to <Unnamed>.  Unnamed is in effect no filter.

2. From the InRoads menu bar, select Surface > Feature > Feature Properties.
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The illustration below shows the Feature Properties dialog box as displayed with no active 
feature filter.

3. On the InRoads main dialog box, set the Feature Filter to T_B*.
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Notice that in the Feature Properties dialog box only features that start with T_B are displayed.  
The illustration below shows the dialog box with the filter active.

4. Close the Feature Properties dialog box.

5. Set the Feature Filter back to <Unnamed>. 

Next, the Pen/Pencil mode and the Station lock are demonstrated.

6. On the InRoads main dialog box, set the Pen/Pencil mode to Pencil.

7. Turn the Station lock off.
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8. <D> the Geometry tab in the InRoads Explorer and verify that the SH 86 alignment is 
active.

9. From the InRoads menu bar, select Geometry > View Geometry > Stationing.

10. On the View Stationing dialog box, <D> Apply.

11. Examine the stationing displayed.  The regular stations end in “+80”.  This is not CDOT 
standard.

12. On the InRoads main dialog box, turn the Station lock on.

13. Redisplay the Stationing.
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14. Examine the stationing displayed.  There are two things to note.  First, the original 
stationing was deleted and the new stationing was displayed.  This is a result of the Pencil 
mode.  Second, the Stations end in “+00” in even 500 foot intervals.

15. On the InRoads main dialog box, set the Pen/Pencil mode to Pen.

16. Turn Delete Ink off.  Delete Ink makes Pen mode behave like Pencil mode.  It is turned 
off here to illustrate Pen mode.

Next, Pen mode is demonstrated.

17. Redisplay the Stationing.  The stationing will appear the same as it did in the previous step.  
This is done so that the stations are displayed with Pen mode.  Stationing displayed in 
Pencil mode will always behave in Pencil mode.
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18. Turn off the Station lock and redisplay the stationing.  This time the original stationing is 
left in place and the new stationing is also displayed.

Section Summary:
♦ The Feature Filter lock has two items to set; The Filter Name and the Filter lock On/

Off switch.

♦ Items placed retain the Pen/Pencil mode they were placed with, regardless of the mode 
setting at the time the items are placed again.

♦ Station lock On is the standard operating mode for CDOT.

Lab 1.5 - Precision and Factors

Precision affects the number of decimal places used in InRoads dialog boxes.  Factors 
determine the size of graphic elements displayed by InRoads.  This lab illustrates these affects.

First, precision is examined.  The Review Horizontal Alignment command is used to illustrate 
the affects.

1. In the InRoads Explorer, select the Geometry tab.

2. Expand 12345DES_Geometry to show the SH 86 alignment.
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3. From the InRoads menu bar, select Tools > Options.

4. Verify that the Precision tab is active.

Notice that the precision for Station is set to 0.12.

5. In the InRoads Explorer, <R> on the SH 86 alignment and select Review from the right 
click menu.

In the Review Horizontal Alignment dialog box, notice that the stations have 2 decimal places.

6. Close the Review Horizontal Alignment dialog box.

7. In the Options window, change the Station precision to 0.1234.
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8. <D> Apply.

9. Redisplay the Review Horizontal Alignment dialog box for SH 86.  

Notice that the stations now show 4 decimal places.  Next the affects of factors is demonstrated.

10. Reset the Station precision back to 0.12.

11. On the Options dialog box, <D> the Factors tab.  Notice that the Text Scale Factor is set 
to 100.
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12. From the InRoads main menu, select Geometry > View Geometry > Stationing.

13. On the View Stationing dialog box, <D> Apply.

14. Zoom in on a station and note the size of the text.

15. On the Options dialog box, key in 50 for the Text Scale Factor and <D> Apply.

16. Redisplay the stationing and notice the change in the text size.  The illustration below 
shows the difference.

17. Reset the Text Scale Factor to 100, then close InRoads and MicroStation.

Section Summary:
♦ Precision controls the decimal places displayed in InRoads dialog boxes only.

♦ Factors control the size of text, cells, and linestyles displayed by InRoads.
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♦ The Linestyle Scale should be set to 1, Text and Cell scales should be set to the plot 
scale.

Chapter Summary:

 Start a project by creating the directory for the project.

 Project defaults make it easier to Open and Save project data files.

 Locks affect the way InRoads works and displays information.  These should be set as 
desired prior to work on the project.

 Precision and Factors affect displays in InRoads dialog boxes and items placed by InRoads.  
These should be set as desired prior to work on the project
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The purpose of  this lab is to go into a more detailed review of the contents of the 
12345DES_Geometry geometry project (12345DES_Geometry.alg) file used in the previous 
lab.

The 12345DES_Geometry geometry project is a collection of all the data from the initial 
topographic survey.  Existing linear objects such as pavement lines, breaklines, streamlines, etc 
are stored as horizontal alignments. Survey shots of singular features such as signs, utilities, 
ground shots, trees, etc. are written to the cogo buffer and stored as individual points.

In subsequent labs geometry data will also be loaded from the ROW_Survey directory structure  
for reference purposes only.  To maintain the integrity of the ROW_Survey geometry data, 
subsequent exercises will show you how to copy geometry projects in their entirety and also 
how to selectively copy information (alignments and cogo points) to a separate geometry 
project.

Important! Data from the ROW/Survey directory should only be modified by the ROW/
Survey group.  Staff from other disciplines should not modify ROW/Survey 
geometry projects in any way and take any precautions to ensure that it is not 
changed.

Chapter Objectives:

 Illustrate the process of setting active geometry.

 Review an exisisting geometry project.

 Review alignment attributes.

 Review alignment stationing.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 2.1 - Review Geometry Project

Section Objectives:

♦ Verify the correct geometry is loaded.

♦ Learn how to identify and change the “active” geometry.

♦ Learn how to review and view geometry including cogo points.

♦ Learn how to save the results of an InRoads report.

♦ Learn how to clean up MicroStation graphics and keep them in sync with InRoads data.

♦ Practice gathering alignment infomation.

1. Open the file in the 12345DES_Model.dgn file from the 
C:\Projects\12345\Design\Drawings\Reference Files folder.
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2. Open the geometry project named 12345DES_Design.alg located in the folder  
C:\Projects\12345\Design\InRoads. You should see something similar to the image 
below.

3. Expand the screen display of the geometry project by selecting the + (plus) symbol 
located to the left of the geometry project name.

4. Look to the right side of the InRoads pane. Use the Scroll bar at the bottom of the window 
to view the columns of information to the right. The following is a list of columns you 
should see but may be in a different order:

♦ Name - The horizontal alignment name and the Cogo Buffer are shown here.

♦ Style - The Style name attached the the horizontal alignment is listed here.

♦ Description - The horizontal alignment’s description, if any, is shown here.

♦ By Whom - The Windows user ID of the person who created the alignmentis shown 
here.

♦ Last Revised - This column lists the most recent revision date for the file.

♦ Access Mode - This column indicates whether the file has write access or is read only.

♦ Integrity - This column indicates whether the alignment elements are connected 
properly or not.

♦ Curve Definition - This column indicates whether curves are defined by arc or chord.

♦ Start Station - This column lists the beginning station value for the alignment.

♦ End Station - This column lists the ending station value for the alignment.

♦ Number of VAs - This column lists the number of associated vertical alignments.

♦ Number of Superelevations - This column lists the number of associated 
superelevation definitions.

5. <D> on any of column headings to sort ascending or descending.
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6. To reposition the columns either to the left or right, <D> and hold down the column 
heading and slide the mouse on to any of the column headings.

7. <D> on the Cogo Buffer. Notice the detail screen to the right showing the contents of the 
Cogo buffer. Also notice the columns showing Northing, Easting, and Elevation by 
adjusting the view pane.

8. <D> on the first horizontal alignment listed. Notice the associated vertical alignment.

Note: Only one horizontal alignment can be active at a time. Being active specifies the 
alignment to be modified, displayed, or defined by default in dialog boxes.
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9. Select Geometry > Active Geometry.  The Active Geometry dialog will appear.

10. Set Type to Horizontal Alignment.

11. <D> on alignment Side Road.

12. <D> Apply then Close.

Notice that the alignment called Side Road in the InRoads explorer pane shows a red 
indicator box around it signifying that it is the active alignment.
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13. Select Geometry > Review Horizontal for a textual display of the active alignment. 
When reviewing an alignment, a temporary dynamic display is shown in MicroStation 
representing the location of the alignment being reviewed.

14. Explore the four main areas of the dialog box.

♦ Geometry Project and Horizontal Alignment (in the dialog box frame)

○ Change the Horizontal Alignment

♦ Mode  (in the dialog box frame)

○ Change the Mode and watch how the infomation in the dialog box changes 

♦ Geometry header  (in the veiw port)

○ Note the change to the Project Name, Description, Alignment name, Description, 
Geometry Style

♦ Element Details  (in the veiw port)

○ Note how the element details change according to what mode is selected.

15. Review this display for alignment information such as Cogo point ID assignments, 
bearings, distances, northing, easting, etc.

16. <D> the Close button.

17. Select Geometry > View Geometry > Active Horizontal to write the alignment to 
the MicroStation file.

Note: It may appear that nothing happend.  This is because the view window is not 
postioned correctly to see the data.  The next step will resolve this.

18. Select Geometry > Fit Alignment and <R> (press the right mouse button) in a 
MicroStation view to reposition the MicroStation view to the limits of the active alignment.
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Note: If the graphics for the existing features disappear, us the key in dp = -10000, 
30000 and left click in View 1 to expand the MicroStation clipping planes.

19. In the Workspace Bar <R> (right-click) on the active alignment name.  Note the Active, 
View, Fit, and Review commands are available from the short-cut fly-out menu.

20. Experiment using this fly-out menu with any alignment.
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21. In the Workspace Bar <R> on the Cogo Buffer and select Review...  The Review 
Geometry Points dialog will appear.

22. <D> the Next button to review the information about subsequent points.  Notice the 
available navigation buttons First, Previous, Next, and Last
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23. <D> Report to list all Cogo points stored in the active geometry project.

Note: The buttons on the right side of the Results dialog allow you to save or display this 
report.  These options exist in many InRoads dialogs.

24. They are:

♦ Close - closes the Results dialog

♦ Save As - saves the contents of the dialog to an ASCII (text) file

♦ Append - appends to an existing ASCII file

♦ Display - allows the user to select a location in the MicroStation drawing to place the 
dialog contents as text and using the active text and element settings when writing the 
text to the CADD file

♦ Print - sends the contents to the default system printer

♦ Help - displays the InRoads help file for this command.

25. <D> the Close button in the Results dialog

26. In the Mode section of the Review Geometry Points dialog, toggle the radio button to 
Alignment.  Notice how the Alignment drop-down list is activated.
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27.   Select SH86 in the Alignment drop-down list.

28. <D> the Report button again to review the vertices of the selected alignment.

Note: The Point Name column is not showing point numbers or names (except for point 
1000) indicating this alignment was created as unnamed geometry points.

29. <D> the Close button in both the Results and Review Geometry Points dialogs.
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Note: The previous steps used the short-cut fly-out menus, all actions can also be found 
under the Geometry pull-down menus.

At anytime during these labs you can delete all visible graphics in your MicroStation file using 
the element selection tool or a fence. Note that you are deleting the graphical display of data, 
not the data itself. The graphics can be redisplayed using the InRoads display commands shown 
in previous sections.

Note: The screened topography and the graphics used as training guides are either locked 
graphics or are attached as a reference file so they can not be deleted. These graphics 
will be used in future labs.
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Multiple Geometry Projects can be loaded into memory simultaneously.  However, only one 
geometry project, horizontal, and vertical alignment can be active at any given time.

30. Use the previously covered commands to display the horizontal alignments SH 86 and Side 
Road.

31. Use the review command to investigate the various data for the same two alignments.

♦ What is the beginning station value for:

SH 86   _______________

Side Road  ________________

♦ What is the overall length of:

SH 86  _______________

Side Road ________________

♦ What is the shortest radius used in:

SH 86 ________________

Side Road ________________

Section Summary:
♦ Many of the view and review commands can be accessed from the right click menu as 

well as the main toolbar.

♦ Reports displayed by review commands can be saved to a text file.

♦ Use the Mode options, where available, to display data in different formats.

Lab 2.2 - Review Alignment Attributes

The geometry Name, Description, and Style are assigned to an alignment or Cogo point when 
they are created. These attributes can be queried by utilizing the review geometry command.

Section Objectives:
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♦ Review Alignment Attributes

♦ Review Cogo Point Attributes

1. Select Geometry > Review Horizontal…

2. Using the selection box labeled Horizontal Alignment, Compare the settings for  
alignment SH 86 with the attributes for alignment Side Road. Note the changes in 
Description & Style.

3. Select Geometry > Review Geometry Points… to review Cogo point names, 
descriptions, and style assignments.
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Note: This dialog is used to review both alignments and Cogo points based on the Mode 
setting.

4. This information can also be seen in the InRoads explorer pane.<D> on the Cogo Buffer 
and notice the description(s) and Style(s) as displayed in the feedback pane.

Note: If the Style assigned to the data is not a valid name when displaying an alignment 
or Cogo point (not existing in the Style Manager), a Style by the name Default will 
be used.

The Default CDOT Style for all geometry elements has the same properties as the 
defined style ALG_Proposed.
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Section Summary:
♦ Geometry styles are stored along with surface and survey styles in the CDOT_Civil.xin 

file.

Lab 2.3 - Review Alignment Stationing

The default station at the beginning of a newly created horizontal or vertical alignment is 0+00. 
If the alignment previously existed, the beginning station may not be 0+00. Stationing values 
value can be changed to accomodate the needs of the project as shown in a later lab.

The first thing to do is to determine the existing assigned stationing values by using the  
alignment review commands.

1. Make 12345DES_Geometry the active geometry project by right-clicking on the 
geometry name and selecting Set Active from the fly-out menu.
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2. Right-click on the alignment SH 86 and select Review from the Fly-out menu.  The 
Review Horizontal Alignment dialog will appear.

Note: Fly-out menus can be access from either the workspace or feedback panes. Also 
note that selecting an alignment for review switches it to being the active 
alignment.

3. Write down the initial station value assigned to horizontal alignment SH 86: 
____________.
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4. Review the Vertical alignment SH 86 V associated with horizontal alignment SH 86.

5. Write down the initial station value assigned to vertical alignment SH 86 V: 
____________.

If the horizontal and vertical stationing are not sychronized it will cause confusion in the 
design and construction processes.  Is the stationing for the horizontal and vertical 
alignments synchronized?

Section Summary:
♦ The beginning and ending stations cna be found in the feedback pane or the review 

alignment dialog boxes.
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Chapter Summary:

 Use the right click menus to find many of the view and review geometry commands 
without searching the InRoads main menu.

 Use the navigation buttons provided in th ereview dialog boxes  to move through long 
reports.

 The attributes for geometry elements can be found in the feedback window or in review 
reports.
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This lab demonstrates how annotate horizontal geometry, set and display alignment stationing, and use 
horizontal alignment tracking tools.

Chapter Objectives:

 Display horizontal alignments.

 Annotate horizontal alignments and cogo points.

 Reset stationing on an alignment.

 Display stationing.

 Add a station equation.

 Use Tracking and Horizontal Alignments Tracking.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 3.1 - Geometry Display

Section Objectives:

 Set the proper scale factors.

 Open a saved view in MicroStation.

 Display alignments using the View and Annotation commands.

Options for displaying horizontal alignments are available when using the Horizontal 
Annotation dialog.

1. Select Tools > Global Scale Factors and set the scales to 100 for Text and Cell and 1 
for Line Style .

2. Using the MicroStation menus, select Utilities > Saved Views tools to open the saved 
views dialog.
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3. <D> on the name POB, <D> Apply for view 1, and <D> Close.

Below is an example of the saved view.
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4. Display alignment SH 86 from the Geometry Project 12345_Design by right-clicking <R> 
on the alignment name and selecting View from the fly-out menu.

The alignment display is based on the geometry style assigned to the alignment. This 
display method is suitable but does not allow the user any options or allow annotation of 
the geometry. The next steps illustrate how to customize the graphics display for geometry 
elements.
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5. Select Geometry > View Geometry > Horizontal Annotation.

6. Key in SH 86 in the Annotate field and Tab from the field.

7. Set options for the Display and Annotate sections of the dialog as shown in the above 
screen shot.

8. <D> the Apply button. This will write alignment SH 86 to the MicroStation Screen and 
annotate the alignment.
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Note how Bearing and Distance annotation is displayed along the tangents. If the 
alignment contains horizontal curves, curve data will be displayed.

9. Return to the View Horizontal Annotation dialog.
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10. In the Annotate area of the Main tab, Toggle on Points, <D> Apply

In addition to annotation for tangents and curves, notice that alignment vertices are also 
annotated.
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11. On the Main tab, click the Help button and review the descriptions for the various 
components that can be displayed.

12. Experiment displaying an alignment with Points and Elements turned on or off on both the 
Display tab and the Annotate tab.

13. Experiment displaying the various components available in the display portion of the 
dialog.

Section Summary:

 InRoads displayed graphics are governed by the Global Scale Factor in InRoads. THe 
MicroStation Annotation Scale has no affect on these elements.

 The view alignment commands (from the right click menu of from Geometry > View 
Geometry > Active Horizontal) only display the lines and arcs that make of the alignments 
path.

 Horizontal Annotation also displays the alignment’s path. It can display other geometry 
data as well.

Lab 3.2 - Selection of Geometry for display and/or Annotation

Section Objectives:

 Illustrate methods for defining horizontal alignment elements for display and/or 
annotation.
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1. Select Geometry > View Geometry > Horizontal Annotation.

2. <D> the Main tab.

3. Set the Apply Style to Assigned.

4. <D> in the Include field in the Horizontal Alignments area.  The Filter button becomes 
active.

5. <D> the Filter button.  The Geometry Selection Filter dialog will appear.
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Note: Available alignments are shown on the left, Selected (for display or annotation) 
alignments are shown on the right.  This makes it possible to select multiple 
alignments for display or annotation.

6. Move the alignments SH 86 and Side Road from the Available list to the Selected list by 
<D> the names in the Available list and then <D> the ADD button (or <D><D> on the 
names).

Note: The data in this dialog can be sorted by clicking <D> on the column headers. 
Multiple selections of alignments can be made through the use of the <CTRL> or 
<Shift> keys.
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7. When done identifying the desired alignments in the Filter dialog, <D> OK – the Selected 
geometry is populated in the Selected field

8. <D> Apply and the selected alignments will display in MicroStation.

9. Review the results in MicroStation.
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Section Summary:

 Alignments can be selected for annotation by key in, graphic selection using the  button, 
or by using the Filter options.

  The Display area is used to turn on or off the display of the geometry elements. 

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.3 - Display or Annotation of Cogo Points

Section Objectives:

 Illustrate methods for defining cogo points for display and/or annotation.

Note: Whether you are annotating Points or Alignments, keep in mind that the element 

selection button can be used to graphically identify the geometry of interest. 
This is universally true in InRoads whenever the selection button is displayed.

10. <D> the Include field in the Cogo Points area to activate the Filter button

11. <D> the Filter button. The Geometry Selection Filter dialog will appear.
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12. Select points 1001-1005 & 1010 from the Available field and add them to the Selected 
field.

13. <D> the OK button. The points populate the Selected field.
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14. <D> the Apply button in the View Horizontal Annotation dialog.

15. Experiment displaying various Alignments and Points with the assorted settings.
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Note: Remember to toggle on Points in the Annotation tab if you need to see Cogo 
Point numbers, Northing, and Easting. Keep in mind annotation settings are 
derived from the Geometry Style Manager Type: Points for the assigned Geometry 
Style.

Section Summary:

 Cogo Points can be selected for annotation by key in, graphic selection using the  
button, or by using the Filter options.

  In the Display area, the Points toggle is used to turn on or off the display of the geometry 
elements.

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.4 - Review Alignment Stationing

Section Objectives:

 Review the alignmet to determine its current stationing.

The default station at the beginning of a newly created horizontal or vertical alignment is 0+00. 
This value can be changed as shown later in this lab.

One of the easiest methods for determining assigned stationing values is through the alignment 
review commands.

1. Make 12345_Design the active geometry project by right-clicking on this geometry 
name and selecting Set Active from the fly-out menu.
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2. Right-click on the alignment SH 86 and select Review from the Fly-out menu.  The 
Review Horizontal Alignment dialog will appear.

Note: Fly-out menus can be access from either the workspace or feedback panes. Also 
note that selecting an alignment for review switches it to being the active 
alignment.

3. Investigate the stationing assigned to horizontal Alignment SH 86.

Initial station value is: _____________________________.

4. Review the Vertical alignment SH 86 V associated with horizontal alignment SH 86.

♦ Is the stationing for the horizontal and vertical alignments synchronized?

Section Summary:

 Use the Review command to find out information about the alignment, like stationing, 
without having to display it graphically.
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Lab 3.5 - Displaying Stationing

Section Objectives:

 Display stationing and alignment keypoints.

 Use the Symbology toggles to turn on and off various items.

1. Prior to displaying the stationing, display the lifework for the horizontal alignment  SH 86.

Right-click on the alignment name in the InRoads explorer window and select View from 
the fly-out menu.

2. Select Geometry > View Geometry > Stationing.  The View Stationing dialog 
will appear.

3. <D> the Preferences button.
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Note: The Preferences dialog is used to load preset settings for a particular tool.  In the 
View Stationing dialog the preference is setting the interval and symbology of the 
display graphics.

The following steps load the Preference Proposed–100 Ft Interval as the active symbology.

4. <D> Proposed-100 Ft Interval.

5. <D> Load then Close button.

6. In the Symbology portion of the dialog, select or de-select the alignment components for 
display. Loading the preference sets the default interval for major stations.
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7. <D> Apply to display the stationing.

The View Stationing dialog is populated with the predefined settings from the stored 
preferences. Notice the interval field and settings under the symbology section. The display 
toggles define what will display; the name column reflects the InRoads named symbology 
defining graphical attributes for displayed items.

There are several standard CDOT preferences to choose from, depending upon the type of 
alignment stationed and station interval. Choose the appropriate Preference and <D> 
Apply to see the stationing.

Keep in mind that text size is dependent on the active Global Scale Factor at time of 
display. If necessary, select Tools > Options [Factors] to change the value of the Global 
Scale factors.

8. Change the Global Scale Factor and redisplay stationing.

9. Experiment displaying stationing using various CDOT preferences until presets becomes 
familiar.
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10. Experiment with the various tabs and settings in the View Stationing dialog and 
investigate what changes are made when stationing is redisplayed.

Section Summary:

 The stationing Preferences are set to CDOT standards and should be used in most cases.

 Using the Pencil mode automatically deletes old stationing when new stationing is 
displayed.

Lab 3.6 - Defining Stationing

Section Objectives:

 Change the biginning station of an alignment.

Upon creation, alignments are defined with a beginning stationing of 0+00. Stationing can be 
redefined from any location along the alignment.  Additionally, station equations can be 
incorporated.
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1. Select Geometry > Horizontal Curve Set > Stationing.  By default, this dialog dis-
plays the beginning station value of the active alignment.

2. Select Synchronize Starting Stations in the Vertical and Superelevation Alignments 
section.

3. Set the beginning station of alignment SH 86 by keying in 125+25.36 and choosing 
Apply.

4. Verify the change has been applied by redisplaying the stationing using Geometry > 
View Geometry > Stationing and clicking Apply.  Also, check the beginning station 
value of any associated vertical alignments by using the review command.

Note: The options for Vertical Alignments should be considered carefully.  Do Not 
Update will leave the stationing of vertical application stations as is, 
Synchronize Starting Stations will update their stationing to match that of the 
horizontal and Maintain Station Difference will keep any difference (delta) in 
the current starting stations.

○ InRoads does not require a ‘+’ when keying in a station.  The plus sign will be 
added automatically.
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○ Any point along the alignment can be specified as the location for the input 
stationing value. The alignment location defined by either name or the northing 
and easting fields is the location the input stationing will propagate from.

5. Set the beginning station of alignment SH 86 by keying in 32062.24 and choosing 
Apply.

6. Verify the change has been applied by redisplaying the stationing.  Select Geometry > 
View Geometry > Stationing then click Apply.

Section Summary:

  When stationing is set for a particular point, the stationing for the remainder of the 
alignment (forwards and backwards).

 The reference to Superelevation in the Vertical and Superelevation Alignments area refers 
to geometry created in the 2004 edition of InRoads. It does not affect the superelevation 
contained in the Roadway Designer.
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Lab 3.7 - Station Equations

If there are inequalities in the alignment, station equations may be required. These equations 
can be either gap or overlap equations.

Section Objectives:

 Add a station equation to an existing alignment.

 Redisplay stationing to show the station equation.

1. From MicroStation, select Utilities > Saved Views.  Apply saved view Station Equa-
tion. Once applied, Close the Saved View dialog.
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At the PT of the curve a station equation is necessary to tie to previous work. The values 
are: 
Back   = 356+45.30
Ahead = 356+40.30

2. Select Geometry > Horizontal Curve Sets > Stationing.  The Stationing dialog 
will appear.

3. Verify SH 86 is the horizontal alignment.

4. At the bottom of the dialog, choose New. 

 

5. In the resulting box, set the Mode to By Station.

6. Enter the Back Station and the Ahead Station as shown below.

 

7. <D> Apply.
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8. <D> Cancel to close the Add Station Equation dialog. The station equation will be 
shown in the parent dialog.

9. <D> Close in the Stationing dialog.

10. Redisplay the stationing for alignment SH 86.
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Note: The ahead station must be prefixed with an equation name. The name must consist 
of at least one alpha character.

○ An alignment can contain multiple station equations.
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○ Annotation of stationing lying within the range of a station equation will be 
prefixed with the equation name. If the prefix is undesirable, toggle on Drop 
Station Equation Name in the View Stationing dialog and redisplay the 
stationing.
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Section Summary:

 Station equations are used to change the stationing from a given spot forward, along the 
alignment. Stationing prior to the equation retains its original stationing.

 The ahead station must have a prefix, containing atleast 1 letter, followed by the new 
station number.

Lab 3.8 - Horizontal Alignment Tracking

Two methods exist for receiving interactive information relative to a horizontal alignment. 
Both methods report on stationing, offset, elevation, etc.  One method reports the elevation of 
the active surface, the other reports the elevation of the active vertical alignment.

Section Objectives:

 Demonstrate the Tracking command.

 Demonstrate the Tracking Horizontal Alignments command

Horizontal Alignment & Surface Elevation Tracking

1. Recall Saved View Side Road.

In addition to reporting on station and offset information relative to the active alignment, 
the following method will report on information relative to the active surface.

2. Select File > Open and load the surface 12345SURV_Surface_Existing.dtm from the 
C:\Projects\12345\ROW_Survey\InRoads\DTM folder. 
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3. Select Tools > Tracking > Tracking to track both the active horizontal alignment and 
information relative to the active surface.

4. Select Activate to initialize the command. Slide the cursor along the alignment to 
interactively update the display in the Tracking dialog.  If a <D> (data point) is entered in 
the design file the information toggled on is displayed graphically.

Note: Select the Settings button in the Tracking dialog to examine the attributes 
assigned to annotation placed in the MicroStation design file.

Horizontal & Vertical Alignment Tracking

The second method tracks the station and offset relative to the active horizontal alignment 
along with the elevation of the active vertical alignment.  Station, Offset, and Elevation 
information is displayed in the message field of the InRoads interface. 
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1. Select Tools > Tracking > Horizontal Alignment to track the active horizontal align-
ment.

2. The results display in the status bar of the InRoads interface.

Note: The readout interactively reflects the location of the cursor relative to the active 
alignment. If a second horizontal alignment is selected with a data point, <D> the 
offset displayed will be relative to the two alignments perpendicular to the active 
alignment.

Section Summary:

 Use the Tracking command to get surface information in relation the the horizontal 
alignment.
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 The Tracking command can be used to display the information in its dialog box as 
MicroStation graphics. 

 The tracking Settings options are used to disable the graphic display of items in the 
Tracking  dialog box.

 Use the Horizontal Alignments tracking to get vertical alignment  information in relation 
the the horizontal alignment.

 Horizontal Alignments tracking can not be displayed graphically.

Chapter Summary:

 Alignments can be displayed using the View and View All Horizontals from the right click 
menu or from the main tool bar, or by using the horizontal alignment annotation command.

 Use the preferences to set up the Stationing dialog.  Items in the Stationing dialog box 
should only be changes for special circumstances.

 Use the Stationing options under the Horizontal Curve Set commands to change the 
stationing for the entire alignment.

 Use station Equations to change the stationing from a point on the alignment to the end.

 Tracking is used to gain station and offset information at the cursors location.

 Tracking also collects sufrace data, while Horizontal Alignment tracking gets vertical 
alignment data.
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This lab illustrates some of the common commands used to manage geometry for a project.

Chapter Objectives:

 Copy a geometry project.

 Rename alignments.

 Transpose alignments.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\ROW_Survey\InRoads\InRoads\12345SURV_Fieldbook.alg

Lab 4.1 - Copy a Geometry Project

Section Objectives:

♦ Access a Geometry Project created by the Survey/ROW discipline. 

♦ Save the renamed Geometry Project in the Design project folder (vs. the Survey 
folder).

♦ Rename horizontal alignment names, add/modify descriptions, and review the 
geometry styles assigned to the alignments.

1. From the Geometry tab in the InRoads Explorer window, right-click on Geometry 
Projects and select Open from the shortcut menu.

2. Navigate to the directory C:\Projects\12345\ROW_Survey\InRoads\Geometry.
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3. <D> the Geometry Project 12345SURV_Fieldbook.alg.

4. <D> Open then Cancel button. The Open dialog will close.

At this point, a ‘copy’ of the survey geometry project is loaded into memory. The following 
steps will rename the geometry project and save this copy in the Design discipline folder.

Note: Loading a file into InRoads makes it the active entity by default.
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5. Select Geometry > Copy Geometry.

6. On the Projects tab, in the From section select 12345SURV_Fieldbook01.

7. In the To: field key in FB-Working Copy.

8. In the Description: field key in Copy of Survey data.

9. <D> the Apply then Close buttons.

10. Verify the copy is created by checking the InRoads Explorer pane.
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11. In the InRoads explorer window, <R> on the FB-Working Copy geometry project and 
select Save As… from the shortcut list.  The Save As dialog will appear.

12. Navigate to the C:\Projects\12345\Design\InRoads folder.    If necessary, use the 
drop-down arrow in the Active field and reselect the desired name to ensure the saved file 
name will match the active surface name.

13. <D> the Save then the Cancel buttons. The Save As dialog will close.
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Note: Ensuring that the saved Geometry name in the project folder matches the 
Geometry name displayed in InRoads explorer will minimizes confusion.

14. The original geometry project generated by the survey staff is no longer required.  In the 
InRoads explorer window, <R> on the geometry project name 12345SURV_Fieldbook 
and select Close from the fly-out menu.

Note: This will ‘unload’ the geometry project from memory. It does not delete any files 
from the hard drive.

15. <D> Yes and verify the geometry project is removed from memory.

Section Summary:
♦ Specialty groups using ROW/Survey geometry files should always make their own 

copy of the original data.

Lab 4.2 - Renaming Alignments

In the case of the geometry project copied in the previous exercise, the horizontal alignment 
names (and geometry styles) were assigned when the survey fieldbook was exported based on 
the InRoads Survey feature table (FWF file).  These attributes are assigned based on the feature 
coding assigned in the field. These names accurately reflect the coding used in the field, but 
could benefit from more intuitive naming. 
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Section Objectives:

♦ Modify the alignment names assigned to some the roadway centerline shots, add 
descriptions, and assign appropriate Geometry Styles.

Graphics clean-up

Before continuing with this lab, delete all visible graphics in your MicroStation file using the 
element selection tool or a fence. Note that you are deleting the graphical display of data, not 
the data itself. The graphics could be redisplayed using the InRoads display commands shown 
in previous sections.

Note: The screened topography and the training guides are either locked graphics or in an 
attached reference file, you will not be able to delete these graphics and will use them 
for orientation.

Renaming Horizontal Alignments

1. Right click on the InRoads icon in the top left corner of the view window and choose View 
Save/Recall from the shortcut menu.

2. From the Saved View dialog box click on Survey Alignments.



Colorado Department of Transportation   Page 89

Labs for ROW Geometry & Plans LAB 4 - Geometry Management

3. Click on Apply and then Close.

4. Verify that the view name includes Survey Alignments.  The view window should look 
similar to the following image.
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5. Display alignments 13205 & 131979 by righ clicking on the alignment and choosing 
View from the shortcut window.

The the alignments should show up in the view window as shown below.

6. Select Geometry > Rename Geometry.  The Rename Geometry dialog will appear.
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7. From the Type: drop-down list select Horizontal Alignment.

8. In the From section, verify the Geometry Project is FB-Working Copy.

9. In the From section list locate and <D> on alignment 131979.

Note: This alignment represents the centerline of existing pavement.

10. In the To section key in the Name: Ex CL Seg A.

11. In the To section key in the Description: Ex centerline segment A.

12. In the To section set the Style: ALG_EXISTING.

13. <D> the Apply button a confirmation dialog will appear.

14. <D> the Yes button.

15. Rename the centerline alignment 13205 as follows:

Note: You can use the dialog selection icon    to graphically identify the alignments for 
renaming.

♦ 13205
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♦ Name: Existing CL Seg B
♦ Description: Ex centerline segment B
♦ Style: ALG_EXISTING

Important! Profile or Cross Section sets that were created based on the original 
alignment names will lose their linkage to the alignment names after 
renaming of the alignments.  Geometry renaming should be accomplished 
prior to the generation of Profile or Cross Section sets.

16. When done renaming the alignments Close the Rename dialog and check the InRoads 
explorer window to verify the results.

Renaming Vertical Alignments

Two horizontal alignments have been renamed, a description has been added and the 
alignments are assigned an appropriate geometry style.  Horizontal alignments are ‘parent’ 
alignments which can contain ‘child’ vertical alignments.

17. In the Workspace bar under the Geometry tab check the horizontal alignments for 
associated vertical alignments by expanding the + icon.

18. Select Geometry > Rename Geometry.  The Rename Geometry dialog will 
appear.
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19. From the Type: drop-down list select Vertical Alignment.

20. In the From section verify the Geometry Project is set to FB-Working Copy.

21. In the From section verify the active Horizontal Alignment is set to Existing CL Seg A.

22. In the From section Vertical Alignment list locate and <D> on alignment 131979.

Note: This alignment represents the vertical elevations of existing pavement.

23. In the To section key in the Name: Existing Pavement.

24. In the To section key in the Description: Surveyed elevations.

25. In the To section set the Style: ALG_EXISTING_Vert.

26. <D> Apply then <D> Yes button.

27. Now set the active Horizontal Alignment to Existing CL Seg B to rename the vertical 
alignment associated with the horizontal alignment Existing CL Seg B.

Note: You can use the dialog selection icon    to graphically identify the alignments for 
renaming.

28. In the To section key in the Name: Existing Pavement.

29. In the To section key in the Description: Surveyed elevations.
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30. In the To section set the Style: ALG_EXISTING_Vert.

31. <D> Apply then <D> Yes button.

32. <D> Close the Rename Geometry dialog.

These changes have been made in a copy of the geometry project that was exported from the 
survey fieldbook. In this copy, some key horizontal and vertical alignments have been renamed, 
described, and assigned appropriate geometry styles to conform to CDOT standards with a 
naming convention that is more intuitive.
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This is a good time to save the Geometry Project to disk.

33. <R> on the geometry project FB-Working copy and select Save As from the fly-out 
menu.

34. This will overwrite the geometry project FB-Working Copy stored in the folder 
C:\Projects\12345\Design\InRoads.

Section Summary:
♦ Rename Geometry is used to rename geometry, add or revise a description, and/or 

update the associated style.

Lab 4.3 - Transposing Alignments

Transposing an alignment reverses the direction of that alignment. Tangent sections are 
reversed and left-hand curves become right-hand curves. The beginning stationing value is 
retained; however, any station equations previously defined are deleted.  Associated vertical 
alignments are also reversed.

You may find the need to transpose an alignment if it was surveyed in a direction opposite from 
the direction you wish to design (up-stream vs. down stream). Other instances may be if you 
create an alignment by importing from graphics. InRoads will generate the alignment in the 
direction the MicroStation graphic was drawn which is not necessarily in the direction of ‘up-
station’. Or you may simply create an alignment in the wrong direction using any of the 
InRoads geometry commands.

Section Summary:
♦ Change the stationing direction using the Transpose command.

1. Use the review tools to evaluate both of the renamed horizontal alignments. What direction 
are the tangents running?
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♦ You should notice that the alignment Existing CL Seg A runs northwest and that 
alignment Existing CL Seg B runs southeast.

♦ Alignments created by exporting an electronic fieldbook assume the direction of the 
data collection.

♦ Both alignments should run in a Southeasterly direction.

2. Select Geometry > Utilities > Transpose.

3. Select alignment Existing CL Seg A for transposing <D> Apply.
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4. Review the alignment to verify the transposition.

5. Save the geometry project FB-Working Copy.

Section Summary:
♦ Always review geometry after making changes like Transpose to ensure that the 

command was completed as desired. 

Chapter Summary:

 Take care not to inadvertently edit or delete other group’s work. Communication is the key 
to reducing data loss.

 Survey geometry has name meaningful to them, but possibly not to other groups. Rename 
your copy of survey’s geometry data.

 The direction of an alignment can be changed using the transpose command. Set the 
alignment to the direction that makes the most sense for the design.
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Although there are multiple methods for creating horizontal geometry in InRoads, this lab will concentrate on 
the using the horizontal curve set commands and Importing geometry from graphics.  Additional methods 
covered in the Geometry for ROW course include joining cogo points together and the traversing commands.

Another aspect of this lab is to learn how to modify or create new geometry from geometry features that exist 
in a geometry project.  An example of this would be to create parallel/offset alignment such as a centerline to 
represent the edge of road or other feature that parallels the centerline.

Chapter Objectives:

 Create a new geometry.

 Create alignment tangents.

 Define alignment curves.

 Learn how to define and modify alignment stationing.

 Annotate an alignment.

 Create a horizontal alignment form graphics.

 Modify an existing alignment.

 Create parallel horizontal alignments.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\ROW_Survey\InRoads\InRoads\12345SURV_Fieldbook.alg

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

A predefined workflow for creating geometry is not dictated by InRoads.  However, a typical workflow might 
be:

1. Create or open an existing geometry project

2. Create horizontal alignments (or Cogo points)

3. Assign stationing for alignments

4. Define alignment station equations, if any

5. Define alignment key-points (unique points of interest)

6. Review alignments

7. View created alignments

8. Display stationing for alignments

9. Annotate created alignments

Before continuing with this lab, delete all visible graphics in your MicroStation file using the 
element selection tool or a fence. Note that you are deleting the graphical display of data, not 
the data itself. The graphics could be redisplayed using the InRoads display commands shown 
in previous sections.
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Note: The screened topography and the training guides are either locked graphics or in an 
attached reference file, you will not be able to delete these graphics and will use them 
for orientation.

Lab 5.1 - Review Geometry from Survey

Section Objectives:

♦ Understand the difference between Named and Unnamed cogo points and how to apply 
cogo point names

1. Start InRoads using your desktop icon and opening the file 12345DES_Model.dgn from 
the C:\Projects\12345\Design\Drawings\Reference_Files\ directory.

2. Open up the InRoads Options dialog box from the menu bar under Tools > Options and 
review the settings in the Geometry tab.

Note: For descriptions of each of the items in the Geometry tab, refer to the Practical 
Guide for Using InRoads.

3. Load the geometry project 12345DES_Design.alg from the folder 
C:\Projects\12345\Design\InRoads\.
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Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states:

♦ Unnamed

♦ Named

♦ Cogo Points

4. Review the horizontal alignment and notice that many points on the alignment are not 
named.
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Note: If Point Name During Edits is set to Named on the Geometry tab of the Options 
dialog box, alignment key-points are generated with a name based on the next available 
ID as specified in the Seed Point Name field.   The specified seed point name can be 
alpha, numeric, or alphanumeric characters. The assigned name is also reserved in the 
Cogo buffer.  However the point is not written to the Cogo Buffer automatically.

5. To create point names for all alignment key points and add them to the Cogo Buffer, select 
Geometry > Horizontal Curve Set > Events.

6. In the Horizontal Events dialog box, toggle on Alignment Point to Cogo in the Add As 
section.

7. Key in 200 for the Seed Name:, Proposed Alignment for Description:, and select 
ALG_PRO for the Style:.

8. Click Apply.
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A Results dialog box will appear with the new point name and the associated coordinates of 
the point.  All alignment key points that were not previously assigned a name are written to 
the Cogo buffer beginning with the ID number of 200.

Note: The command Geometry > Utilities > Assign Names can also be used to add, 
delete, or rename geometry points.

9. Close the Results and Horizontal Events dialog boxes.

Lab 5.2 - Create New Geometry

Section Objectives:

♦ Learn how to create a geometry project and place holders for horizontal geometry data.

Next we will create a new geometry project and a placeholder for horizontal alignment data.

1. From the pull-down menu File > New.

 

2. <D> the Geometry tab.

3. For the Type, choose Geometry Project.

4. In the Name field, key in 12345_Geometry Training.
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5. In the Description field, key in Geometry Training class.

Note: The lower portion of the New dialog displays geometry projects that are currently 
loaded into memory.

6. <D> Apply (Do not Close the New dialog box yet).

Note: InRoads created the geometry project and made it the active geometry project. Any 
horizontal alignments created will be placed in the active geometry project.

7. Verify that the new geometry project was created.

Note: This creates the geometry project where all new alignment data will be stored. At 
this point, it is held in RAM (Random Access Memory). When saved to the hard 
drive, the default extension will be *.alg, as was assigned to previous geometry 
projects.
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8. Use the following data to create a place holder for horizontal geometry data.

♦ Type:  Horizontal Alignment
♦ Name:  Design Alt 1
♦ Description:  Alignment by PI method
♦ Style:  ALG_PRO
♦ Curve Definition:  ARC

9. <D> the Apply then Close buttons.

10. Verify the horizontal alignment is created in the active geometry project.

11. From the MicroStation pull-down menu select Utilities > Saved Views.
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12. From the Saved Views dialog <D> saved view name SH 86 ALT 1.

13. <D> the Apply button.

Points A-M represent the required location of alignment PI’s. 

Horizontal curve set commands will be used to create the horizontal alignment. The steps 
will be used to construct the tangents, then insert curves between the tangents once 
constructed.



Note: The following labs will step you through creating an alignment using the Horizontal 
Curve Set, or PI method. While these exercises are based on a roadway alignment, the 
tools and logic apply to any new alignment whether it is for drainage, utilities, 
pavement marking, bridge geometry, parcels, or any other purpose. 

Note: For orientation screened graphics and curve radius values are shown for the alignment 
that will be created.
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Lab 5.3 - Create Alignment Tangents

Section Objectives:

♦ Learn how to create horizontal alignments from PI to PI. 

The first toolbox that we will use is the Horizontal Curve Set commands.  These commands 
present an easy way to create alignments. They consist of five primary commands described 
below and may be accessed from a toolbar (shown) or from the pull-down menu under 
Geometry > Horizontal Curve Set.

Add PI is used to create a PI that begins a new alignment, or to add a PI onto either end of an 
existing alignment thereby extending it.

Insert PI is used to add a PI to an existing alignment between two existing PIs.

Move PI is used to change the location of a PI previously established.

Delete PI is used to remove a PI from an existing alignment. For removing more than one PI, 
you must choose and Accept each one individually. To remove all PIs associated with an 
alignment, but leave the alignment name, right-click on the alignment name in the Explorer 
menu and choose Empty.

Define Curve is used to either establish curves or to edit curves previously defined.

Stationing for establishing stationing or station equations along an alignment

Events are used to establish unique locations relative to an alignment, Cogo points, or the 
assignment of Cogo points along an alignments keypoints.

In this lab you will create an alignment using the Horizontal Curve Set, or PI method. First 
input the tangent sections of the alignment by selecting locations graphically. This is 
accomplished by <D> at the desired location. Once the tangents are in place, curves between 
these tangents will be defined.
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1. Before beginning, verify the proper alignment is Active. This is necessary as any geometry 
entered will be populated in the active alignment.

Design Alt 1 should be the active alignment. If not, several options exist to define it as the 
active alignment.

♦ Right-click <R> on the horizontal alignment name and select Set Active from the fly-
out menu.

♦ From the pull-down menu, select Geometry > Active Geometry and use the 
resulting dialog to set the active alignment.

2. To clear the MicroStation view turn Off the Reference Display for the 
12345SURV_Topo100Scale01.dgn in the References dialog box.

3. Select Geometry > Horizontal Curve Set > Add PI.  You are prompted in the 
MicroStation status bar to Identify Alignment End.
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4. <T> and <D> at point A (tentative or snap, and Data point). The alignment interactively 
displays as you move the cursor.

5. Continue to issue a series of points <T> and <D> through points B-M.

6. <R> (reset) when complete.

7. If the alignment created does not pass through points A-M, use the Insert, Move, or Delete 
PI commands from the Horizontal Curve Set tools to correct the locations.
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8. Review the new alignment using Geometry > Review Horizontal…

Following is a summary of the PI locations

Note: Results may vary based on the specific PI locations defined by the user.

The next lab teaches how to define the horizontal curves.

Lab 5.4 - Define Alignment Curves

Section Objectives:

♦ Learn how to add curves to horizontal alignments using various methods

♦ Learn how the Curve Calculator is useful in calculating an unknown curve radius

The Define Horizontal Curve Set command is used to create curves between alignment 
tangents or to revise existing curve definition. The Previous and Next buttons can used to step 
sequentially through the alignment. The Select button can be used to graphically identify an 
alignment location for editing.  As alignment components are selected, they highlight in the 
MicroStation view. 

PI NORTHING EASTING BEARING DISTANCE STA.
A  1,558,417.74  3,267,409.40   0+00.00
B  1,558,457.06  3,268,756.14  N 88°19'39.62" E  1,347.31' 13+47.30
C  1,558,469.66  3,270,669.73  N 89°37'21.60" E  1,913.63' 32+60.94
D  1,558,050.59  3,272,645.47  S 78°01'28.88" E  2,019.69' 52+80.63
E  1,556,982.55  3,276,540.43  S 74°39'56.80" E  4,038.75' 93+19.38
F  1,556,716.98  3,277,527.47  S 74°56'25.98" E  1,022.14' 103+41.51
G  1,555,931.76  3,280,408.64  S 74°45'18.96" E  2,986.25' 133+27.77
H  1,555,939.60  3,282,135.29  N 89°44'23.81" E  1,726.67' 150+54.44
I  1,555,699.32  3,283,343.64  S 78°45'12.06" E  1,232.01' 162+86.44
J  1,554,474.27  3,288,508.48  S 76°39'23.63" E  5,308.14' 215+94.58
K  1,553,821.34  3,290,431.45  S 71°14'44.01" E  2,030.79' 236+25.37
L  1,553,315.19  3,291,416.57  S 62°48'22.55" E  1,107.55' 247+32.92
M  1,553,346.54  3,293,367.43  N 89°04'46.05" E  1,951.11' 266+84.03
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1. Select Geometry > Horizontal Curve Set > Define Curve.  The first two tangents 
A-B and B-C highlight.

2. Key in Radius 1: 21120.

3. <D> the Apply button.  The curve is created and displays.

4. <D> the Next button.  Tangents B-C and C-D highlight.

5. Key in Radius 1: 3000.

6. <D> the Apply button.

7. Repeat steps 4-6 for the curves at locations:

D  Radius = 11,000.00
E   Radius = 3,000.00
F   Radius = 3,000.00
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For the first 5 curves, radii were input to define the curves. For the curve located at point G, the 
degree of curve is the known component (along with the external deflection angle). Use the 
Curve Calc…. button to solve the curve data.

8. <D> the Next button to define the curve at point G.

9. <D> the Curve Calc… button.

10. Set Compute: to Simple Curve.

11. Calculate based on a 5 degree 30 minute 17 second curve.

12. Key in 5 30 07 for the DOC: the field and verify that the Lock field is Checked On. 
(Verify the Radius option is unlocked and that only 2 fields shown below are locked).

13. <D> Compute.

Notice the changes that occur in the dialog.
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14. <D> OK. The Curve Calculator dialog will close and the calculated radius will be 
populated in the Radius 1 field in the parent dialog.

15. <D> Apply and the curve will be created.

The next curve (location H) will also be developed using the degree-of-curve. However a short-
cut will be used to generate the input for the Radius 1 field.
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16. <D> Next to select the tangents on either side of point H.

17. In the Radius 1: Field Key in D 2-23-14.

18. Press the keyboard <TAB> key to leave the field. The radius (2400.10) will compute for the 
selected location.

19. <D> Apply to form the curve.
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20. If time permits, complete the remainder of the curves as noted in the drawing and listed 
below:

I   Radius = 15,000.00
J   Radius =   5,000.00
K  Radius =  3,000.00
L   DOC =  3-34-52

21. Review the alignment data select Geometry > Review Horizontal.

Lab 5.5 - Alignment Stationing

Section Objectives:

♦ Understand how to change the assigned stationing of an alignment.

The default station value assigned to the start of a new alignment is 0+00. Redefine the 
beginning station to 100+00.00

1. Select Geometry > Horizontal Curve Set > Stationing.

2. Key in Starting Station: 100+00. (Can be entered as 10000 and then tab out of the field)

3. <D> the Apply button.

4. Verify your results using both of these methods:

♦ Geometry > Review Horizontal
♦ Tools > Tracking > Horizontal Alignments
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5. Select Geometry > View Geometry > Stationing.

6. <D> the Preferences button.

7. <D> the saved preference name Proposed-100 Ft Interval.

8. <D> Load and Close.
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9. <D> the Apply button from the View Stationing dialog.  Stationing is displayed.

10. Experiment with changing the global scale factor value for text and redisplaying the 
stationing.

Lab 5.6 - Annotating an Alignment

Section Objectives:

Understand the difference between Named and Unnamed cogo points and how to apply cogo 
point names.

♦ Learn how to annotate an alignment.
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1. Select Geometry > View Geometry > Horizontal Annotation.

2. Verify the settings as shown above and click Apply to display alignment information.
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3. Review the results in MicroStation.

Challenge Exercise:

1. Use Geometry>Copy Geometry to copy alignment Design ALT 1 to a new 
horizontal alignment named Design ALT 1 Modified.

2. Perform the following actions to the copied alignment:

♦ Move an alignment PI

♦ Redefine one or more horizontal curves

♦ Define alignment stationing as ending at station 382+00

♦ Redisplay stationing at a 500 foot interval

♦ Introduce 2 station equations; one overlap and one gap.

♦ Revert the alignment to a simple PI at point B (remove the curve definition)

♦ Transpose the direction of the alignment

♦ Create a profile showing the existing ground profile along the copied alignment with a 
2x vertical exaggeration

Lab 5.7 - Horizontal Alignment from Graphics

Section Objectives:

♦ Learn how to create a new horizontal alignment from MicroStation graphics.

Alignments can be created from existing MicroStation graphics. In this exercise a chained 
MicroStation element will be used to create an alignment.

1. From the MicroStation pull-down menu select Utilities > Saved Views.
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2. From the Saved Views dialog <D> saved view name Holder Driveway.

3. <D> the Apply button.

4. Select File > Import > Geometry.  The Import Geometry dialog will open.



Colorado Department of Transportation   Page 121

Labs for ROW Geometry & Plans LAB 5 - Horizontal Alignments

Horizontal Alignments, Horizontal and Vertical Alignments, Cogo Points or Event Points 
can be imported from MicroStation graphics. If the alignment has curves, it is 
recommended to toggle on Resolve Gaps and Nontangencies. If the alignment was 
drawn as a series of lines and/or arcs that have not been chained together as complex 
elements toggle on All Selected Elements Added to Single Alignment (you must 
define a Fence or Selection Set of the elements).

After specifying the Name, the Description and the Style, choose Apply. If you 
created a Selection Set or defined a fence prior to initializing the command, you will be 
asked to Accept the contents. If this was not done, you’ll be asked to identify the element. 
In either case, after accepting, an alignment or alignments will be added to the geometry 
project specified in the Target section.

5. Fill in the following information on the From Graphics tab:

♦ Type: Horizontal Alignment
♦ Name: Holder Driveway
♦ Description: Driveway at Sta 190+80 RT
♦ Style: ALG_SECONDARY
♦ Geometry Project: 1234_Geometry Training

6. <D> the Apply button.  The Import Geometry dialog will minimize allowing you to 
see more of your MicroStation view.
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7. When prompted to Identify Element <D> on the MicroStation graphic drawn in the center 
of the driveway.

8. <D> again to accept the highlighted graphics in the MicroStation view.

9. <R> in the MicroStation view to terminate the command.  The Import Geometry dialog 
will restore.  The MicroStation graphics have been imported as an alignment.

Note: The geometry name field increments for additional selection(s).

10. <D> the Close button to close the Import Geometry dialog.

11. Verify the alignment was created.

12. Review the alignment using Geometry > Review Horizontal.

13. When finished Close the dialog box.

14. Time permitting, display the alignment graphics, stationing, and curve information.
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Lab 5.8 - Extend Alignment

Section Objectives:

♦ Learn one of the tools used to modify existing alignments.

The alignment Holder Driveway does not intersect the reference line alignment Design Alt 1.  
Standard practice necessitates the driveway alignment to commence at the main-line reference 
line.

1. Select Geometry > Utilities > and hold.

Note: If the commands for Trim and Extend Alignment are not listed in the menu, this 
means that they are not enabled.  These 2 commands are an extension of the 
Horizontal & Vertical Elements command set which must be enabled.

2. Select Tools > Application ADD-Ins.
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3. Enable Horizontal and Vertical Elements Add-In.

4. Once enabled, Select Geometry > Utilities > Extend Alignment.

5. At the prompt: Identify Alignment to extend to, <D> on the alignment Design Alt 1.

6. At the prompt: Identify Alignment to extend, <D> on the alignment Holder Driveway.

7. <D> to accept the presented solution.
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Note: The alignment-alignment intersection is now the initial point of the driveway 
alignment. Because the alignment was edited (extended) from its beginning, the 
initial station value was recalculated and is assigned a station value of -0+12.41. 
The negative value is due to the original points in the alignment retaining their 
assigned station locations.

8. From the pull-down menu Geometry > Horizontal Curve Set > Stationing define the 
driveway beginning station as 3+25.

Challenge Exercises:

♦ Display stationing at a 100 foot interval for Holder Drive.

♦ Display alignment annotation for Holder Drive.

♦ Recall saved view Drive @ 180+00.

♦ Import the graphics representing the driveway centerline into an alignment named 
Drive 180+00.

♦ Use the command Geometry > Utilities > Trim Alignment to remove the portion 
of the driveway alignment that lies north of the main-line reference line.

Note: The order selecting alignments is not important when using the trim alignment 
command and are prompted to select alignments.  However, the location of the 
data point in response to Identify portion to clip will determine both the alignment 
and the portion that will be eliminated.

Lab 5.9 - Saving Geometry

Section Objectives:

♦ Understand the importance of frequently saving InRoads design data.

Alignments cannot be saved individually. They are saved when the geometry project is saved.  
Due to the fact InRoads works on geometry that is loaded in memory, the geometry project 
must be saved at appropriate times.

Geometry projects can be saved using several methods including:

1. From the pull-down File > Save > Geometry Project.  The Save As dialog will appear 
with the Save as type: set to Geometry (*.alg).

2. Verify you are in the correct project directory C:\Projects\12345\Design\InRoads.
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Note: If the geometry project is already saved, then perform a Save operation instead of 
a Save As (see below).

3. The file name should match the Active: name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active: field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an .ALG extension. To minimize 
any confusion between these two names, ensure that the saved Geometry name in 
the project folder matches the Geometry name displayed in InRoads explorer.

4. <D> the Save button and then the Cancel button.  The file will be saved to disk and the 
Save As dialog will close.
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Lab 5.10 - Creating Parallel Horizontal Alignments

Section Objectives:

♦ Learn additional tools for creating alignments.

Offset alignments can be created to generate geometry for elements such as right-of-way limits, 
easement limits, under-drains, retaining walls, bridge decks, etc.

In this lab we will generate right-of-way limits for the mainline road and the side road. The 
Side Road has a right-of-way width of 60’ (30’ on each side of centerline).  The mainline 
alignment has a total right-of-way width of 150’ being 50’ feet north of the reference line and 
100’ south. At the intersection of the right-of-way lines a radius of 15’ is required.

The workflow will consist of using an assortment of geometry commands:

♦ Copying Geometry - used to combine geometry residing in two different geometry 
projects into one project

♦ Multi-Center Curve – to create radius returns

♦ Parallel Horizontal Alignment -  to offset alignments

♦ Join Alignments – to connect separate alignments

♦ Join Elements – to simplify geometry



Page 128 Colorado Department of Transportation

LAB 5 - Horizontal Alignments Labs for ROW Geometry & Plans

The first step is to create alignments relative to both the mainline alignment (SH 86) and the 
side road alignment (Side Road). These two horizontal alignments reside in two different 
geometry projects. To work efficiently, they should reside in a single geometry project. The 
Copy Geometry command is used to achieve this result.

1. Select Geometry>Copy Geometry.
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2. Copy the alignment Side Road from geometry project 12345_Design to the geometry 
project 12345_Geometry Training.

Note: Also copy alignment SH 86 as SH 86 ALT 1 if you feel the mainline alignment 
created by an earlier lab exercise may be problematic.

3. Verify the alignment was copied.

4. Set the geometry project 12345_Geometry Training as Active causing newly created 
geometry to populate this project.

The next step is to generate the radius returns.  This is done by using the Multi-Center Curves 
command.  Begin by creating the radius returns north of the mainline alignment.

5. From the Saved Views dialog <D> saved view name Side Road.

6. Click Apply.
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7. Select Geometry > Utilities > MultiCenter Curve.

8. Choose One Center.

9. Input the following values:

♦ Width 1: 30
♦ Width 2: 50
♦ Radius: 15

10. <D> the Apply button.  Follow the prompts.

11. In the MicroStation view <D> on the Side Road alignment.

12. <D> on the SH 86 alignment.

13. <D> in the Northwest quadrant

14. <D> to accept and create an alignment representing the radius return.

15. Repeat steps 7-12 and <D> in the Northeast quadrant.
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New alignments will be assigned names based on the seed alignment name specified in 
Tools > Options [Geometry].
Two new alignments are created, 1and 2.

Note: Your stationing graphics may appear at a different location than shown above.



The next steps will be to offset the mainline and side road alignments so they match up with the 
returns that were just created.  This is done using the Offset Alignments by Station command.
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16. From the MicroStation pull-down menu, select Utilities > Keyin. The key in browser is 
needed to input the desired station limits and offset distances. Without this, they could be 
defined graphically.

17. From the InRoads pull-down menu Geometry > Utilities > Parallel Horizontal 
Alignment....

18. In the Parallel Horizontal Alignment dialog box toggle on Interactive By Station and 
then click Apply.

19. In the MicroStation view <D> on the mainline alignment.

20. At the prompt Identify First Station/Key in Station, key in 224+00.

21. <D> the Run button or press the Enter key.

22. At the prompt Identify Second Station/Key in Station, key in 224+93.20.

23. <D> the Run button.

24. For Identify Location: key in -50 (50’ to the left).

25.  <D> the in the view window to accept the solution and alignment 3 is created and 
displayed.
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26. Repeat the Geometry > Utilities > Parallel Horizontal by Station command to the 
east of the sideroad using the following data:

♦ Station limits of: 225+86.76 to 227+00, 50’ left of US 86 Alt 1

Note: The station limits can be graphically selected by issuing a data <D> point in the 
MicroStation view. The offset distance can also be graphically selected but using 
the key in field allows a specific distance to be input.

Alignment 4 is created and displayed.

27. Re-execute the command to create the alignments along the Side Road north of the radius 
returns.
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Next we will use the Join Alignment command to connect the alignments created in the 
previous steps single alignments for each quadrant.  This command operates by either 
connecting the components with a straight line segment or by paralleling an alignment to define 
the configuration of the created geometry.

Join alignments 3, 1, & 5 to create the Northwesterly right-of-way limits.

28. Select Geometry > Utilities > Join.

29. Check On Delete Original Alignments. 

Note: The first alignment identified (3) will become the final alignment name and 
alignments (1) and (5) will be deleted upon completion of the command.

30.  <D> the Apply button and follow the prompts.

31. Identify Initial Alignment: <D> on alignment 3.

32. Identify Alignment to Parallel/Skip:  <D> alignment 1 to parallel (overlay) this alignment.

Note: If a reset <R> is issued in the above step, a tangent line would be created from the 
end of alignment 3 to the beginning of alignment 5.  By selecting the alignment 
representing the radius return, a curved section is generated at a zero offset to 
alignment 1.

33. Identify Next Alignment: <D> on alignment 5.

34. Accept or Reject: <D> to accept the dynamic display.
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35. Reset <R> <R> twice to terminate the command.

Alignment 3 is now the combination of the alignments 3, 1, and 5. Alignments 1 and 5 are 
removed from the geometry project.
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36. Review alignment 3.

37. Using the same steps above, join alignments 6, 2, and 4 to create the northeasterly right-of-
way limits; begin with alignment 6.

Once the above step is completed, alignments 3 and 6 define the right-of-way limits on the 
north side of the intersection.

Another method of creating parallel alignments is by element instead of by station.

38. Choose Geometry > Utilities > Parallel Horizontal by Element.
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Parallel by Element differs from by Station in that you can select the limits of the 
alignment to offset by selecting, <D>, alignment components (tangent or curve) to define 
the desired limits.
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Once the horizontal alignment is defined, then the profile and vertical alignment can be created. Profiles are a 
graphic representation of a surface along the path of the horizontal alignment. Profiles are also used to create 
and display vertical alignments.

Chapter Objectives:

 Review an existing vertical alignment.

 Create a profile.

 Update the profile with a variety of features.

 Display profile annotation data.

 Use vertical alignment tracking.

 Create a new vertical alignment.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 6.1 - Reviewing Vertical Alignments

Section Objectives:

♦ Examine the Review Vertical Geometry window.

♦ Explore the functionality of the dialog box.

Reviewing vertical alignments is similar to reviewing horizontal alignments.  The Review 
Vertical Alignment dialog allows you to easily change between multiple Geometry Projects, 
Horizontal, and Vertical alignments.
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1. Select Geometry > Review Vertical.

2. The review dialog can also be opened with the right-click fly-out menus.

Section Summary:
♦ Reviewing vertical alignments works the same as reviewing horizontal alignments.

Lab 6.2 - Creating Profiles

Prior to graphically displaying a vertical alignment a profile must be created.  These are 
referred to as profile sets in InRoads. A profile set can be created using a horizontal alignment, 
a MicroStation element, or interactively to define the horizontal (plan) location the vertical 
information is extracted from.  Upon creation, a profile can display DTM surfaces, vertical 
alignments and DTM features. Once created, a profile set can be refreshed to display additional 
data, turn the display or data off, or to redraw the graphics based on current DTM information.



Colorado Department of Transportation   Page 141

Labs for ROW Geometry & Plans LAB 6 - Profiles and Vertical Alignments

Section Objectives:

♦ Examine the profile dialog box.

♦ Select profile Preferences.

♦ Display vertical alignment annotation.

Prior to creating a profile set, load the DTM 12345Surv_Surface_Existing if not already 
loaded.  This surface will be used to display an existing ground-line.

1. Select File > Open.

2. In the workspace bar under the Geometry tab, verify that 12345_Design is the active 
geometry project and that the horizontal alignment SH86 is the active alignment.

Note: To make something active, <R> on the name and select Set Active from the fly-out 
menu.
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3. Select Evaluation > Profile > Create Profile the Create Profile dialog will appear.

4. <D> the Preferences button.  The Preferences dialog will appear.

5. <D> the predefined settings for 2x vertical.

   

6. <D> the Load then Close buttons.

Note: Load preferences before making any other menu settings. Loading Preferences 
resets all menu settings to those predefined in the preference.

7. Note the Exaggeration specified.
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8. Verify that in the Surfaces portion of the dialog, the Display box is checked for surface 
12345SURV_Surface_Existing.

9. <D> the Source leaf. Verify that the SH 86 alignment is selected.

10. <D> the Apply button.  The Create Profile dialog will temporarily minimize.
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11. You are prompted by MicroStation to ‘Identify location’. <D> in the MicroStation view.  
The Profile window will be placed and the Create Profiles dialog will restore.

Note: For convenience, we are displaying the profile in our current drawing.  Standard 
practice dictates that separate drawings should be created for profile and cross 
section display.  Consult the directory structure and file naming convention for 
your specific discipline to determine standards relating to profile display.

Viewing Vertical Alignments

12. Select Geometry > View Geometry > Active Vertical to display a graphic of the 
active vertical alignment.
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♦ Alternately in the Workspace Bar under the Geometry tab you can <R> on the Vertical 
Alignment and select View just as you did with Horizontal Alignments.

 

Note: Annotation size for the index elevations and stationing text is generated based on 
the global scale factor defined for text.  The text size specified should be set based 
on the ultimate plotting scale.  To change text size on a profile, delete the displayed 
profile, change the global scale factor, and regenerate the profile display.

Annotating Vertical Alignments

Similar to horizontal stationing, annotation of vertical alignments is accomplished much the 
same way.
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13. Select Geometry > View Geometry > Vertical Annotation to view vertical 
alignment annotation.

14. Verify the appropriate Horizontal, Vertical Alignments, and Profile Set are correctly 
identified.

15. Click Apply.
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16. Take some time and investigate the remaining tabs along the top of the View Vertical 
Annotation dialog and the individual settings for each.

17. <D> the Points tab. Note the settings in the Symbology portion of the dialog. By default, 
Symbology for a Proposed alignment loads.

18. <D> the Preferences button.

19. <D> the name Existing.

20. <D> the Load then Close buttons.
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21. Note the change in the defined Symbology.

22. <D> the Apply button from the View Vertical Annotation dialog. Review the results in the 
MicroStation drawing. The content of the graphics should remain the same, however, 
different levels, color, style, and weight are utilized.

23. For practice, continue to Load and Display additional preferences.

24. Investigate what levels the elements are being placed on.  The various preferences 
determine the location of graphics.

Section Summary:
♦ Use the Preferences to make the major settings in the Create Profile and Vertical 

Alignment Annotation dialog boxes.

♦ View Active Vertical only displays the geometry elements that make up the vertical 
alignment.

♦ Vertical Alignment Annotation displays the geometry elements and text data that 
describe the alignment.

Lab 6.3 - Updating Profiles

When a profile is created the user has the option to display items such as: multiple surfaces, profile lines offset 
from the horizontal alignment, and features such as underground utilities and pipes. However, the Create 
Profile command does not allow the user to specify which features are displayed.
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The Update Profile command should be used to add, remove, or update data within an existing profile set.  This 
command allows the user to specify which features will be affected by the command and can also be used to 
update and surface data that has changed since the profile was created.

Section Objectives:

♦ Use the Update Profile command to add features to the display.

♦ Illustrate how Global Scale Factors affect cell size.

♦ Examine how Feature Filters affect dialog box lists.

1. From the pull down menu Evaluation > Profile > Update Profile.  The Update Profile 
dialog will appear.

2. <D> the Crossing Features leaf.

3. Verify SH 86 is the active Profile Set.

4. In the Mode section toggle the radio button Display On.

5. In the Surfaces section <D> 12345SUR_Surface.



Page 150 Colorado Department of Transportation

LAB 6 - Profiles and Vertical Alignments Labs for ROW Geometry & Plans

6. <R> in the Crossing Features list and select All from the menu.

7. <D> the Apply button.  Using MicroStation viewing tools locate a crossing culvert.

Note: Profile and cross section displays are drawn at true horizontal scale.  A vertical 
distortion will be applied to cells displayed in profiles or cross section views based 
on the vertical scale applied to the grid.  Some DTM features displayed in these 
graphics are configured to display at their true horizontal (x-direction) sizes. 
Therefore, prior to displaying features in either profiles or cross sections the global 
scale factor for cells should be set to 1.
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Note: Two classes of elements can be displayed on profiles; 1) True scale items such as 
culverts and 2) items represented by text such as utility crossings, flow-lines, 
ROW, etc.

For item 1:

The global scale factor for cells should be set to 1 and a subset of the dtm crossing 
features should be displayed (or refreshed in this case). This is accomplished with 
the use of feature filters.

For Item 2:

The global scale factor should be set equal to the plot scale.

Note: See the following page for information on updating a profile to refresh the 
graphics.

Refreshing a Profile Display

First, take care of refreshing the display of the true-scale items such as the culverts.

8. Select Tools > Global Scale Factors.

9. Key in the field Cell: 1.

Note: You may need to Unlock the icon to allow modification to the cell scale only. By 
doing so, when you update the profile, the cells will draw at their true sizes. 
Leaving the Text field at 100 and Line Style field set to 1. This allows annotation 
and other commands to remain unaffected by the scale factor that was input 
specific for cells.

10. <D> the Apply then Close buttons in the Scale Factor dialog

11. In the main InRoads interface, select the filter CELL_True-Scale from the drop-down list. 
Also toggle On the Feature Filter lock.
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12. Close and reopen the Update Profile dialog.

13. Verify SH 86 is still the active Profile Set.  Use the target button next to the Profile Set to 
graphically change the active profile set.

14. In the Mode section toggle the Refresh radio button.

15. <D> the Crossing Features leaf.

16. <D> the surface name 12345SURV_Surface.
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17. Select all of the Crossing Features listed.

18. <D> the Apply button.

19. Using MicroStation viewing tools, locate a crossing culvert and review the results.

20. Use MicroStation Measuring tools to verify pipe size(s).

21. From the Locks toolbar select CELL_Plot-Scale filter from the pull down list.
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Note: Verify that the feature filter is toggled on.

22. Change the InRoads Scale Factor to 100 for cells.

Note: This is the desired plot scale change accordingly.

23. Close and reopen the Update Profile dialog.

24. Verify SH 86 is still the active Profile Set.  Use the target button next to the Profile Set to 
graphically change the active profile set.

25. In the Mode section toggle the radio Refresh button.

26. <D> the Crossing Features leaf.

27. <D> the surface name 12345SURV_Surface.

28. Select all of the Crossing Features listed.

29. <D> the Apply button.

30. Turn Off the Feature Filter lock.
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Section Summary:
♦ Update Profile is the better tool to use when adding features to a profile.  With Update 

Profile the user can choose which features to display.  With Create Profile, all features 
that can be displayed (based on feature style settings) are displayed.

♦ There are two types of feature cells used in profiles; true scale cells that use a global 
scale factor of 1 and plot scale cell that use a global scale factor the same as the plot 
scale.

Lab 6.4 - Annotating a Feature in a Profile

Features that have been displayed in profiles (or cross sections) can be annotated with 
information extracted from the surface model.

Section Objectives:

♦ Annotate the true scale features in the profile.

1. Using MicroStation commands, window into any culvert displayed in the profile created in 
the previous lab.

2. From the Locks toolbar select CELL_PLOT-Scale filter and verify the feature filter is 
toggled On.

3. Select Evaluation > Profile > Annotate Feature in Profile.  The Annotate Feature In 
Profile dialog will appear.
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4. <D> the Apply button and review the results.

5. <D> the Points branch.

6. Check On the Feature Description.

7. <D> the Apply button and review the results in your profile.

8. Experiment with enabling other options in the Point tab and redisplaying the annotation
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Challenge Exercise:

Update your profile to show projected features. Annotate the projected features.

Section Summary:
♦ Only features displayed in the profile can be annotated.

♦ Set the global scale factor for text to the plot scale before executing the command.

Lab 6.5 - Annotating a Profile

In addition to annotating vertical alignments, profiles can be annotated with both existing and 
design information.

Section Objectives:

♦ Add Existing and proposed elevation information to the profile.

♦ Add Cut Depth and fill height information to the profile.

1. Select Evaluation > Profile > Annotate Profile.
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2. <D> Apply. The existing and proposed grades annotate the profile.

3. Take some time and review the leaves of the Annotate Profile dialog. Investigate the 
remaining tabs and the individual settings for each.

4. Now go back and <D> the Selection leaf.

Note: The dialog shows two categories; Available and Selected.  Available lists the items 
that can be annotated in a profile, Selected identifies the items chosen for 
annotation.

5. <D> the item Cut Depth from the Available list.
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6. <D> the Add button.  Cut Depth will be added to the Selected list.

7. <D> the item Fill Height from the Available list.

8. <D> the Add button.  Fill Height will be added to the Selected list.

Note: Make sure that Existing and Proposed remain in the 1 and 2 slots. To move a 
selected item, highlight the item and <D> the Move Up or Move Down buttons

9. <D> the Apply button and review the profile display.

Note: You may have to zoom out to view the additional annotation.

Section Summary:
♦ Annotate Profile is used to place existing surface elevations and vertical alignment 

elevations on the profile set.

♦ Other data related to profiles can also be displayed.
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♦ When displaying additional data, make sure Existing and Proposed stay at the top of 
the list.

♦ Change the settings on the Frame leaf to move additional data closer to the profile 
window.

Lab 6.6 - Vertical Alignment Tracking

Vertical alignments can be interactively queried similar to horizontal alignments.

Section Objectives:

♦ Examine Vertical Alignment tracking in the profile.

♦ Examine the vertical alignment data in Horizontal Alignment tracking.

Tracking Vertical Alignments in Profile View

1. Select Tools > Tracking > Vertical Alignments.

2. Move the cursor inside the Profile Set window and review the output in the InRoads Status 
bar.

Note: As you move your cursor in the profile view InRoads displays vertical alignment 
information in the status field.  There is not an option to write this information to 
the MicroStation file.
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Tracking Vertical Grades in Plan View - Review

3. Select Tools > Tracking > Horizontal Alignment.

4. Move the cursor along the active horizontal alignment and review the readout in the 
InRoads Status bar.

Results displayed are the station and offset relative to the active horizontal alignment. The 
elevation is relative to the active vertical alignment.

Section Summary:
♦ Tracking is used to gain information that is related to the horizontal and vertical 

alignments.

Lab 6.7 - Create a vertical alignment

Vertical alignments define an elevation path for the proposed design to follow.  It is stored under the parent 
horizontal alignment.

Section Summary:
♦ Create a new vertical alignment slot.

♦ Add PIs to the vertical alignment .

♦ Define the vertical curves.

Create a slot in the active geometry project for your vertical alignment.

1. Select File > New.

2. Choose the Geometry tab.

3. Toggle the Type to Vertical Alignment and set the following:

4. Key in SH 86 V Alt1 for the Name.
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5. Key in Alternate vertical alignment for the Description.

6. Set the Style to ALG_PRO_Vert.

7. Verify that the Curve Definition is set to Parabolic.

8. Select Apply then Close

9. Set up your MicroStation windows so the entire profile is visible in one window, then open 
another MicroStation window and Zoom in to the beginning of the profile as shown.

        

Next, add PVIs to the Vertical Alignment.

10. Verify that the Write Mode is set Pencil.
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11. Select Geometry > Vertical Curve Set > Add PI.

12. Select Apply.

13. For the first PVI, snap to the beginning of the ground line in the window where you are 
zoomed in.

14. In the MicroStation key in field, enter the following commands: (Be certain to use the % 
sign in your key-in.)

♦ dg=900,-3.76%

♦ dg=400,1.03% 

♦ dg=425,-4.29%
♦ se=11725,6574.78 
                               

The dg= key-ins place additional vertical PIs at the specified distance and grade. The last 
one again places a vertical PI at the station and elevation specified.

15. <R> twice to exit, then Close the Add Vertical PI dialog box.

16. Update the view.
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The vertical alignment is displayed permanently in the design file. Because Pencil mode is 
active, the tangents will automatically update when the curves are added. 

17. Select Geometry > Vertical Curve Set > Define Curve.

The Define Vertical Curve dialog box is automatically displayed ready to accept input for 
the first curve on the vertical alignment. To step to other curve sets, you can use Previous 
and Next, or First and Last.

18. Under the Vertical Curve category, 

♦ Set Calculate By to Length of Curve.

♦ Key in 300 for the Length.

19. Select Design Calc.
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20. Click in the Table Name and Browse to the C:\Program Files\Workspace-CDOT\ 
Standards-Global \ InRoads\Design Checks folder and choose the file Vertical 
Design Checks.txt.  

21. Verify that the length of curve meets your design criteria.

22. Choose Cancel when done.  You do not want to accept the minimum curve, just verify 
that yours meets the criteria.
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23. Select Apply

24. Select Next to move to the second intersection of tangents.

♦ Set Calculate By: to Length of Curve.

♦ Key in 250 for the Length.

25. Select Design Calc.

26. Verify that the length of curve meets your design criteria.

27. Choose Cancel when done.

28. Select Apply.

29. Close the Define Vertical Curve Set dialog.

Section Summary:
♦ Vertical alignments are defined in the profile window.

♦ Vertical PIs can be added by data point or key in.

♦ The Define Curve dialog box can also be used to adjust PI stations and elevations.
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Chapter Summary:

 Use the review vertical alignment command to examine vertical alignment data when a 
profile is not required.

 Profiles are required to view vertical alignments graphically.

 Use Update Profile to add, remove, or revise data in a profile set.

 Annotate Feature in Profile only affects features displayed in the profile.

 Annotate Profile is used to display existing surface and vertical alignment elevations in the 
profile.

 Vertical Alignment Tracking displays Station, Offset, Elevation, and Grade information in 
the InRoads main dialog box.

 Typically, vertical alignments are defined by locating all of the VPIs then placing the 
curves.
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LAB 7 - Building Components

This lab demonstrates the various methods of creating components, setting component and point properties, 
and illustrating how point constraints work.  There are three basic options used to create components; simple, 
constrained/unconstrained, and end condition.

Chapter Objectives:

 Build a simple component

 Build a constrained component

 Build an end condition component

 Demonstrate the commonly used constraints; horizontal, vertical, slope, and vector/offset

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 7.1 - Build A Simple Component

Use the simple option to build a regular closed shape component with horizontal and slope constraints such as 
those used for building pavement components. 

1. Open MicroStation and InRoads using the 12345DES_Model.dgn file found in the direc-
tory C:\Projects\12345\Design\Drawings\Reference_Files.

2. Select File > Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\DES12345_Templates.itl from the 
available files.

4. <D> Open then <D> Cancel the Open dialog box.

5. Select Modeler > Create Template from the InRoads menu bar.

Setting up Template Options makes point placement easier.  For this lab, affixes will be turned 
off  so that the component can be used on either side of the template.  The step value will be set 
so to a small value so that when creating a template, components will snap to the correct points.  
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6. Select Tools > Options from the Create Template menu bar.

7. Toggle off Apply Affixes.

8. Set the X and Y Step Options to 0.10. 

9. <D> OK.

The next series of steps creates a new project specific folder to store the components that will 
be created in the lab.  Creating project specific folders in the template library makes easier to 
find project specific components.

10. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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11. <D> <D> on the 4 ‐ Components folder to expand the folder.

12. <R> on the 4 – Components and select New > Folder from the right click menu.

13. Key in 12345 Components for the folder name.

Components are the building blocks of templates.  Create a pavement component using the 
Simple option.  This option is used because it automatically sets up the constraints of the 
component.

14. <R> on the 12345 Components folder and select New  > Template from the right 
click menu.

15. Key in CONC_Lane_12”x12’ for the component name.
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16. <D> on the Dynamic Settings button to display the Dynamic Settings tool settings box.

17. <R> In the Template View window and Select Add New Component > Simple from 
the right click menu.

The next steps define the style that the component will use, the point names, and the origin of 
the component.

18. In the Current Component area, key in CONC_Lane_12”x12’ into the Name field.

19. Set the Style to D_CONC_Pvmt_12in using the drop down menu.

20. Key in 1 for the Thickness.
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Note: This is where the values of all the constraints are set.  If needed, these values can 
be modified later.

21. Move the pointer into the magenta square (this is the template origin and is usually at the 
coordinate 0,0).  Adjust the pointer location until the Dynamic Settings readout is 0.00 for 
both X and Y.

22. <D> to place the element.

C

23. <D> <D> on the origin.  

24. Select Conc_Centerline‐Top from the Name drop down menu.
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25. <D> Apply.

26. <D> Next and rename the remaining points as shown below using the Name pull-down 
menu.

This completes the creation of a simple, closed shaped component with horizontal and slope 
constraints.

Lab 7.2 - Build a Constrained Component

In addition to building regular closed shape components, irregular and/or open shaped components can be 
created using the contrained or unconstrained options for adding components.  They can also be used to build 
linear, non-end condition components.  Use the constrained option to define horizontal and/or vertical 
constraints (such as a horizontal or vertical offset from another point).  Use the unconstrained method to define 
points that don’t depend on other points for their placement.
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1. <R> on the 12345 Components folder and select New  > Template from the right 
click menu.

2. Key in CONC_Shoulder_12”x8’ for the component name.

3. <R> In the Template View window and Select Add New Component > Constrained 
from the right click menu.

4. In the Current Component area, key in CONC_Shoulder_12”x8’ into the Name field.

5. Set the Style to D_CONC_Pvmt_12in using the drop down menu.

When placing constrained or unconstrained components, each point of the component must be 
placed individually.   Use the Dynamic  Settings dialog box is to enter point names, styles, and 
locations.

6. Select Conc_Laneline‐Top from the Point Name drop down menu on the Dynamic Settings 
dialog box.

7. Move the pointer on to the template origin and <D>.  

8. Dynamic Settings dialog box, Select Conc_EOP‐Top from the Point Name drop down 
menu.

9. Change the key in mode to hs= (horizontal distance and slope).
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10. Key in 8,-.02 in the key in field.  This is the horizontal distance and slope from the 
previously placed point.

11. Press the Enter key to place the point.

12. Select ABC_EOP‐Top from the Point Name drop down menu.

13. Change the key in mode to dl= (horizontal and vertical distance from the last entered 
point).

14. Key in 0,-1 in the key in field.  This is the horizontal distance and vertical distance from 
the previously placed point.

15. Press the Enter key to place the point.

16. Select ABC_Laneline‐Top from the Point Name drop down menu.

17. Change the key in mode back to hs= (horizontal distance and slope).
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18. Key in -8,-.02 in the key in field.  

19. Press the Enter key to place the point.

20. <R> anywhere. This dialog box is where you define if the shape is closed or not. 

21. Verify that Closed Shape is toggled On.

22. Select Finish from the right click menu to complete the component.

You should now understand how to create a constrained, closed shaped component.  By 
reviewing the steps above, now you should also be able to also create unconstrained and open 
shaped components simply by choosing different options from the dialog boxes that were 
introduced.

Lab 7.3 - Build an End Condition Component

In theses next steps you will use the end condition option to create a linear component that can seek a target.   
This lab will focus on the point property called End Condition is Infinite. Once you understand the steps to 
evaluate the effects of this property on and end condition, use the same steps to test the effects of other end 
condition point properties.  Many of these properties determine how the component will behave when a target 
is found.

1. Create a new template as described in the previous lab and name it 6to1_Fill.
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2. <R> In the Template View window and Select Add New Component > End 
Condition from the right click menu.

3. Key in 6 to 1 Fill for the Name.

4. Select D_Toe‐of‐Fill for the Style.

Additional component properties are required for end conditions.  These determine what the 
end condition attempts to tie to (the Target) and the order in which it is processed (the Priority).

5. <D> on the Target Type drop down menu.  Examine the options available.

6. Select Surface from the Target Type drop down menu.  

7. <D> on the Surface drop down menu.  Notice that either Active or a particular surface can 
be selected.

8. Select Active from the drop down menu.  This will allow the end condition to solve 
regardless of the surface specified in Roadway Designer.

9. Key in 1 for the Priority.
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Note: This example illustrates an end section with one component.  When there are 
several components defined in an end condition, they are evaluated in order of 
their assigned priority.  A component with a priority of 1 will be evaluated before a 
component with a priority of 2. 

Next, additional point properties, such as point names, will be defined for the end condition.  
Use the Dynamic Settings dialog box to finish defining these properties.

10. In the Dynamic Settings dialog box, select POSS for the Point Name.

11. Move the pointer on to the template origin and <D>.  

12. In the Dynamic Settings dialog box, toggle on End Condition is Infinite.  This option 
allows a component to “stretch” until a target is found.

13. Select Toe‐of‐Fill for the Point Name.

14. Change the key in mode to hs=.

15. Key in 12,-.1667. and press Enter. (This value could also be typed in as 12,-1:6).  

16. <R> and select Finish from the right click menu.

The steps above created a component that will seek a target at a -1:6 slope for a horizontal 
distance up to 12 feet.  However, because the option End Condition is Infinite was toggled On, 
the component ignores the horizontal distance criteria and will seek a target beyond the 12 foot 
limitation.
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17. In the Create Template dialog box, <D> the Test button located to the bottom right of the 
Template View window as shown below.

18. In the Test End Conditions dialog box, <D> the Draw button.

19. Move the pointer up and down in the view area to see how the end condition performs.

Note: The dotted line in the Test End Condition view window shows the component at 
the defined slope and length.  As the proposed surface moves beyond the limits of 
the defined component, the result of the End Condition is Infinite toggled On is 
that the end condition solution expands beyond the original limits of the 
component.  <D> Close.
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20. <D> <D> on the Toe‐of‐Fill point.

21. Toggle off End Condition is Infinite.

22. <D> Apply and <D> Close.

23. <D> Test.

24. In the Test End Conditions dialog box, <D> Draw and notice how the end condition 
behaves.

25. <D> Close.

Note: When the End Condition is Infinite option is Off, the end condition solution is 
limited to the limits of the originally defined component.

26. Select File > Save the Create Template dialog box.

Lab 7.4 - How Point Constraints Work

Point constraints are used to form a relationship between points.  This relationship is used to change the shape 
of the components based on events that occur within the corridor. The following steps will demonstrate how to 
assign and modify point controls, and how to evaluate a component by making changes to point controls.  
change, create the impact of 

1. Verify the Create Template dialog box is open. 

2. Open the folder 4 – Components > Aggregate Bases > Shoulders.

3. <D> <D>  on the ABC_Outside_Shoulder component.

4. <D> <D> on the ABC_Hinge-Top point.

5. In the Point Properties dialog box, notice that this point has both a Horizontal and Slope 
constraint.
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6. Change the Slope constraint to None and <D> Apply. This will allow the point to move 
up and down independent of any other point.

7. <D> Close.

8. Notice in the Create Template view window how the point symbol (+) changes from red to 
yellow.  This color change means the point has changed from fully constrained to partially 
constrained.

                   

9. <R> on the ABC_Hinge-Top point and select Move Point from the menu.

Note: The Move Point command will not appear in the menu if the point is fully 
constrained.

10. Because the point still has a Horizontal constraint, it will only move up and down while 
maintaining the 12 foot offset from the constraint point, ABC_Shoulder-Top.

11. <R> to exit the Move command.
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12. <D> <D> on the Subbase_Hinge-Top point.

13. Notice that Subbase_Hinge-Top is constrained both horizontally and vertically to  
ABC_Hinge-Top. Therfore, if ABC_Hinge-Top moves, Subbase_Hinge-Top will follow 
according to what is entered in the constraint Value: field. The next few step will 
demonstrate how this works.

14. <D> Close.

15. <R> on the ABC_Hinge-Top point and select Move Point from the menu.

16. Notice how the point Subbase_Hinge‐Top stays 0.5 feet directly below point ABC_Hinge‐
Top. This is because the point has a Horizontal constraint of 0 and a Vertical constraint of -
0.5. from ABC_Hinge-Top.

17. <R> to exit the Move command.

The point ABC_EOP-Top is also fully constrained by ABC_Hinge‐Top. The difference with 
this point it that it that the second constraint is by Vector-Offset instead of Vertical.

18. <D> <D> on the ABC_EOP-Top to look at the Vector/Offset constraint.

19. Notice that this type of constraint uses two parent points instead of one. The slope between 
the two parent points determines the “vector” at which the point will be placed.

20. <D> Close.

21. Move the point ABC_Hinge‐Top again and notice how the point ABC_EOP-Top moves 
with it.  The Vector/Offset constraint forces the point ABC_EOP‐Top to maintain the same 
slope defined by ABC_Shoulder‐Top and ABC_Hinge‐Top.  

22. <R> to exit the Move command.

The next few steps demonstrate how ABC_Hinge-Top behave with a vertical constraint and 
without a horizontal constraint.

23. <D> <D> on the ABC_Hinge-Top point.

24. Change the None constraint back to Slope.
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25. Set the Parent 1 to ABC_Shoulder‐Top and change the Horizontal constraint to None.

26. <D> Apply.

Note: When you click Apply, the two constraints will switch places.  This is because the 
None constraint will always end up as Constraint 2.

27. <D> Close.

28. Move the point ABC_Hinge-Top again an notice that now the point only moves to teh 
left and right.  The Slope constraint forces it to maintain a -2.0% slope from the point 
ABC_Shoulder-Top.

29. <R> to exit the Move command.

30. Reset the point ABC_Hinge-Top back to its original setup. <D> <D> on the  point, change 
the None constraint back to Horizontal, and set Parent 1: to ABC_Shoulder‐Top.

31. <D> Apply.

32. <D> Close.

Chapter Summary:

 Use a simple component to quickly generate an unconstrained closed shape.  Lab 7.1 -Build 
A Simple Component showed how to modify point names in using the Point Properties 
dialog. 

 The next lab, Lab 7.2 -Build a Constrained Component, demonstrated how to create a 
constrained component from scratch using the Dynamic Settings dialog box and various 
methods for the key-in. 
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 Lab 7.3 -Build an End Condition Component explored the special features of an end 
condition component.  For end condition components there are additional options in the 
Dynamic Settings dialog box which determine how end condition points in relation to a 
target.  

 In Lab 7.4 -How Point Constraints Work several constraint options were explored 
including Horizontal, Vertical and Vector-Offset.  This lab demonstrated how changing the 
constraint method affects the points position and how points react to the Parent it is 
constrained to.
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LAB 8 - Building Sections

This lab demonstrates how to create the sub-assemblies known as sections and illustrates the use of parent 
components and display rules.

Chapter Objectives:

 Build a section with existing components using the drag and drop method

 Build an end condition section and reset the priorities so that it functions properly

 Build a section from new and existing components

 Set up the parent/child relationship between components and demonstrate how it works

 Create display rules, apply them to components, and demonstrate their functionality

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\12345\Design\InRoads\DES12345_Templates.itl (This file was 
modified in Lab 1)

Lab 8.1 - Build a Lane Section

This example demonstrates how to assemble basic components into sections using the drag and drop method. 
This lab builds on the concepts and used data from Lab 1 - Building Components.  Open the Create Template 
dialog box.

1. Select Tools > Options from the Create Template menu bar.

2. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 0.10. 
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3. <D> <D> on the root folder in the Template Library pane to expand the folder structure.

4. Expand the 2 – Sections – Pavement folder.

5. Create a new folder under 2 – Sections – Pavement called 12345 Sections.

6. Create a new template in the 12345 Sections folder. Name it Conc_Driving_Lane.

7. Expand the 4 – Components folder.  Also expand the 12345 Components folder created in 
Lab 1.

8. <D> on the Conc_Lane_12"x12' component.  The component is displayed in the Preview 
window.

9. <D> and hold on the component’s origin (the green dot).

10. Drag the component into the template view and drop (release the data button) it on the 
new section’s origin.

11. Expand the 4 – Components >Aggregate Bases > Driving Lanes folder.

12. <D> on the ABC_Lane component.
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13. <D> and hold on the upper right point of the component in the preview window.

14. Drag the component into the Template View and move the pointer on to the lower right 
corner of the concrete component and Drop.  The “+” on the concrete component turns 
white when to pointer is on it.

Note: Steps 14 and 15 were done to show that points do not have to be placed by the 
origin.

This completes the Conc_Driving_Lane section.  This section is now ready to use to create a 
complete template.  This lab illustrates how to build a “backbone” section from existing 
components.  It also shows that components do not have to be placed by their origin, they can 
be placed using any point on th e component.

Lab 8.2 - Build an End Condition Section

This example demonstrates the construction of an end condition.  End conditions are more complicated than a 
simple component and require additional editing to make complete.  The drag and drop method will be used to 
create a new end condition section and the end condition priorities will be modified so that the section operates 
properly..

1. Create a new template in the 12345 Sections folder named 12345_End-Condition.

2. Expand the 4 – Components >End Condition > Z‐Slope > High Speed folder.

3. <D> on the Z‐Slope_12_6_to_1 component.

4. <D> and hold the component’s origin in the preview window.
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5. Drag and Drop the component on the origin in the Template View.

6. Expand the 4 – Components >End Condition > Fill Slope Components folder.

7. <D> on the Fill_6_to_1 component.

8. Drag and Drop the component on to the POSS point.

9. Repeat steps 8 and 9 using Fill_4_to_1 and Fill_3_to_1.

10. Expand the 4 – Components >End Condition > Cut Slope Components folder.



Colorado Department of Transportation   Page 191

Labs for InRoads XM LAB 8 - Building Sections

11. Drag and Drop the Cut_6_to_1, Cut_4_to_1 and Cut_3_to_1 components on to the 
POSS point.

12. <D> <D> on the Fill 6/1 component.

13. Verify that the Priority is set to 1.

14. <D> Next.  This shows the properties for the Fill_4/1 component.

15. Set the Priority is set to 2.  <D> Apply.

16. Set the remaining priorities as follows

♦ Fill_3/1 = 3
♦ Cut_6/1 = 4
♦ Cut_4/1 = 5
♦ Cut_3/1 = 6
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17. Close the Component Properties dialog box

18. <D> the Test button.

19. In the Test End Conditions dialog box, <D> Draw and notice how the end condition 
behaves.

20. <D> Close.

Lab 8.3 - Using Parent Components 

This example places a sidewalk at the end of a cut or fill slope.  It illustrates how the parent/child relationship 
between components can be used.  The sidewalk position end conditions are parents to the sidewalk 
components.  This “turns off” the sidewalk when its parent end condition does not intercept the target surface.

1. Create a new template in the 12345 Sections folder named named Parent Component 
Example.

The end condition component is used to locate the position of the sidewalk.  It contains two 
segments.  The first segment matches the sidewalk’s width and slope.  The second segment 
intercepts the target surface where the actual sidewalk goes.  The Do Not Construct point 
property is used so that the points will be located but the end condition component will not be 
added to the finished template.
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2. <R> in the Template View and select Add New Component  > End Condition.

3. Key in Fill for the component Name.

4. Select D_Toe‐of‐Fill for the Style.

5. Key in 1 for the Priority.

6. In the Dynamic Settings dialog box, set the Point Name to POSS.

7. Place the point on the template origin.

8. In the Dynamic Settings dialog box, toggle off Check for Interception.

9. Verify End Condition is Infinite is toggled off.

10. Toggle on Do Not Construct.

11. Key in Sidewalk_Position for the Point Name.

12. Select D_CONC_Sw for the Point Style.

13. Set the key in mode to hs=.

14. Key in 4,-.02 and press Enter.
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Note: Because the Do Not Construct was toggled on, a line from POSS to Sidewalk Positon 
is not created. 

15. In the Dynamic Settings dialog box, toggle on Check for Interception.

16. Toggle on End Condition is Infinite.

17. Set the Point Name to Toe-of-Fill.

18. Key in 1,-.1667 and press Enter.

19. <R> in the template view and select Finish.
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The Sidewalk and fill slope components that will be used as part of the template are built from 
the toe located by the end condition back to the POSS.

20. Expand the 4 – Components >Sidewalks & Bike Paths > Sidewalks folder.

21. <D> on the 4”_CONC_Sidewalk component.

22. <D> and hold on the upper right point in the Preview.

23. Drag and Drop the component on the Toe‐of‐Fill point.

24. <D> <D> on the CONC_Sidewalk_Front‐Top point.

25. Set Constraint 1 Type: to Horizontal, the Parent 1: field to Toe-of-Fill, and key in -4.00 
for the Value.

26. Set Contraint 2 Type: to Slope constraint, the Parent 1: field to Toe-of-Fill, and key in      
-2.00% for the Value.

27. <D> Apply and Close.

28. <R> in the template view and select Add New Component  > Unconstrained.

29. Key in Fill_6_to_1 for the component Name.

30. Select D_Toe-of-Fill for the Style.

31. Place the first point on the POSS (also the template origin).

32. Place the second point on the CONC_Sidewalk_Front‐Top point.

33. <R> and select Finish.  The illustration below shows the template completed to this point.

The cut components work the same as the fill components built above.

34. <R> in the template view and select Add New Component  > End Condition.

35. Key in Cut for the component Name.

36. Set the Style to D_Top-of-Cut.
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37. Key in 2 for the Priority.

38. In the Dynamic Settings dialog box, set the Point Name to POSS.

39. Place the point on the POSS.

40. In the Dynamic Settings dialog box, toggle off Check for Interception.

41. Toggle on Do Not Construct.

42. Key in Sidewalk_Position1 for the Point Name.

43. Select D_CONC_Sw for the Point Style.

44. Key in 4,.02 and press Enter.

45. In the Dynamic Settings dialog box, toggle on Check for Interception.

46. Toggle on End Condition is Infinite.

47. Set the Point Name to Top-of-Cut.
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48. Key in 1,.1667 and press Enter.

49. <R> and select Finish.

50. <D> on the 4”_CONC_Sidewalk component.

51. <D> and hold on the upper right point in the Preview.

52. Drag and Drop the component on the Top‐of‐Cut point.

53. <R> and select Finish.

54. <D> <D> on the CONC_Sidewalk_Front-Top1 point.

55. Set Constraint 1 to Horizontal and make the Parent 1 Top-of-Cut.

56. Set Constraint 2 to Slope and make the Parent 1 Top-of-Cut.

57. Key in 2.00% for the slope Value.

58. <D> Apply.

59. <D> Close.

60. <R> in the template view and select Add New Component  > Constrained.

61. Key in Cut_6_to_1 for the component Name.

62. Select D_Top-of-Cut for the Style.

63. Place the first point on the POSS (also the template origin).
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64. Place the second point on the CONC_Sidewalk_Front‐Top1 point.

65. <R> and select Finish. The completed template is shown below.

66. <D> the Test button.

In the Test End Conditions dialog box, <D> Draw and notice how the template behaves.  
Notice that both sidewalks remain visible and a third is added as the ground line is moved.  
This is because there is no relationship between the hidden end conditions and the sidewalk 
components.  

67. <D> Close.

The steps below set up the parent/child relationships that will turn off the components for the 
end condition that is not used.

68. <D> <D> on the Cut_6_to_1 Component.

69. Set the Parent Component to CONC_Sidewalk-4”.
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70. <D> Apply.

71. <D> the Next button until Fill_6_to_1 is listed.

72. Set the Parent Component to CONC_Sidewalk-4”.

73. <D> Apply.

74. <D> the Next button until CONC_Sidewalk-4” is listed.

75. Set the Parent Component to Fill.

76. <D> Apply.

77. <D> the Next button until CONC_Sidewalk-4”1 is listed.

78. Set the Parent Component to Cut.

79. <D> Apply.

80. <D> the Test button.

81. In the Test End Conditions dialog box, <D> Draw and notice how the end condition 
behaves; only the components that are children of the end condition solution are displayed.

Lab 8.4 - Using Display Rules

 Display rules turn on or off the display of components based on user defined criteria.  In this example, display 
rules are used to exchange the normal end condition for a guardrail end condition.  

The typical section created in this lab contains two seperate end conditions, the standard Z12_6_to_1 section 
and an end condition used with guardrail.  Both end conditions could apply at any given template drop.  To 
determine which end condition will be used, the Height Check component is added to the template.  This 
component determines the fill height from the edge of pavement to the existing ground. If the fill height 
excedes the maximum value the guardrail end condition is used.

The standard end condition section is added to the template.

1. Create a new template in the 12345 Sections folder. named Display Rules  Example.

2. Expand the 3 – Sections ‐ End Sections > Z‐Slope End Conditions > High Speed End 
Conditions folder.
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3. <D> on the Z12_6_to_1 Section.

4. <D> and Hold the section’s origin in the Preview window.

5. Drag and Drop the section on the new template’s origin.

Height Check is an end condition component.  It runs vertically through the template origin 
(which will also contain the EOP point) to intercept the existing ground.  The distance between 
the Fill Height point and the EOP is used to determine if the guardrail is used.

6. <R> in the Template View and select Add New Component  > End Condition.

7. Key in Height Check for the Name.

8. Select Default for the Style.

9. In the Dynamic Settings dialog box, key in Height Anchor for the Point Name.

10. Select Default for the Point Style.

11. Set the key in mode to XY=.
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12. Key in 0,1 and press Enter.

This pointsets the Height Check end condition over the EOP so that the fill height can be 
checked vertically at this point.

13. Key in Fill Height for the Point Name.

14. Toggle on Check for Interception, Place Point at Interception, End Condition is 
Infinite, and Do Not Construct.

15. Key in 0,-2 and press Enter.

This sets the starting location for the Fill Height point.  This point intercepts the existing 
ground directly under the EOP to determine the fill height.  The 2 foot distance below the 
template origin is an arbitrary value, so long as the Fill Height point is placed below the Height 
Anchor point the template will work properly.

16. <R> and select Finish.  

17. Select File > Save. (This is an intermediate save to prevent loss of information.)
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The Z-Slope_12_6_to_1 component will be set to a child of the Height Check so that its display 
can be turned on and off based on the fill height.

18. Toggle on Display All Components.

19. <D> <D> on the Z-Slope_12_6_to_1 component.

20. In the Component Properties dialog box, set the Parent Component to Height Check.

The Display Rule sets the criteria for the component to be displayed.

21. <D>  Edit to display the Component Display Conditional Expression dialog box.

22. In the Component Display Conditional Expression dialog box, <D> Add.  The Display 
Rule dialog box is displayed.

The Display Rule determines when the Z-Slope_12_6_to_1 component is displayed.  It is set so 
that when the fill height at the edge of pavement is more than 12 feet, the normal end condition 
is turned off.

23. In the Display Rule dialog box , key in Height Check for the Name.
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24. Key in Fill height check for guardrail in the Description field.

25. Set the Type to Vertical.

26. Set Between to Fill Height.

27. Set And to EOP.

28. Set the expression to >.

29. Key in -12 in the value field.

30. <D> OK.

31. Back in the Component Display Conditional Expression dialog box, highlight the Height 
Check entry in the Template Display Rules area.  

32. <D> the Selected Rule button.

33. <D> OK.
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34. In the Component Properties dialog box, <D> Apply.

35. <D> Close.

As defined in the Z12_6_to_1 Section, the 3 to 1 fill slope will never be used.  This is because 
the guardrail component is activated before the 4 to 1 option reaches its maximum distance.  By 
changing the value on the horizontal constraint to 32 on the 4 to 1 slope, it will reach its 
maximum length before the guardrail end condition is used.  

36. <D> <D> on the Toe-of-Fill1 point.

37. Change the Value of the Horizontal Constraint to 32.

38. <D> Apply.

39. <D> Close.  The template looks like the illustration below.

40. <D> Test.  
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41. <D> Draw.  Notice that once the ground line drops 12 feet below the EOP, the Z-
Slope_12_6_to_1 component disappears.

42. <D> Close to return to the Create Template dialog box.

Now we will add the Normal_Paved_Installation-6ft-Shoulder component to the template. This 
component uses the Height Check display rule along with the NOT operator to display the 
guardrail components only when the standard end condition is not used.

43. Expand the 4 – Components > Barriers & Misc Components > Guardrail Widening folder.

44. <D> on Normal_Paved_Installation-6ft-Shoulder in the library tree view.

45. <D> and Hold on the component’s origin (the upper left point)  in the Preview window.

46. Drag and Drop the section on the EOP point in the template view.

47. <D> <D> on the HMA_GRAIL-Widening_Normal_6ft-Shoulder component.

48. <D> the Edit button for the Display Rules.

49. In the Component Display Conditional Expression dialog box, <D> the NOT button.

50. Highlight Height Check in the Template Display Rules area, then <D> the Selected 
Rule button.

51. <D> OK.

52. In the Component Properties dialog box, <D> Apply and Close.

Because the display rules don’t work well with end conditions, this component is used to 
locate the toe of the fill slope from the end of the guardrail section.

53. Zoom in around the guardrail widening component placed above.

54. <R> in the Template View and select Add New Component  > End Condition.

55. Key in Fill_2_to_1 for the Name.

56. Select Default for the Style.
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57. <D> on the Breakpoint point.

58. In the Dynamic Settings dialog box, Key in Toe-of-Fill_3 for the Point Name.

59. Toggle on Check for Interception, Place Point at Interception, End Condition is 
Infinite, and Do Not Construct.

60. Set the key in mode to hs=

61. Key in 2,-.5 and press Enter.

62. <R> and select Finish.

The final component actually constructs the fill slope in the template.  It will be made a child of 
the guardrail widening  component so that it displays only when the guardrail widening  
component is displayed.

63. <R> in the Template View and select Add New Component  > Constrained

64. Key in Fill_2_to_1 for the Name.

65. Set the Style to D_Toe-of-Fill.
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66. <D> on the Breakpoint point.

67. <D> on the Toe-of-Fill_3 point.

68. <R> and select Finish. 

69. <D> <D> on the Fill_2_to_1 component.

70. Set the Parent Component to HMA_GRAIL-Widening_Normal_6ft-Shoulder.

71. <D> Apply.

72. <D> Close.

73. <D> Test.  

74. <D> Draw.  Notice that when the Z-Slope_12_6_to_1 component disappears the 
guardrail component and its children are shown.

Chapter Summary:

 All four exercises used the drag and drop method to add components to a section.

 In Lab 8.2 -Build an End Condition Section, the special properties of end condition 
components were illustrated.  Setting the end condition priority determines the processing 
order of end condition components.

 Lab 8.3 -Using Parent Components  and Lab 8.4 -Using Display Rules built sections from 
new and existing components. A variety of methods can be used to put data into a template.

 Lab 8.3 -Using Parent Components  and Lab 8.4 -Using Display Rules used the parent/
child relationship between components to display the proper solution.  This groups 
components so that if the parent is displayed then the children are also displayed.

 In Lab 8.4 -Using Display Rules display rules were created to turn on and off components 
that are not part of the solution.  Display Rules set criteria used to determine if a component 
will be displayed.
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This lab demonstrates how to modify existing templates by changing point constraints, deleting existing 
components and adding new ones.

Chapter Objectives:

 Modify pavement lift thickness.

 Add a sub-base component to the template.

 Add an additional lane to one side of a template.

 Add a median barrier to a divided highway template.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\ 
Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\Combined Surfaces.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl (This file was modified in 
Lab 1)

Lab 9.1 - Modify pavement lift thickness

This exercise demonstrates how to modify point constraints in order to change the lift thickness on an existing 
template.  The HMA_Crowned_B10 template from the template library will be modified so that the bottom lift 
of asphalt will be 4 inches thick. 

1. Open the Create Template dialog box.

2. <D> <D> on the root folder  and expand the 1– Templates folder.

3. <D> <D> on the HMA_Crowned_B10 template.

4. <D> <D> on the ABC_Centerline-Top point to display the Point Properties dialog box.

5. Key in -0.33 for the Value of the Vertical constraint.

6. <D> Apply.
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7. <D> Close.

8. Repeat steps 4 through 7 for the following points:

♦ RT_ABC_Laneline-Top

♦ RT_ABC_Hinge-Top

♦ LT_ABC_Laneline-Top

♦ LT_ABC_Hinge-Top

Note: The two outside points (HMA_Lift3_EOP-Bottom and ABC_EOP-Top) do not 
need to be modified.  This is because they are built with Vector/Offset constraints 
which keeps them in line with the other points on that row.
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Lab 9.2 - Add a sub-base component to the template

This exercise show how to add and modify a component to an existing template in order to add a sub-base 
component to the bottom of the HMA_Crowned_B10 template used above.  The sub-base will be added as a 
new component instead of using one from the libraryin order to minimize the amount of editing.

1. <D> <D> on the HMA_Crowned_B10 template (if it is not already displayed).

2. <R> in the template view and select New Component > Constrained from the menu.

3. Key in SubBase_2 ft in the Name field.

4. Set the Style to D_SUBBASE.

5. Starting at the left, <D> on the points across the bottom of the ABC component.

6. After placing the first point, <R> and verfiy that Closed Shape is checked on.

The next steps build the bottom of the subbase.  The points are placed in the approximate 
location.  There final position is set by editing the point constraints.

7. Place a point approximately below each of the points just entered, working back from right 
to left.

8. <R> in the template view and select Finish from the menu.
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9. <D> <D> on the lower left corner of the new sub-base component.

10. In the Point Properties dialog box, change the Name to LT_SubBase_EOP-Bottom.

Note: The name is the same as the point above it, except that the word Top is replaced 
with the word Bottom.

11. Set the Parent 1 for both constraints to the point directly above (in this case 
LT_SubBase_EOP-Top).

12. Key in 0 for the Horizontal constraint value.

13. Key in -2 for the Vertical constraint value.

14. <D> Apply.

15. <D> Close.

16. Repeat steps 8 through 14 for the remaining points across the bottom of the sub-base 
component.
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The finished template is illustrated below:

Lab 9.3 - Add an Additional Lane to One Side of a Template

This exercise demonstrates how to add new components to an existing template in order to add an addition 
travel lane.  Using the template HMA_Urban_4Lane from the template library, the right curb, ABC, and End 
Conditions will be deleted and a new lane with curb and gutter will be added.

1. <D> <D> on the HMA_Urban_4Lane template.

2. Toggle on Display All Components.

Affixes are used so that point names added to the template are updated to reflect their location 
with respect to the control line.

3. Select Tools > Options from the Create Template menu bar.

4. Toggle on Apply Affixes.
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5. <D> OK.

The existing curb and gutter on the right side of the template and its ABC component must be 
removed from the template to make room for the new lane.

6. <R> in the template view and select Delete Components from the menu.
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7. <D> and hold, then draw a line through the curb, sub-base, and  end conditions components 
on the right side of the template as shown below.  Release the mouse button to complete the 
delete.

The exposed points still have names used by the curb and gutter component.  These must be 
changed to reflect the new role of the point.

8. Rename the points at the right end of the template as follows:

○ RT_HMA_Lift1_Laneline-Top1

○ RT_HMA_Lift2_Laneline-Top1

○ RT_HMA_Lift3_Laneline-Top1

○ RT_ABC_Laneline-Top1

The template library contains a three lift asphalt driving lane section with curb and gutter 
attached.  Use this section to complete the backbone of the template.

9. Expand the 2 – Sections ‐ Pavement > Curb & Gutter Sections folder in the template library 
explorer.

10. <D> on the C/G_Type2-IIB section.

11. <D> and Hold on the section’s origin in the Preview window.
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12. Drag and Drop the section onto the RT_HMA_Lift1_Laneline‐Top1 point.

The new section that was added accomodates a design decision on when to generate a gutter 
with a normal slope and when to generate the gutter with a slope to match the driving lanes. 
This section has two curb components.  Therefore, two end condition sections are required, one 
attached to each curb.  These next steps show how to modify the criteria for the design 
decision.  

13. Zoom in on the right curb components,  there are two (one is shown with dotted lines).

14. <D> <D> on the RT_Curb_Gutter-top point.

15. Change the Slope constraint Value to 5.00%.  This is done so that hidden (dotted) curb 
component is displayed.  It will also allow the points to merge as desired in the following 
steps.

16. <D> Apply.
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17. <D> Close.

18. Expand the 3 – Sections End Conditions > Curb & Gutter Sections  folder in the template 
library explorer.

19. <D> on the Bench_4_6_to_1 section to display it in the Preview window.

20. <D> and Hold on the section’s origin in the Preview window.

21. Drag and Drop the section on to the RT_Curb_Back-Top1 point.

22. <D> <D> on the RT_Benching component that was just placed.

23. Set the Parent Component to RT_C/G_Type2-IIB1.

24. <D> Apply.
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25. <D> Close.

26. <D> <D> on the RT_Curb_Gutter-top point.

27. Change the Slope constraint Value to -2.00%.  This is done so that the hidden (dotted) 
curb component is displayed.  It will also allow the points to merge as desired in the 
following steps.

28. <D> Apply.

29. <D> Close.

30. <D> and Hold on the Bench_4_6_to_1 section’s origin in the Preview window.

31. Drag and Drop the section on to the RT_Curb_Back-Top point.

32. <D> <D> on the RT_Benching1 component that was just placed.

33. Set the Parent Component to RT_C/G_Type2-IIB.

34. <D> Apply.

35. <D> Close.
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Note: Applying the Parent Component settings to the Benching components will make 
the proper end condition display based on the pavement cross slope.

Finally, the missing ABC component is added under the new driving lane.

36. Expand the 4 ‐ Components > Aggtegate Bases > Driving Lanes folder in the template 
library explorer.

37. <D> on the ABC_Lane component to display it in the Preview window.

38. <D> and Hold on the section’s origin in the Preview window.

39. Drag and Drop the section on to the RT_ABC_Laneline-Top point.

40. <R> on the vertical line between RT_ABC_Laneline‐Top and RT_SubBase_Laneline‐Top 
and select Merge Components from the menu.
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The finished template is illustrated below:

Lab 9.4 - Add a Median Barrier to a Divided Highway Template

In order to add a median barrier to the CONC_Divided_TypeA_4Lane template, the slope components will be 
deleted, the ABC components will be modified, a Guardrail_Type 7-CE component will be added, and the 
pavements will be tied to the barrier.

To start the process, the points that define the median ditch are deleted, removing the ditch from the template.

1. <D> <D> on the CONC_Divided_TypeA_4Lane template.

2. <R> on the RT_Median_POSS point and select Delete Point.

3. In the Delete Point dialog box, <D> All.

4. <D> OK. This deletes the point from RT_SubBase_Shoulder and deletes the Z‐
Slope_12_6_to_12 and RT_Median components.

5. <R> on the RT_Inside_SubBase_EOP-Top2 point and select Delete Point.

6. Using the same method as the steps above, delete the following points:

♦ LT_Median_POSS
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♦ LT_SubBase_EOP-Top

♦ Median_Flowline

Place a Type-7 barrier in the template.  In this case, the center bottom of the barrier is placed on 
the template origin.

7. Toggle off Apply Affixes (either on the Dynamic Settings dialog or from Tools > 
Options).

8. Expand the 4 – Components > Barriers & Misc Components > Guardrail Type 7 folder in 
the template library explorer.

9. <D> on the Guardrail_Type 7-CE component to highlight it; do not make it active.

10. In the Preview window, <D> and Hold on the component’s Insertion Point (The green + 
sign in the middle of the barrier).

11. Drag and Drop the component to the template’s origin.

Now the pavement edges need to be attached to the barrier.  This is done by modifying the 
constraints for the those points.

12. <D> <D> on the point RT_Inside_Conc_EOP-Top.

13. Set the Parent 1 for both constraints to RT_Connect.

14. Key in 0 for the Value of both constraints.

15. <D> Apply.
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16. <D> Close.

17. Repeat steps 12 through 15 for point LT_Inside_Conc_EOP-Top using LT_Connect as 
the  Parent 1 point.

18. Zoom in to the area under the barrier.

The next series of steps places a concrete component under the barrier.  This component is 
placed independent of other points in the template.  It is then constrained so that it will 
move with the barrier.
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19. <R> and select Add New Component > Unconstrained.

20. Key in CONC_Under_ Barrier for the component Name.

21. Select D_CONC_Pvmt for the Style.

22. In the Dynamic Settings dialog box, key in RT_ CONC_Under_Barrier-Top for the 
Point Name.

23. <D> under the right edge of the barrier but not on any existing point or component.

24. In the Dynamic Settings dialog box, key in RT_ ABC_Under_Barrier-Top for the 
Point Name.

25. <D> below the RT_ CONC_Under_Barrier-Top point that was just placed.

26. In the Dynamic Settings dialog box, key in LT_ ABC_Under_Barrier-Top for the 
Point Name.

27. <D> to the left of the point that was just placed.

28. In the Dynamic Settings dialog box, key in LT_ CONC_Under_Barrier-Top for the 
Point Name.

29. <D> above the point that was just placed.

30. <R> and select Finish.

31. <D> <D> on the RT_ CONC_Under_Barrier-Top point.



Page 224 Colorado Department of Transportation

LAB 9 - Modifying Templates Labs for InRoads XM

32. Set the Constraint 1 Type to Horizontal.

33. Set the Constraint 2 Type to Vertical.

34. Set the  Constraint 1 Parent 1  to RT_Barrier-Bottom.

35. Set the  Constraint 2 Parent 1  to RT_Barrier-Bottom.

36. Key in 0 for the Value of both constraints.

37. <D> Apply.

38. <D> Close.

39. <D> <D> on the LT_ CONC_Under_Barrier-Top point.

40. Set the Constraint 1 Type to Horizontal.

41. Set the Constraint 2 Type to Vertical.

42. Set the  Constraint 1 Parent 1  to LT_Barrier-Bottom.

43. Set the  Constraint 2 Parent 1  to LT_Barrier-Bottom.

44. Key in 0 for the Value of both constraints.

45. <D> Apply.

46. <D> Close.
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47. <D> <D> on the RT_ ABC_Under_Barrier-Top point.

48. Set the Constraint 1 Type to Horizontal.

49. Set the Constraint 2 Type to Vertical.

50. Set the  Parent 1  to RT_ CONC_Under_Barrier-Top for both constraints.

51. Key in 0 for the Value of the Horizontal constraint.

52. Key in -0.75 for the Value of the Vertical constraint.

53. <D> Apply.

54. <D> Close.

55. <D> <D> on the LT_ ABC_Under_Barrier-Top point.

56. Set the Constraint 1 Type to Horizontal.

57. Set the Constraint 2 Type to Vertical.

58. Set the  Parent 1  to LT_ CONC_Under_Barrier-Top for both constraints.

59. Key in 0 for the Value of the Horizontal constraint.

60. Key in -0.75 for the Value of the Vertical constraint.

61. <D> Apply.

62. <D> Close.

63. <R> on the RT_Connect point and select Move Point.
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64. <D> on RT_V_Control in the box that pops up listing all available points at this location.

Note: If more than four points are available, <ESC> on your keyboard pages down in the 
list.

65. Move the pointer up and down and notice how the components behave.

66. <R> to end the Move command

Note: This barrier has both a variable height and a variable width. If the height is 34” or 
less, the base is 23” wide. As the height increases above 34” the base varies from 
23” to a maximum of 26.75”. The maximum height is 40”.

Important! Since the barrier width is variable, the adjacent shoulder, lanes, etc. are 
‘pushed out’ as the barrier widens. A decision must be made if this is 
acceptable, or if you want another solution, such as varying the width of 
the shoulder to accomodate the widened barrier. If so, change the Parent of 
the Horizontal Constraint on the inside shoulder point to the V_Control 
point. Since it does not widen with the barrier, the shoulder will be 
variable width. The maximum variation is 3.75”.

An ABC component can be added under the barrier in a similar manner to the concrete 
component described above.

67. <R> and select Add New Component > Unconstrained.

68. Key in ABC_Under_ Barrier for the component Name.
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69. Select D_ABC_Class 6 for the Style.

70. In the Dynamic Settings dialog box, key in RT_ ABC_Under_Barrier-Top1 for the 
Point Name.

71. <D> under the right edge of the component just added but not on any existing point or 
component.

72. Continue adding the other three points (as was done with the concrete component) Naming 
them:

♦ RT_ SubGrade_Under_Barrier-Top
♦ LT_ SubGrade_Under_Barrier-Top
♦ LT_ ABC_Under_Barrier-Top1

73. <R> and select Finish.

74. <D> <D> on RT_ SubGrade_Under_Barrier-Top.

75. Set the Parent 1 to RT_ ABC_Under_Barrier-Top1 on both constraints.

76. Key in 0 for the Value of the Horizontal constraint.

77. Key in -1.00 for the Value of the Vertical constraint.

78. <D> Apply.

79. <D> Close.

80. Repeat steps 71 through 76 for LT_ SubGrade_Under_Barrier‐Top, using LT_ 
ABC_Under_Barrier‐Top1 as the Parent 1 point.



Page 228 Colorado Department of Transportation

LAB 9 - Modifying Templates Labs for InRoads XM

81. <R> on the RT_ ABC_Under_Barrier-Top1 point and select Add Constraint > Full 
Constraint.

82. <D> on the RT_ ABC_Under_Barrier-Top.

83. <D> on RT_ ABC_Under_Barrier-Top on the Point Selection dialog box.

84. In the Add Full Constraint dialog box, key in 0 for both offsets.
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85. <D> OK.

86. Repeat steps 79 through 82 for the point LT_ ABC_Under_Barrier-Top1, selecting point 
LT_ ABC_Under_Barrier-Top in the Point Selection dialog box.

The template is now completed.
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Chapter Summary:

 In some cases, only minor alterations can change a standard template into a project specific 
one.  In Lab 9.1 -Modify pavement lift thickness point constraints were changed to modify 
the thickness of a pavement lift.

 Other minor modifications include the addition of components.  In Lab 9.2 -Add a sub-base 
component to the template a new component was created to add a sub-base component to 
the template.

 There are some case when major modifications can be made to an existing template.  In 
Lab 9.3 -Add an Additional Lane to One Side of a Template components were deleted from 
an existing template and new components were added from the template library to add an 
additional lane to one side of a template.

 Editing a template does not always require deleting and/or adding whole components.  
Sometimes the desired reaults can be achieved working with the points on components.  In 
Lab 9.4 -Add a Median Barrier to a Divided Highway Template components and specific 
component points were deleted, new components from the library and ones built from 
scratch were added and point constraints were modified to add a median barrier to a 
divided highway template.



Colorado Department of Transportation   Page 231

LAB 10 - Corridors and Template Drops

This lab demonstrates the initial procedures used when starting Roadway Designer.  The exercises below 
define the path and cross section for the design model and determine what information is displayed in the 
Roadway Designer views.

Chapter Objectives:

 Create a corridor using a horizontal and vertical alignment

 Develop initial template drops

 Generate additional template drop details

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\ 
Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 10.1 - Create a Corridor

The first step in creating a design model is to create a corridor. The corridor defines where the model is located, 
both horizontally and vertically.  The corridor in this example runs the total length of the alignment so no 
station limits are needed.

1. Select the Geometry tab in the InRoads Explorer.

2. <R> Geometry Projects, select Open, and select the 12345DES_Geometry.alg file 
from the \12345\Design\InRoads directory.
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3. Verify that SH 86 is the active horizontal alignment and SH 86 V is the active vertical 
alignment. 

4. Select Modeler > Roadway Designer from the InRoads menu bar.

5. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the corridor management button .

6. In the Manage Corridors dialog box, key in 12345DES in the Name field.

7. <D> Add.

8. <D> Close.
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Note: By default, the Type is set to Alignment and the Horizontal Alignment and Vertical 
Alignment are set to the active alignments, though any alignment can be selected.  
Notice that data is now displayed in the Roadway Designer views.

Lab 10.2 - Devlop Initial Template Drops

Design model cross sections are developed by applying templates along a corridor.  A template drop needs to 
be defined at any location where the cross section of the corridor changes.  Template drops are assigned to the 
corridor through the Template Drops dialog box.  This exercise uses a single template drop that runse the entire 
length of the corridor.  The starting station for the template drop defaults to the beginning of the alignment. 
Therefore, all that needs to be done is to select the desired template and set the interval.

1. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

template drops button .

2. In the Template Drops dialog box, key in 25 for the Interval.

3. Expand the 1- Templates folder in the Library Templates area. of the Template Drops 
dialog box.

4. <D> on the HMA_Crowned_B10 template.

5. <D> Add.
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6. <D> Close.

This is a good spot to save the roadway designer (IRD) file.

7. Select File > Save from the Roadway Designer menu bar.

8. Verify that the file is being saved to the directory C:\Projects\12345\Design\InRoads\.

9. In the File name field, key in 12345DES.ird.
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10. <D> Save then <D> Cancel.

The template data is displayed in the cross section view of the Roadway Design.  Notice, in 
the template view of the Roadway Designer, that the end conditions have already been 
solved.  

There are two options for scrolling through the design, 1) using the station arrows below 
the template view and 2) using the station line in the plan view.

11. To navigate to a specific station <D> on the station arrows to scroll through the stations or 
type in the station to review..
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12. To get a quick overview of how the template is working throught the cooridor, <D> and 
Hold on the yellow station line.  Move the pointer back and forth to scroll through the 
design.

The model is now ready to be evaluated.

Lab 10.3 - Generate Additional Details for Template Drops

Between the regular station intervals defined by a template drop, design data is generated using straing line 
interpolation.  In order to generate precise data at “stations of interest” other than a regular station (i.e. stations 
for drainage structures), those stations need to be identified as an Event Points and then processed using the 
Roadway Designer. Other standard “stations of interest” that are usually not at regulare station intervals are 
Cardinal Points.

The Roadway Designer Options dialog box determines which of the “stations of interest” get processed and 
what information is added to the template view window.  The data generated by the Roadway Designer options 
provides the designer additional real time information that is useful in the evaluation and analysis of the 
proposed design.

This exercise will demonstrate several of the options including:

 Processing cardinal and event points

 Displaying cut and fill information

 and Generating a report of component and point information.

The first series of steps tell the Roadway Designer to process the  horizontal cardinal and event points. 

1. From the Roadway Designer menu bar, select Tools > Options.

2. In the Roadway Designer Options dialog box, toggle on Horizontal Cardinal Points 
and Horizontal Event Points.
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3. <D> OK.

4. Scroll through the stations and notice that some stations do not fall on even intervals.  
These are the cardinal and event points.

The following series of steps adds volume information to the template view of the Roadway 
Designer.

5. Open the Roadway Designer Options dialog box again.

6. Toggle on Cut and Fill Graphics, Cut and Fill Values, and Net Volume.
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7. <D> OK.

8. Scroll through the stations and notice that Cut and Fill areas are shown graphically and 
areas and volumes are shown in text format at the bottom of the template view.

The final series of steps illustrates what is included in the default processing report and shows 
what information can be added to the report.

9. <D> the Process All button.  

10. This displays the Results dialog box.  Some of the information displayed includes:

♦ Stations where end conditions failed to intercept their target

♦ Results of display rule calculations, and 

♦ Which point controls were used for each station processed.
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This information should be used to determine problems areas of the model and what 
modifications should be made to the template or corridor controls.

11. <D> Close on the Result dialog box.

12. Open the Roadway Designer Options dialog box again.

13. Toggle on Component Information and Point Information.

14. <D> OK.

15. <D> the Process All button.  
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16. This report list detailed information about every component and point in the model.  Like 
the previous report, this information can be used to help troubleshoot problems with 
templates and corridor controls. 

Note: The Results dialog box is limited to a report of up to approximately 16,000 
lines.  This equals about 220 template drops (about a mile at a 25’ interval) 
when using the HMA_Crowned_B10 template.

17. <D> Close on the Result dialog box.

18. Select File > Save from the Roadway Designer menu bar.

19. In the Save As dialog box, key in 12345DES for the file name.



Colorado Department of Transportation   Page 241

Labs for InRoads XM LAB 10 - Corridors and Template Drops

20. <D> Save.

21. <D> Cancel to dismiss the Save As dialog box.

22. <D> Close to dismiss the Roadway Designer window.

Chapter Summary:

 A corridor defines the horizontal and vertical location of the design.  In Lab 10.1 -Create a 
Corridor a corridor was created using the active horizontal and vertical alignment.

 Templates define the prism of the project.  These are processed at specific intervals along 
the corridor.   In Lab 10.2 -Devlop Initial Template Drops Template Drops for a two lane 
road template were added to the corridor. 

 The options in Roadway Designer allow the user to see design evaluation information in 
real time.   The user can also specify that geometry points are processed with template 
drops.  In Lab 10.3 -Generate Additional Details for Template Drops various settings for 
the Roadway Designer options were used to add specific stations for processing, display 
volume information in the designer’s template view, and add more detail to the processing 
report.
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This lab demonstrates the use of the Superelevation Wizard.  The wizard is the easiest way to add 
superelevation to a corridor.

Chapter Objectives:

 Use the Superelevation Wizard to enter data into the corridor.

 Edit a Superelevation Control Line.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\ 
Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 11.1 - Using the Superelevation Wizard

This lab uses the DES12345 corridor built in the previous lab.  There are two main steps to 
using superelevation:

♦ Select the superelevation rate table and

♦ Calculate the rate for each curve

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. From the Roadway Designer dialog box, select Superelevation > Create Super-   
elevation Wizard > Table from the menu bar.  The Table Wizard is displayed.

3. <D> the Browse button and select:

C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Superelevation Tables\AASHTO 2004\06_55.sup.

4. <D> the Load Values From Table button. The superelevation table has been selected.
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5. <D> Next.

On this screen the template points that define the superelevation range and pivot points are 
identified.  It doesn’t matter which station is active when these points are selected.

6. On the Superelevation Section Definitions dialog box, <D> Add.  This displays the Add 
Superelevation Section dialog box.

7. <D> the target button for the Crown Point. Then <D> on the finish grade centerline point.

8. <D> the target button for the Left Range Point. Then <D> on the finish grade left edge of 
pavement point.

9. <D> the target button for the Right Range Point. Then <D> on the finish grade right edge 
of pavement point.

10. <D> OK.

o

11. <D> Next on the Superelevation Section Definitions dialog box.  This displays the Super‐        
elevation Controls dialog box.
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This dialog box is mainly for informational purposes. It is provide so that the superelvation 
control line properties can be reviewed/updated before they are applied.

12. <D> the Finish button to complete the superelevation entry.

13. <D> the Display Superelevation button on the Roadway Designer dialog box.

This adds the superelevation view window to the Roadway Desiner dialog box.

14. <D> the Process All button.  If it appears, Close the Results window. 

15. <D> the Fit button for the Plan View and the Superelevation Control Line views.

The illustration below shows the data generated by the Superelevation Wizard.

The data in the plan view is color coded to show different cross slopes. The colors that 
represent the cross-slope values are:

♦ Green-Blue for slopes from 0.5% to 10% to the right with dark blue representing slopes 
greater than 10% to the right

♦ Yellow-Red colors for slopes from 0.5% to 10% to the left with dark red representing 
slopes greater than 10% to the left

♦ White for slopes less than 0.5%
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16. Select File > Save from the Roadway Designer menu bar.

Lab 11.2 - Edit a Superelevation Control Line

In this exercise the superelevation stations for the first curve are edited to even stations.  This illustrates the 
procedure for editing superelevation.  There are a couple of methods for editing superelvation stations:

 Edit the superelevation points from the superelvation view and

 Use the Edit Curve Set Stations tool

1. This first example is to edit the superelevation points directly from the view window.  <D> 
<D> on the first superelevation point.

2. The Point Selection dialog box is displayed.  <D> <D> on the Section1 
RT_HMA_Lift1_Laneline-Top-RT_HMA_Lift1_EOP-Top - 230+32.50.

3. The Superelevation Point Properties dialog box is displayed.  Key in 230+32.00 in the 
Station field.

4. <D> Apply.

5. <D> Close.

The other method is to use the Edit Curve Set Stations command. The dialog box may be more 
use since it uses common terminolgy used to define superlevation stations such as Full Super, 
Reverse Crown, Super Runoff, and Normal Crown. 
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6. <R> in the Superelevation Control Line view and select Edit Curve Set Stations from 
the menu.  The Superelevation Control Curve Set Station Edit dialog box displays.

7. Set the Curve Set to 1.  This can be done with a key in or by using the arrow buttons.

8. <D> the upper “+” button to display additional stations.  Continue to display additional 
stations until the Normal Crown at station 230+32.00 appears at the top of the list.

9. <D> the lower “+” button until the Normal Crown at station 236+15.77 is displayed.

10. Toggle off the Constrained toggle for Super Runoff at station 230+83.12.  Superelevation 
station that have a Grey  background cannot be changed without turning off the 
Constrained toggle.  

11. Round the Station value from 230+83.12 to 230+83.00.  Be sure to use the Tab key to 
accept the new value.

Note: The rounding of stations is a design decision.  Consult the Project Manager for 
guidance with this change.

12. Repeat steps 10 and 11 as needed and round the other stations as indicated below.
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♦ Reverse Crown 231+34.00
♦ Full Super232+37.00
♦ Full Super234+12.00
♦ Reverse Crown235+14.00
♦ Super Runoff235+65.00
♦ Normal Crown236+16.00

13. <D> Apply.

14. <D> Close.  This dismisses the Superelevation Control Curve Set Station Edit dialog box.

 

Note: If the constraints are toggled back on, the stations will revert back to those 
calculated by the wizard.

15. <D> the Process All button. The computer will now apply the template drops and 
superelevation to all the stations in the corridor.

16. Scroll through the first curve to see how the superelevation works.

17. Select File > Save from the Roadway Designer menu bar.

18. <D> Close.

Chapter Summary:

 Lab 11.1 -Using the Superelevation Wizard demonstrated how to use the Superelevation 
Wizard to define the location of the Crown and Range points using the cross section view 
window.  These points are used to determine how the template superelevates through a 
curve.

 Lab 11.2 -Edit a Superelevation Control Line showed two methods to edit a Superelevation 
Control Line; 1) manually and 2) using the Edit Curve Stations... dialog box.  It is 
important to rember that editing superelevation stations is a design decision based on 
standard design criteria from the AASHTO manual and project specific conditions.
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LAB 12 - Point Controls, Secondary 
Alignments, and Parametric Constraints

This lab demonstrates the use of various controls to modify a template during processing.  It will highlight 
various settings in point controls, illustrate the effects of a secondary alignment, and demonstrate the use of 
parametric constraints.

Chapter Objectives:

 Create a Horizontal Point Control to add an additional lane using offsets.

 Create a Horizontal and Vertical Point Control to add a scab-on detour.

 Create a Horizontal Point Control using a Secondary Alignment.

 Use Parametric Constraints to widen the road surface.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 12.1 - Adding an Additional Lane with Offset Point Controls

In this exercise the corridor created in the previous lab is modified by adding an additional lane to the right side 
of the template using a standard point control.  This control is based on the centerline (SH 86) alignment and 
uses offset distances from this alignment to modify the template.  Three control entries are required to 
complete the transition.

1. Select Modeler > Roadway Designer from InRoads.

2. Verify that the 12345DES corridor is active.

The first point control transitions from two lanes to three lanes. 

3. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 

bar or <D> the point controls button .

4. In the Point Controls dialog box, select RT_HMA_Lift1_EOP-Top for the point.  Use the 

drop down menu or <D> the “target”  button and then <D> the point in the template 
view to make the selection.

5. Toggle on Horizontal for the Mode.
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6. Set the Horizontal Alignment to SH 86.

7. Key in 220+00.00 in the Station Limits Start field.

8. Key in 222+50.00 in the Station Limits Stop field.

9. Key in 24 in the Horizontal Offsets Start field.

10. Key in 36 in the Horizontal Offsets Stop field.

11. <D>  Add.  The entry is added to the Horizontal and Vertical Controls list.

This creates the beginning transition for the additional lane.

The Point, Mode, Control Type, and Horizontal Alignment stay the same for the two 
remaining entries.  Only the Stations and Offsets change.  the second point control 
maintains the third lane.

12. Key in 222+50.00 in the Station Limits Start field.
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13. Key in 229+00.00 in the Station Limits Stop field.

14. Key in 36.00 in the Horizontal Offsets Start field.

15. Key in 36.00 in the Horizontal Offsets Stop field.

16. <D>  Add.  This entry maintains the full width of the additional lane.

The third point control transitions from three lanes back to two lanes.

17. Key in 229+00.00 in the Station Limits Start field.

18. Key in 231+50.00 in the Station Limits Stop field.

19. Key in 36.00 in the Horizontal Offsets Start field.

20. Key in 24.00 in the Horizontal Offsets Stop field.

21. <D>  Add.  This entry transitions the template back to its normal width.

22. <D> Close to dismiss the Point Controls dialog box.

This series of steps sets the display in the template view to a specific size.  This makes it easier 
to see the transitions occur when scrolling through the stations.

23. <R> in the template view of the Roadway Designer dialog box and select Display 
Properties from the menu.

24. Toggle on Center Backbone.

25. Key in 75% (.75) for the Backbone Screen Width.

26. Select 5 for the Vertical Exaggeration.

27. <D> OK.  This makes the template change easier to see when scrolling through the 
stations.
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28. Scroll through the stations between 220+00.00 and 231+50.00 and notice how the template 
behaves.

29. Select File > Save from the Roadway Designer menu bar.

Lab 12.2 - Creating a Scab-On Detour using Point Controls

In this exercise a scab-on detour is added to the left side of the existing pavement from station 206+00 to 
215+00.  This requires a new corridor, template drop, and two sets of point controls.  One is a horizontal and 
vertical control that follows the existing edge of pavement.  The second is a horizontal offset control that 
transitions the detour to its full width.

1. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the Manage Corridors button .

2. In the Manage Corridors dialog box, key in Scab-on Detour for the Name.

3. Toggle on the Station Limits.

4. Key in 206+00.00 for the Start station.

5. Key in 215+00.00 for the Stop station.

6. <D> Add.

7. <D> Close.

This corridor could have been built on the edge of pavement feature from the dtm, but by 
using the alignment it will be easier to locate stations.
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8. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

Template Drops button 

9. In the Template Drops dialog box, key in 206+00.00 for the Station.

10. Key in 25 for the Interval.

11. Expand the C:\Projects\12345\Design\InRoads\DES12345-Templates.itl >    
1- Templates folder in the Library Templates area and highlight the Scab-on Detour 
template.

12. <D> Add.

13. <D> Close.

The first point control moves the origin of the template from the SH 86 alignment to the left 
edge of pavement feature in the 12345 Existing Ground surface.

14. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 
bar or <D> the point controls button.

15. In the Point Controls dialog box, select HMA_Lift1_Shoulder-Top for the Point.
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16. Toggle on Both for the Mode.

17. Select Feature for the Control Type.

18. Select T_Traffic Single Solid White386 for the feature (This is the 18th T_Traffic Single 
Solid in the pull down list).

Note: Creating a feature filter will make it easier to locate the desired feature.  The filter 
should Start With None, use the Name Attribute, and have a Value of *386*.  
See the module “Initial Surface Procedures” of the “Practical Guide for InRoads 
XM” for more information in feature filters.

Note: The 12345 existing ground surface is the only dtm loaded so it is selected by 
default.

19. <D> Add.

Notice that the template has moved to approximately 12 feet to the left.  Next, a horizontal 
point control is created that transitions the detour to its full width.  

20. In the Point Controls dialog box, set the Point to LT_HMA_Lift1_EOP-Top.

21. Toggle on Horizontal for the Mode.

22. Set the Control Type to Alignment.

23. Set the Horizontal Alignment to SH 86.

24. In the Station Limits area, key in 206+00.00 for the Start station.

25. Key in 208+50.00 for the Stop station.

26. In the Horizontal Offsets area, key in -11.93 for the Start offset.

27. Key in -24.00 for the Stop offset.
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28. <D> Add.

The Point, Mode, Control Type, and Horizontal Alignment stay the same for the two remaining 
entries.  Only the Stations and Offsets change.  The steps below create a point control that 
maintains the detour’s full width.

29. Key in 208+50.00 in the Station Limits Start field.

30. Key in 212+50.00 in the Station Limits Stop field.

31. Key in -24.00 in the Horizontal Offsets Start field.

32. Key in -24.00 in the Horizontal Offsets Stop field.

33. <D>  Add.  This entry maintains the full width of the additional lane.

The final point control transitions from the full width to the end of the detour.

34. Key in 212+50.00 in the Station Limits Start field.

35. Key in 215+00.00 in the Station Limits Stop field.

36. Key in -24 in the Horizontal Offsets Start field.

37. Key in -12.22 in the Horizontal Offsets Stop field.

Note: The offset distances entered are measured from the specified Horizontal alignment 
and not from the origin of the template.

38. <D>  Add.  

39. <D> Close to dismiss the Point Controls dialog box.

Scroll through the stations and notice how the template behaves.  From station 206+00 to 
station 208+50 the template expands from the existing edge of pavement until it reaches its full 
width.  Then it maintains that width from station 208+50 to station 212+50.  Finally,  it 
contracts back to the pavement edge from station 212+50 to station 215+00.  

40. Select File > Save from the Roadway Designer menu bar.
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Lab 12.3 - Using Horizontal Point Control and a Secondary 
Alignment

Alignments other than the design centerline can be used for horizontal controls.  Typically, they are used to 
modify the width of the template.  They can also be used to change the direction (in relation to the design 
centerline) that the template components are placed.  When an alignment is used in this manner, it is called a 
secondary alignment.  

This exercise uses a secondary alignment to create the beginning of an off ramp.  A new corridor is created 
using the SH 86 alignment.

1. Select Corridor > Corridor Management from the Roadway Designer menu bar or 
<D> the Corridor Management button.

2. In the Manage Corridors dialog box, key in Off Ramp for the Name.

3. Toggle on the Station Limits.

4. Key in 205+00.00 for the Start station.

5. Key in 215+00.00 for the Stop station.

6. <D> Add.

7. <D> Close.

A single template drop is required for this corridor.

8. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 
Template Drops button.

9. In the Template Drops dialog box, key in 205+00.00 for the Start station.
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10. Key in 25 for the Interval.

11. Expand the C:\Projects\12345\Design\InRoads\DES12345-Templates.itl >    
1- Templates folder in the Library Templates area and highlight the 
CONC_4Lane_Right-Side_Only template.

12. <D> Add.

13. <D> Close.

A horizontal point control is used to widen the template and reposition its components 
perpendicular to the Off Ramp alignment.

14. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 
bar or <D> the point controls button.

15. In the Point Controls dialog box, select RT_Conc_Shoulder-Top for the Point.

16. Toggle on Horizontal for the Mode.

17. Select Alignment for the Control Type.

18. Select Off Ramp for the Horizontal Alignment.
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19. In the Station Limits area, key in 205+00.00 for the Start station.

20. Key in 215+00.00 for the Stop station.

21. Make sure the Horizontal Offsets are set to 0.

22. Toggle on Use as Secondary Alignment.

23. <D> Add.

24. <D> Close.

25. Scroll through the stations between 205+00.00 and 215+00.00 and notice how the template 
behaves.  The orange line in the plan view and the template view represents the Off Ramp 
alignment.  Notice how the template line (the yellow line in the plan view) outside the Off 
Ramp alignment changes so that it is perpendicular to the Off Ramp alignment.

26. Select File > Save from the Roadway Designer menu bar.

Lab 12.4 - Using Parametric Constraints to Widen the Road 
Surface

Parametric Constraints are used to modify the value of the constraint.  This option allows greater flexibility of 
what can be modified during processing as slopes and vector/offsets can be modified in addition to the usual 
horizontal and vertical controls.  In this exercise, the Horizontal Constraint of a template point is modified to 
widen the template on the left side.  This is done in a similar maner to the first exercise.
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The corridor used in Lab 6.1 is also used here.

1. In the Roadway Designer dialog box, select 12345DES for the corridor.

2. Select Tools > Parametric Constraints from the Roadway Designer menu bar.

3. In the Parametric Constraints dialog box, select LT_EOP-Top-Horiz for the Constraint 
Label.

4. Key in -36 for the Stop Value (the Start Value stays the same for this entry).

5. In the Station Limits area, key in 237+00.00 for the Start station.

6. Key in 239+50.00 for the Stop station.
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7. <D> Add.

8. Key in -36 for the Start Value (the Stop Value stays at -36).

9. In the Station Limits area, key in 239+50.00 for the Start station.

10. Key in 252+50.00 for the Stop station.

11. <D> Add.

12. Key in -24 for the Stop Value (the Start Value stays at -36).

13. In the Station Limits area, key in 252+50.00 for the Start station.

14. Key in 255+00.00 for the Stop station.

15. <D> Add.

16. <D> Close. This dismisses the Parametric Constraints dialog box.
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17. Scroll through the stations between 237+00.00 and 255+00.00 and notice how the template 
behaves.

18. Select File > Save from the Roadway Designer menu bar.

19. <D> Close to dismiss the Roadway Designer dialog box.

Chapter Summary:

 In Lab 12.1 -Adding an Additional Lane with Offset Point Controls Horizontal Point 
Controls were used to add an additional lane to the design.  The control was based off the 
design centerline with offset distances measured from that alignment. 

 Lab 12.2 -Creating a Scab-On Detour using Point Controls a Horizontal and Vertical Point 
Control was created to locate a template on the edge of the existing pavement.  The edge of 
pavement feature from the existing ground surface was used to locate the template.  A 
horizontal control based off the design centerline was also used to transition the template, 
creating the scab-on detour. 

 In Lab 12.3 -Using Horizontal Point Control and a Secondary Alignment a Horizontal 
Point Control using a Secondary Alignment was created.  By changing the angle of the 
components outside of the secondary alignment, their shape is maintained around curves 
making this option ideal for ramps and street returns.

 Lab 12.4 -Using Parametric Constraints to Widen the Road Surface used Parametric 
Constraints to widen the road surface.  The results were similar to those achieved in the 
first exercise but a different method was used.
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LAB 13 - Template Transitions and End 
Condition Overrides

This lab demonstrates how template transitions and end condition overrides are set up.  Template transitions 
are used to make a smooth change from one template to another.  End condition overrides are used to make 
changes in end conditions without having to create a new template.

Chapter Objectives:

 Set up a template to template transition.

 Create an end condition transition.

 Create an end condition override.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 13.1 - Set Up a Template to Template Transition

In this exercise a new corridor is defined with two template drops.  The transition area is identified in the plan 
view by a colored block at the transition location. The transition between the templates is defined using this 
block.

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the corridor management button .

3. In the Manage Corridors dialog box, key in Template Transition in the Name field.

4. <D> Add.
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5. <D> Close.

Next, the template drops are defined.  The first template requires two template drops, one at the 
beginning of the project and the second at the beginning of the transition.

6. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

template drops button .

7. Select Template Transition for the corridor name.

8. Key in 25 for the Interval.

9. Expand the 1- Templates folder in the Library Templates area.

10. <D> on the 12345_HMA_2Lane template.

11. <D> Add.

12. In the Template Drops dialog box, key in 208+00.00 for the Station.

13. <D> on the 12345_HMA_2Lane template.
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14. <D> Add.

The final template drop is used from the end of the transition to the end of the project.

15. In the Template Drops dialog box, key in 211+00.00 for the Station.

16. <D> on the 12345_HMA_4Lane template.

17. <D> Add.

18. <D> Close.

Note: Notice in the Plan view a yellow box has been displayed.  This is the area of the 
transition.  The yellow indicates that some of the points have been connected 
between the templates.  Next, the remainder of the points are connected.

The color coding indicates that not all of the template points are connected.    The steps blow 
connect the remaining unconnected points.



Page 266 Colorado Department of Transportation

LAB 13 - Template Transitions and End Condition Overrides Labs for InRoads XM

19. <D> <D> on the transition area.  This displays the Edit Transition – 208+00.00 to 
211+00.00 dialog box.

The display in the Edit Transition – 208+00.00 to 211+00.00 dialog box shows the 
connections between points and the points that are not connected.  The illustration below 
shows examples of unconnected points.

20. Zoom in on the bold “+”  on the right side of the bottom template.

21. <D> on the “+”.  A line is attached to the “+” and the pointer.

22. Zoom out, then zoom in on the corresponding point on the upper template.
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23. <D> on the “+”.  The line is now attached to the “+” and it is unbolded.

24. Repeat steps 19 through 22 on the left side.

All of the points on the bottom template have been attached to points on the top template.  
However, points on the top template remain unconnected.  These are connected to the 
appropriate laneline points of the bottom template.

25. <R> on the green “+” on the bottom template and select Move Template.

p

26. Move the bottom template so that it is easier to see the points to be connected.
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27. <D> to complete the move.

28. Starting at the bottom of the template, connect the outside lanelines on the four lane 
template to the lanelines on the two lane template.



Colorado Department of Transportation   Page 269

Labs for InRoads XM LAB 13 - Template Transitions and End Condition Overrides

29. Connect the remaining points as shown below.

30. <D> OK. This displays the Edit Transition Midpoint – 208+00.00 to 211+00.00 dialog 
box.

In order for the transition to function properly, the horizontal constraints on the lanelines 
must be deleted.

31. <R> on the RT_HMA_Lift1_Laneline-Top1 point and select  Delete Horizontal 
Constraint from the menu.
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32. <R> on the LT_HMA_Lift1_Laneline-Top1 point and select  Delete Horizontal 
Constraint from the menu.

33. Move the Transition slider and notice how the template behaves.  The additional lane 
expands and contracts as the slider is moved back and forth.

34. <D> OK to complete the transition edit.

Notice in the plan view that the transition area is now dark blue.  This signifies that all of 
the points are connected.

35. Select File > Save from the Roadway Designer menu bar.

Lab 13.2 - Set Up an End Condition Transition

In this exercise the transition between a cut slope and a fill slope between stations 219+75 to 220+00 is 
defined.  This is done in a similar manner as the transition of two templates but it is accessed differently.



Colorado Department of Transportation   Page 271

Labs for InRoads XM LAB 13 - Template Transitions and End Condition Overrides

1. In the Roadway Designer dialog box, use the station indicator to select station 219+75.00.

2. Select Corridor > End Condition Exceptions from the Roadway Designer menu bar 

or <D> the End Condition Exceptions button  .

3. In the End Condition Exceptions dialog box, note that the desired stations are already 
selected.

4. Toggle on Right Transition.

5. <D> Add.  This adds the data to the End Condition Exceptions list.

6. Highlight the entry.
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7. <D> Edit.  This displays the Edit Transition – 219+75.00 to 220+00.00 Right dialog box.

8. Connect the two bold “+” symbols.

9. <D> OK.  This displays the Edit Transition Midpoint – 219+75.00 to 220+00.00 Right 
dialog box.

10. Move the Transition slider and notice how the template behaves.

11. <D> OK to complete the transition edit.

12. <D> Close to dismiss the End Condition Exceptions dialog box.

13. Select File > Save from the Roadway Designer menu bar.

Note: This exercise illustrates the use of the End Condition transition command.  
Typically, these transitions occur in areas where there is a template change.  The 
transitions between typical cuts and fills do not have to be defined. 
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Lab 13.3 - Set Up an End Condition Exception

With using end condition exceptions, end condition points and components can be added, deleted, and/or 
modified.  In this exercise an end condition override is used to create a deeper ditch from station 203+80.28 to 
206+50.00.  The existing cut slope is deleted and a new end condition is added to extend the ditch foreslope 
and create the backslope.

1. In the Roadway Designer dialog box, use the station indicator to select station 203+80.28.

2. Select Corridor > End Condition Exceptions from the Roadway Designer menu bar 
or <D> the End Condition Exceptions button.

3. In the End Condition Exceptions dialog box, key in  206+50.00 for the Stop station (the 
Start station is already set).

4. Toggle on Right Override.

5. <D> Add.  This adds the data to the End Condition Exceptions list.

The steps below are used to actually modify the end condition data.

6. Highlight the entry.

7. <D> Edit.  This displays the Right Override – 203+80.28 to 206+50.00 dialog box.

The existing end condition components are deleted from the right side of the template.  
Deleting the existing components is done in the same way as in the Create Template dialog box.  
However, when using an end condition override, the backbone components can not be deleted.
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8. In the Right Override – 203+80.28 to 206+50.00 dialog box, <R> and select Delete 
Components.

9. Zoom in around the existing cut slope component.

10. <D> and hold, then drag a line through the existing cut slope component.  Release the 
mouse button to complete the delete.

Note: The deleted component remains visible shown in light blue.  However it is not 
incorporated into the model.

Next, the new ditch components are added.  Adding new components is done in the same way 
as in the Create Template dialog box.  However, when using an end condition override, only 
end condition components can be selected.

11. Select Tools > Options from the menu bar.
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12. Toggle on Apply Affixes.

13. Key in 0.10 for the X and Y Step Options.

14. <D> OK.

15. <D> the Dynamic Setting button on the view control button bar.  This displays the 
Dynamic Settings dialog box.

16. <R> in the template view and select New Component > End Condition from the 
menu.

17. In the Current Component area, key in Special Ditch for the Name.
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18. Select D_Top-of-Cut for the Style.

19. In the Dynamic Settings dialog box, select POSS for the Point Name.

20. <D> on the RT_POSS point.

21. In the Dynamic Settings dialog box, toggle off Check for Interception.

22. Key in Ditch_Bottom for the Point Name.

23. Set the Point Style to D_DITCH-Bottom.
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24. In the precision key-in field, key in 6,-0.1667.

25. Press the Enter key.

26. In the Dynamic Settings dialog box, toggle on Check for Interception.

27. Toggle on End Condition is Infinite.

28. Select Top-of-Cut  for the Point Name.

29. In the precision key-in field, key in 6,0.1667.

30. Press the Enter key.
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31. <R> in the template view and select Finish from the menu.

32. <D> OK.  This completes the edit of the override.

33. <D> Close to dismiss the End Condition Override dialog box.

34. Use the Station indicator to scroll through the affected stations.  Notice the changes.

35. Select File > Save from the Roadway Designer menu bar.

36. <D> Close to exit the Roadway Designer.

Chapter Summary:

 In Lab 13.1 -Set Up a Template to Template Transition the process of setting up a template 
to template transition was demonstrated.  This included the necessary template drops, 
connecting template points and changing point constraints.

 In Lab 13.2 -Set Up an End Condition Transition an end condition transition was built.  
This involved selecting station a for the transition and connecting end condition points.

 In Lab 13.3 -Set Up an End Condition Exception an end condition override was created.  
This involved selecting a station for the override, deleting existing end condition 
components, and adding a new component.
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LAB 14 - Modifying Single Template Drops and 
Target Aliasing

This lab demonstrates the procedure for editing a single template drop and setting up a corridor for target 
aliasing.  Modifying single template drops is used for making minor corrections to the design prior to creating 
a surface.  Target aliasing is used to specify alternate targets for end condition interception.

Chapter Objectives:

 Modify a single template drop by moving a point.

 Add a parallel corridor and use target aliasing to tie to the original corridor as needed.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 14.1 - Modifying a Single Template Drop

At station 225+50.00 the design toe falls inside a small rise in the natural ground creating an area that pools 
water.  This station is edited to move the toe to the top of that rise.

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. Select 12345DES for the corridor (created in lab 4).

3. Key in 225+50.00 in the Station indicator and press the Tab key.
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4. <R> in the template view and select Edit Station from the menu.

5. In the Editing Template at Station 225+50.00 Only dialog box, <R> on the LT_Toe-of-Fill 
point and select Move Point.
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6. Move the pointer to the small rise approximately 50’ to the left of the centerline.  The point 
snaps to the ground line. <D> at that location to complete the move.

7. <D> OK to dismiss the Editing Template at Station 225+50.00 Only dialog box.

8. Select File > Save.

This method of modifying template drops should be used sparingly.  If there are more than a 
couple of locations that require editing, modifying the template should be considered over 
editing single template drops.

Lab 14.2 - Target Aliasing

Target aliasing is used to define multiple targets for an end condition.  In this exercise two parallel corridors are 
constructed.  The first corridor ties to the existing ground exclusively.  The second corridor ties to the existing 
ground or the first corridor.  This lab uses the 12345DES corridor created in lab 4 in addition to a new corridor 
created in this lab.

First, the offset corridor is created.

1. Select Corridor > Corridor Management from the Roadway Designer menu bar or 
<D> the Corridor Management button.

2. In the Manage Corridors dialog box, key in SH 86_Offset_Left for the Name.

3. Verify that the Horizontal Alignment is SH 86 and the Vertical Alignment is SH 86 V.

4. <D> Add.
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5. <D> Close.

A template drop is added to the offset corridor.

6. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 
Template Drops button.

7. In the Template Drops dialog box, key in 25 for the Interval.

8. Expand the 1 – Templates folder.

9.  Highlight the HMA_Crowned_B10 template.

10. <D> Add.
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11. <D> Close.

The corridor is built on the same alignment as the 12345DES alignment.  A point control is 
used to move SH 86_Offset_Left corridor 80’ to the left.

12. Select Corridor > Point Controls from the Roadway Designer menu bar or <D> the 
Point Controls button.

13. In the Point Controls dialog box, select HMA_Lift1_Centerline-Top for the Point.

14. Toggle on Horizontal for the Mode.

15. In the Horizontal Offsets area, key in -80 for both the Start and Stop offsets.

16. <D> Add.
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17. <D> Close.

The final step is to add the target aliasing.

18. Select Tools > Target Aliasing from the Roadway Designer menu.  The Target Aliasing 
dialog box is displayed.

19. In the Target Aliasing dialog box, Highlight Corridor – 12345DES from the Surface or 
Corridor list.
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20. <D> Add.  The highlighted entry is moved to the Aliases list.

21. Highlight Surface – 12345 Existing Ground from the Surface or Corridor list.

22. <D> Add.

23. <D> Cancel to dismiss the Target Aliasing dialog box.  

The order that aliases are listed is important because it determines the testing order.  In this 
exercise, the end condition tests against the Corridor – 12345DES first.  If it cannot tie to the 
corridor it tests against the Surface – 12345 Existing Ground.

24. Scroll through the stations and notice how the right end condition behaves.

25. Select File > Save from the Roadway Designer menu bar.

26. <D> Close to dismiss the Roadway Designer dialog box.

Chapter Summary:

 In Lab 14.1 -Modifying a Single Template Drop a single template drop was modified by 
moving a point.

 InLab 14.2 -Target Aliasing target aliasing was used to tie one corridor to another.  This 
method also allowed the corridor to tie to the existing ground as needed.
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LAB 15 - Creating Design Surfaces

This lab demonstrates the methods of creating design surfaces. These range from creating a single surface from 
a single corridor to creating multiple surfaces from multiple corridors to creating a single surface from multiple 
corridors.

Chapter Objectives:

 Create a surface from a single corridor.

 Create multiple surfaces from multiple corridors.

 Create an alternate surface for a corridor.

 Create a single surface by combining corridors.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird (created in lab 4)

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

 C:\Projects\12345\Design\InRoads\Combine Surfaces.ird

Lab 15.1 - Create a Surface (dtm) From a Single Corridor

Creating a surface from a single corridor uses the basic functionality of the Create Surface command.  Here, a 
single design surface is created from the 12345DES corridor.

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 

Create Surface button  .

3. In the Create Surface dialog box, key in 12345DES for the Name.  To avoid confusion 
later on, it is best to use the corridor name for the surface name.

4. Set the Default Preference to Proposed.

5. Verify that the following check boxes are toggled on:

♦ Empty Design Surface (to ensure no residual data is used)

♦ Add Exterior Boundary (to eliminate erroneous triangles in concave areas of the 
design model)

♦ Triangulate (to create the triangulated model)

♦ Remove Loops (to correct areas where template drops cross)

6. Set the exterior boundary style to Exterior Boundary or DTM_Exterior.

7. Highlight the 12345DES corridor from the Create Surface(s) From list.
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8. <D> Apply.  This creates the surface and displays the Results window.

9. Examine the contents of the Results window then Close it.  The information displayed will 
depend on the Option settings.  These are found under Tools > Options on the Roadway 
Designer menu bar. 

10. <D> Close to dismiss the Create Surface dialog box.

11. Minimize the Roadway Designer dialog box.

One method of reviewing the dtm is to display the features into the MicroStation file.  Follow 
the steps below to display the features from the newly created surface.

12. From the InRoads menu bar, select Surface > View Surface > Features.

13. In the View  Features dialog box, select 12345DES for the Surface.

14. Verify that all features are highlighted in the Features list.
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15. <D> Apply.

16. <D> Close to dismiss the View Features dialog box.

17. Examine the displayed features.

DTMs created with the Roadway Designer have some properties that need to be set.  These 
control how the surface is displayed and how it is used in volume calculations.  Follow the 
steps below to make the settings changes. 

18. In the InRoads main dialog box, select the Surfaces bottom tab.
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19. <R> on 12345DES and select Properties from the menu.

20. Notice the Preference and Type in the Surface Properties dialog box.  The Preference 
controls some display properties and the Type determines how the surface is used when 
calculating volumes.

21. <D> the Advanced Tab.

22. In both the Cross Sections and Profiles areas, set the Symbology to D_Finished-Grade.

23. <D> Apply to accept the changes.

24. <D> Close to dismiss the Surface Properties dialog box.

Lab 15.2 - Creating Multiple Surfaces from Multiple Corridors.

This exercise illustrates the process of creating multiple surfaces at one time.
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When the surface properties were accessed in the previous lab, the active surface was set to the 
12345DES surface.  The active surface needs to be set to the 12345_Existing Ground surface in 
order for the corridors to process correctly.

1. Expand the Roadway Designer dialog box.

2. Set the Active Surface to 12345_Existing Ground.

3. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 
Create Surface button.

4. Toggle on the New Surface for Each Corridor check box.  This disables the Name 
field and each new surface is named after its corridor.

5. Verify that the settings made in the previous lab are still in affect.

6. Highlight all of the corridors in the Create Surface(s) From list.
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7. <D> Apply.

8. Examine the contents of the Results window.  Note the point control information from the 
previous labs.  Close the Results winow.

9. <D> Close to dismiss the Create Surface dialog box.

10. Minimize the Roadway Designer dialog box.

11. In the InRoads dialog box, notice that there is a new surface for each corridor (the 
12345DES surface created in the first exercise was emptied and the data replaced with this 
run).  InRoads uses the corridor name for the surface name when creating multiple 
surfaces.

12. Expand the Roadway Designer dialog box and select File > Save from the menu bar.

13. <D> Close to Dismiss the Roadway Designer dialog box.
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Lab 15.3 - Create an Alternate Surface

The Alternate Surface option is used to create a surface from points specified in the template.  This is in 
addition to the normal, finished grade surface that is created.  This exercise illustrates the process of creating an 
alternate surface.  The HMA_Crowned_B10 template is modified to create the alternate surface, the Template 
Drop is updated, and the surfaces are created.

In the first series of steps the template is updated to specify the points that are used for the 
alternate surface.

1. From the InRoads menu bar, select Modeler > Create Templates.

2. In the Template Library area, expand the C:\Projects\12345\Design\InRoads\ 
DES12345_Templates.itl folder.

3. Expand the 1 – Templates folder.

4. <D> <D> on the HMA_Crowned_B10 template.

5. <D> <D> on the LT_POSS point.

6. Toggle on the Alternate Surface check box.

7. In the Alternate Surface key in field, type Subgrade.

8. <D> Apply.

9. <D> Close.

10. Repeat steps 3 through 8 for the points indicated in the illustration above.

11. Select File > Save from the Create Template menu bar.

12. <D> Close.

The template is prepared to create the alternate surface.  Next the template drop is updated.

13. From the InRoads menu bar, select Modeler > Roadway Designer.

14. Set the Corridor to SH 86_Left_Offset.



Page 294 Colorado Department of Transportation

LAB 15 - Creating Design Surfaces Labs for InRoads XM

15. Select Corridor > Template Drops from the Roadway Designer dialog box, or <D> the 
Template Drops button.

16. In the Template Drops dialog box, highlight the entry in the Current Template Drops list.

17. <D> Synchronize With Library button.

18. <D> Close.

Everything is ready to create the alternate surface.  The finished grade design surface and the 
alternate surface are created at the same time.

19. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 
Create Surface button.

20. Toggle off the New Surface for Each Corridor check box.

21. In the Create Surface dialog box, key in SH 86_Left_Offset for the Name.  

22. Highlight the SH 86_Left_Offset corridor from the Create Surface(s) From list.

23. Toggle on the Create Alternate Surfaces check box.
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24. <D> Apply.

25. Review the report displayed in the Results dialog box, then <D> Close the Results dialog 
box.

26. <D> Close to dismiss the Create Surfaces dialog box.

27. Select File > Save from the Roadway Designer menu bar.

28. Minimize the Roadway Designer dialog box.
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29. Notice, in the InRoads dialog box, that the Subgrade surface has been created.

Lab 15.4 - Create a single surface from two corridors

Many design types have multiple corridors.  Divided highways, intersections, and interchanges can use two or 
more corridors.  Often, it is desirable to have a surface model of the entire project instead of a separate surface 
for each part.  This exercise demonstrates how to a create single surface from two parallel corridors.

This exercise uses a different corridor than the previous exercises.  The first steps load the 
Combine Surfaces.ird file.

1. Expand the Roadway Designer dialog box.

2. Select File > Open from the Roadway Designer menu bar.

3. Highlight the C:\Projects\12345\Design\InRoads\Combine Surfaces.ird file 
and <D> Open.

4. Scroll through the stations for both corridors.  The 12345DES corridor is the initial phase 
of construction and is tied to the existing ground.  The SH86_Offset_Left corridor is the 
second phase and ties to the 12345DES corridor on the right and the existing ground on the 
left.

5. Select the SH86_Offset_Left corridor.

6. Select Tools > Target Aliasing from the Roadway Designer menu bar.
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7. Notice that aliases have been set up for this corridor.  Target Aliasing is used to determine 
how corridors are clipped when combining corridors.

8. <D> Cancel to dismiss the Target Aliasing dialog box.

The next series of steps identifies the settings used in the Create Surface dialog box.

9. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 
Create Surface button.

10. Key in SH 86_Combined for the Name.  

11. Set the Default Preference to Proposed.

12. Verify that the following check boxes are toggled on:

♦ Empty Design Surface
♦ Add Exterior Boundary
♦ Triangulate
♦ Remove Loops

13. Set the exterior boundary style to Exterior Boundary or DTM_Exterior.

14. Highlight the 12345DES and the SH86_Offset_Left corridors from the Create Surface(s) 
From list.  Hold the Ctrl key and <D> on each corridor.

Clipping options determine how the two corridors will be combined into one surface.  The 
option used here, Clip End Conditions Only, will delete overlapping end condition features 
from the 12345DES corridor.

15. <D> the Clipping Options button.

16. In the Clipping Options dialog box, <D> on the entry in the Clipping Option column until 
it reads Clip End Conditions Only.
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17. <D> OK. This dismisses the Clipping Options dialog box.

18. In the Create Surface dialog box, verify that New Surface for Each Corridor and 
Create Alternate Surfaces are toggle off .

19. <D> Apply to create the combined surface.

20. Review then <D> Close on the Results dialog box.

21. <D> Close to dismiss the Create Surface dialog box.

22. Select File > Save from the Roadway Designer menu bar.

23. <D> Close to dismiss the Roadway Designer dialog box.

The last series of steps displays the combined surface’s features into the MicroStation file for 
review.

24. Delete any graphics displayed in the drawing.

25. From the InRoads Menu bar, select Surface > View Surface > Features.

26. In the View  Features dialog box, select SH 86_Combined for the Surface.

27. Verify that all features are highlighted in the Features list.

28. <D> Apply.

29. <D> Close to dismiss the View Features dialog box.  The illustration below shows the 
features in the combined surface.
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Cross sections are discussed in the next chapter, however, below is a sample cross section of 
the combined surface.

30. In the InRoads dialog box, <R> on the 12345DES Surface and select Save from the menu.  
This surface is used in the next lab.

Chapter Summary:

 In Lab 15.1 -Create a Surface (dtm) From a Single Corridor a surface was created from a 
single corridor.  The basic settings used when creating most surfaces were demonstrated.

 In Lab 15.2 -Creating Multiple Surfaces from Multiple Corridors. multiple surfaces were 
created from multiple corridors.  When generating multiple surfaces, each surface is named 
after the corridor that created it.

 In Lab 15.3 -Create an Alternate Surface an Alternate surface was created.  The template 
was modified to identify which points are used to create the alternate surface.  The template 
drops were updated and setting changed in the Create Surface command.

 In Lab 15.4 -Create a single surface from two corridors a single surface created by two 
combining corridors.  Target Aliasing was used to identify how corridors are clipped to 
create the combined surface.



Page 300 Colorado Department of Transportation

LAB 15 - Creating Design Surfaces Labs for InRoads XM



Colorado Department of Transportation   Page 301

LAB 16 - Cross Sections, Volumes, and 
Reports

This lab illustrates the changes in cross sections, volumes, and reporting from InRoads 2004 to InRoads XM.  
These changes came about due to changes in the templates and dtm.

Chapter Objectives:

 Create and update a set of cross sections to show the design surface and components.

 Calculate End Area Volumes for the cross sections.

 Add an area of unsuitable material to the volume calculation.

 Use a volume exception when calculating End Area Volumes

 Examine the End Area Volume reports.

 Create a Station Base report to an alignment.

 Create a Station Base report to a feature.

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences\CDOT_Civil.xin

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

Lab 16.1 - Create Cross Sections

This lab demonstrates the changes made in the Create Cross Sections command and illustrates the changes 
made in the surface (dtm) from the 2004 edition to the XM edition of InRoads.

Step 1 resets the text scale factor for InRoads so that the cross sections will display correctly.

1. Select Tools > Options and <D> the Factors tab and set the scale factors to 30.  This 
can also be done from the Global Scale Factors dialog box.

2. <D> Apply.

3. <D> Close.

The cross sections created in the following steps display the existing ground and the 
trinagulated design surface only.  This is to illustrate what features (template points) are used to 
create the triangulated surface model.

4. Select Evaluation > Cross Section > Create Cross Section from the InRoads menu 
bar.
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5. In the Create Cross Section dialog box, toggle on the 12345 Existing Ground and the 
12345DES surfaces.

6. <D> Include in the Create Cross Section explorer.
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7. Toggle off Components.  This is done to illustrate what is stored as a surface.  Normally, 
this toggle is left on.  The components will be added to the cross sections in later steps.

8. <D> Apply, then <D> in the MicroStation view window to place the cross sections.

9. <D> Close to dismiss the Create Cross Section dialog box.

10. Examine the first cross section.  The design surface (12345DES) represents the upper most 
points of the template.  The remaining features (created from the template points) are 
stored in the dtm as untriangulated features.

 

Next, the components are added to the cross sections using the Update Cross Section 
command.

11. Select Evaluation > Cross Section > Update Cross Section from the InRoads menu 
bar.

12. Toggle on the Display On radio button.

13. <D> Components in the Update Cross Section explorer.
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14. Highlight 12345DES in the Surface area.

15. <R> in the Component area and select Select All from the menu.

16. <D> Apply.

17. <D> Close to dismiss the Update Cross Section dialog box.

18. Examine the first cross section.  The surfacing components are shown.  End condition 
components are not shown in the cross sections because they are also part of the surface.

Lab 16.2 - Calculate End Area Volumes

This exercise demonstrates the basic End Area Volume command.  This command has changed due to changes 
in the dtm data, however, the concept is the same.  The design surface (specified by the surface Type in the 
Surface Properties) is compared to the existing surface (also specified by the surface Type) to determine the 
amount of Cut and Fill.
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1. Select Evaluation >Volume > End Area Volume from the InRoads menu bar.

2. On the General leaf, notice the Surfaces selected.  Surface 12345 Existing Ground has the 
Type of Existing and 12345DES has the type of Design.

3. Toggle off Create XML Report.

4. Toggle on Cubic Yards.

5. <D> Apply.

6. Examine the cross sections. Notice the various types of data shown in the illustration 
below.

Some materials shown in the template are computed as normal embankment.  In this example, 
the D_SUBBASE material is included as embankment.  The steps below change the settings for 
the subbase so that it can be included as embankment.

7. In the End Area Volumes dialog box, <D> on Classifications in the End Area Volumes 
explorer. 
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8. <D> in the cell of the D_SUBBASE row and the Mass Ordinate column so that it reads  
Include.

9. <D> Apply.

10. Examine the cross sections. Notice the change in the data.

Lab 16.3 - Unsuitable Material

The existing ground may contain material that cannot be used in the construction of the design project.  This 
exercise demonstrates the use of the Unsuitable Materials by Station option.
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The steps below set up the dialog box to use the unsuitable material options.  The other settings 
remain the same.

1. In the End Area Volumes dialog box, <D> Unsuitable Materials by Station in the End 
Area Volumes explorer.

2. Select 203+80.28 for the Start Station.

3. Select 260+43.16 for the Stop Station.

4. Key in 0.50 for the Cut Depth.

5. Key in 1.00 for the Fill Depth.

6. <D> Add.  The data is placed in the Unsuitable Materials list.

Note: There is currently not a style for unsuitable material.  That is why Default is used 
here.

7. <D> Annotation in the in the End Area Volumes explorer.

8. Toggle off Cut Shape and Fill Shape.  fThis is so that the unsuitable material shapes 
can be seen.
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9. <D>  Apply.

10. Examine the cross sections. Notice the change in the data.  The cut and fill volumes have 
changed to account for the unsuitable material.

11. <D> Close on the End Area Volumes dialog box.

12. <D> No on the dialog box that is displayed.

Lab 16.4 - Volume Exceptions

Volume exceptions are used to omit specified cross sections from earthwork calculations.  This allows the 
design model to be run continuously through the project and still account for the area where no earthwork is 
done.  In the exercise, a set of custom cross sections is generated to show the beginning and end of the volume 
exception.  Then the exception is set up in the End Area Volume command.  The volume exception runs from 
station 208+15.83 to station 212+89.50.

The first series of steps is used to set up the custom cross section set.

1. Select Cross Section > Create Cross Section from the InRoads menu bar.
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2. In the Create Cross Section dialog box, on the General leaf, verify that the 12345 Existing 
Ground and 12345DES surfaces are selected.

3. <D> Include in the Create Cross section explorer.

4. Toggle on Components.

5. <D> Custom in the Create Cross section explorer.

The steps below are used to display cross sections normally, from the beginning of the project 
to station 208+00.

6. Key in 208+00.00 for the Stop Station (the Start Station is set to the beginning station 
by default).

7. Key in 50.00 for the Interval.

8. <D> Add.

The steps below are used to display a single cross section at station 208+15.83and at station  
212+89.50 .

9. Set the Type to Perpendicular.

10. Key in 208+15.83 for the Station.
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11. <D> Add.

12. Key in 212+89.50  for the Station. (all other settings remain the same)

13. <D> Add.

The steps below are used to display cross sections normally, from station 213+00 to the end of 
the project.

14. Set the Type to Station Range.

15. Key in 213+00.00 for the Start Station.

16. Key in 260+43.16 for the Stop Station.

17.  Key in 50.00 for the Interval.
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18. <D> Add.

19. <D> Apply.  <D> a blank area of the MicroStation view window to display the cross 
sections.

20. <D> Close to dismiss the Create Cross Sections dialog box.

The data used for the custom cross section set can be saved for use at a later time.  The steps 
below save the data.

21. <D> Yes for the message to save the data for the custom cross sections.

22. In the Save AS dialog box, navigate to C:/Projects/12345/Design/InRoads/ directory.

23. Key in SH 86.xsc for the file name and <D> Save.

To exclude the material within the volume exception, end area volumes must be recalculated.  
The following steps create the  the volume exception and recalculate the volumes.

24. Select Evaluation >Volume > End Area Volume from the InRoads menu bar.

25. <D> General in the End Area Volume explorer.
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26. Select SH 86_1 for the Cross Section Set. The other settings are correct.

27. <D> Volume Exceptions in the End Area Volume explorer.

28. Select 208+15.83 for the Start Station.

29. Select 212+89.50 for the Stop Station.

30. <D> Add.

31. <D> Apply to calculate the volumes.
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32. Examine the cross section at station 212+89.50.  Notice the volumes listed for both cut and 
fill are 0.00.  No earthwork was calculated between the stations 208+15.83 and 212+89.50.

Lab 16.5 - Volume Reports

In addition to having volume information displayed on the cross sections, it can also be written to a tabular 
report. This exercise demonstrates how to create the report and the various templates used with the report.

The steps below create the XML data used for the report.

1. In the End Area Volumes dialog box, <D> General in the End Area Volume explorer.

2. Select SH 86_1 for the Cross Section Set.

3. Toggle on Create XML Report.

4. <D> Apply.  This displays the Bentley InRoads Report Browser.

The XML data is passed to the Bentley InRoads Report Browser so that it can be displayed in a 
useful manner.  The steps below use several report templates to present the volume data in 
different ways. 

5. In the Bentley InRoads Report Browser, <D> the Evaluation folder.

6. <D> the EndAreaVolume.xsl template.

7. Examine the report in the right pane of the browser.  This report only has a grand total line.

8. <D> on the EndAreaVolumePageTotals.xsl template.
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9. Examine the report in the right pane of the browser.  This report only has page totals as well 
as a grand total line.

10. <D> on the Volumes.xsl template.

11. Examine the report in the right pane of the browser.  This report lists areas and volumes for 
cut and fill along with the volumes for the components in the design dtm.

12. Close the Bentley InRoads Report Browser and all open dialog boxes (except the main 
InRoads dialog box).

Lab 16.6 - Station Base Reports

There are numerous other reports that can be generated from InRoads.  they all function in a similar manner.  
This lab demonstrates the process of creating reports.  The Geometry Station Base report is used for an 
example.
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The Station Base report measures the offste distance from the active alignment to a specified 
alignment at given intervals along the active alignment.  The steps below create the XML data 
file for the station base report, then uses several report templates to present the data in a variety 
of formats.

1. From the InRoads menu bar, select Tools > XML Reports > Station Base.

2. In the From area of the Station Base Report dialog box, note that the alignment SH 86 is 
selected.  Measurements are made perpendicular to this alignment.

3. <D> Include from the Station Base Report explorer.
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4. In the Interval field, key in 100.

5. <D> Horizontal Alignments from the Station Base Report explorer.

6. In the Include field, key in Off Ramp.  Press the Tab key to accept the entry.

7. <D> Apply.  This displays the Bentley InRoads Report Browser.

8. In the Bentley InRoads Report Browser, <D> the StationBaseSingle.xls.
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9. Examine the report in the right pane.

This report is useful for determining the distance between two alignments.  It can also be used 
to determine the distance from an alignment to a surface feature.  The steps below create a 
station base report between an alignment and a surface feature.

10. Minimize the Bentley InRoads Report Browser.

11. In the Station Base Report dialog box, <D> Horizontal Alignments in the explorer.

12. In the Include field, key in a space and press the Tab key to accept the entry.  This clears the 
Selected list.

13. <D> Features in the explorer.

14. Select 12345 Existing Ground for the Surface.

15. In the Features list, Highlight T_Edge of Oil497.

16. <D> Apply.
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17. In the Bentley InRoads Report Browser, <D> the StationBaseSingle.xls.

18. Examine the report in the right pane.  

19. Close the Bentley InRoads Report Browser and all open dialog boxes (except the main 
InRoads dialog box).

20. Save the InRoads project then close InRoads.

Chapter Summary:

 In Lab 16.1 -Create Cross Sections a set of cross sections was created showing the existing 
ground and design finished grade.  These were updated to show the design components.

 In Lab 16.2 -Calculate End Area Volumes the cross sections generated above were used to 
calculate End Area Volumes.  The ability to include or exclude components from the 
volume calculations was demonstrated.

 In Lab 16.3 -Unsuitable Material an area of unsuitable material was defined using the 
station method.  This was used to modify the volume calculation.

 In Lab 16.4 -Volume Exceptions A set of custom cross sections was created, then a volume 
exception was defined.

 In Lab 16.5 -Volume Reports the various templates for End Area Volume reports were 
examined.

 In Lab 16.6 -Station Base Reports the procedure for creating a Station Base report was 
demonstrated.  Reports from alignment to alignment and alignment to feature were created
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Creating Plan and Profile sheets is a repetitive and time consuming process.  InRoads has automated this 
process.  This lab demonstrates P and P sheet creation and editing with the InRoads Plan and Profile Generator 
command.

Chapter Objectives:  

 Input data for the initial P and P sheet creation

 Prepare the seed files for the Plan and Profile Generator command

 Edit sheet extents and recreate sheets

 Move reference files within the sheet border

 Add a model file to a single sheet

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.dtm

 C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn

 C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Model.dgn

Note: The 12345DES_Model.dgn file should have feature data displayed from previous 
labs.  If this file is empty or if data not appropriate for plan sheets is near the SH 86 
alignment, then all data in the the file  should be deleted and surface features from 
the 12345DES.dtm and the SH 86 alignment should be displayed prior to working 
the lab.

Lab 17.1 - Creating 100 Scale P and P Sheets

This lab illustrates the user input required to produce an initial set of P and P sheets.

1. Open the C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn file 
in MicroStation.

The step below sets the scale factor so that text displayed by InRoads will be the proper size for 
a 100 scale plan set.
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2. Select Tools > Options and <D> the Factors tab and set the scale factors to 100 for the 
Text Scale Factor and the Cell Scale Factor.  Set the Linestyle Scale Factor to 1.  This can 
also be done from the Global Scale Factors dialog box.

3. <D> Apply then Close.

Preferences are predefined menu settings that are used to set up the dialog box for a particular 
style of plan sheet.  In this case, a 100 scale plan and profile sheet with a 2 times vertical 
exaggeration is desired.  The steps below select the desired preference.

4. From the InRoads menu bar, select Drafting > Plan and Profile Generator.  The Plan 
and Profile Generator dialog box is displayed.

5. On the Plan and Profile Generator Main tab, <D> the Preferences button.  This displays 
the Preferences dialog box.

6. From the Preferences dialog box, highlight 100 Scale P&P (2x Vert).

7. <D> Load.
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8. <D> Close.  This dismisses the Preferences dialog box.

Preferences do not make all of the desired changes to menu settings, in particular those that are 
project specific.  The steps below make the project specific changes to the menu settings.   

9. Back on the Main tab, in the Station Limits area, key in 204+00.00 for the Start station.

10. key in 260+00.00 for the Stop station.

Reference files that make up the plan portion of the sheets are selected from the Plan Controls 
tab.  The following steps are used to select the desired files.
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11. <D> the Plan Controls tab.

12. <D> the Model Files button.  This displays the Open Model File dialog box.

13. Highlight the C:\Projects\12345\Design\Drawings\Reference 
Files\12345DES_Model.dgn file.

14. <D> Open.  The file is added to the Model Files list and the Open Model File dialog box 
is dismissed.

15. <D> the Model Files button.  This displays the Open Model File dialog box.

16. Highlight the C:\Projects\12345\ROW_Survey\Drawings\Reference 
Files\12345SURV_Topo.dgn file.

17. <D> Open.  The illustration below shows the Plan Controls tab with the two files added.
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The Profile controls tab determines how the profiles will be displayed.  Most of the settings are 
by the selected preference, however, it is a good idea to check the Surface area and make sure it 
is set up as desired.  In this exercise, only the existing ground is to be displayed in the profile so 
it is the only one toggled on.  The highlighted surface is used to determine where elevation 
shifts occur.  Because the existing ground is the only surface displayed, it is also used to 
determine elevation shifts. 

18. <D> the Profile Controls tab.

19. In the Surface area, toggle off all surfaces except 12345 existing ground.

20. Verify that the surface 12345 existing ground is toggled on and highlighted.  The 
illustration below shows the tab as completed.

With the exception of the Host File, the Sheet Layout tab is set by the prererence selected.  The 
Host File is the base name that the finished sheets will be called.  The host file name is 
incremented for each sheet created so that they will all have a unique name.  In the steps below, 
the host file name is entered.

21. <D> the Sheet Layout tab.

22. <D> in the Host File field, then <D> the  button.  This displays the Save As dialog box.

23.  In the Save As dialog box, navigate to the C:\Projects\12345\Design\Drawings\ folder.

24. In the File Name field, key in 12345DES_PnP.dgn.
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25. <D> the Save button.  This dismisses the Save As dialog box adds the file name to the 
Host file field.

The Border and Title tab identifies the cell used for the sheet border.  This tab should be 
checked to ensure that the proper border cell is being used.  Also check to make sure that all of 
the toggles in the symbology area are turned off.  If left on, erroneous data could be displayed 
on the sheets.

26. <D> the Border and Title tab.

27. Verify that the Sheet_Design-Sheet cell is selected for the cell Name.
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28. Verify that all of the check boxes in the Symbology area are toggled off.

29. <D> the Apply button.

30. <D> in the MicroStation view window.

The command creates a profile for each sheet (there are 5 sheets in this project) and then 
creates the sheets, each as a separate dgn file.  The last sheet is shown below.
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The plan and Profile generator offers an easy to move between generated sheets.  Using the 
Sheet Index tab, sheets can be opened in without having to navigate through the MicroStation 
menus.  Use the steps below to review the other sheets.

31. <D> the Sheet Index tab.

32. Highlight sheet 1 in the Sheet Index list.

33. <D> the Show Sheet button.

34. Repeat steps 31 and 32 for the remaining sheets.

Lab 17.2 - Creating 50 Scale P and P Sheets

To switch from 100 scale sheets to 50 scale requires some additional setting changes.  Most of 
these are handled through the preferences, however the Annotation Scale for the profile and 
seed host file and the InRoads Scale Factors must be set before executing the command.  This 
insures that the correct annotation scale is applied to each sheet.

The (MicroStation) annotation scale does not affect graphic elements displayed by InRoads but 
it will affect elements added with MicroStation commands.

This lab uses the same data as above to create a set of 50 scale P&P sheets.

In the steps below, the model properties are changed in the 3D-Seed_CDOT.dgn (seed host 
file).  This will ensure that each P and P sheet created will have the proper annotation scale for 
the project.

1. Using the MicroStation menu bar, open the:
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C:\Workspace\Workspace-CDOT_XM\Standards-Global\MicroStation\Seed\3D-
Seed_CDOT.dgn 

2.  <D> The Models button on the MicroStation Primary toolbar.  This displays the Models 
dialog box.

3. On the Models dialog box, <D> the Edit Model Properties button.  This displays the 
Model Properties dialog box.

4. Set the Annotation Scale to 1” = 50’ using the drop down menu.

5. <D> OK.  This dismisses the Model Properties dialog box.

6. <D> Yes on the message window that is displayed.  This has no effect because the drawing 
is empty.

7. Close the Models dialog box.

8. From the MicroStation menu bar, select File > Save Settings.
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Note: The changes to the seed file only last until the computer is logged off.  At the next 
log in, the settings revert back their original state.  The sheets created from the seed 
file maintain the changes.

The same setting made above must also be made in the dgn file that will contain the profile 
information.  The following steps remove the data from the previous lab and update the model 
properties and InRoads scale factors for 50 scale sheets.

9. Open the C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn file.

10. Select File > Save As from the  MicroStation menu bar. Navigate to: 
C:\Projects\12345\Design\Drawings\Reference Files\

11. Key in 12345DES_Prof_50Scale.dgn for the file name.

12. <D> Save.

13. Delete all of the data in the dgn file.

14. Repeat steps 2 through 8 above.

The dgn files are ready for the new scale.  Next the InRoads settings are changed for 50 
scale..

15. From the InRoads menu bar, select Tools > Options and <D> the Factors tab and set the 
scale factors to 50.  This can also be done from the Global Scale Factors dialog box.

16. <D> Apply and then <D> Close to dismiss the dialog box used.

17. Display the Plan and Profile Generator dialog box.

18. <D> the Main tab.

19. <D> the Preferences button.  This displays the Preferences dialog box.

20. From the Preferences dialog box, highlight 50 Scale P&P (1x Vert).  

21. <D> Load.

22. <D> Close.  This dismisses the Preferences dialog box.
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Except for the Host File name, the user defined settings are still active and are used for this 
lab.  To set the Host File name:

23. <D> the Sheet Layout tab.

24. <D> in the Host File field, then <D> the  button.  This displays the Save As dialog box.

25.  In the Save As dialog box, navigate to the C:\Projects\12345\Design\Drawings\ folder.

26. In the File Name field, key in 12345DES_PnP_50Scale.dgn.

27. <D> the Save button.  This dismisses the Save As dialog box and adds the file name to the 
Host file field.

28. <D> the Apply button.

29. In the “Do you want to regenerate Plan Views?”  message box, <D> Yes.

30. In the “Do you want to regenerate ProfileViews?” message box, <D> Yes.

31. <D> in the MicroStation view window.

Nine 50 scale sheets are created.  Follow the steps below to check that the correct annotation 
scale was used.

32. <D> The Models button on the MicroStation Primary toolbar.  This displays the Models 
dialog box.

33. On the Models dialog box, <D> the Edit Model Properties button.  The Model 
Properties dialog looks like the illustration below.

34. <D> Cancel to dismiss the Model Properties dialog box.

35. Close the Models dialog box.
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Lab 17.3 - Edit Sheet Extents

After examining the sheets created in the last lab, the intersection on sheet 4 should be centered 
on the sheet.  In this lab, the sheet extents are changed to center the intersection.

First, view sheet 4 to determine the amount of shift required.

1. <D> the Sheet Index tab.

2. Highlight sheet 4 from the Sheet Index list.
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3. <D> the Show Sheet button.

Examining sheet 4 shifting two stations (200 feet) to the left centers the intersection.
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4. Open the C:\Projects\12345\Design\Drawing\Reference Files\12345DES_Prof.dgn file.

5. Delete the previously displayed profiles.

Plan and Profile Generator can be used to specify the station extents of any sheet.   Here, sheet 
4 is adjusted to center the intersection and the other sheets will automatically be changed to  
match.  The steps below update the station extents on sheet 4.

6. <D> the Main tab.

7. Toggle on Use Plan Views. 

8. Highlight sheet 4 in the Plan Views list.

9. <D> the Edit button.  This displays the Edit Plan View dialog box.

10. In the Edit Plan View dialog box, key in 222+00.00 for the Start station.

11. Key in 229+00.00 for the Stop station.
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12. <D> Apply.  This displays the Adjust Plan Views dialog box.

The next steps update the remaining sheets to match the changes made to sheet 4.

13. In the Adjust Plan Views dialog box, toggle on Adjust all views to maintain view 
lengths.

14. <D> the OK button.

15. <D> Yes on the “Update view names in corresponding sheets?” Message box.
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16. In the Edit Plan View dialog box, <D> Close.

Reducing the start station by 2, shifts the intersection to the middle of the sheet.  Toggling on 
Adjust all views to maintain view lengths, resets the stations on the remaining sheets.

Finally, the steps below regenerate the sheets.

17. On the Plan and Profile Generator dialog box, <D> Apply.

18. <D> Yes in the, “Do you want to regenerate Profile Views?” message.

19. <D> in the MicroStation view window.

20. After processing is complete, examine sheet 4 as described at the first of the lab.  The 
illustration below shows how the sheet looks.
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Lab 17.4 - Moving Reference Files Within the Sheet Border

After adjusting the sheets in the last lab, the first sheet has only 400 feet of data.  The data is 
aligned with the left margin of the sheet border, but should be aligned with the right margin.

This lab demonstrates how to shift the data within the sheet border.

1. Examine sheet 1, as described at the first of the lab.  The illustration below shows sheet 1.  
The reference files for the plan and profile need to be shifted 300 feet or 6” (paper scale) to 
the right.

 

2. On the Plan and Profile Generator’s Sheet Index tab, highlight sheet 1 in the Sheet Index 
list.

3. In the Sheet Views list, highlight sheet 1 Plan.
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4. <D> Edit.  This displays the Edit Sheet View dialog box.

5. In the Anchor X field, key in 7.75.

6. <D> OK. This dismisses the Edit Sheet View dialog box.

7. In the Sheet Views list, highlight sheet 1 Profile.

8. <D> Edit.  This displays the Edit Sheet View dialog box.

9. In the Anchor X field, key in 7.75.
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10. <D> OK.

11. <D> the Regenerate Sheet button.

12. <D> Yes on the message box that is displayed.
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The sheet now looks like the illustration below.

Lab 17.5 - Adding a Model File to a Single Sheet

Many of the specialty groups create data that is included on the plan sheets.  However, much of 
this information applies to a localized area and is contained on one or two sheets in the set ( a 
bridge or intersection, for example).  

This lab demonstrates how to attach a Model File to a single P&P Sheet.  A traffic signal plan is 
added to Sheet 4.
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1. Examine sheet 4, as described at the first of the lab.  The illustration below shows sheet 4.

Additional models are added from the Edit options on the Main tab of the Plan and Profile 
Generator dialog box.  The steps below illustrate this process.

2. <D> the Main tab.

3. Highlight sheet 4 in the Plan Views list.
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4. <D> the Edit button.  This displays the Edit Plan View dialog box.

5. In the Edit Plan Views dialog box, <D> the Model Files button.

6. In the Open Model File dialog box, navigate to 
C:\Projects\12345\Traffic_ITS\Drawings\Reference_Files.

7. Highlight the 12345Signal01.dgn file.

8. <D> Open.

9. Back in the Edit Plan Views dialog box, <D> Apply.
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This change only occurs on sheet 4.   Therefore. there is no need to update the other sheets.

10. <D> No in the message box that is displayed.

11. <D> Close to dismiss the Edit Plan View dialog box.

Since the added model file only affects on sheet (sheet 4), there is no need to generate a new 
complete set.  Instead, only sheet 4 is updated.  The steps below are used to update the sheet. 

12. In the Plan and Profile Generator dialog box, <D> the Sheet Index tab.

13. In the Sheet Views list, highlight sheet 4.

14. <D> the Regenerate Sheet button.
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15. <D> Yes on the message box that is displayed.

The sheet now looks like the illustration below.

16. Close the Plan and Profile Generator dialog box.
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17. <D> Yes on the message box that is displayed.  Navigate to C:\Projects\12345\Design\ 
InRoads\ and name it 12345DES_50Scale.vdf.

18.  Save all of the data files and Close InRoads.

19. Close MicroStation.

Chapter Summary:

 In Lab 17.1 -Creating 100 Scale P and P Sheets the input data for the initial 100 scale Plan 
and Profile Generator run was described

 In Lab 17.2 -Creating 50 Scale P and P Sheets the annotation scale in the seed files was 
changed for 50 scale sheets along with the InRoads scale factors and the Plan and Profile 
Generator settings.  Then a new set of sheets was generated

 In Lab 17.3 -Edit Sheet Extents the sheet extents for the 50 scale plans were modified to 
center the intersection and the sheets were regenerated

 In Lab 17.4 -Moving Reference Files Within the Sheet Border the reference files (plan and 
profile) were moved within the sheet border to the right margin

 In Lab 17.5 -Adding a Model File to a Single Sheet a traffic signal plan model file was 
added to sheet 4 only
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This lab demonstrates the functionality build into the standardized tab sheets.  It highlights the ability to 
quickly modify the sheet’s structure by adding and removing columns and dividing the sheet so that it will fit 
within the sheet border.  The functionality is similar with all of the standardized tab sheets.  This lab uses the 
DES_Tabulation of Surfacing.xls file for the exercises.

Chapter Objectives:

 Update the Pay Item File location

 Add additional columns to the table

 Delete columns from the table

 Modify fields associated with asphalt pay items

 Add additional rows to the table

 Enter data in the new rows and columns

 Divide the main sheet into sub sheets

 Link the sub sheets to a MicroStation sheet border.

The files used in this lab are:

 C:\Projects\12345\Design\Drawings\Tabs\12345DES_Tabulation of Surfacing.xls 

 C:\Projects\12345\Design\Drawings\12345DES_TabMisc##.dgn

Lab 18.1 -  Update the Pay Item File location 

In order for the tab sheet to function properly, it must access the Trnsport_Itemlist.csv file.  The location of this 
file is specified in cell D1 of the Surfacing Sheet worksheet. This exercise demonstrates how to select the the 
Trnsport_Itemlist.csv file’s location.

1. Start Excel and select File > Open.

2. In the Open dialog box, navigate to C:\Projects\12345\Design\Drawings\Tabs.

3. Highlight the 12345DES_Tabulation of Surfacing.xls file and <D> Open.

Notice that the text for the Pay Item File is red.  This indicates that the file is not found.  
Without this file, additional pay items cannot be added.  To locate the Trnsport_Itemlist.csv 
file:
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4. <D> the Update / Browse for Pay Item File button.  This displays the Update / 
Browse for Pay Item File dialog box.

5. <D> The Browse for Pay Item File button. This displays the Open dialog box.

6. Navigate to the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ directory.
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7. Highlight the Trnsport_Itemlist.csv file and <D> Open.

8. <D> the Return to Excel button in the Update / Browse for Pay Item File dialog box.

The text for the Pay Item File is now black, indicating that the Trnsport_Itemlist.csv file is 
available for use.
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Lab 18.2 -  Adding a Pay Item

There are times when additional pay items need to be added after work has begun on the tabulation sheet.  The 
standardized tab sheet can add and sort the additional columns, keeping the existing data in the sheet with its 
proper pay item.  In this exercise, a column for Removal of concrete pavement is added.

The illustration above shows the sheet before adding the column.

1. <D> the Data Entry button.  This displays the Surfacing Data Entry dialog box.

2. Scroll down the list of pay items and highlight the 202-00210 Removal of Concrete 
Pavement pay item.
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3. <D> the Add Items button.

4. <D> Close to dismiss the Surfacing Data Entry dialog box.
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Notice that the Removal of Concrete Pavement is now the first pay item column on the sheet.  
Also note that the data in the sheet was shifted to keep it with the proper pay item.

The illustration above shows the sheet after the new column is added.

Lab 18.3 -  Deleting a Pay Item

Sometimes pay items originally added to the sheet are not used.  The standardized tab sheet can 
remove the specified columns and reorganize the remaining data.  In this exercise, the column 
for patching asphalt is removed.

1. <D> the Data Entry button.  This displays the Surfacing Data Entry dialog box.

2. <D> the Delete a Pay Item already placed in sheet button.  This displays the 
Delete Item dialog box.

3. Highlight the 403-00721 Hot Mix Asphalt (Patching) (Asphalt) pay item.
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4. <D> the  Delete Item button.

5. <D> Close on the Delete Item and the Surfacing Data Entry dialog boxes.

Notice that the patching asphalt column is gone and the columns to the right have shifted over.  
The illustration below shows the final layout.
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Lab 18.4 -  Additional Fields Associated with HMA Pay Items

Unlike concrete, asphalt pavement is laid down in a series of lifts.  Each lift making up the total pavement 
thickness could be a different thickness and/or a different grade (which uses a different pay item code).  The 
DES_Tabulation of Surfacing.xls  In addition, extra material is often added to the first (Bottom) lift of asphalt 
to account for irregularities in the ground surface.  These items are accounted for in the tabulation sheet with 
two fields outside of the table and a heading row within the table. For the exercise below, the pavement 
contains three lifts of PG 64-22 asphalt and one lift (the top lift) of PG 76-28 asphalt.  The sheet shows four 
lifts of PG 64-22 asphalt and one lift  of PG 76-28 asphalt listed as a bottom lift.  It will also use an irregularity 
factor of 2% where the sheet currently shows 5%.  The sheet will be modified to match the pavement 
description given above.

1. <D> in the Number of Lifts cell for the 403-34841 Hot Mix Asphalt (Grading SX) (100) 
(PG 64-22) pay item. (cell I4 in this exercise)

2. Use the drop down menu and select 3 from the list.
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The original Lift 2 row was deleted (including the data).  The Lift 3 and Top rows were shifted 
over and renamed.  The illustration below shows the results.

Next, the lift headings for the Top lift of the PG 64-22 asphalt and the lift of PG 76-28 are 
modified.

3. <D> in cell K9 (it reads Top under the PG 64-22 main heading).

4. Key in Lift 3 and press the Enter key.

5. <D> in cell K10.

6. Key in Top and press the Enter key.

This changes the lift headings for the two asphalt items.  The spreadsheet looks at these 
headings to determine if the irregularity factor is applied.  The irregularity factor is applied to 
the Bottom lift only and if the PG 76-28 lift heading was not changed it would result in an 
erroneous total.  The illustration below shows the changes made.
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Finally, the irregularity factor for the PG 64-22 is changed.  The irregularity factor for the PG 
76-28 does not have to be changed because it is not a Bottom lift.

7. <D> in cell I4. This is the % Irreg to Apply: cell for the 403-34841 Hot Mix Asphalt 
(Grading SX) (100) (PG 64-22) pay item.

8. Key in 2 and press the Enter key.  The change is made in cell I4.  This value is used to 
determine the total amount of material used for irregularities at the bottom of the sheet.

Lab 18.5 - Adding Additional Rows

It is possible that additional rows for data are required.  These can be added using the functionality built into 
Excel.  In this exercise, two additional rows are needed.

1. Highlight rows 32 and 33.  To do this, <D> and hold on the row number 32 and drag 
through number 33 and release.

2. <R> in the highlighted area and select Insert from the menu.

The additional rows are added above row 32.

Lab 18.6 -  Add Additional Data to the Sheet

Now that the sheet is set up, the quantities for the new columns and rows can be added.  Station extents for the 
last five rows are needed.  At the top of the sheet, quantities for removal of concrete pavement are added.  At 
the bottom, the quantities associated with the asphalt pavement are added. ( Note: on an actual project the 
quantity values are calculated based on design data prior to creating this sheet.  Here we are inserting an 
arbitrary value to demonstrate the functionality of the sheet.)

1. <D> in cell F10.  This is the first quantity cell of the removal of concrete pavement pay 
item.

2. Key in 132 and press the Enter key.  This represents the number of square yards of 
concrete pavement removed between station 1+00 and 5+00.
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3. Press Enter twice more.  The cursor is in cell I13.

4. Key in 247 and press Enter.

5. Key in 316 and press Enter.  This is in cell I14.

6. Scroll so that the Project Totals line is visible.  The total for removal of concrete 
pavement is 695.

Next enter the station numbers for the last three lines.  The stations are in 700 foot intervals.

7. <D> in field C32.  This is the first empty cell in the From station field.

8. Key in 15000 and press the Enter key.  This is 700 more the value in the cell above.

9. Continuing entering stations (adding 700 each time) down to cell C36.

10. Repeat this process in the To station column.  The illustration below shows the completed 
station columns.
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11. To finish the data entry, copy the data from row 31 – columns H through O into rows 32 
through 36.  The illustration below shows the completed data entry.
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12. Examine the totals for the Asphalt pay items.  Note:

♦ An irregularities total only for the bottom lift of asphalt

♦ Sub totals for each lift of PG 64-22

♦ A grand total for PG 64-22

Lab 18.7 - Dividing the Surfacing Sheet into Sub Sheets

It the sheet is too long to fit inside the sheet border, there is a option to divide the master sheet into sub sheets 
of a specified number of data rows.  When this option is selected, additional worksheets are added to the file 
that contain a part of the master sheet along with a sheet totals table.  In this exercise, it was decided the 20 
rows of data was the maximum per sheet. (this number will vary based on the tab sheet being used and 
additional information that may be included in the printable sheet.)

1. Scroll to the top of the sheet (if it is not there already).

2. <D> the Divide Sheet button.  This displays the Sheet Rows dialog box.

3. Key in 20.  This is the number of data rows used on each sub sheet.



Page 358 Colorado Department of Transportation

LAB 18 - Tab Sheets Labs for InRoads XM

4. <D> OK.

Two sub sheets (Sub Sheet 1 and Sub Sheet 2) were created along with Sub Sheet Totals.

The master sheet (Surfacing Sheet) is left intact.  To re divide the master sheet by a different 
number of rows, delete the sub sheets and run through the process again.

5. Save but do not close the file.

Lab 18.8 - Link the Sub Sheets to a MicroStation Sheet Border

The final step in creating the tab sheet is to link the Excel file to the MicroStation sheet border.  Linking allows 
the Excel file to be updated and reflect those updates in the MicroStation file.  In this exercise, Sub Sheet 1 is 
linked to the sheet border file.  The process is the same for the other sub sheets.

The first step in linking the spreadsheet is to prepare the MicroStation file.  The miscellaneous 
tab sheet border is copied and renamed to be the surfacing tab sheet.

1. Start MicroStation and open 12345DES_TabMisc##.dgn.

2. Select File > Save As from the MicroStation menu bar.

3. Key in 12345DES_TabSurf01.dgn in the File name field.
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4. <D> Save.  This creates the new file and opens it.

5. Bring Excel to the front.

6. Select the Sub Sheet 1 worksheet.

7. Highlight cells C2 through P29.  This is the entire table.

8. Select Edit > Copy from the Excel menu bar.

9. Bring MicroStation to the front.
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10.  Select Edit > Paste Special from the menu bar. This displays the Paste Special dialog 
box.

11. In the Paste Special dialog box, highlight Linked Microsoft Office Excel 2003 
Worksheet.

12. <D> Paste. This displays the Paste OLE Object tool settings box.

13. In the Paste OLE Object tool settings box, set the Method to By Size.
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14. In the Scale field key in 8.500.  This makes the text in the Excel file the proper size for 
the MicroStation file.

15. A dashed box is connected to the cursor.  This represents the size of the table that is being 
placed.  Center it inside the sheet border and <D>.  The file is now linked to the sheet 
border file.

16. The hatching in the table indicates that the Excel file is open.  Bring Excel to the front and 
close it to remove the hatching.  The illustration shows the final result.

17. Close MicroStation.
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Chapter Summary:

 The tab sheets use the Trnsport_Itemlist.csv file to set the column headings for the tab 
sheet.

  The Trnsport_Itemlist.csv file is updated by ServerCop at log in or it can be manually 
updated.

 Programming that automates the layout and revision of the column headings is accessed 
through various buttons placed in the worksheet.

 Rows are added or deleted using standard Excel functionality.

 Large tab sheets can be divided to fit into multiple sheet borders.

 If the tab sheet is divided, a sheet totals table is also created.

 The tab sheets are linked to a MicroStation sheet border for printing
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In this exercise, you will create a proposed digital terrain model (DTM) without using Roadway Modeler. 
Instead, a combination of feature creation and editing tools is used to develop the breaklines for a pond.

Chapter Objectives:

 To learn the process of using the combination of several feature tools to create a proposed 
design.

 To understand the concept of creating a surface of features solely for use as a target.

 To realize the value of using Generate Longitudinal Feature and Generate Sloped 
Surface in creating proposed designs.
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Lab 19.1 - Load and Create Surfaces

1.  Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Delete any MicroStation graphics currently in the design file.

3. Verify the correct XIN file is loaded.

4. Delete any MicroStation graphics currently in the design file.

5. Select File > Open from the InRoads menu.

6. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm.

7. Cancel the Open dialog box.

8. Toggle Locate Features/Locate Graphics to Locate Graphics.

9. Select File > New.

10. Select the Surface tab.

11. Set the Type to Design

12. Key in the Name 12345 pond.

13. Key in the Description Pond training example

14. Set the Preference to Proposed

15. <D> Apply and Close the New dialog. 
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Lab 19.2 - Display the Pond Graphics

1. Toggle on the display for the 12345DES_Pond.dgn reference file.

2. Fit the view to see the pond graphics.

The pond you are going to create is beside a new roadway SH52. The toe of slope for the 
roadway is the boundary for the pond on the South side, with the existing ROW limiting 
the size on the North and other existing features dictating the basic shape of the pond. The 
graphic that you just toggled on shows what has previously been determined as the outer 
limit of the pond.
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Lab 19.3 -  Creating a feature for the top of pond

In this case, you are going to start with the known outside of the pond, so you must first set the elevations of 
this boundary. You will do this by draping the graphic element onto the existing topo.

1. Select Surface > Design Surface > Generate Longitudinal Feature.

On the Main tab:

2. Toggle off Generate Graphics Only

3. Select 12345 pond as the Surface.

4. Toggle on Interval and set it to10.

5. Toggle on New for the Mode.

6. Key in the feature Name Pond top.

7. Set the Feature Style to H_Detention_Pond-Top.

8. Set the Point Type to Breakline.

9. Leave the Point Density Interval set to 0.
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On the Controls tab:

10. Set the Horizontal Method to Offset from Primary Feature.

11. Set both Offsets to 0.00.

12. Set the Vertical Method to Drape.

13. Set the Drape Surface to 12345 existing ground.

14. <D> Apply, then <D> to Identify and <D> to Accept the pond outline as the 
Primary Element.
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15. <D> to Identify and <D> to Accept the same shape again as the Reference Element.

16. Reset <R> for the Entire shape.

17. <D> anywhere for the Location.

Note: If your Horizontal Offsets were not 0, you would be telling InRoads which side to 
offset by moving your cursor to that location before <D>; since they are both 0, it 
does not matter where you identify the location.

The shape is draped on the existing model, but placed in the new surface.

18. <D> Close on the Generate Longitudinal Feature dialog.

Lab 19.4 - Review the feature

1. Select Surface > Feature > Feature Properties.

2. Set the Surface to 12345 pond.

3. Highlight the Pond top feature and choose List Points.
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Note: If you do not see the Pond top feature in the surface, go back and try the 
Generate Longitudinal Feature command again.

4. You should see all different elevations for the feature. If you have a feature listed, but the 
elevations are not in the range shown, use Surface > Edit Surface > Delete Feature to 
delete the feature, then try again.

5. <D> Close on the Results box and again on Feature Properties.

Lab 19.5 - Create a target for the pond bottom

In this series of steps, you will create features from the two lines at either end of the pond. The one on the West 
side represents the 5144 elevation and on the East end 5141. These features will then be triangulated to form a 
‘dummy’ surface that can be used as a target to create the pond bottom.

1. Select File > New.

2. Set the Type to Design.

3. Key in the Name: 12345 dummy pond bottom.

4. Key in the Description: Pond training example.

5. Set the Preference to Proposed.
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6. <D> Apply and Close the New dialog.

On the Surface tab:

Select Surface > Design Surface > Generate Longitudinal Feature (GLF).

7. Set the Surface to 12345 dummy pond bottom.
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8. Set the other criteria as shown to create a new feature.
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9. <D> Apply.

10. Select the West linestring with a data point <D>.

The linestring highlights and you are prompted to Accept/Reject.

11. <D> to accept.

You are prompted to Identify Reference Element.

12. Select the same linestring again with a <D> and <D> again to Accept when the linestring 
highlights.

A tracking line appear and you are prompted to Identify Beginning (Reset for Entire 
Element).

13. <R> Reset to copy the entire element.

14. <D> for the location.

Note: Since the horizontal offsets are 0.00, the location of the data point does not matter. 
If there were horizontal offsets, the data point would tell the software which way to 
make the copy, similar to a MicroStation copy command.

The shape is made into a feature at elevation 5144 in the surface dummy pond bottom.
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Lab 19.6 - Review the feature

1. Select Surface > Feature > Feature Properties.

2. Set the Surface to 12345 dummy pond bottom.

3. Highlight the Pond target (5144 elevation) feature and choose List Points.

You should see all 5144 elevations for the feature.

4. Repeat section 1.5 steps 7-13 to create a feature in the same surface for the East line, which 
should be set to an elevation of 5141.

You should now have two features in 12345 dummy pond bottom.

5. Select Close to dismiss the GLF dialog box.

6. Turn off the reference with the original pond graphics.
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7. Triangulate the dummy pond bottom surface.

Lab 19.7 - Define the pond side slopes

This series of steps takes you through creating sideslopes from the new top-of-pond outline down to the target 
DTM. 

1. Set the Locate mode to Features.

Since the source for the slopes is the feature created for the bottom of the pond, you must 
first change the Locate mode.

2. Select the Surface > Design Surface > Generate Sloped Surface (GSS).
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On the Main tab:

3. Set Source Surface to 12345 pond.

4. Set Intercept Surface to 12345 dummy pond bottom.

5. Set Destination Surface to 12345 pond.

6. For Interval key in 10.

7. For Cut Slope key in 50%.

8. For Fill Slope key in -50%.

In the Feature category:

9. Turn off Generate Graphics Only.

10. Toggle off Tic Marks and Source.

11. Toggle on Transverse. Key in transverse for the Name and set the Feature Style to 
DTM_Transverse.

12. Toggle on Catch Point. For Catch Point key in Pond bottom and set the Feature Style 
to H_Detention_Pond-Bottom.

13. Set the Point Type to Breakline.

14. For Point Density Interval key in 10.000.
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15. On the Advanced tab, key in 5^00’00.00” for Exterior Arc.

16. <D> Apply to run the GSS command.

You will be prompted to Identify Feature.

17. <D> on the closed feature that represents the top of your pond.

The entire pond top will highlight and you will be prompted to <Accept/Reject>.
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18. <D> in an area away from the shape to accept the pond top.

19. When prompted to Identify beginning/Reset for Entire, <R> to run side slopes around the 
entire complex shape.

20. When prompted for Location, <D> inside the shape, so the sideslopes will go in instead of 
out.

Graphics will appear as shown.

21. <R> and then select Close to dismiss the dialog box.
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Lab 19.8 - Evaluate the pond surface

1. Right-click on the pond surface in the Explorer portion of the InRoads menu and select Tri-
angulate.

2. Select Surface > View Surface > Contours.

3. Select Preferences.

4. Highlight the Proposed 5’ Mjr – 1’ Minor preference.

5. <D> Load, then Close.

6. Set the Surface to 12345 pond.
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7. <D> Apply.
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Lab 19.9 - Save the pond surface to the hard disk

1. Select File > Save As.

2. Set the Save as type to Surfaces (*.dtm).

3. Set the Active Surface to 12345 pond.

4. Verify the Name is 12345 pond.dtm.

5. Verify the folder is c:\12345\Design\InRoads.

6. Select Save.

7. Cancel the Save As box.

Lab 19.10 - Calculate the pond’s capacity

1. Select Tools > Application Add-ins, toggle on Hydrology and Hydraulics Add-in 
(if it’s not already on) and choose OK.

The command for calculating the pond volume is located on this add-in.
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Next, compute the volume of water your pond will hold for a range of water elevations.

2. Select Evaluation > Hydrology and Hydraulics > Compute Pond Volumes.

3. Set the Surface to 12345 pond.

4. Set the Method to Incremental.

5. For the Minimum Water Elevation key in 5142.

6. For the Maximum Water Elevation key in 5147.

7. For the Interval key in 0.5.

8. Select the Target button next to the Northing and Easting fields and place a <D> in the 
middle of your pond toward the lower end.

9. <D> Apply and the volume is calculated for the range of elevations you entered. A report 
is shown with the incremental volumes.

10. Save the report to your hard drive if desired.

11. Close the Compute Pond Volumes dialog.
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Lab 19.11 - Challenge

If you would like a challenge on this activity, complete the following steps. 

1. Add a micro pool of your own design at the deep end of the pond.

2. Add a trickle channel from the upper end down to the micro pool.

3. Zoom in close to the upper end of the pond and look at the pond toe line. Clean up the 
problems in the corner using Design Surface and Edit Surface tools.

Chapter Summary:

 Design surfaces can be created using a variety of tools to create features.

 Dummy surfaces can be created just to use as intercept targets for design commands.

 The Generate Longitudinal Feature command is a very proficient tool for creating 3D 
features.

 Simple sideslopes can be formed with GSS.

 Staged water volumes can be computed for DTMs using the Pond Volumes command on 
the Hydrology and Hydraulics Add-in.



Colorado Department of Transportation   Page 383

LAB 20 - Constructing A Driveway

Driveway modeling should not be done to the level of detail that mainline corridor modeling is done.  
However, there may be times when a drive should be modeled accurately.  This lab describes a workflow for 
modeling driveways quickly and easily.

Chapter Objectives:  This lab models a driveway from the proposed edge of pavement of the design 
corridor to the existing ground at the right of way line.  The following InRoads tools are used to 
complete the model:

 Use Tracking to determine the location of the ramp.

 Use Generate Longitudinal Feature to construct the centerline and edge features of the 
ramp.

 Use Drape Surface to create the end of the drive.

 Use Import Surface to create features from MicroStation graphics.

 Use Fillet Feature to construct the drive returns.

 Use Join Features to create a continous feature from the driveway edges and returns.

 Use Apply Template create sideslopes for the driveway.

The following files are used for this lab:

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\SH86.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

The driveway is 12’ wide extending from the proposed edge of pavement to the right of way, 60’ to the right of 
the SH 86 centerline.  The driveway returns have a 15’ radius.  There is a 12:1 slope for 20’ from the edge of 
pavement.  

Lab 20.1 - Locating The Driveway

The new driveway is located on top of the existing driveway between stations 254+00 and 255+00 or the right 
side of the mainline.

Section Objectives:

 Use Tracking to determine the centerline station of the driveway.

 Use MicroStation key-ins to construct a line for the driveway centerline and end line.

1. Open InRoads using the 12345DES_Driveway.dgn file.

Note: If the existing drive is not visible, display the driveway saved view.  To display a 
saved view:

a. <D> the icon in the left corner of the view title bar and select View Save/Recall.

b. In the Saved Views dialog box, highlignt driveway.
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c. <D> Apply and then <D> Close to dismiss the Saved Views dialog box.

2. Open the following InRoads data files:

♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm

♦ C:\Projects\12345\Design\InRoads\SH86.dtm

♦ C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

♦ C:\Projects\12345\Design\InRoads\DES12345_Templates.itl

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\Preferences\CDOT_Civil.xin file is loaded.

4. Verify that the SH 86 alignment is active.

5. Select Tools > Tracking > Tracking from the InRoads menu bar.
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6. Activate the tracking and <T> to the center of the back of the driveway.

7. Write down the Station listed in the Tracking dialog box.

8. From the CDOT Menu, highlight the Geometry group.

9. <D> the Other button and select Alignment from the item list.
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10. In the MicroStation key-in window, type so=254+47.15,0 and Enter.

Note: Use the station that you wrote down in step 6.

11. Key in so=254+47.15,60 and Enter.  <R> to end the line.

This places a line at the centerline of the driveway.  This line is used as a reference line when 
constructing the driveway surface features.

12. Key in so=254+41.15,60 and Enter. 

13. Key in so=254+53.15,60 and Enter.  <R> to end the line.

Note: Use stations 6’ before and 6’ after the one you wrote down in step 6.

This places a 12’ long line at the end of the driveway representing the width of the drive.  This 
line is also used as a reference line when constructing the driveway surface features.

Section Summary:

The location of the driveway was identified and elements needed to create the driveway 
centerline and end line were placed.

Lab 20.2 - Setting Elevations

In this section, the driveway end line is draped to the existing surface to aquire the elevations for that feature.  
The line for the driveway centerline is moved to the proper elevation, then is modified to give it the proper 
slopes.
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Section Objectives:

 Create a surface for the driveway.

 Use Drape Surface to create the driveway end line feature.

 Display the design surface (SH 86) triangulated features.

 Move the driveway centerline to its proper location (horizontally and vertically.

 Create a centerline feature with the proper slopes using Generate Longitudinal Feature and 
Edit Feature Point.

1. Select File > New from the InRoads menu bar.

2. On the Surface tab, set the Type to Design.

3. In the Name field, key in Driveway 254+47.15 Rt.

4. In the Description field, key in Driveway at station 254+47.15 on the right.

5. Set the Preference to Proposed and <D> Apply then Close.

6. From the InRoads menu bar, select Surface > Design Surface > Drape Surface.

7. Set the Destination Surface to 12345 existing ground.

8. Set the Input Mode to Single.

9. Set the Destination Level to DES_SURFACE _1.

10. Toggle on Delete Original Graphics.
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11. <D> Apply then follow the prompts in the MicroStation message window (lower left 
corner of the screen).

12. Close the Drape Surface dialog box.

This creates a MicroStation graphic element that matches the elevations of the existing ground.  
Next that element is imported into the Driveway 254+47.15 Rt surface.

13. Select File > Import > Surface from the InRoads menu bar.

14. In the Import Surface dialog box, set the Surface to Driveway 254+47.15 Rt.

15.  Set Load From to Single Element.

16. Set Elevations to Use Element Elevations.

17. In the Seed Name field, key in Driveway_End.
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18. Set the Feature Style and Point Type to Breakline.

19. <D> Apply.

20. <D> the element created by the Drape Surface command.  <D> in a blank area to accept 
the element.

21. Close the Import Surface dialog box.

The driveway end line is now stored as a surface feature.  To place the driveway center line at 
the correct location, the features of the SH86 surface must be displayed.  Use the feature filter 
to display only the triangulated features of the SH86 surface, then move the driveway 
centerline to the proper location.

22. On the InRoads Locks toolbar, set the feature filter to XS_Excluded from 
Triangulation.

23. Toggle on the Feature Filter Lock.

24. Select Surface > View Surface > Features from the InRoads menu bar.

25. Select SH86 for the Surface.
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26. Highlight all of the features in the Features list.

27. <D> Apply then Close the View Features dialog box.

The red line running through the existing driveway is the proposed edge of pavement. The 
driveway centerline needs to be moved to start at this edge line.

28. Use the MicroStation Move command and pick up the driveway centerline, snapping to 
the end on the mainline centerline.
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29. Snap to the intersection of the driveway centerline and the edge of pavement feature to 
place the line in its new location.  <D> to complete the move then <R> to exit the 
command.

Next, the point of the “breakover” from the 12 to 1 slope must be located.  This point is 20’ 
from the proposed edge of pavement, or 44’ from the mainline centerline.

30. Select the MicroStation Place Smartline command.   

31. In the MicroStation Key-in window, type so=254+00,44 and press Enter.  The starting 
station of this line is not important as it will be deleted once the driveway centerline is 
modified.

32. Key in so=254+47.15,44 and press Enter.  <R> to end the line.
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33. Select Extend Element to Intersection from the MicroStation main toolbar and shorten the 
driveway centerline back to the line just placed.  The illustration below shows the result.

Now the 12 to 1 slope is added to the line.  The Generate Longitudinal Feature command is 
used to create the sloped element.  The Generate Graphic Only option is used because 
additional editing is required.

34. From the InRoads menu bar, select Surface > Design Surface > Generate 
Longitudinal Feature. 

35. On the Main tab of the Generate Longitudinal Feature dialog box, key in 20 for the 
Interval.

36. set the Feature Style to Breakline.
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37. Toggle on Generate Graphic Only.

38. Select the Controls tab.

39. For the Horizontal control, use Offset from Primary Feature with Start and Stop values 
of 0.00.

40. Set the  Vertical control Method to Elevation/Longitudinal Slope.

41. Set the Start Elevation by selecting the “Target” button then <T> to the beginning of the 
driveway centerline, <D> to accept.  The elevation should be around 6545.80.
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42. Key in 1/12 for the Logitudinal Slope.  The result will be 8.33%.

43. <D> Apply, then follow the prompts in the lower left corner of the MicroStation window.  

44. Select the driveway centerline as the primary and reference element.  

45. <R> to use the entire line, the <D> to finish the command.

Be careful in the next steps, because the original line is under the line just created.  This new 
line is modified by adding a vertex, extending it to the driveway end line.

46. Select Insert Vertex form the MicroStation main toolbar.

47. <T> to the end of the new driveway centerline, then <D> to accept.

48. <T> to the center of the driveway end line and <D> to accept.  <R> to exit the command.

49. Delete the original driveway centerline and the reference lane, they are not used to create 
the driveway surface.
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The elevation of the driveway centerline at the edge of pavement was set when the line was 
moved.  The elevation at the end of the initial slope was set using the Generate Longitudunal 
Feature command.  Finally. the elevation at the end of the drive was set by snapping the new 
vertex to the driveway end line created eariler.  The driveway centerline now represents the 
profile of the driveway.

Section Summary:

In this section, the features of the mainline road were displayed as an aid in designing the ramp.  
The driveway end line was draped to the existing ground and stored in the diveway surface.  A 
3D centerline was created with the desired slopes.

Lab 20.3 - Create Driveway Edges

The Driveway centerline is used to define the driveway edge features, then the Fillet Feature command is used 
to create the drive returns.  The driveway edge lines are then joined to the driveway return to create a single 
feature.

Section Objectives:

 Copy the Driveway centerline to form the edge lines.

 Use Import Surface to create surface features from the edge line  graphic elements.

 Use Fillet Feature to create the driveway returns.

 Use Partial Delete on the edge line features to clear the driveway ramp.

 Use Join Feature to create a single feature from the driveway edge line an the return.

1. Select the Copy command from the MicroStation Main toolbar.

2. <T> to the driveway centerline near the driveway end line and <D> to accept.

3. <T> and  accept to each end of the driveway end line.  The illustration below shows the 
results.

4. From the InRoads menu bar, Select File > Import > Surface.

5. Set up the Import Surface dialog box as in the Setting Elevations (pg. 145) section above, 
using Driveway Edge as the Seed Name.
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6. <D> Apply the <D> on one of the edge lines.  Repeat the process with the other edge line.

7. Close the Import Surface dialog box.

With the driveway edge features added to the surface, the driveway returns can be added.

8. Select Surface > Design Surface > Fillet Feature from the InRoads menu bar.

9. Make the settings as shown in the illustration below.

10. <D> Apply, then move the cursor into the quadrant for the return and <D>.  The return is 
added to the driveway surface.

11. Set the Reference Feature 1 Name to the other driveway edge feature.
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12. Repeat step 10 to create the other driveway return feature.  The illustration below shows 
the results.

13. Close the Fillet Feature dialog box.

14. Save the driveway surface.

Next, the driveway edges from the end of the fillet to the edge of the mainline are trimmed to 
create a smooth cross slope.

15. Verify that the Driveway 254+47.15 Rt surface is active.

16. Select Surface > Edit Surface > Partial Delete from the InRoads menu bar.

17. <D> on a Driveway Edge line and <D> to accept it.

18. move the cursor above the mainline edge of pavement line and <D>.  This sets the partial 
delete to the end of the driveway edge line.
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19. <T> to the end of the fillet on the drive way edge line then <D> to complete the partial 
delete.

20. Repeat steps 17 through 19 for the other edge line.

21. Save the driveway surface.

The final step in creating the driveway edge lines is to join the line and return features to form a 
single feature.  This will make it easier to construct the side slopes for the drive way.

22. Verify that the Driveway 254+47.15 Rt surface is active.

23. Select Surface > Edit Surface > Join Features.

24. <D> on a driveway edge line and <D> to accept.
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25. <D> on the corresponding driveway return and <D> to accept. <R> to exit the Join 
Features command.  The two features are now combined into a single feature.  The name 
for the combined feature is that of the first feature selected.

26. Repeat steps 23 through 25 for the other driveway edge.

27. Save the driveway surface.

This completes the backbone of the driveway.

Section Summary:

The 3D centerline was copied to the ends of the driveway end line, forming the basis of the 
driveway edge lines.  These were imported into the driveway surface.  Fillet feature was used to 
form the driveway returns. Then the edge lines were trimmed back to the ends of the returns.  
Finally, the edges and returns were joined to make a single feature out of each.

Lab 20.4 - Sideslopes and the Exterior Boundary

With the backbone of the driveway complete, the sideslopes and exterior boundary can be added to finish the 
driveway model.

Section Objectives:

 Modify an end condition section to search for a specific surface.

 Use Apply Template to create driveway sideslopes.

 Create an exterior boundary from graphic elements.

The sideslopes for the driveway must tie to two different surfaces, the proposed (SH86) surface 
ot the existing (12345 existing ground) surface.  This is accomplished by modifying the end 
condition section to seek a specific surface then applying the section to the area where that 
surface is sought. 
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1. Turn off the reference file display.  This will make it easier to see the data that is used.

2. Select Modeler > Create Template from the InRoads menu bar.

3. Display the Dynamic Settings dialog box.

4. Set the Steps to 0.10 and toggle off Apply Affixes.

5. Navigate to the 3 - Sections - End Conditions folder in the template library explorer.

6. <R> on the 3 - Sections - End Conditions folder and select New > Folder.

7. Key in Driveway End Conditions for the name.

The next step is to build a new end condition section for the driveway.  It uses components that 
are already in the template library.
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8. <R> on the Driveway End Conditions folder and select New > Template.

9. Key in 4_to_1-Existing for the name.

Now that the template placeholder is built, data can be added to it.  The data for this new 
section comes from the end condition components folders.

10. Navigate to the 4 - Components > End Conditions > Fill Slope Components 
folder.

11. <D> on the Fill_4_to_1 component to display it in the Preview.

12. Drag the component from the Preview into the 4_to_1-Existing section by its origin 
and place it on the origin on the new section.

13. Expand the Cut Slope Components folder and <D> on the Cut_4_to_1 component.

14. Drag and drop this component into the new setion on the origin.

15. Edit the fill component.

16. In the Component Properties dialog box, End Condition Properties area, set the Surface 
to 12345 Existing Ground.
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17. <D> Apply, then Close.

18. Repeat steps 15 and 16 for the cut component.

19. Key in 2 for the Priority of the cut component.

20. <D> Apply, then Close.

21. Save the template library.

This completes the end condition used to tie to the existing surface.  Next, copy this template 
and modify it to seek the design surface.

22. <R> on the 4_to_1-Existing section and select Copy.

23. <R> on the Driveway End Conditions folder and select Paste.

24. Rename the section to 4_to_1-Proposed.

25. <D> <D> on the 4_to_1-Proposed section to make it active.
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26. Edit the component properties as described above, changing the target surface to SH86.

27. Save the template library.

These sections (templates) are used to create the sideslopes on both sides of the driveway.  
They are applied to specific parts of the driveway to target the desired surface in that area.

28. Select Surface > Design Surface > Apply Template from the InRoads menu bar.

29. In the Apply Template dialog box, set the Design Surface to Driveway 254+47.15 Rt.

30. Toggle on Interval and key in 1.00 for the value.

31. Toggle on Stroke Tolerance and key in 0.01 for the value.

32. Navigate to  3 - Sections - End Conditions > Driveway End Conditions in the template 
library.

33. <D> on the 4_to_1-Existing section.

34. Verify that Generate Graphics Only is toggled off.
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35. Toggle on Remove Loops and Triangulate Surface.

36. <D> Apply.

37. Follow the prompts displayed in the lower left corner of the MicroStation window.

38. Select the left driveway edge as the Primary and Reference elements.
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39. At the prompt, “Identify Beginning/Reset for Entire”, Set the MicroStation snap mode to 
Intersection.

40. <T> on the mainline top of cut feature then <T> on the driveway edge feature.

41. Use the keypoint snap to select the end point.

Important! After selecting the location to apply the section, the Apply Template dialog 
box reappears.  However, there is still one more prompt to answer.  Do not 
forget the final <D> to accept the solution.
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The result of the Apply Template is shown below (shown inside the circle).

42. Repeat the Apply Template process, using the 4_to_1-Proposed section, to model the 
sideslope to the (proposed) SH86 surface.  The illustration below shows the results after 
applying both sections to the left side.



Colorado Department of Transportation   Page 407

Labs for InRoads XM LAB 20 - Constructing A Driveway

43. In the Apply Template dialog box, toggle on Reflect.
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44. Apply both sections to the right side of the driveway as described above.  The results of all 
of the Apply Template commands are shown below.

The final step for the drive is to create an exterior boundary.  The boundary is defined using the 
graphics of the cut and fill features along with the driveway end feature and the proposed edge 
of pavement from Sh86.  

45. Select the MicroStation Delete command from the Main toolbar.

46. Delete the graphic elements that will not be used for the exterior boundary.  The illustration 
below shows the elements needed.
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To create the boundary, the edge of pavement line needs to be trimmed and the gaps between 
elements need to be filled.

47. In MicroStation, toggle of the Graphic Group lock.

48. Select the Partial Delete command from the MicroStation Main toolbar.

49. Partial delete the edge of pavement lines from where the driveway toes intersect away from 
the driveway.
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50. Select the MicroStation Place Smartline command.  Use this command to fill in the gaps 
between elements.  Be sure to <T> to the ends of the lines.  This will ensure that the 
elements are connected properly.  Not snapping to the lines could result in erroneous 
elevation data.  The gaps filled are illustrated below.

A closed shape element is created from the linework defining the exterior boundary

51. Select the MicroStation Create Complex Shape command.

52. In the toolsettings dialog box, set the Method to Automatic.

53. <D> on an element of the boundary the <D> anywhere.  This creates a closed shape from 
the graphic elements that makeup the exterior boundary.
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Import complex shape into the driveway surface as an exterior boundary, to complete the 
model.

54.  From the InRoads menu bar, select File > Import > Surface.

55. In the Import Surface dialog box, set the Surface to Driveway 254+47.15 Rt.

56.  Set Load From to Single Element.

57. Set Elevations to Use Element Elevations.

58. In the Seed Name field, key in Exterior Boundary.

59. Set the Feature Style to Exterior Boundary.

60. Set the Point Type to Exterior.

61. <D> Apply then <D> on the boundary graphic element.

62. Close the Import Surface dialog box.

63. From the InRoads explorer, <R> on the Driveway 254+47.15 Rt surface and select 
Triangulate.
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64. To evaluate the ramp, creat a single cross section at station 254+47.15.

Below is a rendered view of the driveway

Section Summary:

In this section,  end conditions were developed and applied to the driveway edges to form the 
side slopes.  Features from the driveway surface and the mainline (SH86) surface were 
displayed and used to build the exterior boundary graphically.  This graphic was imported into 
the driveway surface to finish the model.  A cross section was created to review the ramp.
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Chapter Summary:

In this lab, a driveway was designed using a variety of InRoads and MicroStation tools.  From InRoads, the 
following tools were used:

 Tracking

 Create Surface

 Drape Surface

 Generate Longitudinal Feature

  Import Surface from Graphics

 View Features

 Fillet Feature

 Partial Delete (Feature)

 Join Features

 Create Template

 Apply Template

From MicroStation, the following tools were used:

 Place Smartline

 Copy

 Partial Delete (Graphic)

 Delete

 Create Complex Shape
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In this lab, and island with pedestrian ramps is constructed on the southeast corner of the intersection.  Surface 
features of the island are built using various MicroStation commands and InRoads surface design and editing 
tools.  The island model is added to the proposed intersection model to create a triangulated model of the 
finished grade surface.  Because the island is constructed by feature modeling techniques, there are no 
components included in the model.

Chapter Objectives:

 Lay out the horizontal geometry of the island.

 Identify ramp locations.

 Add elevations to the island shape.

 Create curb and ramp features.

The following files are used with this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Intersec100SH86.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Islands.alg

 C:\Projects\12345\Design\InRoads\Intersection.dtm

The two roads of the intersection are 4 lane curb and gutter.  Each has an additional lane through the 
intersection for a turn bay and acceleration lane.  The island protects the right turn lane from through traffic on 
SH 86.

The SE Curb Return alignment (in the quadrant of the island) represents the edge of pavement for the right turn 
lane.  The features constructed for the island represent the gutter flowline around the island and the pedestrian 
ramps leading on to the island.

Lab 21.1 - Layout the Island Geometry

Section Objectives:

 Use horizontal alignment graphics to create the basic outline of the island.

 Define the radii for the island corners.

 Layout the initial geometry for the pedestrian ramps.

The basic outline of the island is created by offseting the alignment graphics.  This is done by 
displaying the alignments from InRoads then using the MicroStation Move Parallel command 
to copy the graphics to the desired locations.  Construct Circular Fillet is used to create the 
rounded corners for the island.  The pedestrian ramps are laidout with a variety of  
MicroStation tools like, Place Smartline, Construct Line at Active Angle, Extend Element to 
Intersect, etc.

1. Open MicroStation and InRoads with the 
C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Intersec100SH86.dgn 
file.

2. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\Preferences\CDOT_Civil.xin is loaded.
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3. Open the following InRoads files (they are all in the C:\Projects\12345\Design\InRoads\ 
folder):

♦ 12345DES_Geometry-Islands.alg

♦ Intersection.dtm

4. From the InRoads menu bar, select File > New.

5. Select the Surface tab in the New dialog box.

6. Set the Type to Design.

7. Key in SE Island for the Name.

8. Key in Island for SE quad SH 86 and Side Road for the Description.

9. Set the Preferance to Proposed.

10. <D> Apply then <D> Close.

This surface is used to store the island surface data as its being created.  It also protects the data 
in the Intersection.dtm from being accidently modified while editing the island surface 
features.

11. In the InRoads Explorer, expand the 12345DES_Geometry geometry project.

12. <R> on the SH 86 horizontal alignment and select View from the menu.

13. Repeat the process for the SideRoad and SE Curb Return  horizontal alignment

The MicroStation Move Parallel command is used to offset these lines.  The SE Curb Return 
line is offset 14’ (12’ for the driving lane and 2’ for the gutter) to the left to form one side of the 
island.  The SH 86 and SideRoad lines are offset 26’ (24’ for the driving lane and 2’ for the 
gutter) to the right to form the other two sides.
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14. From the MicroStation Main toolbar, select Move Parallel.

15. In the Move/Copy Parallel tool settings box, toggle on Distance.

16. Key in 14 for the value.

17. Toggle on Make Copy.  

18. <D> on the SE Curb Return line.

19. Move the cursor to the left of the line and <D> to make the copy. <R> to exit the command.

20. In the Move/Copy Parallel tool settings box, key in 26 for the value.

21. <D> on the SH 86 line the <D> to the right of the line.  <R> to exit the command.
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22. <D> on the SideRoad line the <D> to the right of the line.  <R> to exit the command.  
The illustration below shows the results.

Next the radii for the island corners are added.  The corner facing into the intersection has a 15’ 
radius.  The other two have a radius of 5’.  These are placed using the Construct Circular Fillet 
command.

23. Select the Construct Circular Fillet command from the MicroStation Main toolbar.

24. In the tool settings box, key in 15 for the Radius.

25. Set Truncate to Both.
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26. <D> on the lines as shown in the illustration below.

27. In the tool settings box, key in 5 for the Radius.

28. Place the other two fillets as done in step 25.  The illustration shows the results.

With the outline of the island in place, the pedestrain ramps can be located.  These are placed in 
the center of each side of the island.  The MicroStation Construct Line At Active Angle 
command is used to place the ramp centerline perpendicular to the island side.  

Note: The dimensions for the pedestrain ramp are taken from the M-608-1 Curb Ramps 
standard, page 104 of the M & S Standards July 2006 edition.

29. Select the Construct Line At Active Angle command from the MicroStation Main 
toolbar.
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30. In the tool settings dialog box, set the Method to From Point.

31. Set the Active Angle to 90^00’00”.

32. Toggle on Length and key in 3 for the value.  This is the length of the 20:1 slope at the 
mouth of the ramp.

33. <T> to the center of a side of the island, move the cursor inside the island and <D>.

34. Repeat step 32 for the other two sides.  The illustration shows the results.

35. From the MicroStation Main toolbar, select Move Parallel.

36. In the Move/Copy Parallel tool settings box, toggle on Distance.

37. Key in 2 for the value.

38. Copy each of the ramp centerlines to either side of itself.  These will make up the edges of 
the ramp tread.  The illustration shows the results.

39. Delete the ramp centerline elements, they will not be used again.

40. From the MicroStation Main toolbar, select Move Parallel.

41. In the Move/Copy Parallel tool settings box, toggle on Distance.

42. Key in 6 for the value.
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43. Copy each of the ramp edge lines to the outside of itself.  These lines are used to create the 
ramps “wings”.   The illustration shows the results.

Section Summary:

InRoads was used to display the alignments that are the basis of the island.  These were copied 
to their exact XY location using the MicroStation Move Parallel command.  Rounded corners 
were added to the island using the Construct Circular Fillet command.  The initial parts of the 
pedestrain ramps were added using the Construct Line At Active Angle command.

Lab 21.2 - Create Ramp and Curb Graphic Elements

The outline of the island is complete.  Now this outline needs to match the elevations in the design surface.  
The Drape Surface and Import Surface From Graphics commands are used to create dtm features of the island 
at the desired elevations.  The ramp elements are draped to set the initial elevation, then Generate Longitudinal 
Feature is used to apply the proper slope to the element.

Section Objectives:

 Create graphic elements of the island at the design surface elevation.

 Modify slope on ramp landing elements.

 Create curb elements.

 Modify the curb elements for the ramp wings.

 Add the ramp wing elements.

All of the graphic elements that make up the island and curb ramps are draped to the 
intersection surface.  This sets the graphic elements of the island outline to the proper elevation.  
It also sets the initial elevations for the curb ramp features.

1. Highlight all of the elements that make up the island and ramp.
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2. Select Surface > Design Surface > Drape Surface from the InRoads main menu.  
This displays the Drape Surface dialog box.

3. In the Drape Surface dialog box, set the Destination Surface to Intersection (this is the 
surface whose elevations are going to be matched).

4. Set the Input Mode to Single.

5. Toggle on Destination Level and select DES_ROADWAY_Curb-Flowline from the 
drop down menu.

6. Toggle on Delete Original Graphics.
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7. <D> Apply.   This displays a message window asking, “Use elements contained in 
selection set?”.  <D> OK to complete the processing.

8. <D> Close to dismiss the Drape Surface dialog box.

The result of the command is that the graphic elements selected are redrawn at the elevation of 
the  intersection surface.  Next, the lines representing the pedestrian ramps are given the proper 
slope.  These elements represent the landing pad of the pedestrian ramp and have a 20:1 slope.

9. Zoom In around the ramp lines on the long arc of the island.

10. Select Extend Element to Intersection from the MicroStation main menu.

11. Extend the outside ramp line to meet the Island line.

Next, check the direction of the lines.  This will affect how the Generate Longitudinal Feature 
command operates.

12. <D> the Change Element Direction tool from the Misc. Tools bar.  The toolbar is 
usually docked at the top of the MicroStation window.  If it is not docked, select CDOT 
Tools > Misc. Tools from the CDOT Menu menu bar.
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13. <D> on one of the ramp landing edge lines.  An arrow appears on the line.

14. Repeat step 13 for each of the ramp lines

15. Select Surface > Design Surface > Generate Longitudinal Feature from the 
InRoads main menu.  This displays the Generate Longitudinal Feature dialog box.

16. On the Generate Longitudinal Feature dialog box Main tab, Toggle on Interval and set 
the value to 1.00.

17. Toggle on Stroke Tolerance and set the value to 0.01.

18. Use the Feature Style drop down menu and select D_CONC_Sw.
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19. Toggle on Generate Graphics Only.

20. <D> the Controls tab.

21. Set the Horizontal Method to Offset From Primary Feature.  Leave the Start and Stop 
values at 0.00.

22. Set the Vertical Method to Elevation/Longitudinal Slope.

23. <D> the ‘target” button for Start Elevation, then <T> to the ramp landing line where it 
intersects the island outline and <D> to accept.

24. Key in 5.00% (1:20) for the Longitudinal Slope.
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25. <D> Apply.  Follow the prompts located in the lower left corner of the MicroStation 
window.  Use the same line for the Primary and Secondary element.  The illustration below 
lists the prompts and the action taken.

The illustration below shows the results of the Generate Longitudinal Feature command in a 
rotated view.

26. Repeat steps 23 through 25 for the remaining ramp landing lines (there are 5 more).

27. Rotate the view so the the originl ramp tread lines can be seen under the new lines.
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28. Delete the original ramp tread lines from each ramp.

29. Rotate the view back to a Top view.

30. Select the MicroStation Place Smartline command.

31. Place a line connecting the back of each ramp tread line.  Be sure to <T> to the end of of 
each line so that the elevation of the new line will be correct.

Next, the generate longitudinal feature command is used to create the back of the pedestrian 
ramps.
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32. From the InRoads main menu, select Surface > Design Surface > Generate 
Longitudinal Feature.  The settings on the Main tab are the same as those set earlier.

33. <D> the Controls tab.

34. In the Horizontal area, set the Method to Offset from Primary Feature.

35. Key in 4.50 for the Start Offset and Stop Offset.  This is the minimum length for this 
section of the ramp according to the M & S Standard.

36. In the Vertical area, set the Method to Offset/Offset.
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37. Key in 0.32 for the Start Offset and Stop Offset.  This is the difference in height from the 
end of the 20 to 1 tread slope to the top of the curb.

38. <D> Apply.  Then follow the prompts.  Use the ramp tread end line as the primary and 
reference element.  <R> to use the entire line.  <D> in the middle of the Island for the 
location.
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39. Repeat step 38 for each ramp.  The illustration below shows the results.  Dismiss the 
Generate Longitudinal Feature dialog box when finished.

40. Select the MicroStation Place Smartline command.

41. Place a lines to complete the sides of each ramp tread.  Be sure to <T> to the end of of each 
line so that the elevation of the new line will be correct.  The illustration below shows the 
results.

Next, elements defining the curb are added.  The Generate Longitudinal Feature command is 
used for this.

42. From the InRoads main menu, select Surface > Design Surface > Generate 
Longitudinal Feature.

43. On the Main tab, key in 1.00 for the Interval.
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44. Set the Feature Style to D_C/G_Ty2_Sect II-B.  The other settings remain as set.

45. <D> the Controls tab.

46. Verify that the Horizontal Method is set to Offset from Primary Feature.

47. Key in 0.125 for the Start Offset and Stop Offset.  This is the horizontal distance from the 
gutter flowline to the top front of the curb according to the M & S Standard.  Note: the 
entry will be rounded to 0.13 in the dialog box.

48. Verify that the Vertical Method is set to Offset/Offset.
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49. Key in 0.50 for the Start Offset and Stop Offset.  This is the height of the curb.

50. <D> Apply.  Then follow the prompts.  <D> an island outline element for the primary 
feature and use the same one for the reference feature.  <D> in the middle of the Island for 
the location.  The illustration shows an example of the results.

51. Repeat step 49 for each element in the island outline.
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52. On the Generate Longitudinal Feature’s Controls tab, key in 0.375 for the Horizontal 
Start Offset and Stop Offset.  This is the width of the curb top. Note: the entry will be 
rounded to 0.38 in the dialog box.

53. In the Vertical area, key in 0.00 for the Start Offset and Stop Offset.

54. <D> Apply.  Then follow the prompts.  <D> a top of curb element for the primary feature 
and use the same one for the reference feature.  <D> in the middle of the Island for the 
location.  The illustration shows an example of the results.
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55. <D> Close to dismiss the Generate Longitudinal Feature dialog box.

The final step, before importing the graphics into the surface is to modify the curbs and add the 
ramp wings.  This includes partial deleting the top of curb lines in the area of the ramps and 
drawing lines for the wings.

56. Zoom in around one of the ramps so that the wing lines and each of the curb lines are 
visible.

57. From the MicroStation main toolbar, select the IntelliTrim command.

58. In the tool settings dialog box, set the Mode to Quick.

59. Set the Operation to Cut.

60. <T> the <D> on the ends of each of the wing lines.  This cuts the curb top lines in these 
locations.

61. <D> and drag through the curb top lines inside the ramp tread as shown in the illustration 
below.

This has broken each of the curb top lines into four sections.  The sections inside the ramp area 
will be modified after they are imported into the surface.  Those outside will be left as is.

Next the lines representing the ramp wings are drawn.

62. From the MicroStation main toolbar, select the Place SmartLine command.
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63. <T> then <D> to the points indicated in the illustration below.

Important! Be sure to snap to the curb top lines.  Snapping to any othe line in this area 
will result in the wing being placed at the wrong elevation.

64. Select the MicroStation Delete command.

65. Delete the wing position lines.
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66. Repeat steps 56 through 65 for the other two ramps.  The illustration below shows the 
island and ramps completed to this point.

Section Summary:
♦ The InRoads Generate Longitudinal Feature command is used to provide elevation to 

graphic elements.

♦ When creating additional elements to be imported into a surface, snapping to elements 
at the proper elevation creates additional elements at the proper elevation.

Lab 21.3 -  Importing Graphics to Surface and Modifying Features

With the exception of the curb top lines inside the ramp areas, the graphic elements for creating the island 
surface are in place.  In this section, the graphic elements are imported into a surface and InRoads tools are 
used to modify the curb features inside the ramp areas.

Section Objectives:

♦ Import Graphics to create a surface.

♦ Use Trim Feature to modify curb top features in the ramp areas.

♦ Use Edit Feature Point for the final cleanup of the curb top features.
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1. Zoom out in the MicroStation view so that the entire Island can be seen.

2. On the MicroStation menu bar, select Edit > Select All.  This highlights all of the 
elements in the drawing.

3. From the InRoads menu bar, select File > Import > Surface.

4. In the Import Surface dialog box, verify that the From Graphics tab is selected.

5. Select SE Island for the Surface.

6. Verify that Load From is set to Single Element.

7. Verify that Elevations is set to Use Element Elevations.

8. In the Seed Name field, key in SE_Island.

9. Set the Feature Style to D_Curb.
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10. Verify that the Point Type is set to Breakline.

11. <D> Apply.

12. <D> OK on the “Use elements contained in selection set?” message window.

13. <D> Close to dismiss the Import Surface dialog box.

All of the graphic elements have been save into the dtm (surface).  The elements used to create 
the surface are deleted because they will be in the way when performing the next steps.  The 
feature editing commands will automatically update displayed feature graphics but not the 
MicroStation elements originally used to create those features.

14. Select the MicroStation Delete command or press the Delete key to delete the graphic 
elements.
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15. Select Surface > View Surface > Features from the InRoads menu bar.

16. In the View Features dialog box, verify that the Surface is set to SE Island.

17. Verify that all of the  features are highlighted.

18. <D> Apply then <D> Close to dismiss the View Features dialog box.

19. In the MicroStation view, zoom in on one of the ramps.

20. From the InRoads menu bar select Surface > Edit Surface > Trim Features.
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21. In the Trim Features dialog box, in the Elevation area, toggle on Match at 
Intersection.

22. <D> the target button  Then <D>  the curb back line.  This highlights that feature in the 
list.

23. <D> Apply then <D> to Accept.

24. <D> the ramp tread line then <D> again to accept it.

25. <D> inside the tread area to accept the command and trim the curb feature.



Colorado Department of Transportation   Page 441

Labs for InRoads XM LAB 21 - Creating an Island

26. Repeat steps 22 through 25 for the other curb top features in the ramp area.  The illustration 
shows the results.

In a rotated view, notice that the curb top lines do not slope consistantly from the wing to the 
tread.  This is because the Trim Feature command matches the elevation from the intersection 
of the features to the next vertex in the trimmed feature.

To correct this, the feature points between the beginning and end point are deleted.

27. From the InRoads menu bar, select Surface > Edit Surface > Edit Feature Point.

28. Verify that the Surface is set to SE Island.
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29. <D> the target button for Feature, then <D> on the curb back line.

30. <D> the advance point button  to select point 2 on the feature.

31. <D> the Delete button then <D> Apply.

32. Repeat step 31 until only two points are left in the feature.

33. Repeat steps 29 through 32 to the remaining curb top features within the ramp area.  The 
illustration below shows a completed ramp.
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34. Repeat steps 19 through 33 for the other two ramps.  

Important! Be sure to rotate to a Top view when performing the Trim Feature 
command.  This will make it easier to identify the trim location.

35. In the InRoads Explorer, <R> on SE Surface and select Triangulate from the right click 
menu.

36. <R> on SE Surface and select Save.

37. Exit InRoads and MicroStation.

The illustration below shows the contours for the island.
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Below is a rendering of the Island surface on the Intersection surface.

Section Summary:
♦ When importing graphic elements into a surface, if the elements are not selected ahead 

of time, each element can be given a unique name.

♦ Use the Trim Feature command in a top view.  This helps when indicating which part 
of the feature to trim.

♦ Use the Edit Feature Point command to remove points from a feature.  Delete Feature 
Point only works with Random points.

Chapter Summary:

 The island was created using MicroStation commands and InRoads surface editing 
commands.

 Because it was created as surface features only, there are no components in the island 
surface.

 The Drape Surface and Generate Longitudinal Feature commands were used to create 
graphic elements that were edited before they were imported into the surface.
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Modeling the surface at the ends of a bridge can accomplished using a variety of tools. This lab illustrates a 
simple slope, but more complex slopes can be modeled using the same tools and methodologies. In general, 
you will be using InRoads tools to create breaklines that define the desired surface. For additional information 
on the tools used here as well as others, please see the Surface Editing chapter of the Practical Guide for 
Using InRoads XM.

Chapter Objectives:: 

 To develop an understanding of modeling surfaces without templates.

 To learn how some of InRoads’ Surface tools can create breaklines necessary for modeling 
surfaces at the ends of a bridge.

Lab 22.1 - Create the Surface East of the Bridge

In this section, the design surface is used to create a smaller surface for the portion of the roadway East of the 
bridge. This surface will subsequently be used as the basis for the grading around the bridge abutment.

Open MicroStation and InRoads using the 12345DES_Model.dgn file.

1. Select File > Open from the InRoads menu.

2. Open 12345 SH52 71st intersection.dtm, 12345 SH119 SH52 interchange.alg, and 12345 
existing ground for interchange.dtm.

3. Select File > Reference from the MicroStation menu.

4. Select Tools > Attach.

5. Select C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Outline.dgn.
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6. <D> OK to accept the default reference settings.

7. In the Level Display dialog, toggle on the reference file level BRDG_Outline-Bridge.

8. Fit the view.

An outline of the proposed bridge is shown in the file.

9. Set the Pen/Pencil lock to Pencil

10. Select Surface > Update 3D/Plan Surface Display.

11. Toggle Display On and highlight the intersection surface.

12. Toggle on Features.
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13. Right-click in the feature list and choose Select All.

14. <D> Apply.

All of the features are shown in the file.

15. On the MicroStation menu, choose Place Fence.

16. In the Tool Settings box, change the Fence Type to Element.
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17. <D> on the bridge outline in the design file.

18. Choose Surface > Edit Surface > Delete Feature.

19. Set the Surface to SH5271st Intersection.

20. Set the Fence Mode to Inside.

21. Right-click in the feature list and choose Select All.

22. <D> Apply.

23. When prompted to Delete selected feature(s), select OK.

24. Close the dialog box.

25. Clear the fence.
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The features inside the bridge outline are removed from the surface. Next, the features on 
the East side of the bridge are copied to create a new surface.

26. Choose Place Fence.

27. In the Tool Settings box, change the Fence Type to Block.

28. Place a fence that encompasses all features East of the bridge as shown.

29. Select Surface > Edit Surface > Copy Portion of Surface.

30. Set the Surface to SH52 71st intersection.

31. Key in the Destination Surface SH52 71st East of Bridge.

32. Set the Fence Mode to Inside.
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33. If all Features are not highlighted, Right-Click in the feature list and choose Select All.

34. <D> Apply, then Close the dialog box.

35. Choose File > Save As.

36. Set the Save As Type to Surfaces (*.dtm).

37. Use the drop-down to set the Active Surface to 12345 SH52 71st East of Bridge.

Note: If the file name is not listed, use the drop-down again to select the active surface 
and the same name will appear in the Name field. You can then add the 12345 
prefix to the file name on the hard drive.

38. <D> Save.

39. Select Surface > Update 3D/Plan Surface Display.

40. Toggle Display Off and highlight the intersection surface.

41. Toggle on Features.
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42. Right-click in the feature list and choose Select All.

43. <D> Apply.

44. Toggle Display On and highlight the SH52 71st East of Bridge surface.

45. Toggle on Features.

46. Right-click in the feature list and choose Select All.
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47. <D> Apply.

Lab 22.2 - Create a Feature at the Bridge

In this section, a breakline feature is created to ‘cap’ the end of the roadway features where the bridge starts.

1. In the Level Display dialog, toggle off the reference file level BRDG_Outline-Bridge.

2. Select Surface > Design Surface > Place Feature.

3. Set the Surface to SH52 71st East of Bridge.

4. Type in abutment1 for the Feature Name.

5. Type in a description if desired.

6. Set the Feature Style to D_CONC_Pvmt.
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7. Set the Point Type to Breakline.

8. <D> Apply.

9. Do not toggle on either option on the Set Elevation dialog that appears.

10. Snap to the end of each of the roadway features from POSS to POSS as shown.

Note: If you want to use AccuSnap, hold down your <Ctrl> and <Shift> keys and 
MicroStation’s AccuSnap works while using InRoads commands.



Page 454 Colorado Department of Transportation

LAB 22 - Modeling Around Bridge Abutments Labs for InRoads XM

11. <R> when done.

Lab 22.3 - Create the Grading Surface

In this section, the Generate Sloped Surface command is used to create a grading surface from the roadway 
down to the existing ground, effectively under the bridge.

1. In the Level Display dialog, toggle on the reference file level BRDG_Outline-Abutment.

Note: A green line displays that wraps around the edge of the roadway. This is the line 
from which the sloped surface is generated.

2. Select Surface > Design Surface > Generate Sloped Surface.

3. Make sure the Locate Feature / Locate Graphics lock is set to Locate Graphics.

4. Set the Intercept Surface to 12345 existing ground for interchange.

5. Set the Destination Surface to SH52 71st East of Bridge.
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6. Set the other options as shown in the dialog. Be sure to toggle on and key in the feature 
names for Transverse, Source and Catch Point.

7. <D> Apply.

8. <D> to select the green line at the edge of the roadway.

9. <D> again to accept the line.

10. <R> to Reset for Entire Line.



Page 456 Colorado Department of Transportation

LAB 22 - Modeling Around Bridge Abutments Labs for InRoads XM

The Generate Sloped Surface command can be used to create a slope from just a portion of the 
line, which is why the prompts allow specifying a Start and End location. Here, an <R> is used, 
since the slopes need to be created for the entire source line.

11. Move your cursor to the left of the line until you see the sideslopes form.
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12. <D> to Accept the location.

13. <R> to exit the command.

14. <D> Close to close the dialog.

15. Save the Surface.

16. Select Surface > Edit Surface > Partial Delete.

Note: Partial Delete is used just like the MicroStation Partial Delete, except it works on 
features. Here it is used to clean up the toes of slope that extend beyond the sloped 
surface.

17. <D> on the Toe-of-Fill on the North side of the roadway to select it as the feature to partial 
delete.
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18. <D> on the left end to identify the Start Point, then again where the new toe and old toe 
come together as shown for the End Point.

19. Repeat for the Toe-of-Fill on the South side of the roadway.

Note: You may want to toggle off Line Styles under Settings > View Attributes to see the 
ends of the lines more clearly.

20. Save the Surface.

21. Choose Surface > Triangulate Surface.

22. <D> Apply.

23. Select Surface > View Surface > Contours.
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24. <D> Preferences and highlight Proposed 5’ Mjr – 1’ Minor.

25. <D> Load, then Close.

26. Set the Surface to SH52 71st East of Bridge.

27. Toggle off Labels if desired.
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28. <D> Apply to see the contours.

29. <D> Close.

Chapter Summary:

 The Design Surface and Edit Surface tools can be used to modify existing surfaces and 
add to them as necessary to accomplish your design model.

 Modeling the ends of a bridge can be accomplished using a base model of the roadway, and 
adding features to define the desired surface.
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This lab covers how to use Surface Design and Editing tools to create a terraced wall under a bridge. For more 
information on the commands shown here, please see the Surface Editing chapter of A Practical Guide for 
Using InRoads XM.

In this scenario, three terraced walls are to be used under the SH52 bridge over SH119. Horizontal alignments 
have already been defined for the three walls along with verticals for the tops of the walls. A template will be 
created and run along the top wall to seek the other two walls and create the slopes between them.

Chapter Objectives:: 

 To learn to use additional Surface Design tools.

 To expand your knowledge of templates by creating a special case terraced wall template.

 To learn how to use templates without setting up a corridor in Roadway Designer.

Lab 23.1 - Open Data Files

If you have not exited since the last lab, you can skip this section.

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Working 
\CU12345DES_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH119.dtm, 12345 SH52.dtm, 
12345DES_Templates.itl and 12345 SH119 SH52 interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.dtm.

Lab 23.2 - Create Components for the Wall and Slope

The three walls are very similar and therefore one set of components can be created and used 
multiple times in the final template. To start, components are created that will be run off of Wall 
D-16-E and will ‘find’ or ‘target’ Wall D-16-F. This is used in areas where there is a terrace.

1. Delete any MicroStation graphics currently in the design file.
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2. Select Geometry > View Geometry > All Horizontals.

3. Fit the view.

4. Window around the terraced wall area to the left of SH119.

Note: The wall names in the illustration below are for information only. The walls are not 
labeled in your file.
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Note: Walls D-16-E, D-16-F and D-16-G will be created using a terraced wall template.

5. Select Modeler > Create Template.

6. Verify the template library is 12345DES_Templates.itl.

Note: Since there are no similar template to the one needed, a new one is created.

7. Expand the library folder structure for Components > Barriers & Misc Components > 
Walls.

8. Right-click on the Walls folder and select New > Template.

9. While the name is highlighted, type over it with Terrace_Wall.

10. Select Tools > Dynamic Settings.

11. Toggle Apply Affixes off.



Page 464 Colorado Department of Transportation

LAB 23 - Terraced Walls Labs for InRoads XM

12. For X and Y Step, key in 0.1.

13. Right-click in the template view and select Add New Component > End Condition.

14. Under Current Component, key in Finds next wall align for the Name.

15. Set the Style to D_Wall-Retaining.

16. Set the Target Type to Alignment XYZ.

17. Set the Horizontal Alignment to Wall D-16-F.

18. Set the Vertical Alignment to Wall D-16-F.

Note: Since the template will start at Wall D-16-E, Wall D-16-F is the next wall 
alignment. With a target of Alignment XYZ, the component will use a variable 
slope to ‘find’ the horizontal and vertical alignment.

19. In the Dynamic Settings box, key in Wall_E_Top-Front for the Name.

20. Select D_Wall-Retaining for the Style.

21. <D> on the origin point (0,0).

22. Back in the Dynamic Settings box, change the name to Wall_F_Top-Front.
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23. <D> on a point down and to the right of the first point as shown.

24. <R> and <D> Finish to complete the component.

25. Edit the second point, Wall_F_Top-Front. (Either double-click the point or right-click and 
choose Edit.)

26. For the Slope Constraint, set the Value to 50.00%.

27. For the Horizontal Constraint, set the Value to 15.00.

Note: Because the target for this end condition is both a horizontal and a vertical 
alignment, these values are actually ignored when the template is run. However, it 
gives a more accurate picture to use realistic values.

28. <D> Apply, then Close.
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29. Fit the template.

In the following series of steps, another component is added to create the face of the wall, a 
25% slope to the next wall and a flat top for the next wall.

30. Right-click in the template view and select Add New Component > Unconstrained.

31. Right-click again and make certain all options are toggled off.

32. <Esc> to dismiss the menu if everything was already off.

33. Under Current Component, key in Wall face and terrace for the Name.

34. Set the Style to D_Wall-Retaining.

35. In the Dynamic Settings box, select D_Wall-Retaining for the Style.
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36. Key in 1 for the Point Name.

Note: This is just a temporary seed name to place points. You will later rename the 
points.

37. <D> on the Wall_E_Top-Front point to start the component.

38. <D> to create two additional points similar to what is shown.

Note: Do not worry about getting them exact. The slopes and distances will be set with 
constraints.

39. <D> on the Wall_F_Top-Front point for the final point in this component.
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40. Right click and select Finish.

41. Edit the point 11 just inside the Wall_F_Top-Front point. 

Note: This point will create the flat top on Wall F.

42. Key in Wall_F_Top-Back for the Name.

43. Set Constraint 1 to Horizontal.

44. Set Parent 1 to Wall_F_Top-Front.

45. Key in a Value of 1.00. 

46. Set Constraint 2 to Vertical.

47. Set Parent 1 to Wall_F_Top-Front.
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48. Key in a Value of 0.00.

49. <D> Apply, then Close.

50. Edit the point 1 below Wall_E_Top-Front.

Note: This point will become the location where the face of the wall is intercepted by the 
25% backfill slope.

51. Key in Wall_E_Backfill for the Name.

52. Set Constraint 1 to Horizontal.

53. Set Parent 1 to Wall_E_Top-Front.

54. Key in a Value of 0.1. 

Note: This will force a small slope on the front face of the wall to allow triangulation.

55. Set Constraint 2 to Slope.

56. Set Parent 1 to Wall_F_Top-Back.
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57. Key in a Value of -25.00%.

58. <D> Apply, then Close.

Note: Since the horizontal and slope constraints have two different parent points, the 
location of this point varies when either of the parents moves.

59. <D> Test.

60. Under Available Targets, <D> on the wall alignment.

61. <D> Draw.
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62. Move your cursor into the template view to see how the components react.

Note: The original component has a variable slope, while the Wall face and terrace 
component maintains all slopes. It should also be noted that there is no need to 
display the original component. Also, if the original component fails the Wall face 
and terrace component should not display either. Both of these situations will be 
taken care of next.

63. <D> Close on the Test End Conditions box.

64. Edit the Wall_F_Top-Front point.

65. Toggle on Do Not Construct.



Page 472 Colorado Department of Transportation

LAB 23 - Terraced Walls Labs for InRoads XM

66. <D> Apply, then Close.

Note: The Finds next wall align component disappears. However, the portion of the Wall 
face and terrace component that contains the Wall_F_Top-Front point remains. 
This is because Do Not Construct only affects end condition components.

67. Edit the Wall face and terrace component. (Double-click the component or right-click on 
the component and choose Edit.)

68. Set the Parent Component to Finds next wall align.

69. <D> Apply, then Close.
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Note: Now, if the Finds next wall align end condition fails, neither component is used.

70. Test the template again to see the difference. 

Note: Now, only a dashed line is shown initially, indicating when the end condition fails, 
nothing is displayed. When the end condition succeeds, only the Wall face and 
terrace is displayed.

71. <D> Close on the Test End Conditions box.

72. Save the template library.

Lab 23.3 - Create a Component for the Wall Face

In the areas where a perpendicular application of the template from the upper wall alignment 
would not find the next wall, the template should create a wall face. This situation will be 
covered in a new template and combined with the other template later. 
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1. Right-click on Walls folder again in the library and select New > Template.

2. While the name is highlighted, type over it with Wall_Face.

Note: Since the face of the wall will eventually be attached to the Wall_Top-Front points 
which are set to Do Not Construct, the face of the wall must be made up of a non-
end condition component. However, the face of the wall must also be an end 
condition so it will stop when it intercepts the target surface. Therefore, the same 
theory is used for the face as for the terrace: an end condition that doesn’t display is 
used along with a ‘regular’ component that does display.

3. Right-click and select Add New Component > End Condition.

4. Under Current Component, key in Finds active surface for the Name.

5. Set the Style to D_Wall-Retaining.

6. Set the Target Type to Surface.

7. Set the Surface to <Active>.

8. Set the Priority to 2.

Note: Since this component is to be used only where the terraced wall doesn’t work, it 
will need to be second in priority.

9. In the Dynamic Settings box, key in Wall_E_Top-Front for the Name.
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10. Select D_Wall-Retaining for the Style.

11. <D> on the origin point (0,0).

12. Back in the Dynamic Settings box, change the name to Wall_E_Backfill.

13. <D> on a point down and to the right of the first point as shown.

14. Right click and select Finish.

15. Edit the second point, Wall_E_Backfill.

16. Change the Slope Constraint to Vertical and set the Value to -5.00

17. For the Horizontal Constraint, set the Value to 0.1.

18. Toggle on End Condition is Infinite.
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19. Toggle on Do No Construct.

20. <D> Apply, then Close.

21. Fit the template.

Note: The line forming the component disappears, but the points are still there.

22. Right-click in the template view and select Add New Component > Unconstrained.
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23. Right-click again and make certain all options are toggled off.

24. <Esc> to dismiss the menu if everything was already off.

25. Under Current Component, key in Wall face for the Name.

26. Set the Style to D_Wall-Retaining.

27. <D> on the Wall_E_Top-Front point to start the component.

28. <D> on the Wall_E_Backfill point.

29. Right click and select Finish.

30. Edit the Wall face component.

31. Set the Parent Component to Finds active surface.
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Note: Now, if the Finds active surface end condition fails, neither component is used.

32. Test the template. 

Note: Only a dashed line is shown initially, indicating when the end condition fails, 
nothing is displayed. When the end condition succeeds, only the Wall face is 
displayed. The template is ‘fit’ to the view, so the slope seen here is not indicative 
of the final slope.

33. <D> Close on the Test End Conditions box.

34. Save the template library.

Lab 23.4 - Create the Final Wall Template

Next, these templates are combined to create the final wall template.

1. Right-click on Walls folder again in the library and select New > Template.
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2. While the name is highlighted, type over with 3_Terraced-walls.

3. Highlight, but do not make active, Terrace_Wall.

4. Drag the Terrace_Wall template from the preview and drop it on the origin of the new 
template.

5. Highlight, but do not make active, Wall_Face.

6. Drag the Wall_Face template from the preview and drop it on the origin, making certain 
the Wall_E_Top-Front point turns white.

7. <D> Test.

8. <D> on the <Active>-Surface under Available Targets.

9. <D> on Draw.
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10. Move your cursor into the template view.

Note: The wall face appears, indicating that when the first option, the Wall face and 
terrace, fails, the wall face alone will be created.

11. <D> on the Wall D-16-F alignment under Available Targets.

12. <D> on Draw.

13. Move your cursor into the template view.

Note: The wall face and terrace appear.
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14. <D> Close on the Test End Conditions dialog.

There are two Wall_E_Backfill points in the template, so one was renamed with a suffix. In the 
model, only one of these points will be used at any given location and together, they should 
form just one breakline. This is accomplished with Feature Name Overrides.

15. Select Tools > Apply Feature Name Override.

16. Highlight the two Wall_E_Backfill points

17. Key in Wall_E_Backfill for the Feature Name Override.

18. <D> Apply, then Close.

Note: The names turn red in the template view, indicating the names have been 
overridden.

19. Save the template library.

20. Highlight the 3_Terraced-walls template in the list at left.
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21. Drag and drop the template from the preview onto the Wall_F_Top-Front point, making 
certain the point turns white.
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22. Edit the two backfill points for Wall F and rename the points to Wall_F_Backfill and 
Wall_F_Backfill1.

23. Rename the Wall_F_Top-Front1 point to Wall_G_Top-Front.
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24. Rename the Wall_F_Top-Back1 point to Wall_G_Top-Back.

25. Select Tools > Apply Feature Name Override.

26. Highlight the two Wall_F_Backfill points

27. Key in Wall_F_Backfill for the Feature Name Override.

28. <D> Apply, then Close.
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29. Highlight, but do not make active, Wall_Face.

30. Drag the Wall_Face template from the preview and drop it on Wall_G_Top-Front, making 
certain the Wall_G_Top-Front point turns white.
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31. Change the new Wall_E_Backfill2 point to Wall_G_Backfill.

32. At the bottom of the Template Library list at left, select the Active Template tab.

33. Expand the Components list.
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34. Right-click on Finds next wall align1 and select Edit.

Note: Since this component was created from the original one, it is still seeking the Wall 
F alignments. Here, you’ll change it to seek Wall G.

35. Change the Horizontal and Vertical Alignments to Wall-D-16-G.
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36. <D> Apply, then Close.

37. Save the template library.

38. At the bottom of the Template Library list at left, select the Library tab.

39. Test the 3_Terrace-walls template.

40. <D> Close on the Test End Conditions dialog.

41. <D> Close on the Create Template dialog.

Lab 23.5 - Create the Terraced Wall Surface

In this section, the template is used to create a surface representing the terraced walls. The 
template is run along a graphic element created from the horizontal and vertical alignment for 
Wall E using the Apply Template command. As an alternative, Roadway Designer could be 
used. 

1. Delete the alignment graphics in the file.

Important! If the original graphics remain in the file, you are likely to accidentally 
identify them when selecting the path for the template, so it is best to 
delete the original alignment display. The original graphics are at elevation 
0. The graphic you are creating is 3D.

2. Select Geometry > View > 3D Alignment.

Note: This command creates a 3D linestring, taking the X and Y coordinates from the 
specified horizontal alignment and the Z coordinate from the specified vertical 
alignment.

3. Select the Horizontal and Vertical alignments Wall-D-16-E.
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4. Toggle on Station Limits.

5. Leave the Start Station set to 0+00.00.

6. Key in 1+98.35 for the Stop Station.

Note: This is the station at the end of the second curve in the wall alignment. From that 
point on, the wall will be created with the ramp.

7. Under Include Cardinal Points, toggle on Horizontal and Vertical.

8. Key in 1.00 for the Interval.

Note: This is how often a vertex is created on the resulting linestring.

9. <D> Apply, then Close.
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10. Fit the view.

 

Note: The 3D linestring is shown here in plan and in a rotated view. It forms the origin 
point for the wall template.

11. Make 12345 SH119 the active surface.

Note: The SH119 surface has a 3:1 slope from the bottom of the ditch that creates a 
‘target’ for the walls.

Important! Since the template was created to search for the active surface, SH119 
must be active.
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12. Set the Locate Features / Locate Graphics toggle to Locate Graphics.

13. Select Surface > Design Surface > Apply Template.

14. Key in 12345 walls E F G for the Design Surface.

Note: The design surface does not have to exist. It is created when the command is 
applied.

15. Set the Reference Feature Interval to 10.00.

16. Toggle on Stroke Tolerance.

Note: The Value does not matter unless the reference graphic has an arc in it. Using View 
3D Alignment creates a linestring that does not contain arcs.

17. Highlight the 3_Terraced_Walls template in the 4 Components/Barriers & Misc 
Components/Walls folder.

18. Set Duplicate Names to Replace.

19. Toggle on Remove Loops.

20. Toggle off Generate Graphics Only.
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21. Toggle on Triangulate Surface.

22. <D> Apply.

23. <D> on the 3D alignment graphic to identify the Primary Element.

24. <D> anywhere in the view to accept.

25. <D> on the 3D alignment graphic again to identify the Reference Element.

26. <D> anywhere in the view to accept.

27. <R> to apply the template to the entire element.
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Note: Temporary graphics appear showing the resulting feature locations.
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28. <D> anywhere in the view for the location.

Note: The Results dialog appears showing any end condition failures. Above, you see the 
plan and rotated views of the graphics. There may be failures at either end of the 
graphics, since the alignment actually begins slightly underground.

29. Save the wall surface to the c:\Projects\12345\Design\InRoads folder.

30. Review the surface by displaying triangles and/or contours.

Note: If the view is rotated, return to a top view when done.

31. Set the active alignment to SH52-H.
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32. Select Evaluation > Profile > Create Profile.

33. Toggle on 12345 existing ground for interchange, 12345 SH52, 12345 SH119 and 12345 
walls E F G.

34. Select the Controls branch.

35. Set the Station Limits to 106+00 to 109+00.

36. <D> Apply.

37. <D> a clear area in the design file for the location of the profile.
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38. Window in to see the wall surface.

Note: Since templates can also contain non-triangulating and closed shape components, 
walls, footers, leveling pads, etc. can be created as part of the template if desired.

Note: The features developed here can be combined with features from the other models 
to create an overall interchange model.

Chapter Summary:

 Templates can be used to create features for surfaces other than roadways.

 Templates can be used without Roadway Designer by ‘running’ them on a 3D elements or 
features.

 Using targets other than surfaces can greatly expand the capability of templates, allowing 
them to create features for a variety of design applications.
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Widening and overlay projects are and increasingly large part of the CDOT workload. This lab illustrates the 
MicroStation and InRoads tools used for this type of project.

Chapter Objectives: 

 Create a complex chains for the pavement edges from existing ground features.

 Import the chains as horizontal and vertical alignments.

 Develop a widening and overlay template.

 Define a corridor for the project.

The Following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model_Overlay.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry_Overlay.alg

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

 C:\Projects\12345\DesignROW_Survey\InRoads\DTM\12345 existing ground-
Overlay.dtm

This project runs the length of the SH 86 alignment from station 205+00 to 259+00. Therefore, the display of 
features, etc. will be restricted to an area from station 204+00 to 260+00. This will ensure that enough data is 
available for the full length of the project.

Lab 24.1 - Chain Pavement Edge Features

As single continuous lines are easier to use for point controls than a number of unconnected 
lines. Creating the complex chain also provides the opportunity to close gaps in the pavement 
edge features. 

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Drawings\ 
Reference_Files\12345DES_Model_Overlay.dgn file.

2. Load the following files into InRoads:

♦ C:\Projects\12345\Design\InRoads\12345DES_Geometry_Overlay.alg
♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground-

Overlay.dtm
♦ C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\ 

Templates\CDOT_Template-Library.itl

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\ Preferences\CDOT_Civil.xin file is loaded.

The first step is to mark out the limits of construction. Then a MicroStation fence is used to 
limit InRoads displays to this area.

4. In the InRoads explorer, <D> the Geometry tab.
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5. <R> on the SH 86 horizontal alignment and select View from the right click menu.

6. Select Fit View from the MicroStation view controls.

7. From the CDOT Menu, select the Drafting group.

8. <D> the Border button.

9. Highlight Clip Boundary from the item list. This activates the Place SmartLine 
command.

10. In the MicroStation key-in window, key in so=204+00,500 and press Enter.

11. Key in so=204+00,-500 and press Enter. <R> to finish the line.

This places a line perpendicular to the alignment at the beginning of the project.
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12. The Place SmartLine command is still active. Key in so=260+00,500 and press 
Enter.

13. Key in so=260+00,-500 and press Enter. <R> to finish the line.

14. From the MicroStation Main toolbar, <D> Place Fence.

15. In the Tool Settings dialog box, set the Fence Type to Shape. 

16. <T> then <D> to the ends of the lines. The fence is shown in the illustration below.

Next, a feature filter is set up that will only display edge of pavement features. In this case these 
features are named T-Edge of Oil.
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17. From the InRoads menu bar, select Surface > Feature > Feature Selection Filter.

18. From the Feature Selection Filter dialog box, toggle on None for the Start With option.

19. Verify that the Attribute is set to Name.

20. Key in T_Edge of Oil* for the Value.

21. Toggle on Include for the Mode.

22. <D> the Add Rule button.

23. <D> the Save As button.

24. In the Save Filter As dialog box, key in T_Edge of Oil.
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25. <D> The OK button. This creates the filter and dismisses the Save Filter As dialog box.

26. <D> the OK button to dismiss the Feature Selection Filter dialog box.

27. On the InRoads Locks toolbar, verify that the T_Edge of Oil filter is selected and that the 
Feature Filter Lock is turned on.

With the Feature Filter defined and set active, The pavement features needed can now be 
displayed.

28. Select Surface > View Surface > Features from the InRoads menu bar.

29. In the View Features dialog box, verify that 12345 existing ground-Overlay is set as 
the Surface.

30. Set the Fence Mode to Inside.

31. Hold the Ctrl key and <D> on each of the Parking Lot features to de-select them.
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32. <D> the Apply button to display the features inside the fenced area.

33. <D> Close to dismiss the View Features dialog box.

Note: If the features do not appear in the MicroStation window, <D> the Fit View from 
the view controls button bar.

34. From the MicroStation Main toolbar, <D> Place Fence to dismiss the fence that was 
placed earlier.

Notice that each of the edge of oil features displayed has three gaps and a driveway in it. The 
driveways must be removed and gaps filled in before the pavement edges can be chained 
together. In order for the corridor to function properly, the lines placed to fill in the gaps must 
also include elevation information.

35. Use the MicroStation view controls to zoom in on the area with the driveways.
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36. From the InRoads main toolbar, select the Partial Delete command.

37. <D> on the lines as indicated in the illustration below to remove the driveways.

38.  On the CDOT Menu, select the Design group.

39. Verify that the Status is set to Proposed.

40. <D> the Surface button.
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41. Highlight Surface 4 from the item list. This level was selected because of the contrast to 
the features displayed.

42. <T> then <D> at each end of the gap created in the upper pavement edge line and then <R> 
to exit the place line command.

43. Repeat step 41 for each gap in the pavement edge lines. The illustration below shows all of 
the gaps closed.
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The lines drawn are accurate to the surface only at the points where they were snapped to the 
features. To ensure that the lines represent the surface over the length of the line, the InRoads 
Drape Surface command is used.

44. From the InRoads menu bar, select Surface > Design Surface > Drape Surface.

45. In the Drape Surface dialog box, verify that the Destination Surface is set to 12345 
existing ground-Overlay.

46. Set the Input Mode to Level.

47. Set the Source Level to DES_Surface_4.

48. Set the Destination Level to DES_Surface_3. This level was chosen because its display is 
different from both the lines drawn and the features displayed.
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49. Toggle on Delete Original Graphics.

50. <D> Apply. The original lines are deleted and replaced with linestrings on the destination 
level, DES_SURFACE_3. The new linestrings contain a vertex at each point where the 
original line crossed a triangle in the destination surface.

Now the edge of oil lines can be chained into a single element.

51. Select Fit View from the MicroStation View Controls.

52. From the MicroStation main toolbar, select the Delete command and delete the lines that 
mark the begin and end of the project. This is to ensure that they are not accidentally 
included into one of the chains.

53. From the MicroStation main toolbar, select the Create Complex Chain command.



Colorado Department of Transportation   Page 507

Labs for InRoads XM LAB 24 - Widening and Overlay

54. In the tool settings box, set the Method to Automatic.

55. <D> on the left most element in the top line then <D> in a blank area. All of the elements 
that make up the upper pavement edge highlight.

56. <D> in a blank area to accept the selection set and create a single chain from the elements.

57. <D> on the left most element in the bottom line then <D> in a blank area. 

58. <D> in a blank area to accept the selection set and create the second chain.

Section Summary:
♦ Use Feature Selection Filters to limit the number of features to those needed.

♦ Use a MicroStation fence to further limit what is displayed to the area of the project.

♦ Once displayed, the feature graphics are like any other MicroStation element.

♦ Be careful is the Gap setting is increased for the Create Complex Chain command. 
Increasing the gap could allow the program to grab elements that are not intended to be 
part of the chain.

Lab 24.2 - Creating Alignments from Graphic Chains

Now that the pavement edges have been chained together, these linestrings can be imported as 
horizontal and vertical alignments.These alignments will be used for point controls in a later 
exercise.

Section Objectives:

♦ Import the graphic elements created in the previous exercise as horizontal and vertical 
alignments.

1. From the InRoads menu bar, select File > Import > Geometry.

2. On the Import Geometry dialog box, verify that the From Graphics tab is selected.

3. Set the Type to Horizontal and Vertical Alignment.



Page 508 Colorado Department of Transportation

LAB 24 - Widening and Overlay Labs for InRoads XM

4. In the Name field, key in Lt_EOP.

5. In the Description field, key in Left edge of pavement for point control.

6. Select ALG_OTHER for the Style.

7. Verify that the Geometry Project in the Target area is set to 12345DES_Geometry 
_Overlay.

8. <D> Apply.

9. <D> on the upper chain, then <D> again to accept the selection. <R> to redisplay the 
Import Geometry dialog box.

10. In the Import Geometry dialog box, key in Rt_EOP for the Name.

11. In the Description field, key in Right edge of pavement for point control.

12. <D> Apply.

13. <D> on the lower chain, then <D> again to accept the selection. <R> to redisplay the 
Import Geometry dialog box.

14. <D> Close to dismiss the Import Geometry dialog box.

15. In the InRoads explorer, <D> the Geometry tab and verify that Lt_EOP and Rt_EOP are 
in the geometry project. 

16. Save the 12345DES_Geometry_Overlay geometry project.
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Section Summary:
♦ Take care when importing feature graphics as alignments, overlapping and gaps in 

elements are common and can cause problems in Roadway Designer.

♦ One way to tell if the Import Geometry command worked is to look in the Name field 
after the command was executed. If the last letter in the name has changed, then 
geometry was created.

Lab 24.3 - Creating a Widening and Overlay template

Now that the geometry required for the project is completed, the template and then the corridor 
can be defined. The template for this project has a 2” overlay of the existing pavement and 8’ 
paved shoulders added to the existing pavement width.

Section Objectives:

♦ Copy the standard template library into the project folder

♦ Create a new template placeholder

♦ Add simple components to define the overlay.

♦ Change the constraints on the overlay to Project to Surface.

♦ Add shoulder and end condition sections.

First, the standard template library is copied into the project directory.

1. In the InRoads explorer, <D> the Template tab.

2. <R> on the CDOT_Template-Library and select Save As from the right click menu.

3. In the Save As dialog box, verify that the C:\Projects\12345\Design\InRoads\ 
directory is selected.

4. In the File name field, key in DES12345_Templates-Overlay.
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5. <D> Save then <D> Cancel.

Next, a new template is created in the template library.

6. On the InRoads menu bar, select Modeler > Create Template.

7. In the Create Template dialog box, expand the C:\Projects\12345\Design\ 
InRoads\DES12345_Templates-Overlay.itl > 1 - Templates folder.

8. <R> on the 1 - Templates folder and select New > Template from the right click 
menu.

9. Key in 12345_Overlay for the template name.

10. Display the Dynamic Settings dialog box.

11. Key in 0.10 for the X and Y Steps.

12. Toggle on Apply Affixes.
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13. <R> in the template view and select Add New Component > Simple from the right 
click menu.

14. In the Current Component area, key in HMA_Overlay for the Name.

15. Select D_HMA_Pvmt for the Style.

16. Key in 0.1667 for the Thickness. Note: this will round to 0.17 in the dialog box.

17. <R> in the template view and select Mirror from the right click menu.
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18. <D> on the template origin. This creates the two components shown in the illustration 
below.

19. <R> on the vertical line in the center of the template and select Merge Components 
from the right click menu.

20. <D> <D> on the centerline point of the template to display the Point Properties dialog 
box.

21. In the Point Properties dialog box, select HMA_Liftx_Centerline-Top in the Name field. 
This also sets the Surface Feature Style to Centerline.

22. Change the x to a 1 in the liftx part of the name.
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23. <D> Apply to accept the change.

24. <D> the Next button to select the center bottom point (1).

25. Select HMA_Liftx_Centerline-Top in the Name field. 

26. Change the x to a 1 in the liftx part of the name and change Top to Bottom.

27. Change the Vertical constraint (Constraint 2 in this example) to Project To Surface.

28. Set the Parent 1 of the above constraint to Any Direction.
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29. Verify that the Value for the Project To Surface constraint is set to 12345 existing 
ground-Overlay.

30. <D> Apply to accept the change.

31. <D> the Next button to select the right top point (RT_).

32. In the same manner as done in steps 22 and 26, change the name of the point to 
RT_HMA_Lift1_Laneline-Top.

33. <D> Apply to accept the change.

34. <D> the Next button to select the right bottom point (RT_1).

35. Change the name of the point to RT_HMA_Lift1_Laneline-Bottom.

36. Change the Vertical constraint (Constraint 2 in this example) to Project To Surface.

37. Set the Parent 1 of the above constraint to Any Direction.

38. Verify that the Value for the Project To Surface constraint is set to 12345 existing 
ground-Overlay.

39. <D> Apply to accept the change.

40. <D> the Next button to select the right top point (LT_).

41. In the same manner as done in steps 22 and 26, change the name of the point to 
LT_HMA_Lift1_Laneline-Top.

42. <D> Apply to accept the change.

43. <D> the Next button to select the right bottom point (LT_1).
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44. Change the name of the point to LT_HMA_Lift1_Laneline-Bottom.

45. Change the Vertical constraint (Constraint 2 in this example) to Project To Surface.

46. Set the Parent 1 of the above constraint to Any Direction.

47. Verify that the Value for the Project To Surface constraint is set to 12345 existing 
ground-Overlay.

48. <D> Apply to accept the change.

49. <D> Close to dismiss the Point Properties dialog box. The template looks like the 
illustration below:

Now the shoulders and end conditions are added. 

50. Expand the template library to show the contents of the 2 - Sections - Pavement > 
Shoulder Sections > Hot Mix Asphalt folder. 
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51. <D> on the HMA_Outside_Shoulder_3Lifts-12z section.

52. In the Preview window, <D> and hold on the shoulder’s origin (the upper left point).

53. Drag and drop the section onto the RT_HMA_Lift1_Laneline-Top point.

Note: Because Mirror was turned on when placing the overlay component, both 
shoulders are now placed in the template.
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54. <D> <D> on the RT_HMA_Lift1_EOP-Top point to display the Point Properties dialog 
box.

55. Change the Value of the Horizontal constraint (Constraint 1 in this example) to 8.00.

56. Change the Slope constraint (Constraint 2 in this example) to a Vector-Offset Type.

57. Set the Parent 1 to HMA_Lift1_Centerline-Top.

58. Set the Parent 2 to RT_HMA_Lift1_Laneline-Top.

59. <D> Apply and then <D> Close to dismiss the Point Properties dialog box.

60. Repeat steps 54 through 59 on point LT_HMA_Lift1_EOP-Top, using the corresponding 
points from the left side of the template.  Remember to use -8.00 for the value of the 
horizontal constraint in step 55.

61. Expand the template library to show the contents of the 3 - Sections - End Conditions 
> Z-Slope End Conditions > High Speed End Conditions folder. 

62. <D> on the Z12_6_to_1 section.

63. In the Preview window, <D> and hold on the section’s origin (the upper left point).

64. Drag and drop the section onto the RT_HMA_Lift1_EOP-Top point.

65. This completes the template. Select File > Save from the Create Template menu bar.

66. <D> Close to dismiss the Create Template dialog box.
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The illustration below shows the completed template:

Section Summary:
♦ Using the Project to Surface point constraint will cause the bottom of the overlay to 

match the existing ground exactly.

♦ Once the right click options of Mirror and Reflect are turned on, they remain active 
until they are turned off.

Lab 24.4 - Creating the Overlay Corridor

Finally, a corridor is constructed using the alignments and template developed earlier.

Section Objectives:

♦ Create a corridor for the SH 86 alignment.

♦ Add a template drop using the widening and overlay template.

♦ Add point controls using the edge of pavement and SH 86 alignments.

♦ Review the results in Roadway Designer.

This corridor contains a single template drop and three point controls. These control the two 
laneline points with a horizontal and vertical control and the centerline with a vertical control. 
Superelevation is not required for this corridor because the laneline point controls will cause 
the template to match the existing superelevation.

1. From the InRoads menu bar, select Modeler > Roadway Designer.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management from 
the menu bar.

3. In the Manage Corridors dialog box, key in Overlay Project for the Name.

4. Toggle on Station Limits.

5. Key in 205+00.00 for the Start station.

6. Key in 259+00.00 for the Stop station.
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7. <D>Add then <D> Close to dismiss the dialog box.

8. In the Roadway Designer dialog box, select Corridor > Template Drops from the menu 
bar.

9. In the Template Drops dialog box, key in 25.00 for the Interval.

10. Expand the C:\Projects\12345\Design\InRoads\DES12345_Templates-
Overlay template library to show the contents of the 1 - Templates folder.

11. Highlight the 12345_Overlay template.

12. <D> the Add button then <D> the Close button to dismiss the Template Drops dialog 
box.

The template is now displayed in the cross section view. Next, point controls are added to raise 
the template up 2” and match the existing cross slopes of the original surface.
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13. In the Roadway Designer dialog box, select Corridor > Point Controls from the menu 
bar.

14. In the Point Controls dialog box, set the Point to HMA_Lift1_Centerline-Top.

15. Toggle on Vertical for the Mode.

16. In the Vertical Offsets area, key in 0.1667 for the Start and Stop offset. Note: these will 
be rounded to 0.17.

17. <D> the Add button.

18. In the Point Controls dialog box, set the Point to RT_HMA_Lift1_Laneline-Top.

19. Toggle on Both for the Mode.

20. Select Rt_EOP for the Horizontal Alignment. This automatically sets the vertical 
alignment.

21. In the Vertical Offsets area, key in 0.1667 for the Start and Stop offset. 
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22. <D> the Add button.

23. In the Point Controls dialog box, set the Point to LT_HMA_Lift1_Laneline-Top.

24. Select Lt_EOP for the Horizontal Alignment. This automatically sets the vertical 
alignment.

25. In the Vertical Offsets area, key in 0.1667 for the Start and Stop offset. 

26. <D> the Add button the <D> Close to dismiss the Point Controls dialog box.

This completes the corridor definition. Now the corridor can be reviewed in Roadway 
Designer.
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27. Scroll through the template drops using the station controls under the cross section view. 
Notice that the template top in the backbone of the template maintains a constant slope 
from the centerline to the edge of pavement.

28. Also notice that some areas did not appear to work properly. This is especially noticeable in 
the area between station 240+00 and 250+00. There are two causes for these anomalies. 
The first is the existence of additional features inside the Edge of Oil features used for point 
control alignments.

The illustration below shows the area where other features are inside the edge of oil 
features.

In the example above the grey lines are pavement striping features.

The other situation is similar and occurs where there were gaps in the edge of oil feature. 
Again features may occur inside where the lines were drawn to fill in these gaps.

29. From the Roadway Designer menu bar select Tool > Options.

30. In the Roadway Designer Options dialog box, toggle on Cut and Fill Graphics, Cut 
and Fill Values, and Net Volumes.
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31. <D> OK to accept the changes and dismiss the dialog box.

32. Scroll through the template drops again.

33. Notice the heavy blue line in the cross section display. This represents the design surface 
used to compute volumes.Under the overlay component, this line exactly matches the 
existing ground line. This is a result of the Project to Surface constraint defining each end 
of a segment. When a Project to Surface constraint is used on each end of a template 
segment the line between the points follows the target surface.

34. Also notice that there are no cut or fill areas in the overlay area.

35. From the Roadway Designer menu bar, select File > Save.

36. In the File name field of the Save As dialog box, key in 12345_Overlay_Project.
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37. <D> Save then <D> Cancel to dismiss the dialog box.

38. <D> Close to dismiss the Roadway Designer dialog box.

39. Exit InRoads and MicroStation.

Section Summary:
♦ Point controls can be used to match the existing cross slope of the road.

♦ Displaying Cut and Fill graphics shows the design surface line used to compute 
volumes.

Chapter Summary:

 Surface features can be used to create point control alignments.

 Be aware that other features may reside inside of the edge of pavement which could cause 
problems when modeling the corridor.

 If the edge of pavement is to be saw cut prior to widening, Copy Parallel the edge of 
pavement chain the distance of the saw cut before importing the alignment. Also, in this 
case, the vertical alignment should be created separately, using the Vertical from Surface 
command.

 The Project to surface command is used to make a template segment match the existing 
ground.

 Because the point controls force the template to match the existing cross slope, 
superelevation is not used.

 With minor modification to the template and adjustments in point controls, the exercise can 
be use to rehabilitate existing cross slopes.
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When a divided highway has separate horizontal and vertical controls for each driving surface, the median can 
not have a fixed width. In this lab, an end condition section is developed for a variable width median. 

Chapter Objectives:

 Build components for each median situation.

 Assemble the components into a single section.

 Add Display Rules to turn components on and off.

 Add the median ditch section to a template.

 Update a corridor to use the template and examine its behavior.

The Following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model_Median-
Ditch.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Median-Lab.alg

 C:\Projects\12345\Design\InRoads\12345DES_Templates_Median-Ditch.itl

 C:\Projects\12345\Design\InRoads\12345DES_Median-Ditch.ird

 C:\Projects\12345\Design\InRoads\12345DES_Northbound.dtm

 C:\Projects\12345\DesignROW_Survey\InRoads\DTM\12345SURV_Existing_Ground_VM
D.dtm

Lab 25.1 - Create Median Ditch Components

The median section attaches to the right side of the southbound template. There are four 
different situations that have to be accounted for on the median ditch. These are:

♦ 6:1 / 6:1 “V” Ditch - This option is used when the inside EOP points are less than 24’ 
apart.

♦ 6:1 - 10:1 / 6:1 - 10:1 Compound Ditch - This option is used when the inside EOP 
points are greater than 24’ apart.

♦ 6:1 - 10:1 / 6:1 Compound Ditch - This option is used when the southbound lanes are 
higher than the northbound lanes and the left 10:1 slope intercepts the right 6:1 slope.

♦ 6:1 / 6:1 - 10:1 Compound Ditch - This option is used when the northbound lanes are 
higher than the southbound lanes and the right 10:1 slope intercepts the left 6:1 slope.

A separate component will be built for each situation and tested to be sure it works.

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Drawings\ 
Reference_Files\12345DES_Model_Median-Ditch.dgn file.

2. Load the following files into InRoads:

♦ C:\Projects\12345\Design\InRoads\12345DES_Median-Lab.alg
♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345SURV_Existing_Grou

nd_VMD.dtm
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♦ C:\Projects\12345\Design\InRoads\12345DES_Templates_Median-
Ditch.itl

♦ C:\Projects\12345\Design\InRoads\12345DES_Median-Ditch.ird
♦ C:\Projects\12345\Design\InRoads\12345DES_Northbound.dtm

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\ Preferences\CDOT_Civil.xin file is loaded.

4. From the InRoads menu bar, select Modeler > Create Template.

5. Expand the 4 - Components folder of the template library.

6. <R> on the 4 - Components folder and select New > Folder from the right click menu.

7. Key in Variable Median Ditch for the folder name.

8. <R> on the Variable Median Ditch folder and select New > Template from the right 
click menu.

9. Key in 6:1/6:1_V_Ditch for the template name. The new template is automatically 
opened for editing.

10. Display the Dynamic Settings dialog box.

11. Set both the X Step and Y Step to 0.10.
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12. Verify that Apply Affixes is toggled off.

13. <R> in the template view and select Add New Component > End Condition from 
the right click menu.

14. In the Current Component area, key in Ditch_Width for the Name.

15. Set the Style to Breakline.

16. Set the Target Type to Feature XYZ.

17. Set the Surface to 12345DES_Northbound.

18. Set the Feature to Northbound-Conc_EOP-Top.
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19. In the Dynamic Settings dialog box, select EOP for the Point Name.

20. Move the cursor to the template origin (0.00,0.00) and <D> to place the point.

21. In the Dynamic Settings dialog box, key in NB_EOP for the Point Name.

22. Toggle on End Condition is Infinite and Do Not Construct.

23. Set the key in mode to hs=.

24. Key in 48,0 in the precision key in field and press Enter.

25. <R> and select Finish from the right click menu.

This end condition is used to determine the width of the median. Each of the four components 
used for this median ditch will contain this end condition. Next, the ditch component is added.

26. <R> in the template view and select Add New Component > Unconstrained from 
the right click menu.

27. In the Current Component area, key in V_Ditch for the Name.

28. Set the Style to D_Median.

29. <D> on the EOP point to start the component at the origin.
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Note: When the “+” symbol turns white, the cursor is snapped to the point and the points 
automatically merge.

30. In the Dynamic Settings dialog box, key in Median_Ditch-Bottom in the Point Name 
field.

31. Select D_DITCH-Bottom for the Point Style.

32. <D> between and below the EOP and NB_EOP points.

33. <D> on the NB_EOP point.

34. <R> in an open area. Verify that Closed Shape is toggled off, then select Finish.

35. <D> <D> on the Median_Ditch-Bottom point to display the Point Properties dialog 
box.

36. In the Point Properties dialog box, set both constraints to Slope.

37. Set the Parent 1 for Constraint 1 to EOP.

38. Set the Parent 1 for Constraint 2 to NB_EOP.

39. Key in -16.67% for the Value of Constraint 1.

40. Key in 16.67% for the Value of Constraint 2.
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41. <D> Apply then <D> Close to dismiss the Point Properties dialog box.

This component will now construct a “V” ditch with 6:1 slopes on each side. Now it must be 
restricted to display only when the EOP and NB_EOP points are within 24’ horizontally of 
each other. This is accomplished using a Display Rule.

42. <D> <D> on the line forming the ditch to display the Component Properties for the 
V_Ditch component.

43. In the Component Properties dialog box, <D> the Edit button. This displays the 
Component Display Conditional Expression dialog box.

44. In the Component Display Conditional Expression dialog box, <D> the Add button. This 
displays the Display Rule dialog box.

45. In the Display Rule dialog box, key in V_DitchWidth for the Name.

46. Key in Sets maximum width for the V ditch for the Description.

47. Set the Type to Absolute Horizontal.

48. Set Between to EOP.

49. Set And to NB_EOP.
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50. Set the operator to < and key in 24.00 for the value. The dialog box with completed 
entries is illustrated below:

51. <D> OK. This dismisses the Display Rule dialog box.

52. In the Component Display Conditional Expression dialog box, highlight V_DitchWidth 
in the Template Display Rules area.

53.  <D> the Selected Rule button.

54. <D> OK. This dismisses the Component Display Conditional Expression dialog box and 
adds the rule to the component properties of V_Ditch.
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55. In the Component Properties dialog box, <D> Apply then <D> Close to dismiss the 
dialog box.

If the V_Ditch does not disappear right away, it will when you click in the template view. This 
is because the Display Rule returned a false value (EOP and NB_EOP are more than 24 feet 
apart). Because an end condition controls the NB_EOP point, the template can be tested to see 
if it works properly.

56. <D> the Test button.

57. In the Test End Conditions dialog box, <D> the Draw button.

58. Move the cursor slowly from right to left in the dialog box. Notice that once the cursor is 
moved left of the 25 grid line, the template displays.

59. <D> Close to dismiss the Test End Conditions dialog box.

60. Select File > Save from the Create Template menu bar.

The next component to build is the 6:1 - 10:1 / 6:1 - 10:1 Compound Ditch. This component 
has a 12 foot 6:1 slope extending from each pavement edge. The slope changes to 10:1 at this 
point to form the ditch bottom.

61. Create a new template in the Variable Median Ditch folder as described in steps 6 through 
9 above. Name the template Standard Compound Ditch. 

62. <R> in the template view and select Add New Component > End Condition from 
the right click menu.

63. In the Current Component area, key in Ditch_Width for the Name.

64. Set the Style to Breakline.

65. Set the Target Type to Feature XYZ.

66. Set the Surface to 12345DES_Northbound.

67. Set the Feature to Northbound-Conc_EOP-Top.

68. In the Dynamic Settings dialog box, select EOP for the Point Name.

69. Move the cursor to the template origin (0.00,0.00) and <D> to place the point.

70. In the Dynamic Settings dialog box, key in NB_EOP for the Point Name.

71. Toggle on End Condition is Infinite and Do Not Construct.
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72. Set the key in mode to hs=.

73. Key in 48,0 in the precision key in field and press Enter.

74. <R> and select Finish from the right click menu.

75. <R> in the template view and select Add New Component > Unconstrained from 
the right click menu.

76. In the Current Component area, key in Std_Compound_Ditch for the Name.

77. Set the Style to D_Top-of-Cut. Using a different style for each ditch component will make 
it easier to troubleshoot the template if there is a problem

78. <D> on the EOP point to start the component at the origin.

79. In the Dynamic Settings dialog box, select POSS for the Point Name. Then key in 
SB_POSS for the Point Name. Selecting POSS first automatically sets the Point Style, 
then “SB_” can be appended to the name.

80. In the precision key in field, type 12,-0.1667 and press Enter.

81. In the Dynamic Settings dialog box, key in Median_Ditch-Bottom in the Point Name 
field.

82. Select D_DITCH-Bottom for the Point Style.

83. In the precision key in field, type 12,-0.100 and press Enter.

84. In the Dynamic Settings dialog box, select POSS for the Point Name. Then key in 
NB_POSS for the Point Name. 
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85. In the precision key in field, type 12,0.100 and press Enter.

86. <D> on the NB_EOP point.

87. <R> and select Finish from the right click menu. The illustration below shows the 
component as it appears at this point.

The points on the component form the proper shape. Now they must be constrained to maintain 
that shape.

88. <D> <D> on the SB_POSS point.

89. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

90. Set the Constraint 2 Type to Slope.

91. Set the Parent 1 for both constraints to EOP.
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92. <D> Apply.

93. <D> the Next button to select Median_Ditch-Bottom.

94. Set the Type of both constraints to Slope.

95. Set the Parent 1 of Constraint 1 to SB_POSS.

96. Set the Parent 1 of Constraint 2 to NB_POSS.
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97. <D> Apply.

98. <D> the Next button to select NB_POSS.

99. Set the Constraint 1 Type to Horizontal.

100.Set the Constraint 2 Type to Slope.

101.Set the Parent 1 for both constraints to NB_EOP.

102.<D> Apply then <D> Close to dismiss the Point Properties dialog box.

There are three situations where this component will not work correctly. These are 1) when the 
median is less than 24 feet wide 2) when the NB_POSS drops below the 10:1 slope from the 
SB_POSS and 3) when the Median_Ditch-Bottom is left of the SB_POSS (this can occur when 
the NB_EOP is higher than the SB_EOP). Display rules are used to test for each of these 
situations.

103.<D> <D> on the line forming the ditch to display the Component Properties for the 
Std_Compound_Ditch component.

104.In the Component Properties dialog box, <D> the Edit button. This displays the 
Component Display Conditional Expression dialog box.

105.In the Component Display Conditional Expression dialog box, <D> the Add button. This 
displays the Display Rule dialog box.

106.In the Display Rule dialog box, key in Std_Compound_DitchWidth for the Name.

107.Key in Sets minimum width for the standard compound ditch for the 
Description.

108.Set the Type to Horizontal.
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109.Set Between to SB_POSS.

110.Set And to NB_POSS.

111.Set the operator to < and key in 0.00 for the value. The dialog box with completed entries 
is illustrated below:

112.<D> OK. This dismisses the Display Rule dialog box.

113.In the Component Display Conditional Expression dialog box, <D> the Add button. 

114.In the Display Rule dialog box, key in Std_Compound_DitchVertical1 for the 
Name.

115.Key in Sets minimum height for the standard compound ditch for the 
Description.

116.Set the Type to Vertical.

117.Set Between to NB_POSS.

118.Set And to Median_Ditch-Bottom.

119.Set the operator to < and key in 0.00 for the value. The dialog box with completed entries 
is illustrated below:

120.<D> OK. This dismisses the Display Rule dialog box.

121.In the Component Display Conditional Expression dialog box, <D> the Add button. 

122.In the Display Rule dialog box, key in Std_Compound_DitchVertical2 for the 
Name.

123.Key in Sets maximum height for the standard compound ditch for the 
Description.

124.Set the Type to Horizontal.
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125.Set Between to SB_POSS.

126.Set And to Median_Ditch-Bottom.

127.Set the operator to < and key in 0.00 for the value. The dialog box with completed entries 
is illustrated below:

128.<D> OK to accept the entries and dismiss the dialog box.

129.In the Component Display Conditional Expression dialog box, highlight 
Std_Compound_DitchWidth in the Template Display Rules area.

130. <D> the Selected Rule button.

131.<D> the AND button.

132.Highlight Std_Compound_DitchVertical1 in the Template Display Rules area.

133.<D> the Selected Rule button. 

134.<D> the AND button.

135.Highlight Std_Compound_DitchVertical2 in the Template Display Rules area.

136.<D> the Selected Rule button. The dialog box with completed entries is illustrated 
below:
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137.<D> OK. This dismisses the Component Display Conditional Expression dialog box and 
adds the rule to the component properties of Std_Compound_Ditch.

138.<D> the Apply button then <D> the Close button to dismiss the Component Properties 
dialog box.

Using the three display rules with the AND operator means that all of the rules must return a 
True result in order for the component to be displayed.

139.<D> the Test button.

140.In the Test End Conditions dialog box, <D> the Draw button.

141.Move the cursor slowly from right to left and up and down in the dialog box. Notice the 
different situations that cause the template to disappear.

142.<D> Close to dismiss the Test End Conditions dialog box.

143.Select File > Save from the Create Template menu bar.

Two of the four components required for this template have been completed. The final two 
components define the ditch where the 10:1 slope from one side of the ditch intercepts the 6:1 
slope on the other side.

144.Create a new template in the Variable Median Ditch folder as described in steps 6 through 
9 above. Name the template Compound Ditch NB_EOP High. 

145.<R> in the template view and select Add New Component > End Condition from 
the right click menu.

146.In the Current Component area, key in Ditch_Width for the Name.

147.Set the Style to Breakline.

148.Set the Target Type to Feature XYZ.

149.Set the Surface to 12345DES_Northbound.

150.Set the Feature to Northbound-Conc_EOP-Top.

151.In the Dynamic Settings dialog box, select EOP for the Point Name.

152.Move the cursor to the template origin (0.00,0.00) and <D> to place the point.

153.In the Dynamic Settings dialog box, key in NB_EOP for the Point Name.

154.Toggle on End Condition is Infinite and Do Not Construct.

155.Set the key in mode to hs=.

156.Key in 48,0 in the precision key in field and press Enter.

157.<R> and select Finish from the right click menu.

158.Add a new unconstrained component.

159.Key in NB_EOP-High for the Name.



Page 540 Colorado Department of Transportation

LAB 25 - Variable Median Ditch Labs for InRoads XM

160.Select D_CONC_Sw for the Style.

161.<D> on the EOP point to start the component at the origin.

162.In the Dynamic Settings dialog box, key in Median_Ditch-Bottom in the Point Name 
field.

163.Select D_DITCH-Bottom for the Point Style.

164.<D> between and below the EOP and NB_EOP points.

165.In the Dynamic Settings dialog box, key in NB_POSS in the Point Name field.

166.Select D_POSS for the Point Style.

167.<D> to the right and above Median_Ditch-Bottom and to the left and below NB_EOP.

168.<D> on the NB_EOP point.

169.<R> and select Finish from the right click menu. The illustration below shows the 
component as it appears at this point.

170.<D> <D> on the Median_Ditch-Bottom point.

171.In the Point Properties dialog box, set the Type to Slope on both constraints.

172.Set the Parent 1 for Constraint 1 to EOP.

173.Set the Parent 1 for Constraint 2 to NB_POSS.

174.Key in the -0.1667 for the Value of Constraint 1.

175.Key in the 0.1000 for the Value of Constraint 2.

176.<D> Apply.

177.<D> Next to select the NB_POSS point.

178.Set the Constraint 1 Type to Horizontal.

179.Set the Constraint 2 Type to Slope.

180.Set the Parent 1 for both constraints to NB_EOP.



Colorado Department of Transportation   Page 541

Labs for InRoads XM LAB 25 - Variable Median Ditch

181.Key in the 12.00 for the Value of Constraint 1.

182.Key in the 0.1667 for the Value of Constraint 2.

183.<D> Apply then <D> Close to dismiss the dialog box.

The shape of the ditch is now fixed. Now display Rules must be added to control when this 
component is displayed.

184.<D> <D> on the line forming the ditch to display the Component Properties for the 
NB_EOP_HIGH component.

185.In the Component Properties dialog box, <D> the Edit button. This displays the 
Component Display Conditional Expression dialog box.

186.In the Component Display Conditional Expression dialog box, <D> the Add button. This 
displays the Display Rule dialog box.

187.In the Display Rule dialog box, key in NB_EOP_HIGHWidth for the Name.

188.Key in Sets width for ditch for the Description.

189.Set the Type to Absolute Horizontal.

190.Set Between to EOP.

191.Set And to Median_Ditch-Bottom.

192.Set the operator to < and key in 12.00 for the value. The dialog box with completed 
entries is illustrated below:

193.<D> OK. This dismisses the Display Rule dialog box.

194.In the Component Display Conditional Expression dialog box, <D> the Add button. 

195.In the Display Rule dialog box, key in NB_EOP_HIGHVertical for the Name.

196.Key in Sets height for the ditch for the Description.

197.Set the Type to Vertical.

198.Set Between to NB_POSS.

199.Set And to Median_Ditch-Bottom.
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200.Set the operator to < and key in 0.00 for the value. The dialog box with completed entries 
is illustrated below:

201.<D> OK. This dismisses the Display Rule dialog box.

202.In the Component Display Conditional Expression dialog box, highlight 
NB_EOP_HIGHWidth in the Template Display Rules area.

203. <D> the Selected Rule button.

204.<D> the AND button.

205.Highlight NB_EOP_HIGHVertical in the Template Display Rules area.

206.<D> the Selected Rule button. The dialog box with completed entries is illustrated 
below:

207.<D> OK. This dismisses the Component Display Conditional Expression dialog box and 
adds the rule to the component properties of NB_EOP High.

208.<D> the Apply button then <D> the Close button to dismiss the Component Properties 
dialog box.

This completes the Compound Ditch NB_EOP High component. Next the final component is 
built.
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209.Create a new template in the Variable Median Ditch folder as described in steps 6 through 
9 above. Name the template Compound Ditch SB_EOP High. 

210.<R> in the template view and select Add New Component > End Condition from 
the right click menu.

211.In the Current Component area, key in Ditch_Width for the Name.

212.Set the Style to Breakline.

213.Set the Target Type to Feature XYZ.

214.Set the Surface to 12345DES_Northbound.

215.Set the Feature to Northbound-Conc_EOP-Top.

216.In the Dynamic Settings dialog box, select EOP for the Point Name.

217.Move the cursor to the template origin (0.00,0.00) and <D> to place the point.

218.In the Dynamic Settings dialog box, key in NB_EOP for the Point Name.

219.Toggle on End Condition is Infinite and Do Not Construct.

220.Set the key in mode to hs=.

221.Key in 48,0 in the precision key in field and press Enter.

222.<R> and select Finish from the right click menu.

223.Add a new unconstrained component.

224.Key in SB_EOP-High for the Name.

225.Select D_Shoulder for the Style.

226.<D> on the EOP point to start the component at the origin.

227.In the Dynamic Settings dialog box, key in SB_POSS in the Point Name field.

228.Select D_POSS for the Point Style.

229.<D> between and below the EOP and NB_EOP points.

230.In the Dynamic Settings dialog box, key in Median_Ditch-Bottom in the Point Name 
field.

231.Select D_DITCH-Bottom for the Point Style.

232.<D> between and below the SB_POSS and NB_EOP points.

233.<D> on the NB_EOP point.
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234.<R> and select Finish from the right click menu. The illustration below shows the 
component as it appears at this point.

235.<D> <D> the SB_POSS point.

236.Set the Constraint 1 Type to Horizontal.

237.Set the Constraint 2 Type to Slope.

238.Set the Parent 1 for both constraints to EOP.

239.Key in the 12.00 for the Value of Constraint 1.

240.Key in the -0.1667 for the Value of Constraint 2.

241.<D> Apply to accept the changes.

242.<D> Next to select the Median_Ditch-Bottom point.

243.In the Point Properties dialog box, set the Type to Slope on both constraints.

244.Set the Parent 1 for Constraint 1 to SB_POSS.

245.Set the Parent 1 for Constraint 2 to NB_EOP.

246.Key in the -0.1000 for the Value of Constraint 1.

247.Key in the 0.1667 for the Value of Constraint 2.

248.<D> Apply.

The shape of the ditch is now fixed. Now display Rules must be added to control when this 
component is displayed.

249.<D> <D> on the line forming the ditch to display the Component Properties for the 
SB_EOP-High component.

250.In the Component Properties dialog box, <D> the Edit button. This displays the 
Component Display Conditional Expression dialog box.

251.In the Component Display Conditional Expression dialog box, <D> the Add button. This 
displays the Display Rule dialog box.
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252.In the Display Rule dialog box, key in SB_EOP_HIGHWidth-Max for the Name.

253.Key in Sets maximum width for ditch for the Description.

254.Set the Type to Absolute Horizontal.

255.Set Between to Median_Ditch-Bottom.

256.Set And to NB_EOP.

257.Set the operator to < and key in 12.00 for the value. The dialog box with completed 
entries is illustrated below:

258.<D> OK. This dismisses the Display Rule dialog box.

259.In the Component Display Conditional Expression dialog box, <D> the Add button. 

260.In the Display Rule dialog box, key in SB_EOP_HIGHWidth-Min for the Name.

261.Key in Sets minimum width for ditch for the Description.

262.Set the Type to Horizontal.

263.Set Between to SB_POSS.

264.Set And to Median_Ditch-Bottom.

265.Set the operator to < and key in 0.00 for the value. The dialog box with completed entries 
is illustrated below:

266.<D> OK. This dismisses the Display Rule dialog box.

267.In the Component Display Conditional Expression dialog box, highlight 
SB_EOP_HIGHWidth-Max in the Template Display Rules area.

268. <D> the Selected Rule button.

269.<D> the AND button.
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270.Highlight SB_EOP_HIGHWidth-Min in the Template Display Rules area.

271.<D> the Selected Rule button. The dialog box with completed entries is illustrated 
below:

272.<D> OK. This dismisses the Component Display Conditional Expression dialog box and 
adds the rule to the component properties of SB_EOP High.

273.<D> the Apply button the <D> the Close button to dismiss the Component Properties 
dialog box.

This completes the Compound Ditch SB_EOP High component. All of the variable median 
ditch components can be placed into a single section.

Section Summary:
♦ The components use an end condition to find the edge of the northbound pavement. 

This is so that the component can be tested before it is added to the template. The same 
results can be accomplished with a null point and a point control.

♦ Display rules are used to define when a component will be used. 

♦ Different Styles are used for the ditch line in each component. This is done to facilitate 
troubleshooting. Once the components are assembled into a section and it is working 
properly, the styles will be set to match for each component.

Lab 25.2 - Assemble the Components into a Section

Now that the individual components for the variable median ditch are built, they can be 
assembled into a section.

Section Objectives:

♦ Create a new folder for the variable median ditch section.

♦ Create a new template for the variable median ditch section.

♦ Add the components to the section.
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♦ Delete the redundant end condition components.

♦ Add additional display rules so that only one component is displayed at a time.

The first step is to create the folder and template for the variable median ditch section.

1. Expand the 3 - Sections - End Conditions folder of the template library.

2. <R> on the 3 - Sections - End Conditions folder and select New > Folder from the 
right click menu.

3. Key in Variable Median Ditch for the folder name.

4. <R> on the Variable Median Ditch folder and select New > Template from the right 
click menu.

5. Key in Variable Median Ditch for the template name. The new template is 
automatically opened for editing.

Now the components can be placed into the new template.

6. <D> on the 6:1/6:1_V_Ditch component so that it is displayed in the preview window.

7. Drag the component by its origin (the green dot in the upper left corner) and drop it on the 
origin in the template view.

8. Repeat steps 6 and 7 with the Compound Ditch NB_EOP High, Compound Ditch 
NB_EOP High, and Standard Compound Ditch.
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Because each component has the same end condition in it, the Variable Median Ditch section 
now has four identical end conditions. Three of these end conditions are deleted to remove 
redundancies in the template. Because the same point names are used in each component, 
deleting the extra end conditions will not affect how the individual components operate.

9. <D> the Active Template tab at the bottom of the Template Library tree view.

10. Expand the Components folder.

11. <R> on Ditch_Width1 and select Delete from the right click menu.

12. <D> Yes on the delete warning message box.

13. Repeat steps 10 through 12 for Ditch_Width2 and Ditch_Width3.

Next, test the section and see how each of the components behave.

14. <D> the Test button.

15. In the Test End Conditions dialog box, <D> the Draw button.
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16. Move the cursor around slowly in the view area. Notice that there are two instances when 
two components are displayed at the same time. These occur when the horizontal distance 
between the EOP and NB_EOP is less than 24’ and there is an elevation difference between 
the points.

This is fixed by adding two more display rules to the V_Ditch component.

17. <D> Close to dismiss the Test End Conditions dialog box.

18. In the Create Templates dialog box, <D> <D> on the V_Ditch component in the Active 
Template tree view. This opens the Component Properties dialog box.
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19. <D> the Edit button to display the Component Display Conditional Expression dialog 
box.

20. In the Component Display Conditional Expression dialog box, <D> the Add button to 
display the Display Rule dialog box.

21. In the Display Rule dialog box, key in NB_EOP-High-Displayed for the Name.

22. Key in NB_EOP-High is displayed for the Description.

23. Set the Type to Component is Displayed.

24. Set the Component to NB_EOP-High. The dialog box with completed entries is illustrated 
below:

25. <D> the OK button. This dismisses the Display Rule dialog box and adds the new rule to 
the Template Display Rules list on the Component Display Conditional Expression dialog 
box.

Note: The Template Display Rules list contains all of the rules created thus far in the lab.

26. In the Component Display Conditional Expression dialog box, <D> the Add button to 
display the Display Rule dialog box.

27. In the Display Rule dialog box, key in SB_EOP-High-Displayed for the Name.

28. Key in SB_EOP-High is displayed for the Description.

29. Set the Type to Component is Displayed.

30. Set the Component to SB_EOP-High. The dialog box with completed entries is illustrated 
below:

31. <D> the OK button. 
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32. In the Component Display Conditional Expression dialog box, <D> in the Conditional 
Expression for V_Ditch area to the right of the V_DitchWidth entry.

33. <D> the AND button.

34. <D> the NOT button.

35. Highlight the NB_EOP-High-Displayed rule in the Template Display Rules list.

36. <D> the Selected Rule button.

37. <D> the AND button.

38. <D> the NOT button.

39. Highlight the SB_EOP-High-Displayed rule in the Template Display Rules list.
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40. <D> the Selected Rule button. The dialog box with completed entries is illustrated 
below:

 

41. <D> the OK button to accept the changes and dismiss the dialog box.

42. On the Component Properties dialog box, <D> Apply then <D> Close.

43. Test the section again. Notice that only one component at a time is displayed.

44. <D> Close on the Test End Conditions dialog box.

45. Select File > Save from the Create Template menu bar.

The Variable Median Ditch section is ready to be used on a template.

Section Summary:
♦ As components were added to the section, common points were merged but common 

components (like the end conditions) are not.

♦ Use the Active Template tree view to access components that are not displayed.

♦ Additional display rules can be used to turn off a component when two are displayed at 
the same time.
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Lab 25.3 - Adding the Section to a Template and Reviewing the 
Corridor

The variable median ditch section can now be added to the template and used in the design 
corridor.

Section Objectives:

♦ Add the variable median ditch to the southbound backbone template.

♦ Update the corridor to use the modified template.

♦ Examine the results in the Roadway Designer dialog box.

1. <D> the Library tab to show the Template Library tree view.

2. Expand the 1 - Templates folder.

3. <D> <D> on the Southbound template to make it active.

4. <D> on the Variable Median Ditch section (in the 3 - Sections - End Conditions > 
Variable Median Ditch) to display it in the Preview area.

5. In the Preview area, <D> and hold on the Variable Median Ditch origin.
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6. Drag the section into the template view and Drop it on the SB RT EOP point. 

7. Select File > Save from the Create Template menu bar.

8. <D> Close on the Create Template dialog box.

The template is now ready to use in the corridor.

9. From the InRoads main menu bar, select Modeler > Roadway Designer. This displays 
the Roadway Designer dialog box.

10. In the Roadway Designer dialog box, verify that the Southbound corridor is active.

11. Select Corridor > Template Drops from the Roadway Designer menu bar.

12. Highlight the entry in the Current Template Drops list.

13. <D> the Synchronize with Library button.
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14. <D> Close to dismiss the Template Drops dialog box.

15. Scroll through the stations watching the template view. Notice the changes in the median 
ditch (especially around stations 1407+25 and 1415+75,). The different styles used on the 
median ditch components make it easy to spot when the component changes.

16. On the Roadway Designer menu bar, select File > Save to save the modified ird file.

17. <D> Close on the Roadway Designer dialog box.

18. Close InRoads and MicroStation.

Section Summary:
♦ The variable median ditch requires no further editing to be used in the template.

♦ Always check the Template Drops after editing templates.

♦ After examining the corridor, go back and change the styles of the median ditch 
components so they match.

Chapter Summary:

 Build complex sections in smaller components that can be tested prior to assembling the 
whole thing.

 Use display rules to select a single component when more than one can be displayed.

 Use different styles to facilitate trouble shooting.
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Walls Are used to reduce the width of sideslopes in areas restricted by right of way, roads or other structures, or 
natural obstacles.  Other labs in this series describe the design of independent walls.  In this lab, walls are used 
as part of the template in a corridor run. 

Chapter Objectives:

 Modify an existing wall component for a specific situation.

 Add the modified wall component to a template.

 Construct a new wall component that targets a surface feature.

The Following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Walls-Lab.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Walls-Lab.alg

 C:\Projects\12345\Design\InRoads\12345DES_Walls-Lab.ird

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

 C:\Projects\12345\DesignROW_Survey\InRoads\DTM\12345 Walls-Lab.dtm

Each of these walls are applied to the same corridor.  The wall component that is currently in the library is used 
on the right side of the template.  The new wall component, that is built as part of the lab, is used on the left 
side.

Lab 26.1 - Add an Existing Wall Component to a Template

The existing wall component has the basic layout needed for this project.  It just needs a couple 
of minor alterations to make it fit into the location where it is used.  In this exercise, the wall 
component is added to the template and the minor changes are made.

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Drawings\ 
Reference_Files\12345DES_Walls-Lab.dgn file.

2. Load the following files into InRoads:

♦ C:\Projects\12345\Design\InRoads\12345DES_Walls-Lab.alg
♦ C:\Projects\12345\Design\InRoads\12345DES_Walls-Lab.ird
♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 Walls-Lab.dtm
♦ C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\ 

Templates\CDOT_Template-Library.itl

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\ Preferences\CDOT_Civil.xin file is loaded.

1. In the InRoads explorer, <D> the Template tab.
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2. <R> on the CDOT_Template-Library and select Save As from the right click menu.

3. In the Save As dialog box, verify that the C:\Projects\12345\Design\InRoads\ 
directory is selected.

4. In the File name field, key in DES12345_Walls-Lab.

5. <D> Save then <D> Cancel.

6. From the InRoads menu bar, select Modeler > Create Template.

7. In the Create Template dialog box, expand the C:\Projects\12345\Design\ 
InRoads\DES12345_Templates-Overlay.itl > 1 - Templates folder.

8. <R> on the CONC_Ramp template and select Copy from the right click menu.
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9. <R> on the 1 - Templates folder and select Paste from the right click menu.  This 
creates the CONC_Ramp1 template.

10. <R> on the CONC_Ramp1 template and select Rename from the right click menu.

11. Key in CONC_Ramp_with_Walls for the name.

12. <D> <D> on the CONC_Ramp_with_Walls template to make it active. Display the 
Dynamic Settings dialog box.

13. In the Dynamic Settings dialog box, set the Steps to 0.10.

14. Toggle on Apply Affixes.

15. Delete the POSS and end condition components from the right side of the template.  The 
illustration below show the template with the components deleted.

Next, the RT_SubBase_EOP-Top point is moved to line up under the RT_ABC_EOP-Top 
point.  This is so that it will not overlay into the wall base.

16. <D> <D> on the RT_SubBase_EOP-Top point to display the Point Properties dialog 
box.

17. Change the Constraint 1 Type from Slope to Horizontal.
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18. Key in 0.00 for the Value.

19. <D> the Apply button then <D> Close to dismiss the dialog box.

Now the wall component can be added to the template.

20. In the Template Library explorer, expand the folders to show the contents of the  
C:\Projects\12345\Design\InRoads\DES12345_Walls-Lab.itl > 4 - 
Components > Barriers & Misc Components > Walls folder.

21. <D> on the WingWall_Cast-in-Place-Fixed-Base component to display it in the 
Preview window.

22. <D> and hold on the wall component’s origin (the far left point).
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23. Drag and drop it onto the RT_Conc_EOP-Top point.

Currently, the wall is set 4 feet from the pavement edge.  If the wall is extended to its full 
height, the footer of the wall will expand into the ABC material of the ramp.  To correct this 
problem, the wall is moved 1 foot to the right.

24. <D> <D> on the RT_Wall_Top-Back point to display the Point Properties dialog box.

25. In the Point Properties dialog box, Change the Value of Constraint 2 (the Horizontal 
constraint) to 5.83.
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26. <D> Apply then <D> Close to dismiss the dialog box.

This has moved the wall 1 foot to the right.  It has also left a gap between the wall and the 
segment that connects the wall to the rest of the template.  Next this gap is closed and a shallow 
“V” ditch is created between the wall and pavement edge.

27. <D> <D> on the RT_SwaleToe point.

28. In the Point Properties dialog box, Set the Constraint 2 Type to Vector-Offset.

29. Set the Constraint 2 Parent 1 to RT_Wall_Top-Front.

30. Set the Constraint 2 Parent 2 to RT_Wall_Base-Front.

31. Key in 0.00 for the Constraint 2 Value.
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32. <D> Apply then <D> Close to dismiss the dialog box.

33. <R> on the RT_Base_Elevation_Control component (the line that connects the Wall 
with the pavement edge) and select Insert Point from the right click menu.
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34. Place the point between and below the RT_Conc_EOP-Top and RT_SwaleToe points.

35. <D> <D> on the new point to display the Point Properties dialog box.

36. In the Point Properties dialog box Name field, key in RT_Ditch-Bottom.

37. Set the Surface Feature Style to D_Ditch-Bottom.

38. Set the Type for both constraints to Slope.

39. Set the Parent 1 for Constraint 1 to RT_Conc_EOP-Top.

40. Set the Parent 1 for Constraint 2 to RT_SwaleToe.

41. Key in  -8.33% for the Value of Constraint 1.

42. Key in  8.33% for the Value of Constraint 2.
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43. <D> Apply then <D> Close to dismiss the dialog box.  The illustration below shows the 
dialog box as completed

This completes the edits to the template.

44. Select File > Save from the Create Template menu bar.

45. <D> the Close button on the Create Template dialog box to dismiss it.

Now, examine how the template behaves in Roadway Designer.

46. Select Modeler > Roadway Designer from the InRoads menu bar.

47. From the Roadway Designer menu bar, select Corridor > Template Drops.

48. In the Template Drops dialog box, highlight the entry in the Current Template Drops area.

49. Expand the Template library folder to show the contents of the 1 - Templates folder.

50. Highlight the CONC_Ramp_with_Walls template from the Library Templates list.
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51. <D> Change then <D> Close to dismiss the dialog box.

52. Scroll through the template drops in the Cross Section view of the Roadway Designer 
dialog box.

53. Verify that the wall is expanding and contracting to meet the existing ground.

54. Select File > Save from the Roadway Desgner dialog box.

55. <D> Close to dismiss the dialog box.

Section Summary:
♦ The Wall_Top-Back point is the controlling point for the wall component’s shape.  

Change its horizontal constraint to move the wall away from or closer to the template 
origin.

♦ Adjust the horizontal constraint on the Height Control Point to change the width of the 
Fill component that extends from the back of the wall to the existing ground.

♦ Aside from the Wall_Top-Back, SwaleToe, and Height _Control_Point try not to edit 
other points on the wall component as these can change the shape of the visible 
component but not the hidden components.
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Lab 26.2 - Creating a Custom Wall 

There are cases where the wall components in the template library are not suited for the 
situation under design. In the exercise below, a wall is required on the left side of the template 
from station 1+50 to the end of the project.  The height of the wall is determined by running a 
10 to 1 slope from a target feature in the existing ground dtm up to the base of the wall.

Section Objectives:

♦ Make a copy of the CONC_Ramp_with_Walls template.

♦ Add an end condition that seeks a surface feature.

♦ Build the slope component from the targeted feature to the base of the wall.

♦ Build the wall components.

♦ Update the corridor to use the templates.

First, a copy of the CONC_Ramp_with_Walls template is made.  This template is used for the 
first 150’ of the project.

1. From the InRoads menu bar, select Modeler > Create Template.

2. In the Create Template dialog box, expand the C:\Projects\12345\Design\ 
InRoads\DES12345_Templates-Overlay.itl > 1 - Templates folder.

3. <R> on the CONC_Ramp_with_Walls template and select Copy from the right click 
menu.

4. <R> on the 1 - Templates folder and select Paste from the right click menu.  This 
creates the CONC_Ramp_with_Walls1 template.

5. <R> on the CONC_Ramp_with_Walls1  template and select Rename from the right 
click menu.

6. Key in CONC_Ramp_with_Wall-Rt for the name.

The CONC_Ramp_with_Wall-Lt template is used for the first 150’ of the project.  The 
CONC_Ramp_with_Walls template will be modified with a wall on the left side and is used on 
the remainder of the project.

7. Verify that the CONC_Ramp_with_Walls template is active.
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8. Delete the POSS and end condition components from the left side of the template.  The 
illustration below shows the template with the left end conditions deleted:

9. Display the Dynamic Settings dialog box.

10. In the Dynamic Settings dialog box, verify that the Steps are set to 0.10.

11. Verify that Apply Affixes is toggled on.

12. <R> in a blank area of the template view and select Add New Component > End 
Condition from the right click menu.

13. In the Current Component area, key in 10:1 Fill for the Name.

14. Set the Style to D_Toe-of-Fill.

15. Set the Target Type to Feature XYZ.

16. Set the Surface to 12345_Walls-Lab.

17. Select 03101311 for the Feature.

18. <D> on the HMA_GRAIL-Top point.

19. In the Dynamic Settings dialog box, toggle on End Condition is Infinite and Do Not 
Construct.
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20. Select Toe-of-Fill for the Point Name.

21. <D> below and to the left of the HMA_GRAIL-Top point.

22. <R> and select Finish from the right click menu. The only thing that is displayed is a single 
point (LT_Toe-of-Fill).

This component is only used to locate the feature. The slope and wall will be built back from 
this point to the rest of the template.

Next, the ABC component is modified on the left side and the Wall component is added.

23. <D> <D> the LT_SubBase_EOP-Top point to display the Point Properties dialog box.

24. In the Point Properties dialog box, change the Slope constraint to a Horizontal constraint 
(Constraint 1 in this example).
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25. Key in 0.00 for the Value of the Horizontal constraint.  This moves the point out of the 
way of the wall.

26. <D> Apply then <D> Close to dismiss the dialog box.

27. <R> in a blank area of the template view and select Add New Component > 
Unconstrained from the right click menu.

28. In the Current Component area, key in Fill  Slope for the Name.

29. <D> on on the LT_Toe-of-Fill point.

30. In the Dynamic Settings dialog box, key in Toe-at-Wall for the Point Name.  

31. Verify that the Style is set to D_Toe-of-Fill.
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32. <D> just to the left and below the guardrail asphalt component as shown in the illustration 
below:

33. <R> and select Finish from the right click menu.  Constraints will be added to the LT_Toe-
at-Wall point after the wall component is added.

34. <R> in a blank area of the template view and select Add New Component > 
Unconstrained from the right click menu.

35. In the Current Component area, key in Wall for the Name.

36. Select D_Wall-Retaining for the Style.

37. <D> on the HMA_GRAIL-Top point.

38. In the Dynamic Settings dialog box, key in Wall_Base-Back for the Point Name.  

39. Set the Style set to D_Wall-Retaining.

40. <D> directly below the HMA_GRAIL-Top point about half way through the ABC 
component.

41. In the Dynamic Settings dialog box, key in Wall_Base-Front for the Point Name.

42. Move the cursor to the left until the X coordinate reads -3.90 in the Dynamic Settings 
dialog box then <D>.

43. In the Dynamic Settings dialog box, key in Wall_Top-Front for the Point Name.

44. Move the Cursor straight up and <D> near the level of the HMA_GRAIL-Top point.
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45. <R> and verify that Closed Shape is toggled on, then select Finish to complete the 
component. The illustration below shows the new wall component.

46. <D> <D> the LT_Wall_Base-Back point to display the Point Properties dialog box.

47. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal.

48. Set the Constraint 2 Type to Vertical.

49. Set the Parent 1 for Constraint 1 to HMA_GRAIL-Top.

50. Set the Parent 1 for Constraint 2 to LT_Wall_Base-Front.

51. Key in 0.00 for the Value of both constraints.  The illustration below shows the completed 
dialog box.

52. <D> Apply then <D> Close to dismiss the dialog box.

53. <D> <D> the LT_Wall_Base-Front point. 
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54. Set the Constraint 1 Type to Slope.

55. Set the Constraint 2 Type to Vertical.

56. Set the Parent 1 for both constraints to LT_Toe-at-Wall.

57. Key in 10000% for the Value of Constraint 1.

58. Key in -1.50 for the Value of Constraint 2.  The illustration below shows the completed 
dialog box.

59. <D> Apply then <D> Close to dismiss the dialog box.

60. <D> <D> the LT_Toe-at-Wall point. 

61. Set theType of both constraints to Slope.

62. Set the Parent 1 for Constraint 1 to LT_Toe-of-Fill.

63. Set the Parent 1 for Constraint 2 to LT_Wall_Top-Front.

64. Key in 10.00% for the Value of Constraint 1.
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65. Key in -10000% for the Value of Constraint 2.  The illustration below shows the 
completed dialog box.

66. <D> Apply then <D> Close to dismiss the dialog box.

67. <D> <D> the LT_Wall_Top-Front point. 

68. Set the Constraint 1 Type to Horizontal.

69. Set the Constraint 2 Type to Vertical.

70. Set the Parent 1 for both constraints to HMA_GRAIL-Top.

71. Key in -1.00 for the Value of Constraint 1.
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72. Key in 0.00 for the Value of Constraint 2.  The illustration below shows the completed 
dialog box.

73. <D> Apply then <D> Close to dismiss the dialog box.

74. In the Template Library explorer, expand the folders to show the contents of the  
C:\Projects\12345\Design\InRoads\DES12345_Walls-Lab.itl > 4 - 
Components > Barriers & Misc Components > Guardrail Type 7 folder.

75. <D> on the Guardrail_Type 7-CD component.

76. Drag the component by the origin (lower left corner) and drop it on to the LT_Wall_Top-
Front point. The illustration below shows the completed template.
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77. Select File > Save from the Create Template menu bar.

78. <D> the Close button on the Create Template dialog box to dismiss it.

The template is now ready to use in the corridor.

79. Select Modeler > Roadway Designer from the InRoads menu bar.

80. From the Roadway Designer menu bar, select Corridor > Template Drops.

81. In the Template Drops dialog box, highlight the entry in the Current Template Drops area.

82. In the Station field, key in 1+50.00.

83. <D> the Change button.

84. Highlight the entry again and <D> the Synchronize with Library button.

85. In the Station field, key in 0+00.00.

86. Expand the Template library folder to show the contents of the 1 - Templates folder.

87. Highlight the CONC_Ramp_with_Wall-Rt template from the Library Templates list.

88. <D>the Add button.

89. In the Station field, key in 1+49.99.
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90. <D>the Add button then <D>Close to dismiss the dialog box.  The completed dialog box 
is shown below.

91. Scroll through the template drops in the Cross Section view of the Roadway Designer 
dialog box.

♦ Verify that the wall is expanding and contracting to meet the existing ground.

92. Select File > Save from the Roadway Desgner dialog box.

93. <D> Close to dismiss the dialog box.

94. Close InRoads and MicroStation.

Section Summary:
♦ An end condition was used to locate the feature to tie to.  This can also be done with a 

Null point and a point control.

♦ A true vertical segment can not be used to create a triangulated surface, that is why the 
wall face has a 10000% slope.

Chapter Summary:

 Add walls to a corridor using dedicated templates and template drops.  Using walls as part 
of an end condition solution may result in walls occuring in areas where they are not 
wanted or not occuring in areas where they are needed.

 Wall sections will contain either an end condition or point control to determine the height 
of the wall.

 Changes from the non-wall to the wall template should occur within 0.01 feet.  THis 
ensures a clean change from one template to the other.
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This lab demonstrates a procedure for modeling a roadway which includes a raised median and a median 
opening.  The exercise below uses a single template which utilizes point controls and display rules to achieve 
the two different roadway sections. Additionally a second template is used to model the median openings.

Chapter Objectives:

 Use a single template to model the mainline with and without a median

 Create display rules which determine when the raised median excluded

 Use point controls to define the location of the median nose

 Model multiple corridors

 Combine corridors in a single final surface

Lab 27.1 - Open Lab Files

An initial model of the roadway is crated using the roadway typical section without the median. 
This is done for the purposed of extracting the profile gradeline for the median noses.

1. Open MicroStation and InRoads using the 12345DES_Model-Create Raised Median.dgn 
file.

2. Select File> Open from the InRoads menu bar.

3. Select the file C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\
Preferences\CDOT_Civil.xin

4. Continue to select the following files from C:\Projects\12345\Design\InRoads\ and the 
<D> Open button.

♦ 12345DES_Existing-Create Raised Median.dtm

♦ 12345DES_Geometry-Create Raised Median.alg

♦ 12345DES_Templates-Create Raised Median.itl

♦ 12345DES_Roadweay-Create Raised Median.ird

5. <D> Cancel the Open dialog box to close.

Lab 27.2 - Workflow

A summary of the overall process

1. In addition to the mainline horizontal and vertical alignments, create horizontal align-
ment(s) for the median nose.

2. Create a template for the crowned roadway - without the raised median.

3. Model the mainline using the crowned template.

4. Create the vertical alignments for the median noses by extracting their elevations from the 
surface created in the previous step.

5. Create a template for the median noses
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6. Model the median noses

7. Create a template for the raised median

8. Add Display Rules to the components of the raised median.

9. Create a corridor definition for the raised median

10. Add point controls to constrain the raised median template to run as defined, constrained to 
the medians or to the mainline alignment.

11. Define key stations for template drops.

12. Create the final design surface by modeling the mainline and median openings 
simultaneously.

Modeling Schematic
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Lab 27.3 -  Review The Alignments

In this exercise three alignments are used. Federal CL for the main corridor and Median Nose 
& Median Nose_North which define the median opening and termination.

1. Select the Geometry tab in the InRoads Explorer

2. View the horizontal alignments Federal CL, Median Nose & Median Nose_North 

3. View stationing for horizontal alignment Federal CL
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Lab 27.4 -  Review Data

An initial model of the roadway was created using a crowned roadway section (without the 
raised median). This is done for the purpose of extracting the vertical profile of the median 
noses which is accomplished by using the command File > Import > Geometry [Vertical 
From Surface]. This step has already been completed.

1. Select Modeler > Create Template from the InRoads menu bar.

2. In the Create Template dialog review the template for Median Nose in the 1-Templates 
folder.
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3. Also in the Create Template dialog review the template for Federal Blvd in the 
1-Templates folder. This template was use to create a preliminary model.  This model was 
used to extract vertical alignments for the median alignments.  

4. The template Federal Blvd with Raised Median. Display rules control if the median is 
modeled.

5. An expanded view of the median. The ‘Laneline’ points will be controlled by both the 
Federal Blvd. and median alignments. Additionally the median components will be 
assigned display rules which will test the distance between the lanelines and the PGL.

Lab 27.5 - Add Display Rules

Display rules can be associated with components to test if the component should be displayed 
or not.

1. Copy the template  Federal Blvd with Raised Median to 
Federal Blvd with Raised Median_DR

2. Open Federal Blvd with Raised Median_DR for editing

3. The goal is to eliminate the construction of the median components if the distance between 
either lanelines and the PGL is less than 5.50’.

Note: 5.50 feet represents the distance from the mainline alignment to the PC or PT of 
the alignments for the median noses.
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4. Select the median curb and gutter component named LT_C/G_Type2-1B for editing.

5. Select Edit

6. Select Add

7. Create a Display Rule that tests the distance between the Left Laneline and the PGL.

♦ Name: LeftC/G

♦ Description: test distance between LT laneline and PGL

♦ Type: Absolute Horizontal

♦ Between: LT_Conc_Laneline-Top1 and PGL

♦ Test: >=

♦ Value: 5.50
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8. Select Rule for the LT Laneline, OK & Apply

9. Select the component RT_C/G_Type2-1B for editing.

10. Build and apply a similar rule for the RT Laneline.

♦ Name: RightC/G

♦ Test between RT_Conc_Laneline-Top1 and PGL

♦ All other fields are the same

11. Edit the component CONC_Sidewalk-4”

12. Build and Apply a Display Rule to test for a minimum distance of 11.00 feet between the 
RT and LT Lanelines for the Median Cover (Conc_Sidewalk-4”)

♦ Name: MedianPavt

♦ Description: Test width between lanelines

♦ Type: Absolute Horizontal

♦ Between: LT_Conc_Laneline-Top1 and RT_Conc_Laneline-Top1

♦ Test: >=

♦ Value: 11.00

13. Save and Close the Create Template dialog.
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Lab 27.6 - Create Corridors

Corridors contain definitions for which alignments, templates, point controls, etc. to 
incorporate when modeling the roadway.   In this exercise, three corridors are defined, one for 
each median nose and one for the mainline. 

1. Select Modeler > Roadway Designer

2. Select Corridor > Corridor Management from the Roadway Designer menu bar or 

<D> the Manage Corridors button .

3. Add corridors for both median openings.

♦ Name: Median Nose

♦ Type: Alignment

♦ Horizontal Alignment: Median Nose

♦ Vertical Alignment: Median NoseV

4. Add corridor definition for corridor Median Nose_North

♦ Name: Median Nose_North

♦ Type: Alignment

♦ Horizontal Alignment: Median Nose_North

♦ Vertical Alignment: Median Nose_NorthV

5. Add and Close
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Lab 27.7 -  Add Template Assignments

Templates define the cross section of the design model.  They are assigned to the corridor 
through the Template Drops dialog box.  The starting station defaults to the beginning of the 
alignment so setting the interval and selecting the desired template is all of the input that is 
required.

1. Select Corridor > Template Drops from the Roadway Designer menu bar or <D> the 

template drops button .

2. Add template assignment to Median Nose 

♦ Template: Median Nose

♦ Interval of 1’

3. <D> Add then Close.
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4. Add template assignment to Median Nose_North

♦ Template: Median Nose_North

♦ Interval of 1’

5. <D> Add then Close.

6. Roadway Designer can be used to evaluate the two median corridors.
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Note: The template data is displayed in the template view.  There are two options for 
scrolling through the design, using the station arrows below the template view and 
using the station line in the plan view.

7. <D> on the station arrows to scroll through the design.

8. <D> and Hold on the yellow station line.  Move the pointer back and forth to scroll 
through the design.

The median models are now ready to be evaluated.

9. From the pull down menu in the Roadway Designer dialog 
Corridor > Corridor Management.

10. Create a corridor for the Mainline.

♦ Name: Federal_Display_Rule

♦ Type: Alignment

♦ Horizontal Alignment: Federal CL

♦ Vertical Alignment: Federal CL_V

♦ Start Station: 8+00

♦ Stop Station: 19+00

11. <D> Add

12. <D> Close

13. From the Roadway Designer dialog Corridor > Template Drops

14. Add template assignments to the corridor Federal_Display_Rule.

♦ Station: 8+00
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♦ Interval of 10’

♦ Template:Federal Blvd with Raised Median_DR

15. <D> Add

16. <D> Close

17. Evaluate the Federal_Display_Rule corridor.

Lab 27.8 - Change Roadway Designer Settings

The Roadway Designer settings determine if additional stations are processed, what information is displayed in 
the views, and what information is included in the processing report.  In this exercise, horizontal cardinal and 
event points are processed, cut and fill information is added to the template view, and component and point 
information is added to the processing report.

The first series of steps tell the Roadway Designer to process the  horizontal cardinal and event points. 

1. From the Roadway Designer menu bar, select Tools > Options.
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2. In the Roadway Designer Options dialog box, toggle on Horizontal Cardinal Points, 
Vertical Cardinal Points, External Control Points, Reference Graphics, and 
Transition Graphics.

3. <D> OK.

4. Scroll through the stations and notice that some stations do not fall on even intervals.  
These are the cardinal and event points.
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Lab 27.9 - Point Controls

This series of steps adds Point Controls (overrides) to the corridor definition previously defined 
in Roadway Designer.

1. Select Corridor > Point Controls from the Roadway Designer menu bar or <D> the 

Point Control button .

2. The roadway will model as defined until it encounters a point control. For this design, three 
point controls are required for each side of the roadway (Left laneline and Right laneline). 
The first control instructs the laneline to follow a feature created by the Median Nose 
corridor. The second control instructs the laneline to follow the mainline alignment. The 
third control instructs the laneline to follow a feature created by the Median Nose_North 
corridor.

3. Verify the corridor Federal_Display_Rule is the active corridor.

4. Create the following Point Control entries to instruct the template point  
RT_Conc_Laneline-Top1 to follow a feature (by the same name) created by the Median 
Nose corridor.

5. First Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Corridor Point

♦ Corridor: Median Nose

♦ Reference Point: Conc_Laneline-Top 1

♦ Station Start: 10+00.00 (begin of median radius)

♦ Station Stop: 10+05.50 (end of median radius/nose)

6. <D> ADD

7. Second Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Alignment
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♦ Horizontal Alignment: Federal CL

♦ Vertical Alignment: Federal CL_V

♦ Station Start: 10+05.51 (end of median radius/nose - beginning of median opening)

♦ Station Stop: 12+00.00 (beginning of north median/radius nose)

8. <D> ADD

9. Third Point Control

♦ Point: RT_Conc_Laneline-Top1

♦ Mode: Both 

♦ Control Type: Corridor Point

♦ Corridor: Median Nose_North

♦ Reference Point: Conc_Laneline-Top 1

♦ Station Start: 12+00.00 (begin of median radius/nose)

♦ Station Stop: 12+05.00 (end of median radius)

10. <D> ADD

11. Add the fourth, fith, and sixth entry for the LT_Conc_Laneline-Top1 point. The definitions 
mimic the definitions use for the RT_Conc_Laneline-Top1 point.

12. <D> ADD

13. <D> Close
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14. Review the results graphically in Roadway Designer. You should see the raised median 
disappear between stations 10+00.00 and 10+05.00 and again between 12+00.00 and 
12+05.00. Between these station limits, the corridors for the medians will complete the 
model.

15. You should also see the left and right pavement edges running together between stations 
10+05.51 and 12+00.00.  This represents the median opening.

Lab 27.10 - Adding Key Stations

Key Stations are specific locations you define relative to your design.  At these locations an 
additional template is processed.  You can also elect to create a cross section a locations defined 
by key stations.  Examples of Key Stations may be at driveways, side roads, drainage or in the 
case of this exercise, just prior to and after the application of point controls. This ensures the 
roadway models as designed and eliminates transitions between point controls and the next 
corridor defined interval.

1. Select Corridor > Key Stations  from the Roadway Designer menu bar or <D> the Point 

Control button .

2. Key-in the station values immediately before and after the point controls.  Select Add 
after each entry.

♦ 9+99.99

♦ 10+05.51

♦ 11+99.99
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♦ 12+05.51

3. D > Close

4. Select File > Save from the Roadway Designer menu.

Lab 27.11 - Creating the Model

With all the corridors, template applications, point controls and key stations defined, the model 
is ready to be created.

1. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 

Point Control button 

2. Select the following corridors for modeling:

♦ Federal_Display_Rule

♦ Median Nose

♦ Median Nose_North

3. <D> on Clipping Options

4. Under the Clipping Option column, <D> to cycle through the options and set both the 
Median Nose and Median Nose_North corridors to Clip None.
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Also set:

♦ Name: Design Model

♦ Default Preference: Proposed

And toggle on:

♦ Densify Horizontal Curves using Chord Height Tolerance

♦ Densify Vertical Curves using Chord Height Tolerance

♦ Triangulate

♦ Remove Loops

♦ Display Features in Plan View

And toggle off:

♦ Add Exterior Boundary - Style:

Lab 27.12 - Review the Design

Use you knowledge of InRoads to review your model. 

Some methods may include:
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 A 3D isometric view of DTM features

 DTM triangles

Contours, profiles and cross sections are additional options.

Chapter Summary:

 In Lab 27.5 -Add Display Rules were created and associated with template components.

 In Lab 27.9 -Point Controls were defined to modify the application of the defined template

 In Lab 27.10 -Adding Key Stations are used to define supplemental template application 
stations.

 In Lab 27.11 -Creating the Model multiple corridors are modeled simultaneously and 
corridor clipping option are defined.
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This lab demonstrates the InRoads design process for creating a single lane freeway entrance ramp (tapered 
type) model and the infield, gore and taper area segment of the the mainline model.  The Vertical Gore Tool is 
used to create a guide for revise and tie the ramp vertical alignment into the edge of lane of the mainline taper.  
The corridors are created for both the ramp and mainline models.  Display rules, Point controls, and end 
condition exceptions are used to tie the inside of the ramp model into the mainline corridor model in the gore 
and infield area.  The outside lane of the mainline corridor is widened with a point control to create the ramp 
taper.  After the ramp and mainline surfaces are created from the Roadway Designer, cross sections are 
displayed and examined to view the results.

Chapter Objectives:

 Revise and tie a ramp vertical alignment into the edge of lane of the mainline taper using 
the Vertical Gore Tool.

 Create a freeway entrance ramp (tapered type) model and the infield, gore and taper area 
segment of the the mainline model.

 Create a ramp and mainline surfaces from the Roadway Designer, display cross sections 
and examine the results.

Lab 28.1 -  Open InRoads Data Files

1. Open MicroStation and InRoads uing the 12345DES_Model-Create Ramp Model.dgn file.

2. Load CDOT_Civil-Create Ramp Model.xin

In the MicroStation drawing, notice the entrance ramp and mainline proposed linework 
displayed as a reference and the profile views for each alignment.

3. Select File> Open from the InRoads menu bar.

4. Select the following files from C:\Projects\12345\Design\InRoads\ and <D> Open them.

♦ 12345DES_Geometry-Create Ramp Model.alg

♦ 12345DES_Template-Create Ramp Model.itl

♦ 12345DES_Roadway-Create Ramp Model.ird

♦ 12345DES_Existing-Create Ramp Model.dtm

5. <D> Cancel the Open dialog box to close.

Lab 28.2 - Set the Global Scale Factors

1. Select Tools> Options from the InRoads menu bar.

2. In the Options dialog box:

♦ Select Factors tab.

♦ Key in 200 in the Factor fields.

♦ <D> Apply and <D> Close.
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Lab 28.3 - Create Ramp Vertical Alignment Guide with Vertical 
Gore Tool

Use the Vertical Gore Tool to create a guide for revising the ramp vertical alignment. This 
command is used to create a surface feature envelope of a ramp that merges into a mainline 
corridor. The output from this command includes a surface with four linear features which are 
designed to be plotted on the profile of the ramp alignment. These features specify the 
allowable maximum and minimum elevations of the ramp vertical alignment, as well as the 
ideal locations to make the gore cross slope match the mainline and ramp cross slopes. The 
exercise will use the Mainline Ideal cross slope to set the ramp’s vertical alignment.  This is 
used because the mainline’s cross slope extends out at a constant 2% from the crown in the 50:1 
taper section.  Note the Ramp Ideal cross slope feature is at the same location.

1. Select Modeler> Roadway Designer from the InRoads menu bar.

2. Select Tools> Vertical Gore Tool from the Roadway Designer menu bar.

3. In the Vertical Gore Design Tool dialog box:

♦ Select IH 39 in the Mainline Corridor field
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♦ Select LT_Outside_Conc_EOP-Top for the Mainlined Edge field, using the drop-
down list or the selector button and <D> on the template point in the Roadway 
Designer dialog box.

4. Set NW Ramp as the ramp corridor field.

5. Select IN_Conc_EOP-Top for the Ramp Inside Edge field, using the selector button and 
<D> on the template point in the Roadway Designer dialog box.

♦ Select OUT_Conc_EOP-Top for the Ramp Outside Edge field, using the selector 
button and <D> on the template point in the Roadway Designer dialog box.

♦ Key in 8% in the Maximum Difference field.

♦ Key in 30+50 in the Mainline Start field.

♦ Key in 32+00 in the Mainline Stop field.

♦ Key in Gore Design in the Surface Name field.

♦ Select D_GORE_Max_Vertical for the Maximum Style.

♦ Select D_GORE_Mainline_Ideal for the Mainline Ideal Style.

♦ Select D_GORE_Ramp_Ideal for the Ramp Ideal Style.
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♦ Select D_GORE_Min_Vertical for the Mimimum Style.

♦ <D> Apply and <D> Close

6. In the Roadway Designer dialog box:

♦ <D> Close and select No to save changes

Lab 28.4 - Update NW Ramp profile view to display Projected 
Features from the Gore Design surface

1. Select Evaluation> Profile> Update Profile from the InRoads menu bar.

2. In the Update Profile dialog box:

♦ Verify NW Ramp for the Profile Set.

♦ Select Projected Features in the Update Profile area.

♦ Select Display On for the Mode.

♦ Select Gore Design in the Surfaces area.

♦ Select All features in the Projected Features area.
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♦ <D> Apply and <D> Close.

The vertical alignment displayed in the profile view does not tie into the mainline and was 
created to model the NW Ramp corridor for use in the Vertical Gore design Tool.  The NW 
Ramp vertical alignment needs to be revised to tie into the edge of lane of the mainline 
taper.  Revise VPI #1 to begin at Sta. 31+38.43 and the slope of feature 
D_GORE_Mainline Ideal is extended to the revised VPI #2 location of the proposed sag 
vertical curve at Sta. 35+75.00.  The ramp vertical alignment is lowered to better tie into 
the mainline ditch in the infield area.

3. Set alignment NW Ramp as the Active alignment

4. Select Geometry> Vertical Curve Set> Move PI from the InRoads menu bar.

5. Move VPI #1 to Station 31+38.43, Elev. 5268.54 

6. Move VPI #2 to Station 35+75.00, Elev. 5251.04

Note: The keyin se=station,elevation can be used to move the PI’s

7. Select Geometry> View Geometry> Vertical Annotation from the InRoads menu 
bar.

♦ <D> Apply and <D> Close.
Revise NW Ramp corridor to start at the beginning of the ramp’s revised vertical 
alignment.

8. Select Modeler> Roadway Designer from the InRoads menu bar.

9. In the Roadway Designer dialog box:

♦ Select NW Ramp in the Coordiors field.

♦ Select Corridor > Corridor Management from the Roadway Designer menu bar.

♦ <D> on cooridor NW Ramp

♦ Key in 31+38.43 in the Start field.
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♦ <D> Change.

Define End Condition Exceptions for the IH 39 corridor.  Apply Left Override, 
Backbone Only to left side of IH 39 along the NW Ramp gore and infield area.

10. In the Roadway Designer dialog box:

11. Select IH 39 in the Corridor field and select Corridor> End Condition Exceptions in 
the Roadway designer menu bar.

♦ Key in 31+38.43 in the Start field.

♦ Key in 40+50 in the Stop field.

♦ Select Left Override in the Apply To area.

♦ Select Backbone Only

♦ <D> Add and <D> Close

Lab 28.5 - Define End Condition Exceptions for NW Ramp 
corridor

Apply Right Override, Backbone Only to right side of NW Ramp along the gore and infield 
area.

1. In the Roadway Designer dialog box:

2. Select NW Ramp in the Corridor field and select Corridor> End Condition 
Exceptions in the Roadway designer menu bar.

♦ Key in 31+38.43 in the Start field.

♦ Key in 40+50 in the Stop field.

♦ Select Right Override in the Apply To area.

♦ Select Backbone Only

♦ <D> Add and <D> Close
Define Point Controls for the IH 39 corridor.  Stretch westbound roadway’s left edge of 
pavement to create the ramp taper.

3. In the Roadway Designer dialog box:

4. Select IH 39 in the Corridor field and select Corridor> Point Controls in the Roadway 
designer menu bar.

5. In the Point Controls dialog box:
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♦ Select LT_Outside_Conc_EOP-Top for the Point field, using the selector button and 
<D> on the template point in the Roadway Designer dialog box.

♦ Select Horizontal for the Mode.

♦ Select Alignment in the Control Type field.

♦ Select Outside Edge of Pavement in the Horizontal Alignment field.

♦ Select Use as a Secondary Alignment.

♦ Key in 31+38.43 in the Stop field.

♦ <D> Add and <D> Close

Lab 28.6 - Define Point Controls for the NW Ramp corridor

Create a special ditch between the ramp and mainline shoulders pavements from the gore nose 
to a station where the mainline ditch starts (when the ramp fore slope is flatter than the 3:1 
maximum) and tie the inside (right) fore slope of the ramp to the mainline ditch along the 
infield area when the mainline ditch starts.

1. In the Roadway Designer dialog box:

2. Select NW Ramp in the Corridor field and select Corridor> Point Controls in the 
Roadway designer menu bar.

3. In the Point Controls dialog box: 



Page 606 Colorado Department of Transportation

LAB 28 - Create Ramp Model Labs for InRoads XM

♦ Select IN_Gore_Ditch for the Point field, from the drop-down list..

♦ Select Both for the Mode.

♦ Select Alignment in the Control Type field.

♦ Select Special_Ditch_NW_Ramp in the Horizontal Alignment field.

♦ Unselect Use as a Secondary Alignment.

♦ Key in 31+38.43 in the Start field.

♦ Key in 35+99.90 in the Stop field.

♦ <D> Add

4. In the Point Controls dialog box: 

♦ Select IN_POSS for the Point field, using the selector button and <D> on the template 
point in the Roadway Designer dialog box.
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♦ Select Both for the Mode.

♦ Select Corridor Point in the Control Type field.

♦ Select IH 39 in the Corridor field.

♦ Select LT_Outside_Conc_EOP-Top in the Reference Point field. 

♦ Key in 31+38.43 in the Start field.

♦ Key in 35+99.90 in the Stop field.

♦ <D> Add

5. In the Point Controls dialog box: 

♦ Select IN_Toe-Point-Control for the Point field, from the drop-down list..                
Note: This component has a display rule.

♦ Select Both for the Mode.

♦ Select Corridor Point in the Control Type field.

♦ Select IH 39 in the Corridor field.

♦ Select LT_POSS in the Reference Point field. 

♦ Key in 36+00 in the Start field.

♦ Key in 40+50 in the Stop field.

♦ <D> Add and <D> Close

Lab 28.7 - Define Key station for IH 39 corridor

1. In the Roadway Designer dialog box:

2. Select IH 39 in the Corridor field and select Corridor> Key Stations in the Roadway 
designer menu bar.

♦ Key in 31+38.42 in the Station field.

♦ <D> Add and <D> Close
Define Key station for NW Ramp corridor.
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3. In the Roadway Designer dialog box:

4. Select NW Ramp in the Corridor field and select Corridor> Key Stations in the 
Roadway designer menu bar.

♦ Key in 3599.90 in the Station field.

♦ <D> Add and <D> Close

Lab 28.8 - Create Surfaces to display in cross sections to 
examine design models

1. In the Roadway Designer dialog box:

2. Select Existing_Ground in the Active Surface field and select Corridor> Create  
Surface in the Roadway designer menu bar.

♦ Select the following options and <D> Appy and <D> Close

3. In the Roadway Designer dialog box:

♦  Select File> Save in the Roadway designer menu bar.

Lab 28.9 - Display cross sections and use cross section viewer 
to examine mainline and ramp design models together

1. Make IH 39 the active alignment
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2. Select Evaluation> Cross Section> Create Cross Sections from the InRoads menu 
bar.

3. <D> Preferences and select 40H 20V 320’ Wide

4. Uncheck Gore design surface

♦ Display cross sections in an area to the right of the design data.

5. <D> Apply and <D> in the drawing view to display the cross section set

6. <D> Close  and

7. Select Evaluation> Cross Section> Cross section Viewer from the InRoads menu 
bar.

8. Select 24+00.00 in the Cross Sections area and <D> Run.

9. Examine the ramp and westbound mainline sections as the viewer moves along the taper, 
gore, and infield areas.
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LAB 29 - Forcing Toes Inside of the Right Of 
Way

There are numerous reasons why it may not be possible to aquire additional right of way on a project.  In these 
situations,  the end conditions must adjust to the location of the right of way where it is restrictive and follow 
the proper design criteria where it is not.

In this lab, an end condition section is constructed that determines the proper sideslope based on the criteria 
from the 2005 Roadway Design Guide and the location of the right of way.  This end condition section is then 
attached to a template and used in a corridor to demonstrate its functionality.

Chapter Objectives:

 Modify an existing end condition section to account for the right of way.

 Add the modified section to a “backbone” template.

 Create a corridor that uses the modified template.

 Add point controls so that the template can locate the right if way line.

The following files are used with this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Toes.alg

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES_Templates_Toes-Lab.itl

Lab 29.1 - Modifying the End Condition Section and Adding it to 
a Template

In this exercise, a standard end condition section is copied and modified to account for the right 
of way.  This end condition is then added to a template.

Section Objectives:

♦ Copy the end condition section.

♦ Add NULL points to control the maximum length of sideslopes and locate the right of 
way.

♦ Modify point constraints to place the toes in the proper location.

♦ Add the modified end condition section to a template.

Three NULL points are used to modify the end condition.  Two are used to locate the maximum 
length of the 6 to 1 and 4 to 1.  The third locates the right of way.  The constraints are changed 
on the toe of slope points to extend to the NULL point closest to the centerline.

1. Open MicroStation and InRoads using the C:\Projects\12345\Design\Drawings\ 
Reference_Files\12345DES_Model.dgn file.

2. Load the following files into InRoads:

♦ C:\Projects\12345\Design\InRoads\12345DES_Geometry-Toes.alg
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♦ C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing 
ground.dtm

♦ C:\Projects\12345\Design\InRoads\12345DES_Templates_Toes-Lab.itl

3. Verify that the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ 
InRoads\ Preferences\CDOT_Civil.xin file is loaded.

4. From the InRoads menu bar, select Modeler > Create Template.

5. Expand the template library to show the 3 - Sections - End Conditions > Z-Slope 
End Condition - High Speed End Conditions.

6. <R> on the Z8_6_to_1 and select Copy from the right click menu.

7. Paste the copy into the same folder.

8. Rename the copy Z8_6_to_1-Inside_ROW.

9. <D> <D> on the Z8_6_to_1-Inside_ROW to open it for editing.

10. Open the Dynamic Settings dialog box.
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11. Key in 0.10 for the X and Y Step.

12. Verify that Apply Affixes is toggled off.

13. <R> in the template view and select Add New Component > Null Point from the right 
click menu.

14. In the Dynamic Settings dialog box, key in Max_6_to_1 in the Point Name field.

15. Set the Point Style to Default.

16. Set the precision key in type to xy=.

17. In the precision key in field, key in 24,35 and press the Enter key.  The 24 equals the 
maximum horizontal distance that a 6 to 1 toe can be from the pavement edge.  The 35 
represents the height above the pavement edge.  The height for this point is irrelevant and 
can be set to any value.  35 is used here to place the point out of the way of other data while 
having the fit view  at a reasonable scale.

The Max_6_to_1  point is placed in the correct location, but it is not constrained.  It should 
be constrained to the pavement edge sot that the proper distance is maintained if the pavement 
width is changed.
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18. <R> on the Max_6_to_1 point and select Add Constraint > Full Constraint from the 
right click menu.

19. <D> on the EOP point. This displays the Add Full Constraint dialog box.

The data in the dialog box is correct because the precision key in was used to place the point.

20. <D> OK to accept the constraints and dismiss the dialog box.

21. <R> in the template view and select Add New Component > Null Point from the right 
click menu.

22. In the Dynamic Settings dialog box, key in Max_4_to_1 in the Point Name field.

23. In the precision key in field, key in 62.67,35 and press the Enter key.  

24. <R> on the Max_4_to_1 point and select Add Constraint > Full Constraint from the 
right click menu.

25. <D> on the EOP point. This displays the Add Full Constraint dialog box.

26. <D> OK to accept the constraints and dismiss the dialog box.

Next, a point to follow the right of way is added.

27. <R> in the template view and select Add New Component > Null Point from the right 
click menu.

28. In the Dynamic Settings dialog box, key in ROW_Marker in the Point Name field.
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29. In the precision key in field, key in 100,30 and press the Enter key.  

30. <R> on the ROW_Marker point and select Add Constraint > Full Constraint from 
the right click menu.

31. <D> on the EOP point. This displays the Add Full Constraint dialog box.

32. <D> OK to accept the constraints and dismiss the dialog box.

33. Select File > Save from the Create Template menu bar.

The illustration below shows the template completed to this point.

Next, the constraints on the toe points are changed to use the three Null points just added.

34. <D> <D> on the Toe-of-Fill point.  This displays the Point Properties dialog box.

35. In the Point Properties dialog box, set the Constraint 1 Type to Horizontal Minimum.

36. Set the Parent 1 to Max_6_to_1.

37. Set the Parent 2 to ROW_Marker.

38. Verify that the Value is set to 0.00.
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39. <D> Apply to accept the changes. <D> Close to dismiss the dialog box.

40. Repeat steps 34 through 39 for the Top-of-Cut point.

The Horizontal Minimum constraint uses the left most of the two Parent points as a Horizontal 
constraint.  When the right of way is to the right of the two Max null points, the null point 
distance is used for the sideslope.  When the right of way is to the left of a Max null point, the 
ROW_Marker sets the length of the sideslope.

41. <D> <D> on the Toe-of-Fill1 point.  

42. Set the Constraint 1 Type to Horizontal Minimum.

43. Set the Parent 1 to Max_4_to_1.

44. Set the Parent 2 to ROW_Marker.

45. Verify that the Value is set to 0.00.
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46. <D> Apply to accept the changes. <D> Close to dismiss the dialog box.

47. Repeat steps 41 through 46 for the Top-of-Cut1 point.

48. <D> <D> on the Toe-of-Fill2 point. 

49. Toggle off End Condition is Infinite.

50. Set the Parent 1 for the Horizontal constraint to ROW_Marker.

51. Key in 0.00 for the Value of the Horizontal constraint.
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52. <D> Apply to accept the changes. <D> Close to dismiss the dialog box.

53. Repeat steps 48 through 52 for the Top-of-Cut2 point.

54. Select File > Save from the Create Template menu bar.

This completes the section.  It is now ready to be added to the template backbone.

55. Expand the 1 - Templates folder in the Template Library area.

56. <D> <D> on the HMA_B10-4 Lane template to make it active.

57. In the Dynamic Settings dialog box, toggle on Apply Affixes.

58. <D> on the Z8_6_to_1-Inside_ROW section to display it in the Preview window.

59. <D> an hold on the section’s origin and drag it into the template view.

60. <R> and select Mirror from the right click menu.

61. Drop the section on the HMA_Lift1_EOP-Top point.
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62. <D> <D> on the LT_Toe-of-Fill.  Notice that the Constraint 1 has changed from 
Horizontal Minimum to Horizontal Maximum.  Horizontal Maximum uses the right most 
point of the two parents as a horizontal constraint.

63. Select File > Save from the Create Template menu bar.

64. Close the Create Template dialog box.

This completes the workdone in the template library.  Next, the template is used in a corridor.

Section Summary:
♦ The end condition sections in the standard template library can be easily modified to 

stop at the right of way.

♦ Null points are used to determine the maximum length of the sideslope.

♦ Horizontal Minimum constraints change to Horizontal Maximum constraints when the 
template is reflected (or on the reflected side when mirrored).

Lab 29.2 - Corridor Set up and Run

As designed, the template requires two point controls to follow the right of way lines.  For this exercise, the 
right of way lines have already been chained together and imported as horizontal alignments.

Section Objectives:

♦ Create a corridor and template drop.

♦ Create point controls for the right of way.

♦ Add the right of way alignments as reference displays in the Roadway Designer views.

1. Select Modeler > Roadway Designer from the InRoads menu bar.
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2. From the Roadway Designer menu bar, select File > New.

3. Verify the the directory is C:\\12345\Design\InRoads\.

4. Key in 12345DES_Toes-Lab.ird for the file name.

5. <D> Save to create the Roadway Designer file and dismiss the Save Roadway Design As 
dialog box.

6. Select Corridor > Corridor Management from the Roadway Designer menu bar.

7. Key in SH 86 for the corridor Name.

8. Verify that SH 86 and SH 86 V are set as the Horizontal Alignment and Vertical 
Alignment.

9. <D> Add to create the corridor then <D> Close to dismiss the Manage Corridors dialog 
box.

10. Select Corridor > Template Drops from the Roadway Designer menu bar.

11. Key in 25 for the Interval.

12. In the Library Templates area, expand the C:\Projects\12345\Design\InRoads\ 
12345DES_Templates_Toes-Lab.itl > 1 - Templates folder.

13. Highlight the HMA_Crowned_B10-4 Lane template.
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14. <D> Add then <D> Close to dismiss the Template Drops dialog box.

15. Select Corridor > Point Controls from the Roadway Designer menu bar.

16. In the Point Controls dialog box, set the Point to RT_ROW_Marker.

17. Toggle on Horizontal for the Mode.

18. Verify that the Control Type is set to Alignment.

19. Select RT_ROW for the Horizontal Alignment.

20. <D> Add to create the point control.
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21. Set the Point to LT_ROW_Marker.

22. Select LT_ROW for the Horizontal Alignment.

23. <D> Add to create the point control.  <D> Close to dismiss the Point Controls dialog 
box.

The toes will now remain inside the right of way.  However, it is not apparent.  To show the 
relationship between the toes and the right of way,  The right of way alignments are displayed 
in the Roadway Designer window as references.

24. Select Corridor > Display References from the Roadway Designer menu bar.

25. Verify that Alignment is toggled on.

26. Select RT_ROW for the Alignment.

27. Toggle on Displays as Right of Way.

28. <D> Add.  Notice the line displayed on the right side of the template view.  That line 
represents the offset distance to the right of way from the corridor alignment.

29. Repeat steps 26 through 28 using LT_ROW for the alignment.

30. <D> Close to dismiss the Display References dialog box.
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31. Scroll through the stations.  Notice two things, 1) the toes never go outside the right of way, 
and 2) If the toe can not tie before the right of way, it is omitted.

Note: This end condition will not solve every template drop.  Those template drops that 
do not solve will have to be examined to determine the best solution for those 
areas.  The solutions for those areas are not a part of this lab.

Section Summary:
♦ The ROW_Marker points are attached to the right of way horizontal alignments using  

point controls.

♦ Using Display References hekps to show that the template is working properly.

♦ Design decisions have to be made in areas where the toes can not tie inside the right of 
way.

Chapter Summary: 

 The right of way controls can be easily added to an existing template.

 This example uses a point control, however the same results can be achieved by making the 
ROW markers into end conditions.

 Developing these kinds of templates is an iterative process.  Parts will be developed then 
show areas that need further consideration.
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LAB 30 - End Conditions that Require Multiple 
Solutions

This lab demonstrates the construction of end conditions that require multiple solutions.  The section will place 
a minimum 2-foot depth ditch, with a berm if necessary, when in cut.  The section will also place a 4 to 1 fill 
slope when the embankment height is 10-feet or less and a 3 to 1 fill slope when over 10-feet in height.  This 
section is constructed using the drag and drop method.  Then, the end condition priorities are reset so that the 
section operates properly.

Chapter Objectives:

 Build an end condition section that tests for solutions based on priority

 Build an end condition section using existing components with the drag and drop method

Lab 30.1 -  End Conditions that Require Multiple Solutions

1. Open MicroStation and InRoads uing the 12345DES_Model-End Cond Mult Sol.dgn file.

2. Select File> Open from the InRoads menu bar.

3. Select the C:\Projects\12345\Design\InRoads\
12345DES_Template-End Cond Mult Sol.itl from the available files.

4. <D> Open then <D> Cancel the Open dialog box.

5. Select Modeler> Create Template from the InRoads menu bar.

6. Select Tools> Options from the Create Template menu bar.

7. Make sure that Apply Affixes is toggled off and the X and Y Step Options are set to 
0.10.

8. <D> the OK button.

9. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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10. Expand the 3 - Sections - End Conditions> Z-Slope End Conditions> High Speed End 
Conditions folder.

11. Create a new template in the High Speed End Conditions folder.  Name it 
Z8_6_to_1_Ditch.

12. Expand 4 - Components> End Conditions> Z-Slope Components > 
High Speed End Conditions folder.

13. <D> on the Z-Slope_8_6_to_1 component.  The component is displayed in the Preview 
window.

14. <D> and hold on component’s origin (the green dot).

 

15. Drag the component into the Template View and drop (release the data button) it on the 
new section’s origin.

16. Expand 4 - Components> End Conditions> Cut Slope Components folder.

17. <D> on the Cut_Ditch_with_Berm component.



Colorado Department of Transportation   Page 627

Labs for InRoads XM LAB 30 - End Conditions that Require Multiple Solutions

18. <D> and hold on component’s origin (the green dot).

19. Drag the component into the Template View and move the pointer on to the component 
point named POSS and drop.  The “+” on the component point turns white when the 
pointer is on it.

20. Repeat steps 16, 17 & 18 for the Cut_Ditch component.

21. Expand 4 - Components> End Conditions> Fill Slope Components folder.Repeat steps 
16, 17 & 18 for the Fill__4_to_1 and Fill_3_to_1 components.

22. <D> <D> on the Cut_Ditch_with_Berm component.
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23. Verify that the Priority is set to 1.

24. <D> on the Locate Button next to Name in the Component Properties dialog box.

25. <D> on the Cut_Ditch component in the Template View.

26. Verify that the Priority is set to 2  in the Component Properties dialog box.

27. Set the remaining End Condition Component priorities as follows:

♦ Fill_4/1 = 3
♦ Fill_3/1 = 4

28. Be sure to <D> the Apply button if any Priority values were modified.

29. <D>  the Close button in the Component Properties dialog.

30. <D> the Test Button.
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31. In the Test End Conditions dialog box, <D> Draw and notice how end conditions behave.

32. <D> Close.
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Surface

This lab demonstrates the ability of an end condition to target multiple surfaces, using target aliasing.  In this 
exercise, a template is edited and new corridor is defined to target multiple surfaces. The existing ground 
surface was divided into three separate segments along the length of the project.  There is also a rock layer 
surface 10-feet below the existing ground, for the second and third segments, where there is a deep cut section 
in the profile. The template end conditions target the rock and active surfaces, so target aliasing is required to 
target all the existing ground and rock surfaces as the corridor extends along the three segments of the project.

Chapter Objectives:

 Modify a template end condition to target a rock layer when that surface is present.

 Build a corridor and use target aliasing to target multiple existing ground and rock layer 
surfaces along three segments of the project.

 View the corridor to examine the end condition’s behavior and determine if templates and 
target aliasing are working properly

Lab 31.1 -  Create End Conditions to Search a Surface

1. Open MicroStation and InRoads using the 12345DES_Create End Cond Search Surf.dgn 
file.

In the MicroStation drawing, notice the three perimeters displayed for each existing ground 
surface

2. Select File> Open from the InRoads menu bar.

3. Select the following files from C:\Projects\12345\Design\InRoads\ and <D> Open them.

♦ CDOT_Civil.xin

♦ 12345DES_Geometry-Create End Condit Search Surf.alg

♦ 12345DES_Template-Create End Condit Search Surf.itl

♦ 12345DES_Roadway-Create End Condit Search Surf.ird

♦ Exist_Ground_1-Create End Condit Search Surf.dtm

♦ Exist_Ground_2-Create End Condit Search Surf.dtm

♦ Exist_Ground_3-Create End Condit Search Surf.dtm

♦ Rock_Layer_2-Create End Condit Search Surf.dtm

♦ Rock_Layer_3-Create End Condit Search Surf.dtm

4. <D> Cancel the Open dialog box to close.

Lab 31.2 - Edit template end condition components to target rock 
layer.

1. Select Modeler> Create Template from the InRoads menu bar.

2. <D> <D> on the root folder in the Template Library pane to expand the folder structure.
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3. Expand the 1 - Templates folder.

4. <D> <D> on the 12345_HMA_2Lane_Rock template

5. <D> <D> on the RT_Cut_Rock component.

6. In the Component Properties dialog box, change the Surface to Rock_Layer_2 and 
<D> Apply

Note: This end condition has two components and is only placed when there is a rock 
surface above the ditch bottom. The first component, RT_Cut_Rock, extends to 
intersect the rock layer surface.  The second, RT_Cut_Above_Rock, is a child of 
the first and extends to intersect the active surface (existing ground).  All other end 
condition components in this template target the active surface (existing ground).

7. <D> on the Locate Button next to Name in the Component Properties dialog box

8. On the left side of the template, <D> on the LT_Cut_Rock component.

9. In the Component Properties dialog box, Change the Surface to Rock_Layer_2, then 
<D> Apply and <D> Close.
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Build a corridor that follows the centerline alignment and extends along all three segments 
of the project.

10. Select Modeler> Roadway Designer from the InRoads menu bar.

11. Select Corridor> Corridor Management from the Roadway Designer menu bar or 

<D> the corridor management button .

12. In the Manage Corridors dialog box:

♦ Key in Centerline in the Name field.

♦ Select Centerline Horizontal Alignment.

♦ Select Centerline V Vertical Alignment.

13. <D> Add then <D> Close.

Lab 31.3 - Define template drop for the corridor

1. Select Corridor> Template Drops from the Roadway Designer menu bar or <D> the 

template drops button  .

2. In the Template Drops dialog box:

♦ Select Centerline for the Corridor name.

♦ Key in 50 for the Interval.

♦ Expand 1 - Templates folder in Library Templates area.

♦ <D> on the 12345_HMA_2Lane_Rock template.
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♦ <D> Add.

♦ <D> Close

Lab 31.4 - Define target aliasing

3. Select Tools> Target Aliasing from the Roadway Designer menu bar.

4. In the Target Aliasing dialog box:

♦ Select <Active Surface> for the Target.

♦ Select Surface - Exist_Ground_1, Surface - Exist_Ground_2 and Surface - 
Exist_Ground_3 in the Surface or Corridor area.

♦ <D> Add ->.

♦ Select Rock_Layer_2 for the Target.

♦ Select Surface - Rock_Layer_2 and Surface - Rock_Layer_3 in the Surface or      
Corridor area.
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♦ <D> Add ->.

5. <D> OK

Lab 31.5 - View the corridor to examine the end condition’s 
behavior and determine if templates and target aliasing are 
working properly.

1. In the Roadway Designer dialog box:

♦ Key in 373+00 for the Station.



Page 636 Colorado Department of Transportation

LAB 31 - Create End Conditions to Search a Surface Labs for InRoads XM

♦ Key in 600+00 for the Station.

Note: Notice the end conditions target the multiple existing ground and rock layer surfaces in 
both of the above Roadway Designer dialog’s cross- section viewer. Both of the station 
locations shown are in deep rock cut sections in the profile.

Chapter Summary:

 In this lab an existing template was modified to target a rock layer.

 In this lab a corridor was built to use target aliasing to target multiple existing ground and 
rock layer surfaces along three segments of the project.

 In this lab the corridor was examined at the end condition to determine if templates and 
target aliasing were working properly.
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This intersection lab is based on the Federal Blvd. and 6th Ave. interchange reconstruction project.  The lab 

focuses on the reconstruction of the intersection at Federal Blvd. and 5th Ave.  It describes the tools and 
techniques for modeling an intersection.

Chapter Objectives: 

 Describe the procedures and techniques used to create an at-grade intersection

 Improve proficiency in creating corridors

 Practice creating design surfaces

 Introduce the student to the multi-centered curve tool used to develop geometry for curb 
returns

 Learn how to use point controls in typical sections to model curb returns

 Reinforce techniques for combining surfaces to create a final surface

Project Overview

The scope of work for the Federal Blvd. and 5th Ave. intersection project is a complete reconstruction. Key 
features of the reconstruction are:

 Federal Blvd. (the mainline) is being widened from 4 to 6 lanes

 5th Ave. (the crossing street) is being realigned to accommodate the on ramp to 6th Ave.

  Federal Blvd. uses a concrete pavement design

 5th Ave. uses an asphalt pavement design

 5th Ave. switches to a concrete template prior to the intersection.

  5th Ave has a taper on the south side to facilitate right turns.

Project Data

The following data is provided for this project:

 Federal @ 5thAve.alg - This file contains predefined horizontal and vertical alignments 

for Federal Blvd. and the horizontal alignment 5th Ave. The student will create a vertical 

alignment for 5th Ave. in addition to geometry for each of the curb returns.

 16628_Existing.dtm – This file represents the surveyed surface data of the existing 
intersection.

 Federal_and_5th.itl – This file contains predefined templates for Federal Blvd. and 5th 
Ave.

 16628.xin – This file controls the preferences 

InRoads Design Process

Below is an outline of the InRoads procedures used to create the intersection design model:
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1. Create the initial mainline design surface

2. Create the vertical alignment for crossing street and match the mainline design surface 
through the intersection

3. Create the initial crossing street design surface

4. Add geometry for each curb return

5. Update the mainline design surface to include curb returns

6. Update corridor

7. Create the final intersection Surface

Initial Modeling

Chapter Objectives:

Federal Blvd. is considered the mainline and should be modeled first.  Use this initial Federal Blvd. design 

surface to assist in defining the vertical alignment for 5th Ave., the intersecting street. Using the new vertical 

alignment and the predefined template for 5th Ave., create the initial design surface for the crossing street.  At 
this point there will be two separate design surfaces, one for the mainline and one for the crossing street. 

Create the Initial Federal Blvd. Design Surface

Use the following procedure to create the initial design surface for Federal Blvd.: 

♦ Load project data

♦ Create the Federal Blvd. corridor

♦ Add template drops

♦ Generate the initial mainline design surface

Load Project Data

1. Open the Federal @ 5thAve.alg geometry file.

2. Open the Federal_and_5th.itl template library. 

3. Open the 16628_Existing.dtm surface.

Create the Federal Blvd. Corridor

The Federal Blvd. alignment runs from north of 5th Ave to south of the ramps for eastbound 6th 
Ave.  Because this lab is concerned with the intersection at 5th Ave., the first 300 feet of the 
Federal Blvd. alignment is used.

1. Select Modeler > Roadway Designer from the InRoads menu bar.  This displays the 
Roadway Designer dialog box.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button.  This displays the Manage Corridors dialog box.
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3. In the Manage Corridors dialog box, key in Federal Blvd for the Name.

4. Set the Type to Alignment.

5. Select Federal CL as the Horizontal Alignment.

6. Select Federal CL_V as the Vertical Alignment.

7. Toggle on Station in the Limits area.

8. Key in 0+00.00 for the Start station.

9. Key in 3+00.00 for the Stop station.

10. <D> Add to complete the corridor.

11. <D> Close to dismiss the Manage Corridors dialog box.

Add Federal Blvd. Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  This displays the Template Drops dialog box.



Page 640 Colorado Department of Transportation

Chapter 2 - Intersection Project Labs for InRoads XM

2. In the Template Drops dialog box, Key in 0+00.00 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, expand the 1 – Templates folder.

5. Highlight the Federal Blvd template.

6. <D> Add and <D> Close. 

Create the Initial Federal Blvd. Design Surface

The surface created here will be used in conjunction with the existing ground to lay out the 
vertical alignment for 5th Ave.   Having the Federal Blvd. surface makes it easier to match it’s 
cross slopewith the 5th Ave vertical alignment.

1. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  This displays the Create Surface dialog box.

2. Key in Federal Blvd for the Name.

3. Select Proposed for the Default Preference.

Note: If Proposed is not found in the list, make sure the standard CDOT_Civil.xin file is 
loaded. 
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4. Verify the remaining settings match the illustration below.

5. <D> Apply and <D> Close.

Note: If the Report Lock is On, the Results dialog box will appear with information about 
the creation of the surface.  This can be dismissed.  

Roadway Designer is exited at this point.  Save the ird file so that it can be used in later steps.

6. Select File > Save from the Roadway Designer menu bar.

7. Key in Federal_and_5th.ird for the file name.

8. <D> Save then <D> Cancel in the Save As dialog box.

9. Close the Roadway Designer dialog box.
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Changing the symbology for the cross sections and profiles makes it easier to deferintiate 
between surfaces. 

10. From the InRoads menu bar, select Surface > Surface Properties.  This displays the 
Surface Properties dialog box.

11. In the Surface Properties dialog box on the Main tab, select the Federal Blvd surface.

12. Select the Advanced tab.

13. Select D_Finished-Grade for Cross Sections Symbology.
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14. Select D_Finished-Grade for Profile Symbology.

15. <D> Apply.

16. <D> Close.

This completes the initial design of Federal Blvd.

Create the 5th Ave Vertical Alignment

The vertical alignment for 5th Ave. is created at this point.  Using the initial Federal Blvd 
surface and the existing ground surface, the vertical alignment for 5th Ave. can be tied into 
Federal Blvd. properly.

♦ Create the crossing street profile

♦ Define the crossing street vertical alignment

Create a Profile for 5th Ave.

In order to define a vertical alignment, a profile window is required.  The existing surface along 
with the initial federal Blvd. surfaceare displayed in this profile.

1. In MicroStation, move to an area to the right of the alignments.

2. Verify the 5th_Ave horizontal alignment is active.

3. On the InRoads main menu, select Evaluation > Profile > Create Profile.  This 
displays the Create Profile dialog box.
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4. On the General leaf, enter 5th_Ave for the Set Name.

The 5x Vertical preference is used here so that the slopes are easier to see.

5. <D> Preferences and highlight the preference 5x Vertical from the list.

Note: Because there are so many settings that control the look and feel of a profile, 
several CDOT preferences have been created that can be used to save the end user 
a significant amount of time setting up and creating a profile. Be sure to use a 
standard preference as much as possible.

6. Toggle on Right to Left in the Direction area.

Important! Stationing of alignments normally increase from left to right.  In this case, 

the 5th Ave. alignment increases in stationing from Right to Left so the 
direction of the profile needs to be changed to fit this circumstance.

7. <D> Load to load the preference and then <D> Close.
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8. Toggle on Right to Left in the Direction area.

Important! Stationing of alignments normally increase from left to right.  In this case, 

the 5th Ave. alignment increases in stationing from Right to Left so the 
direction of the profile needs to be changed to fit this circumstance. The 
direction should be set after loading a preference; otherwise it will be 
overwritten by the setting in the preference.

9. Toggle on the 16628_Existing and Federal Blvd surfaces.

10. <D> on the Controls leaf.

11. Toggle on Use in the Station area.

Because this lab is concerned with just the intersection,  the vertical alignment (and the profile) 
is constructed to cover just the area of the intersection.

12. Key in 6+00.00 for the Start station.

13. Key in 9+98.50 for the Stop station.

14. Toggle on Apply in the Window Clearance area.
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15. Key in 25 for both the Top: and Bottom.

16. <D> Apply.

17. <D> in the MicroStation view window to identify the profile’s location.  Because the 
Direction was set to Right to Left, the profile will be place to the right of the data point.

18. The profile should look similar to the following:

19. <D> Close on the Create Profile dialog box to dismiss it.

Define the 5th Ave Vertical Alignment

1. Select the Geometry bottom tab from the InRoads Explorer.
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2. Expand the Federal@5thAve geometry project to show the 5th_Ave horizontal alignment.

3. <R> on the 5th_Ave horizontal alignment and select New from the menu.

4. In the New dialog Box, set the Type to Vertical Alignment.

5. In the Name field, key in 5th_Ave-V.

6. In the Description field, key in 5th Ave Vertical Alignment.

7. Set the Style to ALG_PRO_Vert. (This stands for Alignment Proposed)

8. The dialog box should look like the following:
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9. <D> Apply and <D> Close.

10. Select Geometry > Vertical Curve Set > Add PI from the InRoads main menu.

11. In the Add Vertical PI dialog box, <D> Apply.

12. In the MicroStation Key in window, key in se=6+00.00, 5249.77 and press Enter.

13. Key in se=7+87.03, 5258.98 and press Enter.

14. Key in se=9+57.06, 5262.00 and press Enter.

Note: This is the station where the alignment of 5th Ave. ties into the cross slope of 
Federal Blvd.  Make sure that this is a smooth transition by comparing the cross 
slope of Federal Blvd. to the slope of this tangent.

15. Key in se=9+98.49, 5262.82 and press Enter.

16. <R> to stop placing PI’s.

17. In the Add Vertical PI dialog box, <D> Close to dismiss the dialog box.

18. Select Geometry > Vertical Curve Set > Define Curve from the InRoads main 
menu.

19. In the Define Vertical Curve Set dialog box, verify that the Station is 7+87.03.

20. Verify that the Elevation is 5258.98.
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21. In the Vertical Curve area, key in 200.00  in the Length field.

22. <D> Apply and <D> Close.

Create the Initial 5th Ave. Design Surface

♦ Define the corridor for the crossing street

♦ Add template drops

♦ Add point controls

♦ Create the initial crossing street design surface

Build the 5th Ave. Corridor

1. Select Modeler > Roadway Designer from the InRoads menu bar.  This displays the 
Roadway Designer dialog box.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button.  This displays the Manage Corridors dialog box.

3. In the Manage Corridors dialog box, key in 5th Ave for the Name.

4. Set the Type to Alignment.

5. Select 5th_Ave as the Horizontal Alignment.

6. Select 5th_Ave -V as the Vertical Alignment.
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7. Toggle off Station in the Limits area.

8. <D> Add to complete the corridor.

9. <D> Close to dismiss the Manage Corridors dialog box.

Add 5th Ave. Template Drops

The pavement for 5th Ave. needs to change from an asphalt pavement to a concrete pavement as 
it approaches Federal Blvd.  This takes place at Sta. 8+30.00.  Therefore, the asphalt tmplate is 

used from the beginning of the 5th Ave corridor to station 8+29.99.  The concrete template is 
used from station 8+30.00 to the end of the project.  Switching templates in 1/100 of a foot 
gives a clean change between templates.

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  This displays the Template Drops dialog box.

2. Verify the Corridor is set to 5th Ave

3. In the Template Drops dialog box, Key in 6+00.00 for the Station.

4. Key in 25 for the Interval.

5. In the Library Templates area, expand the 1 – Templates folder.
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6. Highlight the 5th_Ave_Asphalt template.

7. <D> Add.

8. Key in 8+29.99 for the Station.

9. Highlight the 5th_Ave_Asphalt template.

10. <D> Add.

11. Key in 8+30.00 for the Station.

12. Highlight the 5th_Ave_Concrete template.

13. <D> Add.
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14. The template drops should appear in the dialog box as follows:

15. <D> Close. 

Add 5th Ave. Point Controls

The templates are defined to be used “as is” at the beginning of the alignment and are to widen 
out as Federal Blvd. is approached.  The point controls used here reflect the area of widening 
where 5th Ave. approaches Federal Blvd.  

Because the asphalt template and the concrete template use different point names, point 
controls have to be defined for each template.  This first set of point controls define the 
widening on the right side of 5th Ave.  This widening is constant throught the corridor.

1. In the Roadway Designer dialog box, select Corridor > Point Controls or <D> the  
button.  This displays the Point Controls dialog box.

2. In the Point Controls dialog box, set the Point to RT_HMA_Lift1_Laneline-Top using the 

drop down menu or the  Button.

3. Toggle on Horizontal in the Mode area.

4. Set the Control Type to Alignment.

5. Set the Horizontal Alignment to 5th_Ave.
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Note: The settings made in steps 3 through 5 are used for setting up all of the point 
controls that follow.

6. In the Station Limits area, key in 6+00.00 for the Start station.

7. Key in 8+29.99 for the Stop station.

8. In the Horizontal Offsets area, key in 23.89 for the Start and Stop offsets.

9. <D> Add.

10. Advance the Station to 8+30.00 in the Roadway Designer plan view window.

11. Set the Point to RT_Conc_Laneline-Top using the drop down menu or the  button.

12. In the Station Limits area, key in 8+30.00 for the Start station.

13. Key in 9+98.50 for the Stop station.

14. In the Horizontal Offsets area, key in 23.89 for the Start and Stop offsets.

15. <D> Add.

This set of point controls define the widening on the left side of 5th Ave.  It is constant from the 
beginning of the corridor to station 8+30.00 (where the templates change).  From here it 
transitions out to provide the additional width for right turns.  The additional width is 
maintained to the end of the corridor.

16. Set the Point to LT_HMA_Lift1_Laneline-Top.  

17. In the Station Limits area, key in 6+00.00 for the Start station.

18. Key in 8+29.99 for the Stop station.

19. In the Horizontal Offsets area, key in -12.45 for the Start and Stop offsets.
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20. <D> Add.

21. Set the Point to LT_Conc_Laneline-Top.  

22. In the Station Limits area, key in 8+30.00 for the Start station.

23. Key in 9+00.48 for the Stop station.

24. In the Horizontal Offsets area, key in -12.45 for the Start offset.

25. Key in -15.87 for the Stop offset.

26. <D> Add.

27. In the Station Limits area, key in 9+00.48 for the Start station.

28. Key in 9+98.50 for the Stop station.

29. In the Horizontal Offsets area, key in -15.87 for the Start and Stop offsets.

30. <D> Add.

31. At this point there should be (5) point controls setup, (3) for the left side of 5th Ave. and (2) 
for the right side, as shown in the following image.

32. <D> Close.

 Create the Initial 5th Ave. Design Surface

This surface, along with the initinal Federal Blvd. surface, we be used to determine the vertical 
alignments for the curb returns.
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1. On the InRoads Surfaces tab, verify that 16628_Existing is the active surface.

2. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  This displays the Create Surface dialog box.

3. Key in 5th Ave for the Name.

4. Select Proposed for the Default Preference.

5. Highlight only 5th Ave in the Create Surface(s) From list.

6. The remaining settings should be correct.  If not, set them to match the illustration below.

7. <D> Apply.

8. <D> Close.
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9. Select File > Save from the Roadway Designer menu bar.

10. Close the Roadway Designer dialog box.

11. From the InRoads menu bar, select Surface > Surface Properties.  This displays the 
Surface Properties dialog box.

12. In the Surface Properties dialog box on the Main tab, select the 5th Ave surface.

13. Select the Advanced tab.

14. Select D_Finished-Grade for Cross Sections Symbology.

15. Select D_Finished-Grade for Profile Symbology.

16. <D> Apply and <D> Close.

Chapter Summary:At this point there are two initial design surfaces created; a mainline and the crossing 
street.  In order for these surfaces to match up through the intersection additional, geometry will 
need to be created.  

Additional Geometry

Chapter Objectives:

 Create horizontal and vertical geometry for curb retuns.

In this section the two initial design surfaces are used to create a smooth vertical alignment 
transitions around the corners of the intersection.  Horizontal and vertical geometry for each 
curb return is defined the InRoads Create Multicenter Curves tool, offset distances from the 
two corridor alignments, and the initial design surfaces.  The new geometry will be used to 
create the final design surface

Curb Returns

Because this example is a T-intersection there are only two curb returns to model.  In a typical 
intersection there are four returns to model.  The steps shown below can also be used to 
develop curb returns for an intersection with more than one crossing street.

Create Northeast Curb Return

1. From the InRoads menu bar, select Geometry > Utilities > Multicenter Curve….  
This displays the Multicenter Curve dialog box.

2. On the Main tab of the Multicenter Curve dialog box, set the Curve Type to One Center.

3. In the Radii area, key in 75 for Radius 1.

4. In the Widths area, key in 23.89 for Width 1.  This is the width of 5th Ave. from its 
centerline to the right edge of pavement.
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5. Key in 41 for Width 2.  This is the width of Federal Blvd. from its centerline to the right 
edge of pavement.

Important! Use the graphic in the Example area to determine how to enter your curb 
data.  This graphic changes according to the Curve Type:.  As an example, 
when prompted by the software to choose the first alignment, choose the 
alignment that is associated with Width 1.

6. <D> the Advanced tab.

The steps below define the properties of the horizontal alignment representing the northeast 
curb return.

7. In the Name field of the Alignment area, key in 5th_Ave_NE-Quadrant.

8. In the Description field, key in NE Return for Federal & 5th.

9. Set the Style to ALG_OTHER.

The following steps define the vertical alignment for the curb return.  Because the 5th Ave. 
width was entered in Width 1 previously, 5th Ave. data must be used in the First Selected 
Alignment fields here.  The Federal Blvd. data is used in the Second Selected Alignment fields.
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10. Toggle on Create Vertical Alignment.

11. In the First Selected Alignment area, toggle on Surface.

12. Select 5th Ave for the surface.

13. In the Second Selected Alignment area, toggle on Surface.

14. Select Federal Blvd for the surface.

The dialog box should now look like the image below.

15. <D> Apply.

Important! Now you must select the alignments in the same order that they were  
defined in the dialog box.

The following message is displayed in the lower left corner of the MicroStation window:
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16. <D> on the 5th_Ave alignment in the MicroStation view window.  The following 
message is displayed:

17. <D> on the Federal CL alignment.  The following message is displayed:

18. <D> above the 5th_Ave alignment and to the right of the Federal CL alignment. The 
curb return alignment is displayed.

19. <D> one more time to Accept the creation of the new alignment.

 

Create Southeast Curb Return

Again, the 5th Ave. data is used first to create the southeast curb return.

1. From the InRoads menu bar, select Geometry > Utilities > Multicenter Curve….  

2. In the Radii area, key in 60 for Radius 1.

3. In the Widths area, key in 15.87 for Width 1.



Page 660 Colorado Department of Transportation

Chapter 2 - Intersection Project Labs for InRoads XM

4. Key in 41 for Width 2.

5. <D> the Advanced tab.

6. In the Name field of the Alignment area, key in 5th_Ave_SE-Quadrant.

7. In the Description field, key in SE Return for Federal & 5th.  The remaining data is 
the same as used on the northeast quadrant.

8. <D> Apply.  

9. Follow the prompts, identifying 5th_Ave first then Federal CL.  Identify the 
quadrant below the 5th_Ave alignment and to the right of the Federal CL alignment. 
The curb return alignment is displayed.
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10. Verify that the new alignments show up in the Geometry tab of InRoads as shown below.

Chapter Summary:The Multicenter Curve tool created smooth horizontal and vertical alignments from 
the surface of the cross street to the surface of the mainline. You may need to modify these 
alignments depending on the actual design needed for the flowline. 

Final Design Modeling

Chapter Objectives:

 Revise the point controls and template drops for 5th Ave using new curb return alignments.

 Use Target Aliasing to match the surface of Federal Blvd to the surface fo 5th Ave.

 Update the 5th Ave surface

 Update Federal Blvd. template drops and add point controls

 Create a complete final combined surface

Create the Finial 5th Ave. Corridor Surface

The 5th Ave. design surface is created first so that a feature in that surface can be used to control 

the edge of Federal Blvd. through the intersection. The 5th Ave. corridor is used to clip the 
Federal Blvd. corridor, removing the curb and gutter through the intersection that would 
normally be placed by the Federal Blvd. template.
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Edit 5th Ave. Corridor Definition

The 5th Ave corridor is going to clip out portions of the Federal Blvd. corridor when the final 
surface is created.  If the 5th Ave. corridor clips any of the driving lane components in the 
Federal Blvd. template, those components will be lost for calculating volumes.  In order to 
prevent this from occuring, The corridor for 5th Ave. is stopped before it reaches the edge of 
the Federal Blvd. template.

1. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button.  This displays the Manage Corridors dialog box.

2. Highlight 5th Ave in the Corridors list.

3. Toggle on Station in the Limits area.

4. Key in 9+40.00 for the Stop station.  This station was selected because it od about 
halfway through the curb returns and befor the edge of Federal Blvd.

5. <D> Change.

6. <D> Close.

Edit 5th Ave. Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  This displays the Template Drops dialog box.

2. Verify the Corridor is set to 5th Ave.

3. In the Template Drops dialog box, Key in 8+80.00 for the Station.

4. Key in 1 for the Interval
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Note: An interval of 1 is used here in order to sufficiently model the surface around the 
curb retuns.

5. In the Library Templates area, expand the 1 – Templates folder.

6. Highlight the 5th_Ave_Concrete template.

7. <D> Add.

8. <D> Close.

5th Ave. Point Controls for Curb Returns

Additional point controls are added to the 5th Ave. corridor to use the curb return alignments.  
The existing point controls for the concrete pavement must also be modified so that they do not 
overlap the curb returns.

1. Select Modeler > Roadway Designer from the InRoads menu bar.

2. In the Roadway Designer dialog box, select Corridor > Point Controls or <D> the  
button.

3. Set the Point to RT_Conc_Laneline-Top using the drop down menu or the  button.  

4. Toggle on Both in the Mode area.



Page 664 Colorado Department of Transportation

Chapter 2 - Intersection Project Labs for InRoads XM

5. Set the Control Type to Alignment.

6. Set the Horizontal Alignment to 5th_Ave_NE-Quadrant.

Note: Selecting the 5th_Ave_NE-Quadrant alignment automatically sets the Station 
Limits to cover that alignment.

7. Toggle on Use as Secondary Alignment.

8. <D> Add.

Important! The entry is displayed in orange, indicating that there is a conflict with 
another point control.  The point control entered during the initial 
modeling is now too long, so its end station must be adjusted.

9. Highlight the RT_Conc_Laneline-Top control that runs from 8+30.00 to 9+98.50.

10. In the Station Limits area, key in 8+79.06 for the Stop station.  This stops the point 
control where the curb return control starts.
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11. <D> Change.

12. Set the Point to LT_Conc_Laneline-Top using the drop down menu or the  button.

13. Toggle on Both in the Mode area.

14. Set the Control Type to Alignment.

15. Set the Horizontal Alignment to 5th_Ave_SE-Quadrant.

16. Toggle on Use as Secondary Alignment.  This is so that the curb component is placed 
perpendicular to the curb return alignment.

17. In the Horizontal Offsets area, key in 0 for the Start and Stop offsets.
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18. <D> Add.

19. Highlight the LT_Conc_Laneline-Top control that runs from 9+00.48 to 9+98.50.  This 
entry is completely covered by the curb return, so it is deleted.
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20. <D> Delete.
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The illustration below shows the list of point controls used on the Final 5th Ave. corridor.

21. Close the Point Control dialog box.

22. Select File > Save from the Roadway Designer menu bar.

Create the Final 5th Ave. Design Surface

The 5th Ave. surface is remodeled to incorperate the corridor changes made above and to 
generate the feature that will control the edge of pavement for Federal Blvd.  

The target aliasing is set up so that the 5th Ave corridor will clip the Federal Blvd. corridor 
when the final surface is created.

1. In the Roadway Designer dialog box, select Tools > Target Aliasing.
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2. In the Target Aliasing dialog box, highlight both the Corridor – Federal Blvd and 
Surface – 16628_Existing from the Surface or Corridor list.

3. <D> Add.

4. <D> OK to dismiss the Target Aliasing dialog box.

5. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  This displays the Create Surface dialog box.

6. Key in 5th Ave for the Name.

7. Select Proposed for the Default Preference.

8. Highlight only 5th Ave in the Create Surface(s) From list.

Transverse features run perpendicular to the corridor alignment and are placed at each template 
drop.  The last transverse feature created on the 5th Ave. corridor will be used to  control the 
edge of Federal Blvd. through the intersection.

9. Toggle on Add Transverse Features.  

10. Set the transverse feature Style to DTM_Transverse.
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11. Toggle on Display Features in Plan View. (These features will be used to identify 
important stationing for Federal Blvd. template drops.

12. <D> Apply and <D> Close. 

13. If necessary, click Fit View to see the new graphics.

Final Federal Blvd. Corridor Surface

Additional template drops and point controls are required on Federal Blvd. as well.  The 
template drops change the interval to model smoothly around the curb returns.  The point 
controls are used to model the remainig parts of the curb returns and the intersection driving 
surface.

♦ Add template drops to tie into 5th Ave corridor
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♦ Add point controls

Collect Station Information for Template Drops

The locations for the template drops and point controls are determined using tracking.

1. In the InRoads main dialog box, set the InRoads Explorer to Geometry.

2. Set the Federal CL as the active alignment.

3. <R> on the Federal@5thAve geometry project and select View All Horizontals from 
the menu.

4. In the MicroStation view window, zoom in around the intersection.

5. Select Tools > Tracking > Tracking from the InRoads menu bar.  

6. <D> the Activate button.

7. <T> to each of the points indicated in the illustration below and write down the Station for 
each.
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These stations are (from bottom to top):

♦ 0+57.22

♦ 1+00.73

♦ 1+86.15

♦ 2+30.80

Template drops are required at the first an last stations.  The first station starts the one foot 
intervals arond the SE curb return.  The last station is at the end of the intersection and goes 
back to a 25 foot interval.

8. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  This displays the Template Drops dialog box.

9. Verify the Corridor is set to Federal Blvd.

10. In the Template Drops dialog box, key in 0+57.22 for the Station.

11. Key in 1 for the Interval.

12. Highlight Federal Blvd in the Library Templates list.

13. <D> Add.

14. Key in 2+30.80 for the Station.

15. Key in 25 for the Interval.
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16. <D> Add.  The list of template drops is illustrated below.

17. <D> Close.

Federal Blvd. Point Controls for Curb Returns

All four of the stations located above are used for point controls.  The first and second stations  
create a control for the SE curb return.  The second and third stations create a point control that 
follows the last transverse feature in the 5th Ave. surface.  The third and fourth stations create a 
control for the NE curb return. 

1. In the Roadway Designer dialog box, select Corridor > Point Controls or <D> the  
button.

2. Set the Point to RT_Conc_Laneline-Top6 using the drop down menu or the  button.  

3. Toggle on Both in the Mode area.

4. Set the Control Type to Alignment.

5. Set the Horizontal Alignment to 5th_Ave_SE-Quadrant.

6. Toggle on Use as Secondary Alignment.
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7. In the Station Limits area, the Start station is set by the specified alignment.  
Key in 1+00.73 for the Stop station

8. <D> Add.

9. Set the Control Type to Feature.

10. Select 5th Ave for the Surface.



Colorado Department of Transportation   Page 675

Labs for InRoads XM Chapter 2 - Intersection Project

11. Select 5th Ave-9+40.00 for the Feature.

12. In the Station Limits area, key in 1+00.73 for the Start station.

13. Key in 1+86.15 for the Stop station.
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14. <D> Add.

15. Set the Control Type to Alignment.

16. Set the Horizontal Alignment to 5th_Ave_NE-Quadrant.
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17. In the Station Limits area, key in 1+86.15 for the Start station.  The Stop station is set by 
the selected alignment.

18. <D> Add. and <D> Close.

Create the Final Intersection Design Surface

After creating the point controls for Federal Blvd. (using features from the 5th Ave. design 
surface), both corridors are used to create the design surface of the entire intersection.

1. Verify that 16628_Existing is the active surface.

Note: If the Existing surface is not the active surface several template drop errors will be 
listed in the Results dialog box indicating problems with the final surface.

2. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  This displays the Create Surface dialog box.

3. Key in Federal and 5th Intersection for the Name.

4. Select Proposed for the Default Preference.

5. Highlight both 5th Ave and Federal Blvd in the Create Surface(s) From: list.

6. <D> the Clipping Options button.

7. Verify that the Clipping Option is set to Clip All.
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8. <D> OK on the Clipping Options dialog box.

9. Toggle on Add Transverse Features.

10. Set the transverse feature Style to DTM_Transverse.
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11. Toggle on Display Features in Plan View.  This displays the surface features in the dgn 
file for review.

12. <D> Apply and <D> Close.

13. Select File > Save from the Roadway Designer menu bar.

14. <D> Close to dismiss the Roadway Designer dialog box.
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15. Examine the features displayed in the MicroStation view window.  The illustrations below 
show the finished intersection.

16. Use the rotate view command to see the features in 3D
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As part of the Federal Blvd. and 6th Ave. interchange reconstruction project, access from Federal Blvd. to 6th 

Ave. and Bryant Street is being added.  The ramp from Federal Blvd. to 6th Ave (called the SE Ramp) splits to 
provide access to Bryant Street. This lab illustrates the InRoads design process for creating this interchange.  
This lab is concerned with the mergers of the SE Ramp with the 6th Ave. edge of pavement and  and the 
mergers of the Bryant Street ramp with the SE Ramp.  Therefore, the intersections of the ramps at Bryant Street 
and Federal Blvd. will not be modeled.

Chapter Objectives:

 Give a project overview

 Create a corridor for the SE Ramp.

 Define Point Controls to tie to the existing 6th Ave. edge of pavement.

 Create a corridor for Bryant Ramp.

 Create initial design surfaces for SE Ramp and Bryant Ramp.

 Determine key stations for ramp mergers.

 Define Point Controls for street returns in both corridors

 Modify Bryant Ramp template for the area in the intersection.

 Create a combined surface of SE Ramp and Bryant Ramp.

Project Overview

Project Description

This project creates accesses to 6th Ave. and Bryant Street from Federal Bivd.  The Ramp from 
Federal Blvd. merges into the existing edge of pavement of 6th Ave.  The ramp from Bryant 
Street merges into the SE Ramp (from Federal to 6th).

Project Data

 Existing_Ground.dtm – This contains the survey data for the existing terrain.

 Interchange.alg – This contains all of the horizontal and vertical alignments used for 
this project.

 Interchange.itl – The initial templates are stored in this file.

InRoads Design Process

1. Open Data files.

2. Initial Modeling for SE Ramp and Bryant Ramp.

3. Determine Key Stations for ramp mergers.

4. Modify templates for merger areas.
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5. Make changes to corridor data.

6. Create the combined design surface.

7. Review the results  

Getting Started

1. Open the Interchange.alg.  

2. Open the Interchange.itl template library. 

3. Open the Existing Ground.dtm.

Initial Modeling

There are two areas of special importance on this project, where the SE Ramps merges with the existing 6th 
Ave. edge of pavement and where the Bryant Ramp merges with the SE Ramp.  In these areas, the templates 
change to accommodate the narrowing pavement width.  To determine the stations where template changes 
occur, initial design surfaces are created for the SE Ramp and the Bryant Ramp.

Initial SE Ramp Corridor Model

The initial run of the SE Ramp is primarily concerned with locating stations for template 
changes.  Do not be concerned that the template crosses into the 6th Ave. driving lanes, as this 
will be corrected in the final modeling.

Section Objectives:

♦ Create a corridor for the SE Ramp alignment

♦ Add template drops to the corridor

♦ Create the initial SE Ramp surface

Build the SE Ramp Corridor

1. Select Modeler > Roadway Designer from the InRoads menu bar.  This displays the 
Roadway Designer dialog box.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button.  This displays the Manage Corridors dialog box.

3. In the Manage Corridors dialog box, key in SE Ramp for the Name.

4. Set the Type to Alignment.

5. Select SE Ramp as the Horizontal Alignment.

6. Select SE Ramp_V as the Vertical Alignment.

7. <D> Add to complete the corridor.
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8. <D> Close to dismiss the Manage Corridors dialog box.

Add the SE Ramp Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  This displays the Template Drops dialog box.

2. In the Template Drops dialog box, Key in 0+00.00 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, expand the 1 – Templates folder.

5. Highlight the SE Ramp template.

6. <D> Add.
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7. <D> Close. 

Create the Initial SE Ramp Design Surface

1. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  This displays the Create Surface dialog box.

2. Key in SE Ramp for the Name.

3. Select Proposed for the Default Preference.

4. The remaining settings should be correct.  If not, set them to match the illustration below.

5. <D> Apply.
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6. <D> Close.

Initial Bryant Ramp Corridor Model

As with the SE Ramp, do not worry about the Bryant Ramp crossing into the SE Ramp.  In fact, 
this has to occur in order to determine the stations required for new template drops.

Section Objectives:

♦ Create a corridor for the Bryant Ramp alignment

♦ Add template drops to the corridor

♦ Create the initial Bryant Ramp surface

Build the Bryant Ramp Corridor

1. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button.  

2. In the Manage Corridors dialog box, key in Bryant Ramp for the Name.
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3. Set the Type to Alignment.

4. Select Bryant Ramp as the Horizontal Alignment.

5. Select Bryant Ramp_V as the Vertical Alignment.

6. <D> Add to complete the corridor.

7. <D> Close to dismiss the Manage Corridors dialog box.

Add the Bryant Ramp Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button.  

2. In the Template Drops dialog box, Key in 0+00.00 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, expand the 1 – Templates folder.

5. Highlight the Bryant Ramp template.

6. <D> Add.

7. <D> Close.

Create the Initial Bryant Ramp Design Surface

1. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button.  

2. Key in Bryant Ramp for the Name.

3. In the Create Surface(s) from area, highlight Bryant Ramp only.

4. The remaining settings should be correct.  If not, set them to match the illustration below.

5. <D> Apply.
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6. <D> Close.

7. <D> File > Save from the Roadway Designer menu bar.

8. In the Save As dialog box, navigate to the ??? folder.

9. Key in SE Ramp and Bryant Ramp for the File Name.

10. <D> Save.

11. <D> Cancel to dismiss the Save As dialog box.

12. <D> Close to dismiss the Roadway Designer dialog box.
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Determine Key Stations for Ramp Mergers

It was determined that the gore between the merger of SE Ramp and 6th Ave would end at the intersection of 

the RT_POSS and the existing edge of pavement of 6th Ave.  the gore between the merger of SE Ramp and 
Bryant St ends at the intersection of SE Ramp’s LT_POSS and Bryant Ramp’s RT_POSS.  The stations of these 
intersections, along with the intersection of the SE Ramp’s LT_POSS and Bryant Ramp’s LT_POSS, must be 
determined for the additional template drops needed in the final surface.

Display Design Data

The relevant horizontal alignments are displayed in the dgn file give a reference location when 
determining the key stations.

Section Objectives:

♦ Display the horizontal alignments

Display Horizontal Alignment Data

1. <D> the Geometry tab in the InRoads Explorer.

2. <R> on the Interchange geometry project.

3. Select View All Horizontals from the menu.
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The illustration below identifies each of the alignments displayed

Key Station Locations

To determine the key stations, the POSS and EOP features of both initial design surfaces are 
displayed.  Then tracking is used on both the SE Ramp alignment and the Bryant Ramp 
alignment.  The stations are needed on each alignment so that template drops can be entered 
correctly.

Section Objectives:

♦ Display the required surface features from the initial design surfaces

♦ Use Tracking to identify the key stations

Locate Key Stations for SE Ramp at 6th Ave.

Each point on a template creates a feature in the design surface which can make it difficult to 
find the desired features for display.  To reduce the number of features that have to be combed 
through, feature filters are used.  There is a predefined filter that excludes untriangulated 
features.  This is used reduce the number of features in the dialog box to a managible number.

1. On the InRoads Locks toolbar, set the Feature Filter to XS_Excluded from 
Triangulation.

2. Toggle on the Feature Filter Lock.
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3. On the InRoads menu bar, select Surface > Update 3d/Plan Surface Display.

4. In the Update 3d/Plan Surface Display highlight the SE Ramp surface.

5. Toggle on the Features check box.

6. In the Features list, select the features with EOP or POSS in the name.

7. <D> Apply.

8. <D> Close.

After the features are displayed, tracking is used to determine the key stations for the SE Ramp 
along the 6th Ave. edge of pavement.

9. Using the MicroStation view controls, zoom in on the left end of the 6th Ave alignment.

10. Set the SE Ramp alignment active.

11. From the InRoads menu bar, select Tools > Tracking > Tracking.

12. <T> where the feature RT_Conc_EOP-Top crosses the US6_EOP1 alignment and note 
the station.

Note: Use the Intersection snap  to locate the station
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13. <T> where the feature RT_POSS crosses the US6_EOP1 alignment and note the station.

♦ RT_Conc_EOP‐Top and US6_EOP1 – 7+37.39
♦ RT_POSS and US6_EOP1 – 8+23.46

14. <D> Close on the Tracking dialog box.

Locate Key Stations for Bryant Ramp at SE Ramp

The same procedure is used for locating the key stations at the merger of the SE Ramp and the 
Bryant Ramp.

1. On the InRoads menu bar, select Surface > Update 3d/Plan Surface Display.

2. In the Update 3d/Plan Surface Display highlight the Bryant Ramp surface.

3. Toggle on the Features check box.

4. In the Features list, select the features with EOP or POSS in the name.

5. <D> Apply and <D> Close.

6. Using the MicroStation view controls, zoom in to the area where SE Ramp and Bryant 
Ramp intersect.

7. Set the Bryant Ramp alignment active.

8. From the InRoads menu bar, select Tools > Tracking > Tracking.
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9. <T> where the feature RT_POSS from the Bryant Ramp crosses the LT_POSS from the 
Bryant Ramp and note the station.

♦ Intersection of RT_POSS and LT_POSS – 5+07.51

10. <T> where the feature LT_POSS from the Bryant Ramp crosses the LT_POSS from the 
Bryant Ramp and note the station.

♦ Intersection of LT_POSS and LT_POSS – 8+39.60

11. Set the SE Ramp alignment active and determine the stations for the 
locations in 9 and 10 above for this alignment also.

♦ Intersection of RT_POSS and LT_POSS – 3+92.92
♦ Intersection of LT_POSS and LT_POSS – 7+27.40

12. <D> Close on the Tracking dialog box.

Template Modifications

As designed, the SE Ramp and Bryant Ramp templates have curb and end conditions on both sides.  Templates 
must be created for the merger areas that do not have the restrictive components.

SE Ramp Template at 6th Ave.

♦ Copy the SE Ramp template

♦ Modify the copy for the 6th Ave merger area

Copy the SE Ramp Template

The basic SE Ramp template is used once all of the merger areas are cleared.  A copy of this 
template is made so that one can be modified and the other left intact.

1. On the InRoads menu bar, select Modeler > Create Template.
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2. In the Create Template dialog box, expand the template library to show the contents of the 
1‐ Templates folder.

3. <R> on the SE Ramp template and select Copy from the menu.

4. <R> on the 1 – Template folder and select Paste.

5. <R> on the SE Ramp1 template and select Rename.  Key in SE Ramp at 6th Ave for 
the name.

Modify the SE Ramp at 6th Template

This template needs to be modified on the right (6th Ave.) side only.   

1. <D> <D> SE Ramp at 6th template to make it active.
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2. Zoom in on the right side of the template.

3. <R> in the Template view and select Delete Components from the menu.

4. Drag a line through the RT_C/G_Type2-IIB and the RT_Benching components.

Note: The end conditions are also deleted because of the parent/child relationship they 
have with RT_Benching.

5. <R> on the RT_ABC_EOP-Top and select Delete Point from the menu.

6. Delete the RT_SubBase_EOP-Top point also.  The illustration below shows the template 
completed to this point.

Add an End condition to the SE Ramp at 6th Ave template

This end condition is used to create the gore after the SE Ramp edge of pavement seperates 
from the 6th Ave. pavement edge.

1. Select Tools > Dynamic Settings from the Create Template menu bar or <D> 
the Dynamic Settings  button.

2. Select Tools > Options from the Create Template menu bar.

3. Toggle on Apply Affixes.
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4. Set the X and Y Step Options to 0.1.

5. <D> OK.

6. <R> in the Template view and select Add New Component > End Condition.

7. In the Component Properties area, key in Tie_6th_EOP for the Name.

8. Set the Target Type to Alignment XYZ.

9. Select US6_EOP1 for the Horizontal Alignment.  This automatically sets the vertical 
alignment.

10. Set the Style to D_Toe-of-Fill.

11. <D> on the RT_Conc_EOP-Top point to place the first point.

12. In the Dynamic Settings dialog box, toggle on End Condition Is Infinite.

13. Select Toe-of-Fill for the Point Name.  This automatically sets the Point Style.

14. Select hs= for the key in type.
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15. Key in 2,0.25 and press Enter.

16. <R> and select Finish.

SE Ramp Template at Bryant St.

The merger areas for the SE Ramp at 6th Ave. and the SE Ramp at the Bryant ramp overlap.  A 

copy of the SE Ramp at 6th Ave template is modified for use in this merger area.  A seperate 
template is used here because using target aliasing and clipping options would resuld in the loss 
of the ABC component in the clipped template.

Section Objectives:

♦ Copy the SE Ramp at 6th Ave template

♦ Modify the copy for the Bryant Ramp merger area

Copy and Modify the SE Ramp at 6th Ave Template

1. Make a copy of the SE Ramp at 6th Ave and key in SE Ramp at Bryant for the name.
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2. Modify the SE Ramp at Bryant  template as described above deleting the components 
an points on the left side of the template.  The illustration below shows the completed 
template.

Bryant Ramp at the SE Ramp

A copy of the Bryant Ramp template is also modified to work in the merger area.

Section Objectives:

♦ Copy the Bryant Ramp template

♦ Modify the copy for the SE Ramp merger area

Copy and Modify the Bryant Ramp Template

1. Make copy of the Bryant Ramp template as described above. Name it Bryant Ramp 
at SE Ramp.

2. Modify the Bryant Ramp at SE Ramp template as described above making the changes on 
the right side of the template.  The illustration below shows the completed template.
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Set Up For Final Modeling

With the key stations determined and the new templates created, the corridors are modified to use this data.  
Changes in corridor stations, additional template drops, point controls, and target aliasing are used to 
incorporate this data.  Also, after reviewing the initial design surface data, some sideslopes require 
modification

Set Up for the SE Ramp

Section Objectives:

♦ Add template drops for the new SE Ramp templates

♦ Add point controls to match the template to the 6th Ave edge of pavement

♦ Modify sideslopes in the template view

Adding Template Drops 

These are added to include the new templates into teh corridor.

1. Open Roadway Designer.

2. Set the Corridor to SE Ramp and the Active Surface to Existing_Ground.

3. Open the Template Drops dialog box.

Because this alignment runs west to east, the first template drop is at the edge of 6th Ave.  
Therefore, the template for this drop is changed to use the  SE Ramp at 6th Ave template.

4. Highlight the template drop in the Current Template Drops list.

5. In the Library Templates area, expand the 1 – Templates folder and select the SE Ramp 
at 6th Ave template.
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6. <D> Change.

The next two template drops define the change from the SE Ramp at 6th Ave to the SE Ramp at 
Bryant Ramp template.  This change occurs in 0.01 feet so that there is an abrupt change from a 
template with a curb to a template without one.

7. Key in 3+88.03 for the Station.

8. Key in 25 for the Interval.

9. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

10. <D> Add.

11. Key in 3+88.04 for the Station.

12. Key in 25 for the Interval.

13. In the Library Templates area, highlight the SE Ramp at Bryant Ramp template.

14. <D> Add.

Again, an abrupt change between templates is needed so the transition occurs in 0.01 feet.

15. Key in 7+72.78 for the Station.

16. Key in 25 for the Interval.
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17. In the Library Templates area, highlight the SE Ramp at Bryant Ramp template.

18. <D> Add.

19. Key in 7+72.79 for the Station.

20. Key in 25 for the Interval.

21. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

22. <D> Add.

23. Key in 8+23.46 for the Station.

24. Key in 25 for the Interval.

25. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

26. <D> Add.

27. Key in 8+23.47 for the Station.

28. Key in 25 for the Interval.

29. In the Library Templates area, highlight the SE Ramp template.
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30. <D> Add.  The completed Template Drops dialog box is shown below.

31. <D> Close.

Add Point Controls for the SE Ramp

A point control is used to match the right edge of pavement of the SE Ramp templates to the 
existing pavement edge of 6th Ave. (defined by the US6_EOP1 alignment).

1. Select Corridor > Point Controls from the InRoads menu bar.  This displays the Point 
Controls dialog box.

2. Select RT_Conc_EOP-Top for the Point.

3. Toggle on Both for the Mode.

4. Set the Control Type to Alignment.

5. Select US6_EOP1 for the Horizontal Alignment.  The vertical alignment is automatically 
set.

6. In the Station Limits area, leave the Start at 0+00.00 and key in 8+23.46 for the Stop 
station.  
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7. <D> Add and Close.

Modify Side Slopes for SE Ramp

There is a area in this corridor where the computed end condition created an undesirable result.  
Because this area only covers two template drops, it is corrected by modifying the templates at 
those stations.  If this area were larger, an end condition override or a new template should be 
used.

1. Set the Station Indicator to 7+72.79.

2. <D> <D> in the Template View to open the Edit Template at Station 7+72.79 Only dialog 
box.

3. Open the Dynamic Settings dialog box.

4. <D> on the Readout button to change it to X and Slope.
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5. Key in 10.00% for the slope Step.

6. <R> on the LT_Top-of-Cut point and select Move Point from the menu.

7. Move the point to the location shown in the illustration below.  <D> to place it.

Note: The point will snap to the Existing Ground line when the cursor is moved 
next to the line.

8. <D> OK to accept the change and dismiss the dialog box.
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9. Modify station 7+75.00 in a similar manner as shown in the illustration below.

Set Up for the Bryant Ramp

Section Objectives:

♦ Change the end station for the Bryant Ramp corridor

♦ Add template drops for the new Bryant Ramp templates

♦ Add point controls to match the template to the SE Ramp edge of pavement

♦ Define target aliasing to target the SE Ramp surface

♦ Modify sideslopes in the template view

Edit Corridor Stations

The Bryant Ramp alignment runs past the point where the Bryant Ramp template is no longer 
used.  The corridor is modified to end as the same place where the template needs to end.

1. Set the Corridor to Bryant Ramp.

2. Select Corridor > Corridor Management from the InRoads menu bar.  This displays 
the Manage Corridors dialog box.

3. In the Manage Corridors dialog box, highlight the Bryant Ramp entry from the Corridors 
list.

4. In the Limits area, toggle on Station.

5. Key in 8+85.00 for the Stop station.
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6. <D> Change and Close.

Adding Template Drops 

The additional template drops are added to include the modified template properly as explained 
above.

1. Open the Template Drops dialog box.

2. Key in 5+02.76 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, highlight the Bryant Ramp template.

5. <D> Add.

6. Key in 5+02.77 for the Station.

7. Key in 25 for the Interval.

8. In the Library Templates area, highlight the Bryant Ramp at SE Ramp template.
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9. <D> Add and Close. The completed Template Drops dialog box is shown below.

Add Point Controls for the Bryant Ramp

This point control matches the right edge of pavement of the Bryant Ramp to the left edge of 
pavement of the SE Ramp.  It causes the Bryant ramp to transition to 0 by the end of the 
merger.

1. Select Corridor > Point Controls from the InRoads menu bar.  

2. Select RT_Conc_EOP-Top for the Point.

3. Toggle on Both for the Mode.

4. Set the Control Type to Corridor Point.

5. Select SE Ramp for the Corridor.  

6. Select LT_Conc_EOP-Top for the Reference Point.

7. In the Station Limits area, key in 5+02.77 for the Start station and key in 8+85.00 for 
the Stop station.  
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8. <D> Add and Close.

Create Target Aliasing for the Bryant Ramp

Target aliasing is used to tie the Bryant Ramp sideslope to the SE Ramp sideslope in the area 
befor the merger.  Without this, the combined surface will not triangulate properly in areas 
where the toes overlap.

1. Select Tools > Target Aliasing from the Roadway Designer menu bar.

2. Highlight Surface – SE Ramp in the Surface or Corridor list.
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3. <D> Add.

4. Highlight Surface – Existing_Ground in the Surface or Corridor list.

5. <D> Add.  The dialog box looks like the illustration below.

6. <D> OK.  

Modify Side Slopes for Bryant Ramp

This corridor also has an undesirable result on a sideslope.  Again, because this result occured 
in a limited area, the template at the station is edited.

1. Set the Station Indicator to 8+50.00.

2. <D> <D> in the Template View to open the Edit Template at Station 8+50.00 Only dialog 
box.

3. Move the point LT_Toe-of-Fill as shown in the illustration below.
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4. <D> OK to accept the change and dismiss the dialog box

Create the Final Combined Design Surface

The two corridors are combined into one surface of the interchange.

Section Objectives:

♦ Create a combines surface from the SE Ramp and Bryant Ramp corridors

1. Open the Create Surface dialog box.

2. In the Name field, key in SE-Bryant Ramps.

3. Set the Default Preference to Proposed.

4. In the Create Surface(s) From list box, highlight both Bryant Ramp and SE Ramp.

The clipping options are used to modify the combined surface where in end conditions overlap 
prior to the merger.

5. <D> the Clipping Options button.

6. Set the Clipping Option to End Conditions Only.
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7. <D> OK to accept the change and close the Clipping Options dialog box.

8. Verify that Add Exterior Boundary, Triangulate, and Remove Loops are toggled on.
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9. <D> Apply and Close.  Close the Results window if it is displayed.

10. Select File > Save from the Roadway Designer menu bar.

11. <D> Close to dismiss the Roadway Designer dialog box.

Review the Results

Once the design surface is created a review of that surface will determine if additional work is required.

Cross Sections

Cross sections are one of the standard design surface review tools.

Section Objectives:
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♦ Create a set of cross sections

Display Cross Sections with the SE Ramp Alignment

The SE Ramp alignment is the main alignment for this project, so it is used when reviewing the 
data.

1. Set the SE Ramp alignment active.

2. Open the Create Cross Sections dialog box.

3. Set the Left Offset to -150 and the Right Offset to 100.

4. Select the Existing_Ground and SE-Bryant Ramps surfaces

5. <D> Apply and <D> to place the set.

6. Close the Create Cross Sections dialog box.

View 3D Components

With the advent of template components, a new option has been added to the view surface 
commands.  Viewing the design surface components in 3d is a new tool for reviewing surfaces.

Section Objectives:

♦ Display surface components into the MicroStation file

1. Select Surface > View Surface > Components from the InRoads Menu.

2. In the View Surface Components dialog box, select SE-Bryant Ramps for the Surface.

3. In the Component list, <R> and choose Select All from the menu.

4.  Hold the Ctrl key and <D> on the ABC components to deselect them.

5. <D> Apply and Close.

6. Examine the components rotating the view to see different perspectives.  FM_BD_Body2
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